Subject: [nwcrg] Updates on milestones

From: Marie-Jose Montpetit <[email-masked]>
Date: Mon, 8 Apr 2019 09:45:10 -0400

Thanks again to everyone who showed up in Prague in person and on Meetecho.

One thing we now have to doahead of Montreal is to update our milestones and make sure all drafts are current. We may host a virtual interim to review these goals (date TBD).

In order to make sure our milestones are current here my review:
	- ICN/NC is well under way
	- NC and satellite -  same
	- SWIF open source codec same; both the related drafts and the hackaton outcomes
	- The Tetrys draft is outdated; we had however a goal of having a draft per code in nwcrg and are still on that course; we need advice from the authors
	- Interaction between network coding and congestion control: after a burst of interest this seems to have not gathered any further inputs; should we drop it?
	- QUIC and NC: we now have active contributors and we expect the activity to pick up with a goal of QUIC v2 implementation (including multipath)
New potential milestones:
	- New topics related to programmable switching/data plane forwarding and NC (link to COINRG) - to be followed? It was not presented in nwcrg nor coinrg so is this a real interest?
	- New topic on low delay coding - worth to be continued?

So list what do you think?

M/V

Marie-Jose Montpetit, Ph.D.
Research Affiliate, MIT Media Laboratory
[email-masked] <mailto:[email-masked]>
[email-masked] <mailto:[email-masked]>
+1-781-526-2661
@SocialTVMIT

---

From: "David R. Oran" <[email-masked]>
Date: Tue, 09 Apr 2019 09:32:00 -0400

On 8 Apr 2019, at 9:45, Marie-Jose Montpetit wrote:

> One thing we now have to doahead of Montreal is to update our 
> milestones and make sure all drafts are current. We may host a virtual 
> interim to review these goals (date TBD).
>

Just to report, I had a chat with Kazuhisa-san after the RG meeting, and 
we settled that he’ll produce the next draft revision, which I’ll 
review personally and have the ICNRG folks look at so we can get to RG 
last cal expeditiously.

> 	- The Tetrys draft is outdated; we had however a goal of having a 
> draft per code in nwcrg and are still on that course; we need advice 
> from the authors
> 	- Interaction between network coding and congestion control: after a 
> burst of interest this seems to have not gathered any further inputs; 
> should we drop it?

It’s kind of sad that congestion control keeps sliding off the table. 
I understand that we can’t keep pushing stuff that nobody is prepared 
to step up and work on, but taking it off the work plan seems to be 
admitting defeat on something that is sufficiently important that we 
ought not to give up on.

> 	- QUIC and NC: we now have active contributors and we expect the 
> activity to pick up with a goal of QUIC v2 implementation (including 
> multipath)
> 	- New topics related to programmable switching/data plane forwarding 
> and NC (link to COINRG) - to be followed? It was not presented in 
> nwcrg nor coinrg so is this a real interest?

> _______________________________________________
> nwcrg mailing list
> [email-masked]
> https://www.irtf.org/mailman/listinfo/nwcrg

DaveO

---

From: Fernando Ramos <[email-masked]>
Date: Tue, 9 Apr 2019 15:23:14 +0100

Hi All,

Inline.

> On 8 Apr 2019, at 14:45, Marie-Jose Montpetit <[email-masked]> wrote:
> 

We have been developing P4 programs (a language to program programmable data planes, PDPs) to run NC on these devices, but it is still work-in-progress. We are currently evaluating a first prototype in software, and we are now preparing the next stage: to run this in our hardware platforms (a SmartNIC based on NetFPGA, and a Barefoot Tofino switch). We should thus have something to share in the near future -- not necessarily in the next meeting, but hopefully soon.

We have been collaborating with a couple of other research groups around this topic, but besides us my feeling is that there is indeed interest in the community around this topic -- and generally on the opportunity PDPs offer to experiment new networking architectures at scale. For instance, last week I was in Dagstuhl organising a seminar on programmable data planes (https://www.dagstuhl.de/no_cache/en/program/calendar/semhp/?semnr=19141 <https://www.dagstuhl.de/no_cache/en/program/calendar/semhp/?semnr=19141> — a report will be out soon, and maybe a CCR editorial too), and several people seemed interested in this line of work.

Cheers,

Fernando