Subject: [nwcrg] I-D Action: draft-irtf-nwcrg-network-coding-satellites-05.txt

From: [email-masked]
Date: Tue, 04 Jun 2019 09:18:33 -0700

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the Coding for efficient NetWork Communications Research Group RG of the IRTF.

        Title           : Coding techniques for satellite systems
        Authors         : Nicolas Kuhn
                          Emmanuel Lochin
	Filename        : draft-irtf-nwcrg-network-coding-satellites-05.txt
	Pages           : 16
	Date            : 2019-06-04

Abstract:
   This document is the product of the Coding for Efficient Network
   Communications Research Group (NWCRG).  This document follows the
   taxonomy document [RFC8406] and considers coding as a linear
   combination of packets that operate above the network layer.  In this
   context, this memo details a multi-gateway satellite system to
   identify use-cases where coding is relevant.  As example, coding
   operating above the network layer can be exploited to cope from
   residual losses or provide reliable multicast services.  The
   objective is to contribute to a larger deployment of such techniques
   in SATCOM systems.  This memo also identifies open research issues
   related to the deployment of coding in SATCOM systems, such as the
   interaction between congestion controls and coding techniques.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-irtf-nwcrg-network-coding-satellites/

There are also htmlized versions available at:
https://tools.ietf.org/html/draft-irtf-nwcrg-network-coding-satellites-05
https://datatracker.ietf.org/doc/html/draft-irtf-nwcrg-network-coding-satellites-05

A diff from the previous version is available at:
https://www.ietf.org/rfcdiff?url2=draft-irtf-nwcrg-network-coding-satellites-05

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: Kuhn Nicolas <[email-masked]>
Date: Tue, 4 Jun 2019 16:25:31 +0000

Dear all, 

We have uploaded an updated version of this document. 
We believe that we have assessed most of the comments that we have received. 
We will see how we present the changes at next IETF. 

In the meantime, we have added the received comments as issues on the GITHUB repository of the document. 
You can see how each pull-request assessed your comments. 
We believe that this is more efficient than replying to all separate emails.

There are two pending issues that we would like to discuss at next IETF. 

For further comments on this document, please submit issues to the GITHUB repository directly. 

Cheers,

Nico

-----Message d'origine-----
De : nwcrg <[email-masked]> De la part de [email-masked]
Envoyé : mardi 4 juin 2019 18:19
À : [email-masked]
Cc : [email-masked]
Objet : [nwcrg] I-D Action: draft-irtf-nwcrg-network-coding-satellites-05.txt

Abstract:

Please note that it may take a couple of minutes from the time of submission until the htmlized version and diff are available at tools.ietf.org.

_______________________________________________
nwcrg mailing list
[email-masked]
https://www.irtf.org/mailman/listinfo/nwcrg

---

From: Kuhn Nicolas <[email-masked]>
Date: Wed, 5 Jun 2019 13:36:58 +0000

Dear all,

In case all of you can hardly access the GITHUB repository, here is a summary of the main changes on the draft.

Following the various comments on the usage of coding, network coding and the scope of the document: we have updated the introduction to clarify the scope (FEC, coding, etc.) and have rewritten the abstract

The notations used in this document are based on the taxonomy  document [RFC8406]:

   o  Channel and link codings are gathered in the PHY layer coding and

      are out of the scope of this document.

   o  FEC (also called Application-Level FEC) operate above the network

      layer.

   o  This document considers coding (or coding techniques or coding

      schemes) as a linear combination and not as a content coding

      (e.g., to compress a video flow).

Following the comment from John on being robust to losses that occur at the Wi-Fi link from the terminal to the end-user, we have added a use-case to cover this issue

In this use-case, adding coding techniques could prevent the end-to-

   end retransmission from occuring.

-{}- : bidirectional link

-''- : Wi-Fi link

+---------+    +---------+    +---+    +--------+    +-------+    +--------+

|         |    |Satellite|    |SAT|    |Physical|    |Access |    |Network |

|End user |-''-|Terminal |-{}-|   |-{}-|Gateway |-{}-|Gateway|-{}-|Function|

+---------+    +---------+    +---+    +--------+    +-------+    +--------+

     C                       C            C           C

        Figure 6: Network architecture for dealing with LAN losses

Following the comments on the research challenges, we have reformulated and re-organized them:

4.  Research challenges . . . . . . . . . . . . . . . . . . . . .  11

     4.1.  On the joint-use of coding techniques and congestion

           control in SATCOM systems . . . . . . . . . . . . . . . .  12

     4.2.  On the efficient usage of satellite ressource . . . . . .  12

     4.3.  Interaction with virtualized satellite gateways and

           terminals . . . . . . . . . . . . . . . . . . . . . . . .  12

     4.4.  Delay/Disruption Tolerant Networks  . . . . . . . . . . .  12

Other changes can be seen with the diff tool from IETF.

Moreover, there are - in our opinion - two pending issues that we could not resolve:

- Discussion on the DTN research challenge:  https://github.com/irtf-nwcrg/draft-irtf-nwcrg-network-coding-satellites/issues/13

- Discussion on the virtualization research challenge: https://github.com/irtf-nwcrg/draft-irtf-nwcrg-network-coding-satellites/issues/12

Do not hesitate to let us know if you have further issues with this document.

Cheers,

Nico

-----Message d'origine-----
De : nwcrg <[email-masked]> De la part de Kuhn Nicolas
Envoyé : mardi 4 juin 2019 18:26
À : [email-masked]
Objet : Re: [nwcrg] I-D Action: draft-irtf-nwcrg-network-coding-satellites-05.txt

Dear all,

We believe that we have assessed most of the comments that we have received..

Cheers,

Nico

-----Message d'origine-----

De : nwcrg <[email-masked]<mailto:[email-masked]>> De la part de [email-masked]<mailto:[email-masked]> Envoyé : mardi 4 juin 2019 18:19 À : [email-masked]<mailto:[email-masked]> Cc : [email-masked]<mailto:[email-masked]> Objet : [nwcrg] I-D Action: draft-irtf-nwcrg-network-coding-satellites-05..txt

        Authors         : Nicolas Kuhn

                          Emmanuel Lochin

                Pages           : 16

                Date            : 2019-06-04

Abstract:

nwcrg mailing list

[email-masked]<mailto:[email-masked]>

nwcrg mailing list

[email-masked]<mailto:[email-masked]>