Subject: [nwcrg] Link to coinrg

From: Marie-Jose Montpetit <[email-masked]>
Date: Tue, 9 Jul 2019 05:18:17 -0700

(nwcrg chair hat off/coinrg chair hat on)

Hello:

In COIN we are looking at applications that use computing in the network
and of course in this community the idea of doing Galois field arithmetics
in the network nodes especially for re-encoding has always been a solution.
So there room for maybe some common work?

mjm

Marie-José Montpetit, Ph.D.
Research Affiliate, MIT Media Laboratory
[email-masked]
[email-masked]

---

From: Fernando Ramos <[email-masked]>
Date: Tue, 9 Jul 2019 13:38:10 +0100

Hi Marie-José, All,

Here in the Univ. of Lisbon (joint work with Muriel Medard) we are working on P4 programs that perform network coding on programmable data planes. We are working on a draft paper that we may be able to share soon, and will also make the code available. You should hear from us in a few weeks on it.

Best,

Fernando 

> On 9 Jul 2019, at 13:18, Marie-Jose Montpetit <[email-masked]> wrote:
> 
> In COIN we are looking at applications that use computing in the network and of course in this community the idea of doing Galois field arithmetics in the network nodes especially for re-encoding has always been a solution. So there room for maybe some common work?
> 
> mjm
> 
> mariejose@mjmontpetit..com <mailto:[email-masked]>
> [email-masked] <mailto:[email-masked]>_______________________________________________
> nwcrg mailing list
> [email-masked] <mailto:[email-masked]>
> https://www.irtf.org/mailman/listinfo/nwcrg <https://www.irtf.org/mailman/listinfo/nwcrg>

---

From: Marie-Jose Montpetit <[email-masked]>
Date: Tue, 9 Jul 2019 05:40:26 -0700

Great! We have a P4 hackaton on the 20th and my idea was to look into
coding. If you are in Montreal please join us.

On July 9, 2019 at 8:38:51 AM, Fernando Ramos ([email-masked])
wrote:

Hi Marie-José, All,

Here in the Univ. of Lisbon (joint work with Muriel Medard) we are working
on P4 programs that perform network coding on programmable data planes. We
are working on a draft paper that we may be able to share soon, and will
also make the code available. You should hear from us in a few weeks on it.

Best,

Fernando

Hello:

mjm

Marie-José Montpetit, Ph.D.
Research Affiliate, MIT Media Laboratory
mariejose@mjmontpetit..com <[email-masked]>
[email-masked]
_______________________________________________
nwcrg mailing list
[email-masked]
https://www.irtf.org/mailman/listinfo/nwcrg