Subject: [nwcrg] What I SHOULD have said about https://datatracker.ietf.org/doc/html/draft-kuhn-coding-congestion-transport

From: Spencer Dawkins at IETF <[email-masked]>
Date: Thu, 21 Nov 2019 17:08:12 +0800

During Nicholas's presentation this afternoon, I pointed out that it might
be good to consider whether "repair equals loss" was the right model for
sender congestion control responses because we we had considered ECN as
equal to loss for many years, but (FINALLY) redefined the ECT(1) bit to
allow other responses. It might be useful to point the discussion of this
draft in the same direction - assume the use of scalable congestion control
and ECT(1) signaling.

I was talking to Gorry Fairhurst afterwards, and Gorry told me what I
SHOULD have said, was that the sender should perform whatever its response
to congestion would be - if it's an old-style sender, treat recovery as
loss, but if it supports scalable congestion control (L4S is one example),
it doesn't have to treat recovery as loss - it just needs to do something
appropriate.

Again, I hope that's useful, and I appreciate this work a lot, because
people do need it.

Thanks,

Spencer

p.s. cc: Gorry, in case I got that wrong.

---

From: Emmanuel Lochin <[email-masked]>
Date: Fri, 22 Nov 2019 02:25:51 +0100

Le 21/11/2019 à 10:08, Spencer Dawkins at IETF a écrit :
> During Nicholas's presentation this afternoon, I pointed out that it 
> might be good to consider whether "repair equals loss" was the right 
> model for sender congestion control responses because we we had 
> considered ECN as equal to loss for many years, but (FINALLY) 
> redefined the ECT(1) bit to allow other responses. It might be useful 
> to point the discussion of this draft in the same direction - assume 
> the use of scalable congestion control and ECT(1) signaling.
>
> SHOULD have said, was that the sender should perform whatever its 
> response to congestion would be - if it's an old-style sender, treat 
> recovery as loss, but if it supports scalable congestion control (L4S 
> is one example), it doesn't have to treat recovery as loss - it just 
> needs to do something appropriate.
>

Fully agree, we just signal the recovery, the treatment depends on the 
CC policy.

EL

> _______________________________________________
> nwcrg mailing list
> [email-masked]
> https://www.irtf.org/mailman/listinfo/nwcrg

-- 
Emmanuel LOCHIN
Professeur ISAE
ISAE SUPAERO - Institut Supérieur de l'Aéronautique et de l'Espace
10 avenue Edouard Belin - BP 54032 - 31055 TOULOUSE CEDEX 4 FRANCE -
http://www.isae-supaero.fr
Tel +33 5 61 33 84 85 - Fax (+33) 5 61 33 83 45
Web : http://personnel.isae.fr/emmanuel-lochin/

---

From: Kuhn Nicolas <[email-masked]>
Date: Fri, 22 Nov 2019 02:30:57 +0000

Thanks a lot for your interest of the document and for your useful comment.
We will surely consider it in the updated version of the document - stay tuned !

Cheers,

Nico

De : nwcrg <[email-masked]> De la part de Emmanuel Lochin
Envoyé : vendredi 22 novembre 2019 02:26
À : [email-masked]
Objet : Re: [nwcrg] What I SHOULD have said about https://datatracker.ietf.org/doc/html/draft-kuhn-coding-congestion-transport

During Nicholas's presentation this afternoon, I pointed out that it might be good to consider whether "repair equals loss" was the right model for sender congestion control responses because we we had considered ECN as equal to loss for many years, but (FINALLY) redefined the ECT(1) bit to allow other responses. It might be useful to point the discussion of this draft in the same direction - assume the use of scalable congestion control and ECT(1) signaling.

I was talking to Gorry Fairhurst afterwards, and Gorry told me what I SHOULD have said, was that the sender should perform whatever its response to congestion would be - if it's an old-style sender, treat recovery as loss, but if it supports scalable congestion control (L4S is one example), it doesn't have to treat recovery as loss - it just needs to do something appropriate.

Fully agree, we just signal the recovery, the treatment depends on the CC policy.

EL

Again, I hope that's useful, and I appreciate this work a lot, because people do need it.

Thanks,

Spencer

nwcrg mailing list

[email-masked]<mailto:[email-masked]>

--

Emmanuel LOCHIN

Professeur ISAE