Subject: Re: [nwcrg] Recent IPR disclosure against RFC 8681

From: "[email-masked]" <[email-masked]>
Date: Sat, 4 Apr 2020 04:26:26 +0000 (UTC)

MJ

this is an awkward position to be in. You are heavily conflicted 
in roles and responsibilities to MIT and to this list.

The only thing I can see that must be done is that you simply 
need to recuse yourself and step down as co-chair, to avoid 
both a conflict of interest and the appearance of a conflict 
of interest.

You may have played a part in tangling it, but this Gordian knot 
is no longer your responsibility to unravel or influence. 

Stand back, and let others figure it out.

best

L. 

er, 1 April? this isn't an April Fools'? right? right?

Lloyd Wood [email-masked] http://about.me/lloydwood

On Wednesday, 1 April 2020, 03:45:27 GMT+11, Marie-Jose Montpetit <[email-masked]> wrote: 

Dear NWCRG list members:

There was a recent IPR disclosure related to RFC 8681 - Sliding Window Random Linear Code (RLC) Forward Erasure Correction (FEC) Schemes for FECFRAME -
https://datatracker.ietf.org/ipr/4069/ 
This refers to a patent that has me as co-inventor.  This disclosure puts me in a delicate position as the patent co-inventor hence someone who should have disclosed the IPR and at the same time as the NWCRG chair who has been following the RLC development since 2015 and should be impartial.

(w/o chair hat on) 
1. This patent was submitted following some work I did as an MIT researcher in Muriel Médard’s laboratory and as such all my IPR is now owned by MIT for them to license at will. It is the licensee that made the disclosure, not MIT, not me or any of the patent co-inventors most of which have been or are still involved in the NWCRG. I was not made aware of the disclosure and have no relationship with the discloser but it puts me like I said in a delicate position.

According to RFC 8179 I should have disclosed this IPR at the time of the first ID in 2015 or throughout its evolution in the TSVWG from 2017-2019 and its presentations in the NWCRG meetings during that time if I felt that it was related to the work of RFC 8681. I understand the rules of 8179 for the need for timely disclosure. I did not disclose any IPR, as I did not feel that there was a direct relationship between the patent and RLC from its initial ID to the RFC. I also understand that the entity disclosing the IPR does not agree with me.

As far as I am concerned, the work that lead to the patent, where I was co-PI, was a master student thesis on using network coding (the MIT/Caltech RLNC) as an alternative to some of the layer 2 reliability mechanisms in WIMAX-2 networks with wider applicability to other wireless networks. The patent in thus on a novel implementation of coding not a code development. 

Since RFC 8681 is about developing a code with sliding windows and one that compared to the RLNC used in the patent does not allow for re-encoding. I believe our patent to be not directly related hence the reason I never pointed to the IPR. Of course the field of applicability of RFC 8681 includes wireless networks but also many others; applications are not crux of the RFC 8681. As a co-inventor I would have welcomed the discussion at our meetings or in private emails before the disclosures.

(with co-chair hat one) 
2. Other co-inventors from MIT and now Harvard and the disclosing entity, via one of their representatives, were present at almost every NWCRG meetings throughout the development of the RLC since 2015 and are part of our mailing list. Our patent or any other that are now disclosed against RFC 8681 was pointed out as being related. Some of the concerned participants even supported the RLC work. There is a rule in IETF that is followed by the IRTF about "timely disclosures" of related IPR. I am surprised that the disclosing entity took so long against the rule. And at every meeting we emphasized the IPR rules. 

Vincent and I welcome comments on this as we are strategizing for the future of the group.

mjm

Marie-José Montpetit, Ph.D.
[email-masked]

---

From: Carsten Bormann <[email-masked]>
Date: Sat, 4 Apr 2020 11:00:05 +0200

On 2020-04-04, at 06:26, [email-masked] <lloyd.wood=[email-masked]> wrote:
> 
> you simply 
> need to recuse yourself and step down as co-chair

I don’t like the attack vector implied here.

If I don’t like a chair, I find a patent she is on and submit an “IPR declaration” to a random, but at least superficially plausible RFC.

(It is clear that the specific matter in this issue needs to be handled by her co-chair.
If there is any matter here to be handled in a chairly fashion, which I’m not sure of.)

Grüße, Carsten

---

From: Marie-Jose Montpetit <[email-masked]>
Date: Sat, 4 Apr 2020 04:02:00 -0700

Lloyd: I am not heavily conflicted. Not more than any other chair that has
patents with a previous company that are not under his/her control.

MIT licensed the patents to the disclosing entity without me being
involved. Actually if all chairs that have a patent portfolio with a
previous employer had to resign because of potential conflict there would
be a massive resignation issue.

There are IPR rules in the IETF that have to be followed. I followed them
to the best of my knowledge. And when this incident happened I was quick in
taking action and raising the issue with the IRTF chair (Colin).

mjm

On April 4, 2020 at 12:26:50 AM, [email-masked] (
[email-masked]) wrote:

MJ

best

L.

On Wednesday, 1 April 2020, 03:45:27 GMT+11, Marie-Jose Montpetit <
[email-masked]> wrote:

Dear NWCRG list members:

There was a recent IPR disclosure related to RFC 8681 - Sliding Window
Random Linear Code (RLC) Forward Erasure Correction (FEC) Schemes for
FECFRAME -
https://datatracker.ietf.org/ipr/4069/
This refers to a patent that has me as co-inventor.  This disclosure puts
me in a delicate position as the patent co-inventor hence someone who
should have disclosed the IPR and at the same time as the NWCRG chair who
has been following the RLC development since 2015 and should be impartial.

(w/o chair hat on)
1. This patent was submitted following some work I did as an MIT researcher
in Muriel Médard’s laboratory and as such all my IPR is now owned by MIT
for them to license at will. It is the licensee that made the disclosure,
not MIT, not me or any of the patent co-inventors most of which have been
or are still involved in the NWCRG. I was not made aware of the disclosure
and have no relationship with the discloser but it puts me like I said in a
delicate position.

According to RFC 8179 I should have disclosed this IPR at the time of the
first ID in 2015 or throughout its evolution in the TSVWG from 2017-2019
and its presentations in the NWCRG meetings during that time if I felt that
it was related to the work of RFC 8681. I understand the rules of 8179 for
the need for timely disclosure. I did not disclose any IPR, as I did not
feel that there was a direct relationship between the patent and RLC from
its initial ID to the RFC. I also understand that the entity disclosing the
IPR does not agree with me.

As far as I am concerned, the work that lead to the patent, where I was
co-PI, was a master student thesis on using network coding (the MIT/Caltech
RLNC) as an alternative to some of the layer 2 reliability mechanisms in
WIMAX-2 networks with wider applicability to other wireless networks. The
patent in thus on a novel implementation of coding not a code development.

Since RFC 8681 is about developing a code with sliding windows and one
that compared to the RLNC used in the patent does not allow for
re-encoding. I believe our patent to be not directly related hence the
reason I never pointed to the IPR. Of course the field of applicability of
RFC 8681 includes wireless networks but also many others; applications are
not crux of the RFC 8681. As a co-inventor I would have welcomed the
discussion at our meetings or in private emails before the disclosures.

(with co-chair hat one)
2. Other co-inventors from MIT and now Harvard and the disclosing entity,
via one of their representatives, were present at almost every NWCRG
meetings throughout the development of the RLC since 2015 and are part of
our mailing list. Our patent or any other that are now disclosed against
RFC 8681 was pointed out as being related. Some of the concerned
participants even supported the RLC work. There is a rule in IETF that
is followed by the IRTF about "timely disclosures" of related IPR. I am
surprised that the disclosing entity took so long against the rule. And at
every meeting we emphasized the IPR rules.

Vincent and I welcome comments on this as we are strategizing for the
future of the group.

mjm

---

From: Marie-Jose Montpetit <[email-masked]>
Date: Sat, 4 Apr 2020 04:04:42 -0700

Thank you Carsten. In this case the weird thing is since the co-chair is
also the RFC author the situation is doubly complicated.  This is why we
contacted Colin. But like you said I am not sure there is anything that can
be resolved at the chair level in any case.

mjm

On April 4, 2020 at 5:00:06 AM, Carsten Bormann ([email-masked]) wrote:

If I don’t like a chair, I find a patent she is on and submit an “IPR
declaration” to a random, but at least superficially plausible RFC.

(It is clear that the specific matter in this issue needs to be handled by
her co-chair.
If there is any matter here to be handled in a chairly fashion, which I’m
not sure of.)

Grüße, Carsten

---

From: Colin Perkins <[email-masked]>
Date: Sat, 4 Apr 2020 15:10:10 +0100

Lloyd,

I see no reason for Marie-Jose to stand down. As far as I can tell, she’s handled this issue correctly and in conformance with the IPR disclosure rules. I have full confidence in Marie-Jose and Vincent, and expect and hope that they’ll continue as co-chairs of the NWCRG.

Colin

> On 4 Apr 2020, at 05:26, [email-masked] wrote:
> 
> MJ
> 
> 

-- 
Colin Perkins
https://csperkins.org/

---

From: Emmanuel Lochin <[email-masked]>
Date: Sat, 04 Apr 2020 17:13:47 +0200

Dear all,

I support Marie-José and I have full confidence in her impartiality.

Emmanuel

-- 
Emmanuel LOCHIN
ENAC - Ecole Nationale de l'Aviation Civile
7, avenue Edouard Belin CS 54005, 31055 Toulouse Cedex 4 France
http://www.enac.fr
https://elochin.github.io/

---

From: Kuhn Nicolas <[email-masked]>
Date: Sun, 5 Apr 2020 08:32:46 +0000

Hello everyone,

I have no doubt in Marie José and Vincent managing the situation accordingly with IETF rules.

Thanks for your work,
My 2cts,

Nicolas

De : nwcrg <[email-masked]> De la part de Emmanuel Lochin
Envoyé : samedi 4 avril 2020 17:14
À : [email-masked]
Objet : Re: [nwcrg] Recent IPR disclosure against RFC 8681

Dear all,

Lloyd,

Colin

On 4 Apr 2020, at 05:26, [email-masked]<mailto:[email-masked]> wrote:

MJ

of interest.

best

L.

Lloyd Wood [email-masked]<mailto:[email-masked]> http://about.me/lloydwood

On Wednesday, 1 April 2020, 03:45:27 GMT+11, Marie-Jose Montpetit <[email-masked]><mailto:[email-masked]> wrote:

Dear NWCRG list members:

(w/o chair hat on)

(with co-chair hat one)

mjm

[email-masked]<mailto:[email-masked]>

--

Emmanuel LOCHIN

http://www.enac.fr

---

From: Cedric Adjih <[email-masked]>
Date: Sun, 5 Apr 2020 12:08:55 +0200 (CEST)

Hello all, 
I also share this opinion. 
best regards, 
-- Cedric 

> De: "Kuhn Nicolas" <[email-masked]>
> À: "Emmanuel Lochin" <[email-masked]>, "nwcrg" <[email-masked]>
> Envoyé: Dimanche 5 Avril 2020 10:32:46
> Objet: Re: [nwcrg] Recent IPR disclosure against RFC 8681

> I support Marie-José and I have full confidence in her impartiality .

>> Lloyd,
>> I see no reason for Marie-Jose to stand down. As far as I can tell, she’s
>> handled this issue correctly and in conformance with the IPR disclosure rules.
>> I have full confidence in Marie-Jose and Vincent, and expect and hope that
>> they’ll continue as co-chairs of the NWCRG.
>> Colin

>>> On 4 Apr 2020, at 05:26, [ mailto:[email-masked] |
>>> [email-masked] ] wrote:
>>> MJ
>>> Lloyd Wood [ mailto:[email-masked] | [email-masked] ] [
>>> http://about.me/lloydwood | http://about.me/lloydwood ]
>>> On Wednesday, 1 April 2020, 03:45:27 GMT+11, Marie-Jose Montpetit [
>>> mailto:[email-masked] | <[email-masked]> ] wrote:
>>> Dear NWCRG list members:
>>> There was a recent IPR disclosure related to RFC 8681 - Sliding Window Random
>>> Linear Code (RLC) Forward Erasure Correction (FEC) Schemes for FECFRAME -
>>> [ https://datatracker.ietf.org/ipr/4069/ |
>>> https://datatracker.ietf.org/ipr/4069/ ]
>>> This refers to a patent that has me as co-inventor.  This disclosure puts me in
>>> a delicate position as the patent co-inventor hence someone who should have
>>> disclosed the IPR and at the same time as the NWCRG chair who has been
>>> following the RLC development since 2015 and should be impartial.
>>> (w/o chair hat on)
>>> 1. This patent was submitted following some work I did as an MIT researcher in
>>> Muriel Médard’s laboratory and as such all my IPR is now owned by MIT for them
>>> to license at will. It is the licensee that made the disclosure, not MIT, not
>>> me or any of the patent co-inventors most of which have been or are still
>>> involved in the NWCRG. I was not made aware of the disclosure and have no
>>> relationship with the discloser but it puts me like I said in a delicate
>>> position.
>>> According to RFC 8179 I should have disclosed this IPR at the time of the first
>>> ID in 2015 or throughout its evolution in the TSVWG from 2017-2019 and its
>>> presentations in the NWCRG meetings during that time if I felt that it was
>>> related to the work of RFC 8681. I understand the rules of 8179 for the need
>>> for timely disclosure. I did not disclose any IPR, as I did not feel that there
>>> was a direct relationship between the patent and RLC from its initial ID to the
>>> RFC. I also understand that the entity disclosing the IPR does not agree with
>>> me.
>>> As far as I am concerned, the work that lead to the patent, where I was co-PI,
>>> was a master student thesis on using network coding (the MIT/Caltech RLNC) as
>>> an alternative to some of the layer 2 reliability mechanisms in WIMAX-2
>>> networks with wider applicability to other wireless networks. The patent in
>>> thus on a novel implementation of coding not a code development.
>>> Since RFC 8681 is about developing a code with sliding windows and one that
>>> compared to the RLNC used in the patent does not allow for re-encoding. I
>>> believe our patent to be not directly related hence the reason I never pointed
>>> to the IPR. Of course the field of applicability of RFC 8681 includes wireless
>>> networks but also many others; applications are not crux of the RFC 8681. As a
>>> co-inventor I would have welcomed the discussion at our meetings or in private
>>> emails before the disclosures.
>>> (with co-chair hat one)
>>> 2. Other co-inventors from MIT and now Harvard and the disclosing entity, via
>>> one of their representatives, were present at almost every NWCRG meetings
>>> throughout the development of the RLC since 2015 and are part of our mailing
>>> list. Our patent or any other that are now disclosed against RFC 8681 was
>>> pointed out as being related. Some of the concerned participants even supported
>>> the RLC work. There is a rule in IETF that is followed by the IRTF about
>>> "timely disclosures" of related IPR. I am surprised that the disclosing entity
>>> took so long against the rule. And at every meeting we emphasized the IPR
>>> rules.
>>> [ mailto:[email-masked] | [email-masked] ]

> [ http://www.enac.fr/ | http://www.enac.fr ]
> [ https://elochin.github.io/ | https://elochin.github.io/ ]

> _______________________________________________
> nwcrg mailing list
> [email-masked]
> https://www.irtf.org/mailman/listinfo/nwcrg

---

From: <[email-masked]>
Date: Mon, 6 Apr 2020 17:23:20 +0100

Dear All,

Following the email (here enclosed) of Marie-José Montpetit, co-chair of the NWCRG, we would like to point out the following:

1.	Code On Network Coding (“Code On”) is a small start-up having to promote a technology / ecosystem and manage a portfolio of over 100 patents (many of them licensed from over 10 Universities) with limited resources. 
2.	Despite not having in-house IP capabilities, Code On takes IPR activity very seriously and adheres to IETF policies to the best of its ability.  

3.	Code On understands that RFC 8179 provides that participants must disclose the existence of any IPR that they believe might cover the technology under discussion.  And it is in this spirit that Code On has consistently made IPR disclosures to the IETF since 2013, as per the links hereafter [https://datatracker.ietf.org/ipr/search/?draft= <https://datatracker.ietf.org/ipr/search/?draft=&rfc=&doctitle=&group=&holder=code+on&submit=holder&iprtitle=&patent=> &rfc=&doctitle=&group=&holder=code+on&submit=holder&iprtitle=&patent= ];[ https://www.linkedin.com/feed/update/urn:li:activity:6651777131674238976 ] 

4.	We strongly reject the statement of the Co-Chair that our disclosure was done against the rules:   

*	In general, all of our disclosures have followed the rules of RFC 8681;
*	In particular, this disclosure, relevant for a contribution made by somebody else, is a “timely disclosure” because it was made by us promptly once we reached a belief of the relevancy of this specific patent. 

5.	We reject the notion that we should have discussed the relevance of our disclosure either at a general meeting or in private emails, since the duty to disclose is personal to each participant.

6.	We will not comment on the Co-Chair’s statement that she did not disclose this IPR because she did not feel that there was a direct relationship between the patent and RLC from its initial ID to the RFC, but are surprised that a Co-Chair would comment on the relevance of a disclosure of one of the contributors in light of the fact that RFC 8179 specifically states that the IETF will make no determination about the validity of any particular IPR claim. 

Best

Kavim Shroff

M: +44 (0) 7932 073 224 | Skype: kavimds

 <http://www.codeontechnologies.com/> 

Information transmitted in or attached to this e-mail is intended only for the person or entity to which it is addressed, and may contain confidential and/or privileged material. If this email has been sent to you by mistake and you are not the intended recipient, please telephone or email the sender immediately and delete it from your system; do not read, copy or disclose its contents to anyone. No responsibility is accepted by Code On for any loss or damage arising in any way from the receipt or use of this e-mail or its attachments. Please note that all e-mail messages are subject to interception for lawful business purposes.

 <https://www.linkedin.com/company/code-on-technologies>  <https://twitter.com/codeontech?lang=en-gb> 

Subject: [nwcrg] Recent IPR disclosure against RFC 8681
From: "Marie-Jose Montpetit" <[email-masked]>
To: <[email-masked]>
Cc: "Vincent Roca" <[email-masked]>, "Colin Perkins" <[email-masked]>
Date: Tue, 31 Mar 2020 17:45:06 +0100

Dear NWCRG list members:

(w/o chair hat on) 

(with co-chair hat one) 

mjm

Marie-José Montpetit, Ph.D.
[email-masked] <mailto:[email-masked]>

---

From: Carsten Bormann <[email-masked]>
Date: Mon, 6 Apr 2020 18:43:45 +0200

On 2020-04-06, at 18:23, [email-masked] wrote:
> 
> are surprised that a Co-Chair would comment on the relevance of a disclosure of one of the contributors in light of the fact that RFC 8179 specifically states that the IETF will make no determination about the validity of any particular IPR claim. 

I’m sure the IETF will not make a determination.

(This is the IRTF anyway, and I’m sure that will not make a determination either.)

However, both organizations are composed of experts, and many of us have opinions on issues like this.  We certainly shouldn’t voice those opinions while acting as a functionary of the organization.

I don’t think that has happened in this case: I heard Marie-Jose voice an opinion based on her being an expert sufficiently well-versed with the technology that she actually is named as an inventor on the patent in question.

(I don’t have an opinion whether you acted good or bad in this case, but I’m happy that you did provide the disclosure, once you reached a belief of the relevancy of this specific patent, and I’m aware that I’m not entitled to further information on how you reached that belief.  This doesn’t leave me less curious...)

Grüße, Carsten

---

From: Marie-Jose Montpetit <[email-masked]>
Date: Mon, 6 Apr 2020 10:06:10 -0700

Thank you for your reply.

it is not the role of the IETF (and we are the IRTF BTW) to make a
determination on the validity of a patent. It is not our role. The IRTF is
there to foster research. We just need to know about the IPR for potential
licensing aspects in the future.

I made the comments you refer as to justify the fact that I had not made
the disclosure as an expert with technical knowledge of both the RFC and
the patent content. This   could be interpreted as a potential conflict of
interest. I would have appreciated being advised of this disclosure as it
created some questioning but as you say you did not have to. I dealt with
the consequences like I will do in the future on other potential
disclosures that involve my patents.

It is fine that you made the disclosure but again the timeliness of it was
another issue that i think was important as CodeOn was aware of the work
from the beginning. Again you disagree and it is well noted.

This morning we decided to close this issue. It showed the importance of
the IPR issues is the IETF/IRTF and we will continue to be vigilant.

mjm

On April 6, 2020 at 12:23:52 PM, [email-masked] (
[email-masked]) wrote:

Dear All,

Following the email (here enclosed) of Marie-José Montpetit, co-chair of
the NWCRG, we would like to point out the following:

   1. Code On Network Coding (“Code On”) is a small start-up having to
   promote a technology / ecosystem and manage a portfolio of over 100 patents
   (many of them licensed from over 10 Universities) with limited resources.

   2. Despite not having in-house IP capabilities, Code On takes IPR
   activity very seriously and adheres to IETF policies to the best of its
   ability.

   1. Code On understands that RFC 8179 provides that participants
*must* disclose
   the existence of any IPR that they believe might cover the technology under
   discussion.  And it is in this spirit that Code On has consistently made
   IPR disclosures to the IETF since 2013, as per the links hereafter [
   https://datatracker.ietf.org/ipr/search/?draft=&rfc=&doctitle=&group=&holder=code+on&submit=holder&iprtitle=&patent=
   ];[
   https://www.linkedin.com/feed/update/urn:li:activity:6651777131674238976
   ]

   1. We strongly reject the statement of the Co-Chair that our disclosure
   was done against the rules:
      - In general, all of our disclosures have followed the rules of RFC
      8681;
      - In particular, this disclosure, relevant for a contribution made by
      somebody else, is a “timely disclosure” because it was made by
us promptly
      once we reached a belief of the relevancy of this specific patent.
   2. We reject the notion that we should have discussed the relevance of
   our disclosure either at a general meeting or in private emails, since the
   duty to disclose is personal to each participant.

   1. We will not comment on the Co-Chair’s statement that she did not
   disclose this IPR because she did not feel that there was a direct
   relationship between the patent and RLC from its initial ID to the RFC, but
   are surprised that a Co-Chair would comment on the relevance of a
   disclosure of one of the contributors in light of the fact that RFC 8179
   specifically states that the IETF will make no determination about the
   validity of any particular IPR claim.

Best

*Kavim Shroff*

*[image: file:///Users/mariejose/Library/Group
Containers/2E337YPCZY.airmail/Library/Application
Support/it.bloop.airmail2/Airmail/General/Local/1586191742854415872/Attachments/[email-masked]]*
<http://www.codeontechnologies.com/>

Information transmitted in or attached to this e-mail is intended only for
the person or entity to which it is addressed, and may contain confidential
and/or privileged material. If this email has been sent to you by mistake
and you are not the intended recipient, please telephone or email the
sender immediately and delete it from your system; do not read, copy or
disclose its contents to anyone. No responsibility is accepted by Code On
for any loss or damage arising in any way from the receipt or use of this
e-mail or its attachments. Please note that all e-mail messages are subject
to interception for lawful business purposes.

[image: file:///Users/mariejose/Library/Group
Containers/2E337YPCZY.airmail/Library/Application
Support/it.bloop.airmail2/Airmail/General/Local/1586191742854415872/Attachments/[email-masked]]
<https://www.linkedin.com/company/code-on-technologies>[image:
file:///Users/mariejose/Library/Group
Containers/2E337YPCZY.airmail/Library/Application
Support/it.bloop.airmail2/Airmail/General/Local/1586191742854415872/Attachments/[email-masked]]
<https://twitter.com/codeontech?lang=en-gb>

Dear NWCRG list members:

(w/o chair hat on)

(with co-chair hat one)

mjm

---

From: [email-masked]
Date: Tue, 7 Apr 2020 09:38:28 +0000 (UTC)

https://www.ietf.org/about/administration/ 

The legal entity here is IETF LLC; saying IRTF really doesn't matter.

Lloyd Wood [email-masked]

On Tuesday, April 7, 2020, 3:06 am, Marie-Jose Montpetit <[email-masked]> wrote:

#yiv8566231503 body{font-family:Helvetica, Arial;font-size:12px;}Thank you for your reply. 
it is not the role of the IETF (and we are the IRTF BTW) to make a determination on the validity of a patent. It is not our role. The IRTF is there to foster research. We just need to know about the IPR for potential licensing aspects in the future.
I made the comments you refer as to justify the fact that I had not made the disclosure as an expert with technical knowledge of both the RFC and the patent content. This   could be interpreted as a potential conflict of interest. I would have appreciated being advised of this disclosure as it created some questioning but as you say you did not have to. I dealt with the consequences like I will do in the future on other potential disclosures that involve my patents.
It is fine that you made the disclosure but again the timeliness of it was another issue that i think was important as CodeOn was aware of the work from the beginning. Again you disagree and it is well noted.
This morning we decided to close this issue. It showed the importance of the IPR issues is the IETF/IRTF and we will continue to be vigilant.
mjm 
 Marie-José Montpetit, [email-masked]

On April 6, 2020 at 12:23:52 PM, [email-masked] ([email-masked]) wrote:

Dear All,

   - Code On Network Coding (“Code On”) is a small start-up having to promote a technology / ecosystem and manage a portfolio of over 100 patents (many of them licensed from over 10 Universities) with limited resources. 
   - Despite not having in-house IP capabilities, Code On takes IPR activity very seriously and adheres to IETF policies to the best of its ability.  
   
   - Code On understands that RFC 8179 provides that participants must disclose the existence of any IPR that they believe might cover the technology under discussion.  And it is in this spirit that Code On has consistently made IPR disclosures to the IETF since 2013, as per the links hereafter [https://datatracker.ietf.org/ipr/search/?draft=&rfc=&doctitle=&group=&holder=code+on&submit=holder&iprtitle=&patent= ];[ https://www.linkedin.com/feed/update/urn:li:activity:6651777131674238976 ] 
   
   - We strongly reject the statement of the Co-Chair that our disclosure was done against the rules:   
   
   - In general, all of our disclosures have followed the rules of RFC 8681;
   - In particular, this disclosure, relevant for a contribution made by somebody else, is a “timely disclosure” because it was made by us promptly once we reached a belief of the relevancy of this specific patent. 
   
   - We reject the notion that we should have discussed the relevance of our disclosure either at a general meeting or in private emails, since the duty to disclose is personal to each participant.

   - We will not comment on the Co-Chair’s statement that she did not disclose this IPR because she did not feel that there was a direct relationship between the patent and RLC from its initial ID to the RFC, but are surprised that a Co-Chair would comment on the relevance of a disclosure of one of the contributors in light of the fact that RFC 8179 specifically states that the IETF will make no determination about the validity of any particular IPR claim. 

Best

Kavim Shroff

Information transmitted in or attached to this e-mail is intended only for the person or entity to which it is addressed, and may contain confidential and/or privileged material. If this email has been sent to you by mistake and you are not the intended recipient, please telephone or email the sender immediately and delete it from your system; do not read, copy or disclose its contents to anyone.. No responsibility is accepted by Code On for any loss or damage arising in any way from the receipt or use of this e-mail or its attachments. Please note that all e-mail messages are subject to interception for lawful business purposes.

Dear NWCRG list members:

There was a recent IPR disclosure related to RFC 8681 - Sliding Window Random Linear Code (RLC) Forward Erasure Correction (FEC) Schemes for FECFRAME -
https://datatracker.ietf.org/ipr/4069/ This refers to a patent that has me as co-inventor.  This disclosure puts me in a delicate position as the patent co-inventor hence someone who should have disclosed the IPR and at the same time as the NWCRG chair who has been following the RLC development since 2015 and should be impartial.
(w/o chair hat on) 1. This patent was submitted following some work I did as an MIT researcher in Muriel Médard’s laboratory and as such all my IPR is now owned by MIT for them to license at will. It is the licensee that made the disclosure, not MIT, not me or any of the patent co-inventors most of which have been or are still involved in the NWCRG. I was not made aware of the disclosure and have no relationship with the discloser but it puts me like I said in a delicate position.
According to RFC 8179 I should have disclosed this IPR at the time of the first ID in 2015 or throughout its evolution in the TSVWG from 2017-2019 and its presentations in the NWCRG meetings during that time if I felt that it was related to the work of RFC 8681. I understand the rules of 8179 for the need for timely disclosure. I did not disclose any IPR, as I did not feel that there was a direct relationship between the patent and RLC from its initial ID to the RFC. I also understand that the entity disclosing the IPR does not agree with me.

Since RFC 8681 is about developing a code with sliding windows and one that compared to the RLNC used in the patent does not allow for re-encoding. I believe our patent to be not directly related hence the reason I never pointed to the IPR. Of course the field of applicability of RFC 8681 includes wireless networks but also many others; applications are not crux of the RFC 8681. As a co-inventor I would have welcomed the discussion at our meetings or in private emails before the disclosures.
(with co-chair hat one) 2. Other co-inventors from MIT and now Harvard and the disclosing entity, via one of their representatives, were present at almost every NWCRG meetings throughout the development of the RLC since 2015 and are part of our mailing list. Our patent or any other that are now disclosed against RFC 8681 was pointed out as being related. Some of the concerned participants even supported the RLC work. There is a rule in IETF that is followed by the IRTF about "timely disclosures" of related IPR. I am surprised that the disclosing entity took so long against the rule. And at every meeting we emphasized the IPR rules. 
Vincent and I welcome comments on this as we are strategizing for the future of the group.
mjm
Marie-José Montpetit, [email-masked]

---

From: Carsten Bormann <[email-masked]>
Date: Tue, 7 Apr 2020 11:53:46 +0200

On 2020-04-07, at 11:38, lloyd.wood=[email-masked] wrote:
> 
> The legal entity here is IETF LLC

None of us are acting as officers of the LLC.

Can we now go back to technical work, please?
This is not a list for armchair lawyering.

Grüße, Carsten

---

From: Colin Perkins <[email-masked]>
Date: Tue, 7 Apr 2020 12:53:09 +0100

> On 7 Apr 2020, at 10:53, Carsten Bormann <[email-masked]> wrote:

And Marie-Jose was clear that she was speaking as an individual participant, and not as RG co-chair, when giving her opinion on the relation of the patent to RFC 8681.

Colin