Subject: [nwcrg] NWCRG meeting@ietf109 follow-up…

From: Vincent Roca <[email-masked]>
Date: Wed, 18 Nov 2020 08:36:27 +0100

Dear all,

Since we run short of time during our meeting yesterday (sorry for that), here are a few additional items to discuss on the list:

##1  BATS I-D adoption as RG Item

Main comment during adoption call (in September) was about the lack of research perspective, the ID being more a specification IETF document than an IRTF document.
Authors updated their ID in the -04 version, adding in particular section 6. « Data Delivery Protocol Considerations ».
NWCRG chairs think it’s a good initiative, but it still lacks the required depth. Chairs also think It should not be very difficult to add a more detailed discussion, given the 
major academic background and reputation of the team, given the practical experience gained by the team during field experiments.
Adding this discussion would highlight the way BATS codes can answer some of these challenges.

Chairs believe we have a small but sufficient set of reviewers (although small, 2-3 people) for adoption, and since the ID is already in good shape, finishing the NWCRG 
work mid-2021 seems feasible.

————
Suggestion: adopt it as RG Item document.

@all: raise your hand if you object by next week.
————

##2  NC for CCN/NDN: Requirements and Challenges

The NWCRG chairs think the ID is almost ready for IRSG, it’s just a matter of revising the ID to reflect yesterday’s comments (no serious issue was found).

————
@ICNRG chairs: Do you agree?
————

##3   About « Coding for QUIC » and « RLC Forward Erasure Correction (FEC) Schemes for QUIC »  I-Ds

No decision has been taken by authors regarding the strategy: keep it as NWCRG informational document, or move them to QUIC IETF WG.
The work on multipath QUIC could justify moving IDs there.

Authors will determine a strategy by IETF110.

##4  « Tetrys, an On-the-Fly Network Coding protocol » 

@Authors: what do you want/intend to do?

Cheers,

   Marie-Jose and Vincent

---

From: Emmanuel Lochin <[email-masked]>
Date: Wed, 18 Nov 2020 10:50:18 +0100

Dear all,

> @Authors: what do you want/intend to do?

We did not receive any feedback for a long time, and we only have slight 
modifications to add.
So we expect to update it in the next days. We are still interested in 
pursuing the whole process.

EL

-- 
Emmanuel LOCHIN
ENAC - Ecole Nationale de l'Aviation Civile
7, avenue Edouard Belin CS 54005, 31055 Toulouse Cedex 4 France
http://www.enac.fr
https://elochin.github.io/

---

From: "Morten V. Pedersen" <[email-masked]>
Date: Wed, 18 Nov 2020 12:35:26 +0100

Dear all,
Since there was no time for questions yesterday feel free to also put 
you questions to the repair patterns talk here - and I'll do my best to 
answer.

You can find some of the motivation behind the talk here:
https://www.steinwurf.com/blog/2020-10-30-content-aware-ecc-fec.html

Which shows the repair pattern concerns wrt. FEC/ECC coding a video stream.

All the best,
Morten

On 18.11.20 08:36, Vincent Roca wrote:
> Dear all,
>
> Since we run short of time during our meeting yesterday (sorry for 
> that), here are a few additional items to discuss on the list:
>
>
> *##1  BATS I-D adoption as RG Item*
>
> Main comment during adoption call (in September) was about the lack of 
> research perspective, the ID being more a specification IETF document 
> than an IRTF document.
> Authors updated their ID in the -04 version, adding in particular 
> section 6. « Data Delivery Protocol Considerations ».
> NWCRG chairs think it’s a good initiative, but it still lacks the 
> required depth. Chairs also think It should not be very difficult to 
> add a more detailed discussion, given the
> major academic background and reputation of the team, given the 
> practical experience gained by the team during field experiments.
> Chairs believe we have a small but sufficient set of reviewers 
> (although small, 2-3 people) for adoption, and since the ID is already 
> in good shape, finishing the NWCRG
> *@all:* raise your hand if you object by next week.
> ————
>
>
> *##2  NC for CCN/NDN: Requirements and Challenges*
>
> The NWCRG chairs think the ID is almost ready for IRSG, it’s just a 
> matter of revising the ID to reflect yesterday’s comments (no serious 
> issue was found).
>
> ————
> *@ICNRG chairs:* Do you agree?
> ————
>
>
> *##3   About « Coding for QUIC » and « RLC Forward Erasure Correction 
> (FEC) Schemes for QUIC »  I-Ds
> *
> No decision has been taken by authors regarding the strategy: keep it 
> as NWCRG informational document, or move them to QUIC IETF WG.
> *##4  « Tetrys, an On-the-Fly Network Coding protocol »
> *
> _______________________________________________
> nwcrg mailing list
> [email-masked]
> https://www.irtf.org/mailman/listinfo/nwcrg

---

From: "David R. Oran" <[email-masked]>
Date: Wed, 18 Nov 2020 09:29:00 -0500

Few comments embedded:

> @all: raise your hand if you object by next week.
No objection but a potentially good research connection is the recent 
work by Mike Luby and John Byers published at this year’s UCN 
conference, which might connect well with using BATS in an experimental 
setting to validate their coding-centric ICN architecture. Coding folks 
should definitely read the paper: 
https://dl.acm.org/doi/10.1145/3405656.3418710

> matter of revising the ID to reflect yesterday’s comments (no 
> serious issue was found).
>
> ————
Yes for my part. Please also check with Dirk.

> The work on multipath QUIC could justify moving IDs there.
I suspect it’s likely to be a better home since for me the only 
researchy aspects (as opposed to engineering questions) are related to 
congestion control, which we are going to continue to noodle on in NWCRG

DaveO

---

From: "Dirk Kutscher" <[email-masked]>
Date: Wed, 18 Nov 2020 15:31:50 +0100

> Yes for my part. Please also check with Dirk.

Yes -- thanks!

Dirk

---

From: whyeung <[email-masked]>
Date: Wed, 18 Nov 2020 22:34:03 +0800

Many thanks, Dave.

Raymond

> On 18 Nov 2020, at 10:29 PM, David R. Oran <[email-masked]> wrote:
> 
> Few comments embedded:
> 
> No objection but a potentially good research connection is the recent work by Mike Luby and John Byers published at this year’s UCN conference, which might connect well with using BATS in an experimental setting to validate their coding-centric ICN architecture. Coding folks should definitely read the paper: https://dl.acm.org/doi/10.1145/3405656.3418710
> 
>> 
>> 
> I suspect it’s likely to be a better home since for me the only researchy aspects (as opposed to engineering questions) are related to congestion control, which we are going to continue to noodle on in NWCRG
>

---

From: Vincent Roca <[email-masked]>
Date: Fri, 27 Nov 2020 15:31:01 +0100

Dear all,

Following our email from last week and feedback received on the list:

- we adopt BATS I-D as RG Item document.
	Status has been changed accordingly in the datatracker. 
	@authors: please, next time you submit an update, change the name for: draft-irtf-nwcrg-bats-code-00

- about draft-matsuzono-nwcrg-nwc-ccn-req:
	Given ICNRG approval, once the I-D is updated to take into account Vincent’s feedback, we will hand the I-D to IRSG.
	@authors: we’re waiting for an update

Thank you.

Regards,

   Marie-José and Vincent

> Le 18 nov. 2020 à 08:36, Vincent Roca <[email-masked]> a écrit :
> 
> Dear all,
>