Subject: Re: [nwcrg] [icnrg] low-latency and scalable video distribution

From: Marie-Jose Montpetit <[email-masked]>
Date: Wed, 23 Mar 2022 06:44:07 -0400

Many use cases seem to suggest reasons to bring back coding in QUIC.

mjm

Marie-José Montpetit, Ph.D.
[email-masked]

From: Dirk Kutscher <[email-masked]> <[email-masked]>
Reply: Dirk Kutscher <[email-masked]> <[email-masked]>
Date: March 23, 2022 at 6:22:24 AM
To: ICNRG <[email-masked]> <[email-masked]>
Subject:  Re: [icnrg] low-latency and scalable video distribution

Here is a comprehensive presentation that includes most of the aspects I
mentioned:

https://datatracker.ietf.org/meeting/113/materials/slides-113-moq-5-range-of-architectures-00

Dirk

On 23 Mar 2022, at 11:19, Dirk Kutscher wrote:

Hello,

in case you missed it, the MOQ (Media over QUIC,
https://datatracker.ietf.org/meeting/113/materials/agenda-113-moq-06) BOF
at IETF-113 is discussing low-latency video distribution use cases.

The idea is to reduce latency for live streaming, i.e., achieving
interactive conferencing latency without losing scalability.

The current thinking is using either RUSH (
https://datatracker.ietf.org/doc/html/draft-kpugin-rush-00) or SRT over
QUIC (meh ;-).

I believe that eventual solutions will have to do with stream
prioritization, "relaxed" congestion control and incorporating the concept
of relays.

Other topics/ideas that came up:

   - application layer multicast
   - local retransmissions
   - content naming

Maybe something to look into from an ICN perspective...

Dirk
------------------------------

icnrg mailing list
[email-masked]
https://www.irtf.org/mailman/listinfo/icnrg

_______________________________________________
icnrg mailing list
[email-masked]
https://www.irtf.org/mailman/listinfo/icnrg

---

From: Dirk Kutscher <[email-masked]>
Date: Wed, 23 Mar 2022 11:55:16 +0100

I wouldn't start with the assumption that everything has to be based on a protocol with a connection-based security model.

Dirk