Subject: Re: [oam] [mpls-tp] IAB/IESG Joint Design Session on Forwarding Plane Operations, Administration and Maintenance

From: Alexander Vainshtein <[email-masked]>
Date: Fri, 8 Oct 2010 09:33:10 +0200

Ron, all,
As it happens neither I nor any of my colleagues will be able to attend.

I attach the position paper on the subject just in case.

Regards and apologies,
     Sasha

________________________________________
From: Alexander Vainshtein
Sent: Friday, September 24, 2010 11:44 PM
To: Ronald Bonica
Cc: Robert Rennison; Prashant Desai; Alexander Kugel; Rotem Cohen; Andrew Sergeev; Idan Kaspit; David VanRyzin; Jacob Ruthstein
Subject: RE: [mpls-tp] IAB/IESG Joint Design Session on Forwarding Plane Operations, Administration and Maintenance

Ron hi,
Please see attached a presentation prepared by my colleagues and myself.
I am sending it to you because I have not found any indications about how it should be submitted. And the deadline that has been announced seems quite close 9if not beyond us).
Unfortunately, converting this presentation to an I-D was not possible due to lack of time.

Regards,
     Sasha

-----Original Message-----
From: Alexander Vainshtein
Sent: Saturday, September 11, 2010 4:54 PM
To: 'Ronald Bonica'
Cc: Robert Rennison; Prashant Desai; Idan Kaspit; Alexander Kugel; Rotem Cohen; David VanRyzin
Subject: RE: [mpls-tp] IAB/IESG Joint Design Session on Forwarding Plane Operations, Administration and Maintenance

Ron,
My colleagues and I plan to submit a position paper for the Joint Design Session.
We would appreciate any tips regarding the submission process since the deadline is close but, as of writing this,  no information (beyond  the size - 1 to 5 pages) seems to be available.

Regards,
     Sasha

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Ronald Bonica
Sent: Friday, September 03, 2010 8:31 PM
To: [email-masked]; [email-masked]
Subject: [mpls-tp] IAB/IESG Joint Design Session on Forwarding Plane Operations, Administration and Maintenance

Folks,

Would anyone intending to submit a position paper please notify me privately?

                                         Ron

> ----- Original Message -----
> From: "IESG Secretary" <[email-masked]>
> To: "IETF Announcement list" <[email-masked]>
> Sent: Friday, August 20, 2010 7:36 PM
> Subject: IAB/IESG Joint Design Session on Forwarding Plane Operations,
> Administration and Maintenance
>
>
> > The IAB and IESG would like to announce a joint design session on
> > Forwarding Plane Operations, Administration and Maintenance (OAM) to
> be
> > held on October 12 through October 14 at George Mason University in
> > Fairfax, Virginia, USA.
> >
> > IP and ICMP support very simple forwarding plane diagnostic tools
> (e.g.,
> > PING, TRACEROUTE). During the Internet's first decades, these tools
> > fulfilled most operational requirements. However, during the last
> decade,
> > network operators have deployed many technologies that rely upon
> > tunneling. These technologies include Pseudo-wires, Layer 2 Virtual
> > Private Networks, and Layer 3 Virtual Private Networks. While the
> internet
> > community has enhanced its forwarding plane diagnostic tool kit with
> the
> > deployment of Bidirectional Forwarding Detection (BFD), some suggest
> that
> > the tool kit is still inadequate for tunneled applications.
> >
> > The purpose of this design session is to discover and document
> > operational requirements and constraints for tunneled forwarding
> plane
> > OAM. The design session will also entertain solution proposals.
> > While
> most
> > activity in this area has been associated with Multi-Protocol Label
> > Switching (MPLS), session organizers also encourage generic
> > proposals
> that
> > include other tunneling mechanisms (e.g., IP-in-IP).
> >
> > The scope of this design session is limited to the forwarding plane.
> > Proposals concerning control and management plane protocols will not
> be
> > accepted. For example, a proposal that probes a tunnel for
> > continuity would be acceptable, while a proposal for reporting
> > tunnel continuity
> to a
> > routing protocol or management station would be productive, but
> beyond the
> > scope of this workshop.
> >
> > Those intending to make presentations must submit position papers to
> the
> > IAB/IESG by September 24. Position papers should constitute one to
> five
> > pages on the problem or solution space, with a particular emphasis
> > on areas that the IETF should address or revisit. Evaluation of the
> position
> > papers will be performed by a committee consisting of IESG and IAB
> > members. A limited number of seats will be available for persons not
> > presenting.
> >
> > Position papers will be made publicly available. On the basis of the
> > position papers, a number of invited speakers will be asked to
> present at
> > the workshop. A final agenda with timeslots will be published by
> October
> > 1.
> >
> >
> > Further information about position paper submission procedures are
> > forthcoming. Interested parties are advised to subscribe to the oam
> at
> > ietf.org mailing list for discussion and announcements related to
> > the workshop. Additional information will be available at
> > http://www3.tools.ietf.org/area/ops/trac/wiki/oamJDS.
> >
> > Ron Bonica, IESG
> > Danny McPherson, IAB
> > Hannes Tschofenig, IAB
_______________________________________________
mpls-tp mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/mpls-tp

---

From: Ronald Bonica <[email-masked]>
Date: Fri, 8 Oct 2010 12:16:52 -0400

Would any of you be available to present remotely?

                              Ron

> From: Alexander Vainshtein [mailto:[email-masked]]
> Sent: Friday, October 08, 2010 3:33 AM
> To: Ronald Bonica
> Cc: Robert Rennison; Prashant Desai; Alexander Kugel; Rotem Cohen;
> Andrew Sergeev; Idan Kaspit; David VanRyzin; Jacob Ruthstein;
> [email-masked]
> Subject: RE: [mpls-tp] IAB/IESG Joint Design Session on Forwarding
> Plane Operations, Administration and Maintenance
> 
> Ron, all,
> Cc: Robert Rennison; Prashant Desai; Alexander Kugel; Rotem Cohen;
> Andrew Sergeev; Idan Kaspit; David VanRyzin; Jacob Ruthstein
> Subject: RE: [mpls-tp] IAB/IESG Joint Design Session on Forwarding
> Plane Operations, Administration and Maintenance
> 
> Ron hi,
> I am sending it to you because I have not found any indications about
> how it should be submitted. And the deadline that has been announced
> seems quite close 9if not beyond us).
> Subject: RE: [mpls-tp] IAB/IESG Joint Design Session on Forwarding
> Plane Operations, Administration and Maintenance
> 
> Ron,
> We would appreciate any tips regarding the submission process since the
> deadline is close but, as of writing this,  no information (beyond  the
> size - 1 to 5 pages) seems to be available.
> 
> Regards,
>      Sasha
> 
> Subject: [mpls-tp] IAB/IESG Joint Design Session on Forwarding Plane
> Operations, Administration and Maintenance
> 
> Folks,
>

---

From: Greg Mirsky <[email-masked]>
Date: Fri, 8 Oct 2010 11:14:13 -0700

Dear Sasha,
I hope there will be presentation or an IETF submission. In the meantime
I've got couple questions listed below:

   - slide #2 do you mean "Connectivity Verification" or it was intended to
   be "Continuity Verification"?
   - do you see CV as exclusively on-demand tool that can not, would not be
   used as proactive tool?
   - slide #5 is Forward Defect Notification used interchangeably with FDI
   (Indication)?
   - slide #5 do you see FRR in MPLS-TP beyond unidirectional MPLS-TP LSP?
   - slide #7 first node D listed as MEP even though LSP path characterized
   as A->B->C->D->E. Then node E referenced as MEP ("FDI is received ...")
   - Regarding you concern shouldn't the head-end node A inform E that
   condition was cleared after node A receives Path Error message Tunnel
   Locally Repaired? It would be preferable to inform node C but it might not
   be reachable via G-ACh.

Regards,
Greg

On Fri, Oct 8, 2010 at 12:33 AM, Alexander Vainshtein <
[email-masked]> wrote:

> Cc: Robert Rennison; Prashant Desai; Alexander Kugel; Rotem Cohen; Andrew
> Sergeev; Idan Kaspit; David VanRyzin; Jacob Ruthstein
> Subject: RE: [mpls-tp] IAB/IESG Joint Design Session on Forwarding Plane
> I am sending it to you because I have not found any indications about how
> it should be submitted. And the deadline that has been announced seems quite
> close 9if not beyond us).
> Subject: RE: [mpls-tp] IAB/IESG Joint Design Session on Forwarding Plane
> deadline is close but, as of writing this,  no information (beyond  the size
> - 1 to 5 pages) seems to be available.
>
> Regards,
>     Sasha
>
> oam mailing list
> https://www.ietf.org/mailman/listinfo/oam
>
>

---

From: Robert Rennison <[email-masked]>
Date: Sat, 9 Oct 2010 10:17:37 -0400

Ron,

I've managed to change my plans will be able to attend in person.

Cheers

Rob Rennison

______________
From: Ronald Bonica [[email-masked]]
Sent: Friday, October 08, 2010 12:16 PM
To: Alexander Vainshtein
Cc: Robert Rennison; Prashant Desai; Alexander Kugel; Rotem Cohen; Andrew Sergeev; Idan Kaspit; David VanRyzin; Jacob Ruthstein; [email-masked]
Subject: RE: [mpls-tp] IAB/IESG Joint Design Session on Forwarding Plane Operations, Administration and Maintenance

                              Ron

---

From: Robert Rennison <[email-masked]>
Date: Sun, 10 Oct 2010 18:03:11 -0400

Greg,

Thanks for the comments. I'll answer since  Sasha  is on vacation and , hopefully, not reading too much email!.

> *   slide #2 do you mean "Connectivity Verification" or it was intended to be "Continuity Verification"?

Looks like  a typo to me,  the two bullets should be 
Continuity Check (proactive)
Connectivity Verification (on-demand)

 >*   do you see CV as exclusively on-demand tool that can not, would not be used as proactive tool?

I see CV more as a commissioning troubleshooting thing, rather than as proactive. It  should of course be possible to use it as  be a proactive function but in its default mode I'd think of it as more of a troubleshooting mechanism.

> *   slide #5 is Forward Defect Notification used interchangeably with FDI (Indication)?
It is being used synonymously here.

 *   slide #5 do you see FRR in MPLS-TP beyond unidirectional MPLS-TP LSP?

> *   slide #7 first node D listed as MEP even though LSP path characterized as A->B->C->D->E. Then node E referenced as MEP ("FDI is received ...")
I agree Node E should be a MEP 

> *   Regarding you concern shouldn't the head-end node A inform E that condition was cleared after node A receives Path Error message Tunnel Locally Repaired? It would be preferable to inform node C but it might not be reachable via G-ACh.
I am sure one could code/specify ones way around this, I think the main point being made is that is that the presence of MPLS FRR can complicate life if FDI is being used. (Note I am not sure who is proposing to use it but I'm sure will hear on Tuesday)

Cheers

Rob

On Fri, Oct 8, 2010 at 12:33 AM, Alexander Vainshtein <[email-masked]<mailto:[email-masked]>> wrote:
Ron, all,
As it happens neither I nor any of my colleagues will be able to attend.

Regards and apologies,
    Sasha

Ron hi,

Regards,
    Sasha

-----Original Message-----
From: Alexander Vainshtein
Sent: Saturday, September 11, 2010 4:54 PM
To: 'Ronald Bonica'
Cc: Robert Rennison; Prashant Desai; Idan Kaspit; Alexander Kugel; Rotem Cohen; David VanRyzin
Subject: RE: [mpls-tp] IAB/IESG Joint Design Session on Forwarding Plane Operations, Administration and Maintenance

Ron,

Regards,
    Sasha

-----Original Message-----
From: [email-masked]<mailto:[email-masked]> [mailto:[email-masked]<mailto:[email-masked]>] On Behalf Of Ronald Bonica
Sent: Friday, September 03, 2010 8:31 PM
To: [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>
Subject: [mpls-tp] IAB/IESG Joint Design Session on Forwarding Plane Operations, Administration and Maintenance

Folks,

                                        Ron

> From: "IESG Secretary" <[email-masked]<mailto:[email-masked]>>
> To: "IETF Announcement list" <[email-masked]<mailto:[email-masked]>>
> > ietf.org<http://ietf.org> mailing list for discussion and announcements related to
_______________________________________________
mpls-tp mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/mpls-tp

_______________________________________________
oam mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/oam

---

From: "David Harrington" <[email-masked]>
Date: Mon, 11 Oct 2010 14:39:27 -0400

Hi,

apologies for using this for attendee stuff, but there is no
OAMattendees list ;-)

I'm at the university. anybody else in town? interested in dinner?
(you should probably contact me directly so we don't have an archived
record of dinner plans ;-)

David Harrington
Director, IETF Transport Area
[email-masked] (preferred for ietf)
[email-masked]
+1 603 828 1401 (cell)
ietfdbh@gmail for jabber/googletalk

> From: [email-masked] [mailto:[email-masked]] On 
> Behalf Of Ronald Bonica
> Sent: Friday, October 08, 2010 12:17 PM
> To: Alexander Vainshtein
> Cc: Alexander Kugel; Andrew Sergeev; Prashant Desai; Idan 
> Kaspit; [email-masked]; VanRyzin; [email-masked]; Robert 
> Rennison; Jacob Ruthstein; Rotem Cohen
> Subject: Re: [oam] [mpls-tp] IAB/IESG Joint Design Session on 
> Forwarding Plane Operations, Administration and Maintenance
> 
[mailto:[email-masked]]
> > Unfortunately, converting this presentation to an I-D was 
> not possible
> > due to lack of time.
> > 
> > Regards,
> >      Sasha
> > 
> > From: [email-masked] [mailto:[email-masked]]
On
> > Behalf Of Ronald Bonica
> > > > Forwarding Plane Operations, Administration and 
> Maintenance (OAM)
> > to
> > > be
> > > > community has enhanced its forwarding plane diagnostic tool
kit
> > with
> > > > Proposals concerning control and management plane protocols
will
> > not
> > > > Those intending to make presentations must submit 
> position papers
> > to
> > > the
> > > > members. A limited number of seats will be available for
persons
> > not
> > > > presenting.
> > > >
> > > > Position papers will be made publicly available. On the basis
of