Subject: [oauth-ext-review] OAuth IANA Registration of Multiple Response Types

From: Mike Jones <[email-masked]>
Date: Mon, 3 Dec 2012 21:37:32 +0000

Hannes, as the designated expert, can you please approve this OAuth IANA registration request, per the procedures at http://tools.ietf.org/html/rfc6749#section-11.3?

                                                                Thank you,
                                                                -- Mike

From: Mike Jones
Sent: Sunday, October 14, 2012 1:00 PM
To: [email-masked]
Subject: Registration of Multiple Response Types

This is a request to register the response_type values defined in http://openid.net/specs/oauth-v2-multiple-response-types-1_0.html.  The individual response_type registration requests follow.

                                                            -- Mike

Response Type Name:  id_token
Change Controller:  OpenID Foundation Artifact Binding Working Group - [email-masked]<mailto:[email-masked]>
Specification Document(s):  http://openid.net/specs/oauth-v2-multiple-response-types-1_0.html

Response Type Name:  none
Change Controller:  OpenID Foundation Artifact Binding Working Group - [email-masked]<mailto:[email-masked]>
Specification Document(s):  http://openid.net/specs/oauth-v2-multiple-response-types-1_0.html

Response Type Name:  code token
Change Controller:  OpenID Foundation Artifact Binding Working Group - [email-masked]<mailto:[email-masked]>
Specification Document(s):  http://openid.net/specs/oauth-v2-multiple-response-types-1_0.html

Response Type Name:  code id_token
Change Controller:  OpenID Foundation Artifact Binding Working Group - [email-masked]<mailto:[email-masked]>
Specification Document(s):  http://openid.net/specs/oauth-v2-multiple-response-types-1_0.html

Response Type Name:  id_token token
Change Controller:  OpenID Foundation Artifact Binding Working Group - [email-masked]<mailto:[email-masked]>
Specification Document(s):  http://openid.net/specs/oauth-v2-multiple-response-types-1_0.html

Response Type Name:  code id_token token
Change Controller:  OpenID Foundation Artifact Binding Working Group - [email-masked]<mailto:[email-masked]>
Specification Document(s):  http://openid.net/specs/oauth-v2-multiple-response-types-1_0.html

---

From: "Hannes Tschofenig" <[email-masked]>
Date: Fri, 21 Dec 2012 12:04:26 +0100

Hi Mike, 

thank you for submitting this request for response types to this list. 

I have reviewed the request for correctness of the token syntax with the ABNF defined in http://tools.ietf.org/html/rfc6749, for conflict with already registered tokens at http://www.iana.org/assignments/oauth-parameters/oauth-parameters.xml, and the availability of the indicated specification. 

I approve the request. 

Ciao
Hannes

-------- Original-Nachricht --------
> Datum: Mon, 3 Dec 2012 21:37:32 +0000
> Von: Mike Jones <[email-masked]>
> An: Hannes Tschofenig <[email-masked]>
> CC: "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>
> Betreff: OAuth IANA Registration of Multiple Response Types

> Hannes, as the designated expert, can you please approve this OAuth IANA
> registration request, per the procedures at
> http://tools.ietf.org/html/rfc6749#section-11.3?
> 
>                                                                 Thank you,
>                                                                 -- Mike
> 
> From: Mike Jones
> This is a request to register the response_type values defined in
> http://openid.net/specs/oauth-v2-multiple-response-types-1_0.html.  The individual
> response_type registration requests follow.
> 
>                                                             -- Mike
> 
> Change Controller:  OpenID Foundation Artifact Binding Working Group -
> [email-masked]<mailto:[email-masked]>
> Specification Document(s): 
> http://openid.net/specs/oauth-v2-multiple-response-types-1_0.html
> 
> Response Type Name:  none
> Change Controller:  OpenID Foundation Artifact Binding Working Group -
> [email-masked]<mailto:[email-masked]>
> Specification Document(s): 
> http://openid.net/specs/oauth-v2-multiple-response-types-1_0.html
> 
> Change Controller:  OpenID Foundation Artifact Binding Working Group -
> [email-masked]<mailto:[email-masked]>
> Specification Document(s): 
> http://openid.net/specs/oauth-v2-multiple-response-types-1_0.html
> 
> Change Controller:  OpenID Foundation Artifact Binding Working Group -
> [email-masked]<mailto:[email-masked]>
> Specification Document(s): 
> http://openid.net/specs/oauth-v2-multiple-response-types-1_0.html
> 
> Change Controller:  OpenID Foundation Artifact Binding Working Group -
> [email-masked]<mailto:[email-masked]>
> Specification Document(s): 
> http://openid.net/specs/oauth-v2-multiple-response-types-1_0.html
> 
> Change Controller:  OpenID Foundation Artifact Binding Working Group -
> [email-masked]<mailto:[email-masked]>
> Specification Document(s): 
> http://openid.net/specs/oauth-v2-multiple-response-types-1_0.html
> 
>