Subject: [oauth-ext-review] Request to register OAuth parameters

From: Mike Jones <[email-masked]>
Date: Fri, 13 Nov 2015 19:47:24 +0000

Dear Designated Experts and IANA,

I am writing to you on behalf of the OpenID Connect Artifact Binding working group requesting to register the OAuth Dynamic Client Registration Metadata and OAuth Token Endpoint Authentication Methods parameters defined in http://openid.net/specs/openid-connect-registration-1_0-29.html#IANA.  The individual registration requests are repeated below.

These parameters were defined in the OpenID Dynamic Client Registration specification that became final in February, 2014.  Now that the OAuth Dynamic Client Registration Metadata registry and the OAuth Token Endpoint Authentication Methods registries have been established at http://www.iana.org/assignments/oauth-parameters/oauth-parameters.xhtml#client-metadata and http://www.iana.org/assignments/oauth-parameters/oauth-parameters.xhtml#token-endpoint-auth-method, those parameters not already registered by RFC 7591 are now being registered.

                                                            Thank you,
                                                            -- Mike

________________________________
 TOC <http://openid.net/specs/openid-connect-registration-1_0-29.html#toc>

10.1.  OAuth Dynamic Client Registration Metadata Registration

This specification registers the following client metadata definitions in the IANA "OAuth Dynamic Client Registration Metadata" registry [IANA.OAuth.Parameters]<http://openid.net/specs/openid-connect-registration-1_0-29.html#IANA.OAuth.Parameters> established by [RFC7591]<http://openid.net/specs/openid-connect-registration-1_0-29.html#RFC7591>:

________________________________
 TOC <http://openid.net/specs/openid-connect-registration-1_0-29.html#toc>

10.1.1.  Registry Contents
*        Client Metadata Name: application_type
*        Client Metadata Description: Kind of the application -- "native" or "web"
*        Change Controller: OpenID Foundation Artifact Binding Working Group - [email-masked]
*        Specification Document(s): Section 2 (Client Metadata)<http://openid.net/specs/openid-connect-registration-1_0-29.html#ClientMetadata> of this document
*        Client Metadata Name: sector_identifier_uri
*        Client Metadata Description: URL using the https scheme to be used in calculating Pseudonymous Identifiers by the OP
*        Change Controller: OpenID Foundation Artifact Binding Working Group - [email-masked]
*        Specification Document(s): Section 2 (Client Metadata)<http://openid.net/specs/openid-connect-registration-1_0-29.html#ClientMetadata> of this document
*        Client Metadata Name: subject_type
*        Client Metadata Description: subject_type requested for responses to this Client -- "pairwise" or "public"
*        Change Controller: OpenID Foundation Artifact Binding Working Group - [email-masked]
*        Specification Document(s): Section 2 (Client Metadata)<http://openid.net/specs/openid-connect-registration-1_0-29.html#ClientMetadata> of this document
*        Client Metadata Name: id_token_signed_response_alg
*        Client Metadata Description: JWS alg algorithm REQUIRED for signing the ID Token issued to this Client
*        Change Controller: OpenID Foundation Artifact Binding Working Group - [email-masked]
*        Specification Document(s): Section 2 (Client Metadata)<http://openid.net/specs/openid-connect-registration-1_0-29.html#ClientMetadata> of this document
*        Client Metadata Name: id_token_encrypted_response_alg
*        Client Metadata Description: JWE alg algorithm REQUIRED for encrypting the ID Token issued to this Client
*        Change Controller: OpenID Foundation Artifact Binding Working Group - [email-masked]
*        Specification Document(s): Section 2 (Client Metadata)<http://openid.net/specs/openid-connect-registration-1_0-29.html#ClientMetadata> of this document
*        Client Metadata Name: id_token_encrypted_response_enc
*        Client Metadata Description: JWE enc algorithm REQUIRED for encrypting the ID Token issued to this Client
*        Change Controller: OpenID Foundation Artifact Binding Working Group - [email-masked]
*        Specification Document(s): Section 2 (Client Metadata)<http://openid.net/specs/openid-connect-registration-1_0-29.html#ClientMetadata> of this document
*        Client Metadata Name: userinfo_signed_response_alg
*        Client Metadata Description: JWS alg algorithm REQUIRED for signing UserInfo Responses
*        Change Controller: OpenID Foundation Artifact Binding Working Group - [email-masked]
*        Specification Document(s): Section 2 (Client Metadata)<http://openid.net/specs/openid-connect-registration-1_0-29.html#ClientMetadata> of this document
*        Client Metadata Name: userinfo_encrypted_response_alg
*        Client Metadata Description: JWE alg algorithm REQUIRED for encrypting UserInfo Responses
*        Change Controller: OpenID Foundation Artifact Binding Working Group - [email-masked]
*        Specification Document(s): Section 2 (Client Metadata)<http://openid.net/specs/openid-connect-registration-1_0-29.html#ClientMetadata> of this document
*        Client Metadata Name: userinfo_encrypted_response_enc
*        Client Metadata Description: JWE enc algorithm REQUIRED for encrypting UserInfo Responses
*        Change Controller: OpenID Foundation Artifact Binding Working Group - [email-masked]
*        Specification Document(s): Section 2 (Client Metadata)<http://openid.net/specs/openid-connect-registration-1_0-29.html#ClientMetadata> of this document
*        Client Metadata Name: request_object_signing_alg
*        Client Metadata Description: JWS alg algorithm that MUST be used for signing Request Objects sent to the OP
*        Change Controller: OpenID Foundation Artifact Binding Working Group - [email-masked]
*        Specification Document(s): Section 2 (Client Metadata)<http://openid.net/specs/openid-connect-registration-1_0-29.html#ClientMetadata> of this document
*        Client Metadata Name: request_object_encryption_alg
*        Client Metadata Description: JWE alg algorithm the RP is declaring that it may use for encrypting Request Objects sent to the OP
*        Change Controller: OpenID Foundation Artifact Binding Working Group - [email-masked]
*        Specification Document(s): Section 2 (Client Metadata)<http://openid.net/specs/openid-connect-registration-1_0-29.html#ClientMetadata> of this document
*        Client Metadata Name: request_object_encryption_enc
*        Client Metadata Description: JWE enc algorithm the RP is declaring that it may use for encrypting Request Objects sent to the OP
*        Change Controller: OpenID Foundation Artifact Binding Working Group - [email-masked]
*        Specification Document(s): Section 2 (Client Metadata)<http://openid.net/specs/openid-connect-registration-1_0-29.html#ClientMetadata> of this document
*        Client Metadata Name: token_endpoint_auth_signing_alg
*        Client Metadata Description: JWS alg algorithm that MUST be used for signing the JWT used to authenticate the Client at the Token Endpoint for the private_key_jwt and client_secret_jwt authentication methods
*        Change Controller: OpenID Foundation Artifact Binding Working Group - [email-masked]
*        Specification Document(s): Section 2 (Client Metadata)<http://openid.net/specs/openid-connect-registration-1_0-29.html#ClientMetadata> of this document
*        Client Metadata Name: default_max_age
*        Client Metadata Description: Default Maximum Authentication Age
*        Change Controller: OpenID Foundation Artifact Binding Working Group - [email-masked]
*        Specification Document(s): Section 2 (Client Metadata)<http://openid.net/specs/openid-connect-registration-1_0-29.html#ClientMetadata> of this document
*        Client Metadata Name: require_auth_time
*        Client Metadata Description: Boolean value specifying whether the auth_time Claim in the ID Token is REQUIRED
*        Change Controller: OpenID Foundation Artifact Binding Working Group - [email-masked]
*        Specification Document(s): Section 2 (Client Metadata)<http://openid.net/specs/openid-connect-registration-1_0-29.html#ClientMetadata> of this document
*        Client Metadata Name: default_acr_values
*        Client Metadata Description: Default requested Authentication Context Class Reference values
*        Change Controller: OpenID Foundation Artifact Binding Working Group - [email-masked]
*        Specification Document(s): Section 2 (Client Metadata)<http://openid.net/specs/openid-connect-registration-1_0-29.html#ClientMetadata> of this document
*        Client Metadata Name: initiate_login_uri
*        Client Metadata Description: URI using the https scheme that a third party can use to initiate a login by the RP
*        Change Controller: OpenID Foundation Artifact Binding Working Group - [email-masked]
*        Specification Document(s): Section 2 (Client Metadata)<http://openid.net/specs/openid-connect-registration-1_0-29.html#ClientMetadata> of this document
*        Client Metadata Name: request_uris
*        Client Metadata Description: Array of request_uri values that are pre-registered by the RP for use at the OP
*        Change Controller: OpenID Foundation Artifact Binding Working Group - [email-masked]
*        Specification Document(s): Section 2 (Client Metadata)<http://openid.net/specs/openid-connect-registration-1_0-29.html#ClientMetadata> of this document

________________________________
 TOC <http://openid.net/specs/openid-connect-registration-1_0-29.html#toc>

10.2.  OAuth Token Endpoint Authentication Methods Registration

This specification registers the following token endpoint authentication methods in the IANA "OAuth Token Endpoint Authentication Methods" registry [IANA.OAuth.Parameters]<http://openid.net/specs/openid-connect-registration-1_0-29.html#IANA.OAuth.Parameters> established by [RFC7591]<http://openid.net/specs/openid-connect-registration-1_0-29.html#RFC7591>:

________________________________
 TOC <http://openid.net/specs/openid-connect-registration-1_0-29.html#toc>

10.2.1.  Registry Contents
*        Token Endpoint Authentication Method Name: client_secret_jwt
*        Change Controller: OpenID Foundation Artifact Binding Working Group - [email-masked]
*        Specification Document(s): Section 9 of OpenID Connect Core 1.0 [OpenID.Core] (Sakimura, N., Bradley, J., Jones, M., de Medeiros, B., and C. Mortimore, "OpenID Connect Core 1.0," August 2015.)<http://openid.net/specs/openid-connect-registration-1_0-29.html#OpenID.Core>
*        Token Endpoint Authentication Method Name: private_key_jwt
*        Change Controller: OpenID Foundation Artifact Binding Working Group - [email-masked]
*        Specification Document(s): Section 9 of OpenID Connect Core 1.0 [OpenID.Core] (Sakimura, N., Bradley, J., Jones, M., de Medeiros, B., and C. Mortimore, "OpenID Connect Core 1.0," August 2015.)<http://openid.net/specs/openid-connect-registration-1_0-29.html#OpenID.Core>

---

From: Hannes Tschofenig <[email-masked]>
Date: Tue, 24 Nov 2015 12:35:12 +0100

Hi Mike,

thanks for the request.

I have read through the list of items and I don't see a problem with the
proposed entries to the two registries. Hence, I approve them.

I only have one minor question: Do you think that the change controller
should be the 'OpenID Foundation Artifact Binding Working Group'? I
would have rather said that it would better be the OpenID Foundation in
general since that specific working group may not exist forever.

To IANA: Use the text from the original email since the text below seems
to be garbled. Also note that the words 'Section 2 of this document'
refer to Section 2 of this specification:
http://openid.net/specs/openid-connect-registration-1_0-29.html

Ciao
Hannes

On 11/13/2015 08:47 PM, Mike Jones wrote:
> I am writing to you on behalf of the OpenID Connect Artifact Binding
> working group requesting to register the OAuth Dynamic Client
> Registration Metadata and OAuth Token Endpoint Authentication Methods
> parameters defined in
> http://openid.net/specs/openid-connect-registration-1_0-29.html#IANA. 
> The individual registration requests are repeated below.
> 
>  
> 
> These parameters were defined in the OpenID Dynamic Client Registration
> specification that became final in February, 2014.  Now that the OAuth
> Dynamic Client Registration Metadata registry and the OAuth Token
> Endpoint Authentication Methods registries have been established at
> http://www.iana.org/assignments/oauth-parameters/oauth-parameters.xhtml#client-metadata
> and
> http://www.iana.org/assignments/oauth-parameters/oauth-parameters.xhtml#token-endpoint-auth-method,
> those parameters not already registered by RFC 7591 are now being
> registered.
> 
>  
> 
>                                                             Thank you,
> 
>                                                             -- Mike
> 
>  
> 
> ------------------------------------------------------------------------
> 
> * TOC *
> <http://openid.net/specs/openid-connect-registration-1_0-29.html#toc>
> 
> 
> This specification registers the following client metadata definitions
> in the IANA "OAuth Dynamic Client Registration Metadata" registry
> [IANA.OAuth.Parameters]
> <http://openid.net/specs/openid-connect-registration-1_0-29.html#IANA.OAuth.Parameters>
> established by [RFC7591]
> <http://openid.net/specs/openid-connect-registration-1_0-29.html#RFC7591>:
> 
>  
> 
> ------------------------------------------------------------------------
> 
> * TOC *
> <http://openid.net/specs/openid-connect-registration-1_0-29.html#toc>
> 
> 
> ·        Client Metadata Name: application_type
> 
> ·        Client Metadata Description: Kind of the application --
> "native" or "web"
> 
> ·        Change Controller: OpenID Foundation Artifact Binding Working
> Group - [email-masked]
> 
> ·        Specification Document(s): Section 2 (Client Metadata)
> <http://openid.net/specs/openid-connect-registration-1_0-29.html#ClientMetadata>
> of this document
> 
> ·        Client Metadata Name: sector_identifier_uri
> 
> ·        Client Metadata Description: URL using the httpsscheme to be
> used in calculating Pseudonymous Identifiers by the OP
> 
> ·        Change Controller: OpenID Foundation Artifact Binding Working
> Group - [email-masked]
> 
> ·        Specification Document(s): Section 2 (Client Metadata)
> <http://openid.net/specs/openid-connect-registration-1_0-29.html#ClientMetadata>
> of this document
> 
> ·        Client Metadata Name: subject_type
> 
> ·        Client Metadata Description: subject_typerequested for
> responses to this Client -- "pairwise" or "public"
> 
> ·        Change Controller: OpenID Foundation Artifact Binding Working
> Group - [email-masked]
> 
> ·        Specification Document(s): Section 2 (Client Metadata)
> <http://openid.net/specs/openid-connect-registration-1_0-29.html#ClientMetadata>
> of this document
> 
> ·        Client Metadata Name: id_token_signed_response_alg
> 
> ·        Client Metadata Description: JWS algalgorithm REQUIRED for
> signing the ID Token issued to this Client
> 
> ·        Change Controller: OpenID Foundation Artifact Binding Working
> Group - [email-masked]
> 
> ·        Specification Document(s): Section 2 (Client Metadata)
> <http://openid.net/specs/openid-connect-registration-1_0-29.html#ClientMetadata>
> of this document
> 
> ·        Client Metadata Name: id_token_encrypted_response_alg
> 
> ·        Client Metadata Description: JWE algalgorithm REQUIRED for
> encrypting the ID Token issued to this Client
> 
> ·        Change Controller: OpenID Foundation Artifact Binding Working
> Group - [email-masked]
> 
> ·        Specification Document(s): Section 2 (Client Metadata)
> <http://openid.net/specs/openid-connect-registration-1_0-29.html#ClientMetadata>
> of this document
> 
> ·        Client Metadata Name: id_token_encrypted_response_enc
> 
> ·        Client Metadata Description: JWE encalgorithm REQUIRED for
> encrypting the ID Token issued to this Client
> 
> ·        Change Controller: OpenID Foundation Artifact Binding Working
> Group - [email-masked]
> 
> ·        Specification Document(s): Section 2 (Client Metadata)
> <http://openid.net/specs/openid-connect-registration-1_0-29.html#ClientMetadata>
> of this document
> 
> ·        Client Metadata Name: userinfo_signed_response_alg
> 
> ·        Client Metadata Description: JWS algalgorithm REQUIRED for
> signing UserInfo Responses
> 
> ·        Change Controller: OpenID Foundation Artifact Binding Working
> Group - [email-masked]
> 
> ·        Specification Document(s): Section 2 (Client Metadata)
> <http://openid.net/specs/openid-connect-registration-1_0-29.html#ClientMetadata>
> of this document
> 
> ·        Client Metadata Name: userinfo_encrypted_response_alg
> 
> ·        Client Metadata Description: JWE algalgorithm REQUIRED for
> encrypting UserInfo Responses
> 
> ·        Change Controller: OpenID Foundation Artifact Binding Working
> Group - [email-masked]
> 
> ·        Specification Document(s): Section 2 (Client Metadata)
> <http://openid.net/specs/openid-connect-registration-1_0-29.html#ClientMetadata>
> of this document
> 
> ·        Client Metadata Name: userinfo_encrypted_response_enc
> 
> ·        Client Metadata Description: JWE encalgorithm REQUIRED for
> encrypting UserInfo Responses
> 
> ·        Change Controller: OpenID Foundation Artifact Binding Working
> Group - [email-masked]
> 
> ·        Specification Document(s): Section 2 (Client Metadata)
> <http://openid.net/specs/openid-connect-registration-1_0-29.html#ClientMetadata>
> of this document
> 
> ·        Client Metadata Name: request_object_signing_alg
> 
> ·        Client Metadata Description: JWS algalgorithm that MUST be used
> for signing Request Objects sent to the OP
> 
> ·        Change Controller: OpenID Foundation Artifact Binding Working
> Group - [email-masked]
> 
> ·        Specification Document(s): Section 2 (Client Metadata)
> <http://openid.net/specs/openid-connect-registration-1_0-29.html#ClientMetadata>
> of this document
> 
> ·        Client Metadata Name: request_object_encryption_alg
> 
> ·        Client Metadata Description: JWE algalgorithm the RP is
> declaring that it may use for encrypting Request Objects sent to the OP
> 
> ·        Change Controller: OpenID Foundation Artifact Binding Working
> Group - [email-masked]
> 
> ·        Specification Document(s): Section 2 (Client Metadata)
> <http://openid.net/specs/openid-connect-registration-1_0-29.html#ClientMetadata>
> of this document
> 
> ·        Client Metadata Name: request_object_encryption_enc
> 
> ·        Client Metadata Description: JWE encalgorithm the RP is
> declaring that it may use for encrypting Request Objects sent to the OP
> 
> ·        Change Controller: OpenID Foundation Artifact Binding Working
> Group - [email-masked]
> 
> ·        Specification Document(s): Section 2 (Client Metadata)
> <http://openid.net/specs/openid-connect-registration-1_0-29.html#ClientMetadata>
> of this document
> 
> ·        Client Metadata Name: token_endpoint_auth_signing_alg
> 
> ·        Client Metadata Description: JWS algalgorithm that MUST be used
> for signing the JWT used to authenticate the Client at the Token
> Endpoint for the private_key_jwtand client_secret_jwtauthentication methods
> 
> ·        Change Controller: OpenID Foundation Artifact Binding Working
> Group - [email-masked]
> 
> ·        Specification Document(s): Section 2 (Client Metadata)
> <http://openid.net/specs/openid-connect-registration-1_0-29.html#ClientMetadata>
> of this document
> 
> ·        Client Metadata Name: default_max_age
> 
> ·        Client Metadata Description: Default Maximum Authentication Age
> 
> ·        Change Controller: OpenID Foundation Artifact Binding Working
> Group - [email-masked]
> 
> ·        Specification Document(s): Section 2 (Client Metadata)
> <http://openid.net/specs/openid-connect-registration-1_0-29.html#ClientMetadata>
> of this document
> 
> ·        Client Metadata Name: require_auth_time
> 
> ·        Client Metadata Description: Boolean value specifying whether
> the auth_timeClaim in the ID Token is REQUIRED
> 
> ·        Change Controller: OpenID Foundation Artifact Binding Working
> Group - [email-masked]
> 
> ·        Specification Document(s): Section 2 (Client Metadata)
> <http://openid.net/specs/openid-connect-registration-1_0-29.html#ClientMetadata>
> of this document
> 
> ·        Client Metadata Name: default_acr_values
> 
> ·        Client Metadata Description: Default requested Authentication
> Context Class Reference values
> 
> ·        Change Controller: OpenID Foundation Artifact Binding Working
> Group - [email-masked]
> 
> ·        Specification Document(s): Section 2 (Client Metadata)
> <http://openid.net/specs/openid-connect-registration-1_0-29.html#ClientMetadata>
> of this document
> 
> ·        Client Metadata Name: initiate_login_uri
> 
> ·        Client Metadata Description: URI using the httpsscheme that a
> third party can use to initiate a login by the RP
> 
> ·        Change Controller: OpenID Foundation Artifact Binding Working
> Group - [email-masked]
> 
> ·        Specification Document(s): Section 2 (Client Metadata)
> <http://openid.net/specs/openid-connect-registration-1_0-29.html#ClientMetadata>
> of this document
> 
> ·        Client Metadata Name: request_uris
> 
> ·        Client Metadata Description: Array of request_urivalues that
> are pre-registered by the RP for use at the OP
> 
> ·        Change Controller: OpenID Foundation Artifact Binding Working
> Group - [email-masked]
> 
> ·        Specification Document(s): Section 2 (Client Metadata)
> <http://openid.net/specs/openid-connect-registration-1_0-29.html#ClientMetadata>
> of this document
> 
>  
> 
> ------------------------------------------------------------------------
> 
> * TOC *
> <http://openid.net/specs/openid-connect-registration-1_0-29.html#toc>
> 
> 
> This specification registers the following token endpoint authentication
> methods in the IANA "OAuth Token Endpoint Authentication Methods"
> registry [IANA.OAuth.Parameters]
> <http://openid.net/specs/openid-connect-registration-1_0-29.html#IANA.OAuth.Parameters>
> established by [RFC7591]
> <http://openid.net/specs/openid-connect-registration-1_0-29.html#RFC7591>:
> 
>  
> 
> ------------------------------------------------------------------------
> 
> * TOC *
> <http://openid.net/specs/openid-connect-registration-1_0-29.html#toc>
> 
> 
> ·        Token Endpoint Authentication Method Name: client_secret_jwt
> 
> ·        Change Controller: OpenID Foundation Artifact Binding Working
> Group - [email-masked]
> 
> ·        Specification Document(s): Section 9 of OpenID Connect Core 1.0
> [OpenID.Core] (Sakimura, N., Bradley, J., Jones, M., de Medeiros, B.,
> and C. Mortimore, “OpenID Connect Core 1.0,” August 2015.)
> <http://openid.net/specs/openid-connect-registration-1_0-29.html#OpenID.Core>
> 
> 
> ·        Token Endpoint Authentication Method Name: private_key_jwt
> 
> ·        Change Controller: OpenID Foundation Artifact Binding Working
> Group - [email-masked]
> 
> ·        Specification Document(s): Section 9 of OpenID Connect Core 1.0
> [OpenID.Core] (Sakimura, N., Bradley, J., Jones, M., de Medeiros, B.,
> and C. Mortimore, “OpenID Connect Core 1.0,” August 2015.)
> <http://openid.net/specs/openid-connect-registration-1_0-29.html#OpenID.Core>
> 
> 
>  
>

---

From: Mike Jones <[email-masked]>
Date: Wed, 25 Nov 2015 04:57:35 +0000

All the existing OpenID Connect registrations at http://www.iana.org/assignments/oauth-parameters/oauth-parameters.xhtml already list the OpenID Foundation Artifact Binding Working Group as the change controller.  Consistency argues for all them being the same.

Given that the OpenID Foundation is listed, should the working group be closed, the foundation would be able to take over as the change controller anyway.

				-- Mike

-----Original Message-----
From: Hannes Tschofenig [mailto:[email-masked]] 
Sent: Tuesday, November 24, 2015 3:35 AM
To: Mike Jones <[email-masked]>; [email-masked]
Subject: Re: Request to register OAuth parameters

Hi Mike,

thanks for the request.

I have read through the list of items and I don't see a problem with the proposed entries to the two registries. Hence, I approve them.

I only have one minor question: Do you think that the change controller should be the 'OpenID Foundation Artifact Binding Working Group'? I would have rather said that it would better be the OpenID Foundation in general since that specific working group may not exist forever.

To IANA: Use the text from the original email since the text below seems to be garbled. Also note that the words 'Section 2 of this document'
refer to Section 2 of this specification:
http://openid.net/specs/openid-connect-registration-1_0-29.html

Ciao
Hannes

On 11/13/2015 08:47 PM, Mike Jones wrote:
> These parameters were defined in the OpenID Dynamic Client 
> Registration specification that became final in February, 2014.  Now 
> that the OAuth Dynamic Client Registration Metadata registry and the 
> OAuth Token Endpoint Authentication Methods registries have been 
> established at 
> http://www.iana.org/assignments/oauth-parameters/oauth-parameters.xhtm
> l#token-endpoint-auth-method, those parameters not already registered 
> by RFC 7591 are now being registered.
> 
>  
> 
>                                                             Thank you,
> 
>                                                             -- Mike
> 
>  
> 
> *        Specification Document(s): Section 2 (Client Metadata)
> *        Client Metadata Description: URL using the httpsscheme to be
> *        Specification Document(s): Section 2 (Client Metadata)
> *        Client Metadata Description: subject_typerequested for
> *        Specification Document(s): Section 2 (Client Metadata)
> *        Client Metadata Description: JWS algalgorithm REQUIRED for
> *        Specification Document(s): Section 2 (Client Metadata)
> *        Client Metadata Description: JWE algalgorithm REQUIRED for
> *        Specification Document(s): Section 2 (Client Metadata)
> *        Client Metadata Description: JWE encalgorithm REQUIRED for
> *        Specification Document(s): Section 2 (Client Metadata)
> *        Client Metadata Description: JWS algalgorithm REQUIRED for
> *        Specification Document(s): Section 2 (Client Metadata)
> *        Client Metadata Description: JWE algalgorithm REQUIRED for
> *        Specification Document(s): Section 2 (Client Metadata)
> *        Client Metadata Description: JWE encalgorithm REQUIRED for
> *        Specification Document(s): Section 2 (Client Metadata)
> *        Client Metadata Description: JWS algalgorithm that MUST be used
> *        Specification Document(s): Section 2 (Client Metadata)
> *        Client Metadata Description: JWE algalgorithm the RP is
> *        Specification Document(s): Section 2 (Client Metadata)
> *        Client Metadata Description: JWE encalgorithm the RP is
> *        Specification Document(s): Section 2 (Client Metadata)
> *        Client Metadata Description: JWS algalgorithm that MUST be used
> *        Specification Document(s): Section 2 (Client Metadata)
> *        Specification Document(s): Section 2 (Client Metadata)
> *        Client Metadata Description: Boolean value specifying whether
> *        Specification Document(s): Section 2 (Client Metadata)
> *        Specification Document(s): Section 2 (Client Metadata)
> *        Client Metadata Description: URI using the httpsscheme that a
> *        Specification Document(s): Section 2 (Client Metadata)
> *        Client Metadata Description: Array of request_urivalues that
> *        Specification Document(s): Section 2 (Client Metadata)
> This specification registers the following token endpoint 
> authentication methods in the IANA "OAuth Token Endpoint Authentication Methods"
> *        Specification Document(s): Section 9 of OpenID Connect Core 1.0
> and C. Mortimore, "OpenID Connect Core 1.0," August 2015.) 
> *        Specification Document(s): Section 9 of OpenID Connect Core 1.0
> and C. Mortimore, "OpenID Connect Core 1.0," August 2015.)

---

From: Hannes Tschofenig <[email-masked]>
Date: Wed, 25 Nov 2015 23:42:39 +0100

Thanks for the quick response.

This makes sense. Keep the OpenID Foundation Artifact Binding Working
Group as the change controller for consistency reasons; the OpenID
Foundation will have to figure out who the appropriate contact point
will be after the close the working group.

I consider my review as completed.

Ciao
Hannes

On 11/25/2015 05:57 AM, Mike Jones wrote:
>> l#client-metadata

---

From: Hannes Tschofenig <[email-masked]>
Date: Thu, 26 Nov 2015 19:44:12 +0100

Dear IANA,

I did my review of the request below and my questions have been
answered. Please add the requested entries to the registry.

Ciao
Hannes

-------- Forwarded Message --------
Subject: Re: Request to register OAuth parameters
Date: Wed, 25 Nov 2015 23:42:39 +0100
From: Hannes Tschofenig <[email-masked]>
To: Mike Jones <[email-masked]>, [email-masked]
<[email-masked]>

Ciao
Hannes