Subject: [oauth-ext-review] Request to register OAuth Authorization Server Metadata: claims_interaction_endpoint, uma_profiles_supported, permission_endpoint, resource_registration_endpoint

From: Eve Maler <[email-masked]>
Date: Fri, 16 Jun 2017 17:40:38 -0700

As required by draft-ietf-oauth-discovery (currently at 06) Section 7, the
authors of the specifications User-Managed Access (UMA) 2.0 Grant for OAuth
2.0 Authorization
<https://docs.kantarainitiative.org/uma/wg/oauth-uma-grant-2.0-05.html>
and Federated
Authorization for User-Managed Access (UMA) 2.0
<https://docs.kantarainitiative.org/uma/wg/oauth-uma-federated-authz-2.0-05.html>
are
requesting to register the following four items of OAuth Authorization
Server Metadata:

   - For the UMA Grant spec (metadata definitions appear in Section 2
   <https://docs.kantarainitiative.org/uma/wg/oauth-uma-grant-2.0-05.html#as-config>;
   IANA request appears in Section 7.2
   <https://docs.kantarainitiative.org/uma/wg/oauth-uma-grant-2.0-05.html#rfc.section.7.2>
   ):
      - claims_interaction_endpoint
      - uma_profiles_supported
   - For the UMA Federated Authorization spec (metadata definitions appear
   in Section 2
   <https://docs.kantarainitiative.org/uma/wg/oauth-uma-federated-authz-2.0-05.html#as-config>;
   IANA request appears in Section 9.1
   <https://docs.kantarainitiative.org/uma/wg/oauth-uma-federated-authz-2.0-05.html#rfc.section.9.1>
   ):
      - permission_endpoint
      - resource_registration_endpoint

Thank you. We look forward to your response.

*Eve Maler*ForgeRock Office of the CTO | VP Innovation & Emerging Technology
Cell +1 425.345.6756 | Skype: xmlgrrl | Twitter: @xmlgrrl

---

From: Mike Jones <[email-masked]>
Date: Wed, 28 Jun 2017 22:25:33 +0000

As I mentioned to you in person, Eve, this registry won’t exist until draft-ietf-oauth-discovery is an RFC.  Hopefully this will happen within a few months, at which point, your registration request can be considered.

                                                                Best wishes,
                                                                -- Mike

From: oauth-ext-review [mailto:[email-masked]] On Behalf Of Eve Maler
Sent: Friday, June 16, 2017 5:41 PM
To: [email-masked]
Cc: Maciej Machulak <[email-masked]>; Justin Richer <[email-masked]>
Subject: [oauth-ext-review] Request to register OAuth Authorization Server Metadata: claims_interaction_endpoint, uma_profiles_supported, permission_endpoint, resource_registration_endpoint

As required by draft-ietf-oauth-discovery (currently at 06) Section 7, the authors of the specifications User-Managed Access (UMA) 2.0 Grant for OAuth 2.0 Authorization<https://docs.kantarainitiative.org/uma/wg/oauth-uma-grant-2.0-05.html> and Federated Authorization for User-Managed Access (UMA) 2.0<https://docs.kantarainitiative.org/uma/wg/oauth-uma-federated-authz-2.0-05.html> are requesting to register the following four items of OAuth Authorization Server Metadata:

  *   For the UMA Grant spec (metadata definitions appear in Section 2<https://docs.kantarainitiative.org/uma/wg/oauth-uma-grant-2.0-05.html#as-config>; IANA request appears in Section 7.2<https://docs.kantarainitiative.org/uma/wg/oauth-uma-grant-2.0-05.html#rfc.section.7.2>):

     *   claims_interaction_endpoint
     *   uma_profiles_supported

  *   For the UMA Federated Authorization spec (metadata definitions appear in Section 2<https://docs.kantarainitiative.org/uma/wg/oauth-uma-federated-authz-2.0-05.html#as-config>; IANA request appears in Section 9.1<https://docs.kantarainitiative.org/uma/wg/oauth-uma-federated-authz-2.0-05.html#rfc.section.9.1>):

     *   permission_endpoint
     *   resource_registration_endpoint
Thank you. We look forward to your response.

Eve Maler
ForgeRock Office of the CTO | VP Innovation & Emerging Technology
Cell +1 425.345.6756 | Skype: xmlgrrl | Twitter: @xmlgrrl

---

From: Eve Maler <[email-masked]>
Date: Wed, 28 Jun 2017 15:46:34 -0700

Righto. :-) Should we keep this IANA request subsection in the spec, do you
think, and change it over into a note about it being a forward/future
reference?

On Wed, Jun 28, 2017 at 3:25 PM, Mike Jones <[email-masked]>
wrote:

> As I mentioned to you in person, Eve, this registry won’t exist until
> draft-ietf-oauth-discovery is an RFC.  Hopefully this will happen within a
> few months, at which point, your registration request can be considered.
>
>
>
>                                                                 Best
> wishes,
>
>                                                                 -- Mike
>
>
>
> *From:* oauth-ext-review [mailto:[email-masked]] *On
> Behalf Of *Eve Maler
> *Sent:* Friday, June 16, 2017 5:41 PM
> *To:* [email-masked]
> *Cc:* Maciej Machulak <[email-masked]>; Justin Richer <
> [email-masked]>
> *Subject:* [oauth-ext-review] Request to register OAuth Authorization
> Server Metadata: claims_interaction_endpoint, uma_profiles_supported,
> permission_endpoint, resource_registration_endpoint
>
>
>
> authors of the specifications User-Managed Access (UMA) 2.0 Grant for
> OAuth 2.0 Authorization
> <https://docs.kantarainitiative.org/uma/wg/oauth-uma-grant-2.0-05.html> and
> Federated Authorization for User-Managed Access (UMA) 2.0
> <https://docs.kantarainitiative.org/uma/wg/oauth-uma-federated-authz-2.0-05.html> are
>    - For the UMA Federated Authorization spec (metadata definitions
>    appear in Section 2
> *Eve Maler *ForgeRock Office of the CTO | VP Innovation & Emerging
> Technology
> Cell +1 425.345.6756 <(425)%20345-6756> | Skype: xmlgrrl | Twitter:
> @xmlgrrl
>

---

From: Mike Jones <[email-masked]>
Date: Wed, 28 Jun 2017 23:07:12 +0000

I’d just leave it in the spec.  Once AS Metadata is an RFC, we can then just act on it.

                                                                -- Mike

From: Eve Maler [mailto:[email-masked]]
Sent: Wednesday, June 28, 2017 3:47 PM
To: Mike Jones <[email-masked]>
Cc: [email-masked]; Maciej Machulak <[email-masked]>; Justin Richer <[email-masked]>
Subject: Re: [oauth-ext-review] Request to register OAuth Authorization Server Metadata: claims_interaction_endpoint, uma_profiles_supported, permission_endpoint, resource_registration_endpoint

Righto. :-) Should we keep this IANA request subsection in the spec, do you think, and change it over into a note about it being a forward/future reference?

Eve Maler

On Wed, Jun 28, 2017 at 3:25 PM, Mike Jones <[email-masked]<mailto:[email-masked]>> wrote:
As I mentioned to you in person, Eve, this registry won’t exist until draft-ietf-oauth-discovery is an RFC.  Hopefully this will happen within a few months, at which point, your registration request can be considered.

                                                                Best wishes,
                                                                -- Mike

From: oauth-ext-review [mailto:[email-masked]<mailto:[email-masked]>] On Behalf Of Eve Maler
Sent: Friday, June 16, 2017 5:41 PM
To: [email-masked]<mailto:[email-masked]>
Cc: Maciej Machulak <[email-masked]<mailto:[email-masked]>>; Justin Richer <[email-masked]<mailto:[email-masked]>>
Subject: [oauth-ext-review] Request to register OAuth Authorization Server Metadata: claims_interaction_endpoint, uma_profiles_supported, permission_endpoint, resource_registration_endpoint

     *   permission_endpoint

Eve Maler
ForgeRock Office of the CTO | VP Innovation & Emerging Technology
Cell +1 425.345.6756<tel:(425)%20345-6756> | Skype: xmlgrrl | Twitter: @xmlgrrl