Subject: [oauth-ext-review] Request for parameter name: device_code and 6 others

From: William Denniss <[email-masked]>
Date: Fri, 31 May 2019 15:22:17 -0700

Designated Experts,

The OAuth 2.0 Device Authorization Grant draft was approved for publication
and is currently in IANA*A state.

We are requesting the registration of 7 OAuth extension values, as
documented in section 7 of draft-ietf-oauth-device-flow-15.

https://tools.ietf.org/html/draft-ietf-oauth-device-flow-15#section-7

Kind regards,
William (on behalf of the authors)

---

From: Hannes Tschofenig <[email-masked]>
Date: Sat, 1 Jun 2019 06:56:14 +0000

Hi William,

I reviewed the request for parameters.

The document registers
• One OAuth parameters,
• One OAuth URI,
• several error values, and
• authorization server metadata.

The requested values are OK.

Just one minor nit:

The registry for the authorization server metadata is called “OAuth Authorization Server Metadata”  and the draft calls it “OAuth 2.0 Authorization Server Metadata”. The metadata description could be a bit more detailed by saying that the device_authorization_endpoint metadata is "The URL of the authorization server's device authorization  endpoint" rather than just "The Device Authorization Endpoint."

This is, however, only cosmetic.

Ciao
Hannes

From: William Denniss <[email-masked]>
Sent: Samstag, 1. Juni 2019 00:22
To: [email-masked]; Mike Jones <[email-masked]>; John Bradley <[email-masked]>; Hannes Tschofenig <[email-masked]>; Rifaat Shekh-Yusef <[email-masked]>
Subject: Request for parameter name: device_code and 6 others

Designated Experts,

The OAuth 2.0 Device Authorization Grant draft was approved for publication and is currently in IANA*A state.

We are requesting the registration of 7 OAuth extension values, as documented in section 7 of draft-ietf-oauth-device-flow-15.

Kind regards,

IMPORTANT NOTICE: The contents of this email and any attachments are confidential and may also be privileged. If you are not the intended recipient, please notify the sender immediately and do not disclose the contents to any other person, use it for any purpose, or store or copy the information in any medium. Thank you.