Subject: [oauth-ext-review] [IANA #1158951] Requested review for IANA registration in draft-ietf-ace-oauth-authz (oauth-parameters - OAuth Extensions Error, OAuth Access Token Types, OAuth Parameters, OAuth Token Introspection Response)

From: "Amanda Baber via RT" <[email-masked]>
Date: Tue, 07 Jan 2020 22:50:02 +0000

Hi Justin, all,

Because Hannes is both an author and the sole designated expert for the registries named in Sections 8.2, 8.5, and 8.8, Ben is reviewing those registrations for us. Of the sections listed below, we only need Justin to review this one:

https://tools.ietf.org/html/draft-ietf-ace-oauth-authz-29#section-8.10

We've sent Ben's questions/comments to the authors and chairs. 

Best regards,

Amanda Baber
Lead IANA Services Specialist

On Sat Dec 21 11:33:52 2019, [email-masked] wrote:
> Hello OAuth registry reviewers,
> 
> the IESG-designated experts for the OAuth parameters registry have asked
> me to send a review request to you about the OAuth parameters registered
> here:
> 
> https://tools.ietf.org/html/draft-ietf-ace-oauth-authz-29#section-8.2
> 
> and here:
> 
> https://tools.ietf.org/html/draft-ietf-ace-oauth-authz-29#section-8.5
> 
> and here:
> 
> https://tools.ietf.org/html/draft-ietf-ace-oauth-authz-29#section-8.8
> 
> and here:
> 
> https://tools.ietf.org/html/draft-ietf-ace-oauth-authz-29#section-8.10
> 
> 
> Thank you in advance for you review comments.
> 
> Regards,
> 
> Ludwig
>

---

From: Justin Richer <[email-masked]>
Date: Wed, 8 Jan 2020 16:15:18 -0500

The registration request is missing the “cnonce” and “exi" claims, both of which are mentioned in 5.7.2 but aren’t listed in the registry request. If those are added then I think the registration is fine.

 — Justin

> On Jan 7, 2020, at 5:50 PM, Amanda Baber via RT <[email-masked]> wrote:
> 
> Hi Justin, all,
> 
> _______________________________________________
> oauth-ext-review mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/oauth-ext-review