Subject: [oauth-ext-review] Request to register OAuth Authorization Server Metadata parameters

From: Mike Jones <[email-masked]>
Date: Sun, 26 Apr 2020 20:50:31 +0000

Dear Designated Experts and IANA,

I am writing to you on behalf of the OpenID Connect Artifact Binding working group requesting to register the OAuth Authorization Server Metadata parameters defined in https://openid.net/specs/openid-connect-discovery-1_0-29.html#MetadataRegistry.  The individual registration requests are repeated below.

These parameters were defined in the OpenID Connect Discovery specification that became final in February 2014.  Now that the OAuth Authorization Server Metadata registry has been established at https://www.iana.org/assignments/oauth-parameters/oauth-parameters.xhtml#authorization-server-metadata, those parameters not already registered by RFC 8414 are now being registered.

                                                            Thank you,
                                                            -- Mike

8.2.  OAuth Authorization Server Metadata Registry

This specification registers the following metadata names in the IANA "OAuth Authorization Server Metadata" registry [IANA.OAuth.Parameters]<https://openid.net/specs/openid-connect-discovery-1_0-29.html#IANA.OAuth.Parameters> established by [RFC8414]<https://openid.net/specs/openid-connect-discovery-1_0-29.html#RFC8414>.

________________________________
 TOC <https://openid.net/specs/openid-connect-discovery-1_0-29.html#toc>
8.2.1.  Registry Contents
*        Metadata Name: userinfo_endpoint
*        Metadata Description: URL of the OP's UserInfo Endpoint
*        Change Controller: OpenID Foundation Artifact Binding Working Group - [email-masked]<mailto:[email-masked]>
*        Specification Document(s): Section 3<https://openid.net/specs/openid-connect-discovery-1_0-29.html#ProviderMetadata> of this document
*        Metadata Name: acr_values_supported
*        Metadata Description: JSON array containing a list of the Authentication Context Class References that this OP supports
*        Change Controller: OpenID Foundation Artifact Binding Working Group - [email-masked]<mailto:[email-masked]>
*        Specification Document(s): Section 3<https://openid.net/specs/openid-connect-discovery-1_0-29.html#ProviderMetadata> of this document
*        Metadata Name: subject_types_supported
*        Metadata Description: JSON array containing a list of the Subject Identifier types that this OP supports
*        Change Controller: OpenID Foundation Artifact Binding Working Group - [email-masked]<mailto:[email-masked]>
*        Specification Document(s): Section 3<https://openid.net/specs/openid-connect-discovery-1_0-29.html#ProviderMetadata> of this document
*        Metadata Name: id_token_signing_alg_values_supported
*        Metadata Description: JSON array containing a list of the JWS "alg" values supported by the OP for the ID Token
*        Change Controller: OpenID Foundation Artifact Binding Working Group - [email-masked]<mailto:[email-masked]>
*        Specification Document(s): Section 3<https://openid.net/specs/openid-connect-discovery-1_0-29.html#ProviderMetadata> of this document
*        Metadata Name: id_token_encryption_alg_values_supported
*        Metadata Description: JSON array containing a list of the JWE "alg" values supported by the OP for the ID Token
*        Change Controller: OpenID Foundation Artifact Binding Working Group - [email-masked]<mailto:[email-masked]>
*        Specification Document(s): Section 3<https://openid.net/specs/openid-connect-discovery-1_0-29.html#ProviderMetadata> of this document
*        Metadata Name: id_token_encryption_enc_values_supported
*        Metadata Description: JSON array containing a list of the JWE "enc" values supported by the OP for the ID Token
*        Change Controller: OpenID Foundation Artifact Binding Working Group - [email-masked]<mailto:[email-masked]>
*        Specification Document(s): Section 3<https://openid.net/specs/openid-connect-discovery-1_0-29.html#ProviderMetadata> of this document
*        Metadata Name: userinfo_signing_alg_values_supported
*        Metadata Description: JSON array containing a list of the JWS "alg" values supported by the UserInfo Endpoint
*        Change Controller: OpenID Foundation Artifact Binding Working Group - [email-masked]<mailto:[email-masked]>
*        Specification Document(s): Section 3<https://openid.net/specs/openid-connect-discovery-1_0-29.html#ProviderMetadata> of this document
*        Metadata Name: userinfo_encryption_alg_values_supported
*        Metadata Description: JSON array containing a list of the JWE "alg" values supported by the UserInfo Endpoint
*        Change Controller: OpenID Foundation Artifact Binding Working Group - [email-masked]<mailto:[email-masked]>
*        Specification Document(s): Section 3<https://openid.net/specs/openid-connect-discovery-1_0-29.html#ProviderMetadata> of this document
*        Metadata Name: userinfo_encryption_enc_values_supported
*        Metadata Description: JSON array containing a list of the JWE "enc" values supported by the UserInfo Endpoint
*        Change Controller: OpenID Foundation Artifact Binding Working Group - [email-masked]<mailto:[email-masked]>
*        Specification Document(s): Section 3<https://openid.net/specs/openid-connect-discovery-1_0-29.html#ProviderMetadata> of this document
*        Metadata Name: request_object_signing_alg_values_supported
*        Metadata Description: JSON array containing a list of the JWS "alg" values supported by the OP for Request Objects
*        Change Controller: OpenID Foundation Artifact Binding Working Group - [email-masked]<mailto:[email-masked]>
*        Specification Document(s): Section 3<https://openid.net/specs/openid-connect-discovery-1_0-29.html#ProviderMetadata> of this document
*        Metadata Name: request_object_encryption_alg_values_supported
*        Metadata Description: JSON array containing a list of the JWE "alg" values supported by the OP for Request Objects
*        Change Controller: OpenID Foundation Artifact Binding Working Group - [email-masked]<mailto:[email-masked]>
*        Specification Document(s): Section 3<https://openid.net/specs/openid-connect-discovery-1_0-29.html#ProviderMetadata> of this document
*        Metadata Name: request_object_encryption_enc_values_supported
*        Metadata Description: JSON array containing a list of the JWE "enc" values supported by the OP for Request Objects
*        Change Controller: OpenID Foundation Artifact Binding Working Group - [email-masked]<mailto:[email-masked]>
*        Specification Document(s): Section 3<https://openid.net/specs/openid-connect-discovery-1_0-29.html#ProviderMetadata> of this document
*        Metadata Name: display_values_supported
*        Metadata Description: JSON array containing a list of the "display" parameter values that the OpenID Provider supports
*        Change Controller: OpenID Foundation Artifact Binding Working Group - [email-masked]<mailto:[email-masked]>
*        Specification Document(s): Section 3<https://openid.net/specs/openid-connect-discovery-1_0-29.html#ProviderMetadata> of this document
*        Metadata Name: claim_types_supported
*        Metadata Description: JSON array containing a list of the Claim Types that the OpenID Provider supports
*        Change Controller: OpenID Foundation Artifact Binding Working Group - [email-masked]<mailto:[email-masked]>
*        Specification Document(s): Section 3<https://openid.net/specs/openid-connect-discovery-1_0-29.html#ProviderMetadata> of this document
*        Metadata Name: claims_supported
*        Metadata Description: JSON array containing a list of the Claim Names of the Claims that the OpenID Provider MAY be able to supply values for
*        Change Controller: OpenID Foundation Artifact Binding Working Group - [email-masked]<mailto:[email-masked]>
*        Specification Document(s): Section 3<https://openid.net/specs/openid-connect-discovery-1_0-29.html#ProviderMetadata> of this document
*        Metadata Name: claims_locales_supported
*        Metadata Description: Languages and scripts supported for values in Claims being returned, represented as a JSON array of BCP 47 language tag values
*        Change Controller: OpenID Foundation Artifact Binding Working Group - [email-masked]<mailto:[email-masked]>
*        Specification Document(s): Section 3<https://openid.net/specs/openid-connect-discovery-1_0-29.html#ProviderMetadata> of this document
*        Metadata Name: claims_parameter_supported
*        Metadata Description: Boolean value specifying whether the OP supports use of the "claims" parameter
*        Change Controller: OpenID Foundation Artifact Binding Working Group - [email-masked]<mailto:[email-masked]>
*        Specification Document(s): Section 3<https://openid.net/specs/openid-connect-discovery-1_0-29.html#ProviderMetadata> of this document
*        Metadata Name: request_parameter_supported
*        Metadata Description: Boolean value specifying whether the OP supports use of the "request" parameter
*        Change Controller: OpenID Foundation Artifact Binding Working Group - [email-masked]<mailto:[email-masked]>
*        Specification Document(s): Section 3<https://openid.net/specs/openid-connect-discovery-1_0-29.html#ProviderMetadata> of this document
*        Metadata Name: request_uri_parameter_supported
*        Metadata Description: Boolean value specifying whether the OP supports use of the "request_uri" parameter
*        Change Controller: OpenID Foundation Artifact Binding Working Group - [email-masked]<mailto:[email-masked]>
*        Specification Document(s): Section 3<https://openid.net/specs/openid-connect-discovery-1_0-29.html#ProviderMetadata> of this document
*        Metadata Name: require_request_uri_registration
*        Metadata Description: Boolean value specifying whether the OP requires any "request_uri" values used to be pre-registered
*        Change Controller: OpenID Foundation Artifact Binding Working Group - [email-masked]<mailto:[email-masked]>
*        Specification Document(s): Section 3<https://openid.net/specs/openid-connect-discovery-1_0-29.html#ProviderMetadata> of this document

---

From: John Bradley <[email-masked]>
Date: Mon, 27 Apr 2020 20:19:58 -0400

I have reviewed the request and approve.

On 4/26/2020 4:50 PM, Mike Jones wrote:
> I am writing to you on behalf of the OpenID Connect Artifact Binding
> working group requesting to register the OAuth Authorization Server
> Metadata parameters defined in
> https://openid.net/specs/openid-connect-discovery-1_0-29.html#MetadataRegistry. 
> The individual registration requests are repeated below.
>
>  
>
> These parameters were defined in the OpenID Connect Discovery
> specification that became final in February 2014.  Now that the OAuth
> Authorization Server Metadata registry has been established at
> https://www.iana.org/assignments/oauth-parameters/oauth-parameters.xhtml#authorization-server-metadata,
> those parameters not already registered by RFC 8414 are now being
> registered.
>
>  
>
>                                                             Thank you,
>
>                                                             -- Mike
>
>  
>
>
> This specification registers the following metadata names in the IANA
> "OAuth Authorization Server Metadata"
> registry *[IANA.OAuth.Parameters]*
> <https://openid.net/specs/openid-connect-discovery-1_0-29.html#IANA.OAuth.Parameters> established
> by *[RFC8414]*
> <https://openid.net/specs/openid-connect-discovery-1_0-29.html#RFC8414>.
>
>  
>
> ------------------------------------------------------------------------
>
> * TOC *
> <https://openid.net/specs/openid-connect-discovery-1_0-29.html#toc>
>
>
>       8.2.1.  Registry Contents
>
> ·        Metadata Name: userinfo_endpoint
>
> ·        Metadata Description: URL of the OP's UserInfo Endpoint
>
> ·        Change Controller: OpenID Foundation Artifact Binding Working
> Group - [email-masked]
> <mailto:[email-masked]>
>
> ·        Specification Document(s): *Section 3*
> <https://openid.net/specs/openid-connect-discovery-1_0-29.html#ProviderMetadata> of
> this document
>
> ·        Metadata Name: acr_values_supported
>
> ·        Metadata Description: JSON array containing a list of the
> Authentication Context Class References that this OP supports
>
> ·        Change Controller: OpenID Foundation Artifact Binding Working
> Group - [email-masked]
> <mailto:[email-masked]>
>
> ·        Specification Document(s): *Section 3*
> <https://openid.net/specs/openid-connect-discovery-1_0-29.html#ProviderMetadata> of
> this document
>
> ·        Metadata Name: subject_types_supported
>
> ·        Metadata Description: JSON array containing a list of the
> Subject Identifier types that this OP supports
>
> ·        Change Controller: OpenID Foundation Artifact Binding Working
> Group - [email-masked]
> <mailto:[email-masked]>
>
> ·        Specification Document(s): *Section 3*
> <https://openid.net/specs/openid-connect-discovery-1_0-29.html#ProviderMetadata> of
> this document
>
> ·        Metadata Name: id_token_signing_alg_values_supported
>
> ·        Metadata Description: JSON array containing a list of the JWS
> "alg" values supported by the OP for the ID Token
>
> ·        Change Controller: OpenID Foundation Artifact Binding Working
> Group - [email-masked]
> <mailto:[email-masked]>
>
> ·        Specification Document(s): *Section 3*
> <https://openid.net/specs/openid-connect-discovery-1_0-29.html#ProviderMetadata> of
> this document
>
> ·        Metadata Name: id_token_encryption_alg_values_supported
>
> ·        Metadata Description: JSON array containing a list of the JWE
> "alg" values supported by the OP for the ID Token
>
> ·        Change Controller: OpenID Foundation Artifact Binding Working
> Group - [email-masked]
> <mailto:[email-masked]>
>
> ·        Specification Document(s): *Section 3*
> <https://openid.net/specs/openid-connect-discovery-1_0-29.html#ProviderMetadata> of
> this document
>
> ·        Metadata Name: id_token_encryption_enc_values_supported
>
> ·        Metadata Description: JSON array containing a list of the JWE
> "enc" values supported by the OP for the ID Token
>
> ·        Change Controller: OpenID Foundation Artifact Binding Working
> Group - [email-masked]
> <mailto:[email-masked]>
>
> ·        Specification Document(s): *Section 3*
> <https://openid.net/specs/openid-connect-discovery-1_0-29.html#ProviderMetadata> of
> this document
>
> ·        Metadata Name: userinfo_signing_alg_values_supported
>
> ·        Metadata Description: JSON array containing a list of the JWS
> "alg" values supported by the UserInfo Endpoint
>
> ·        Change Controller: OpenID Foundation Artifact Binding Working
> Group - [email-masked]
> <mailto:[email-masked]>
>
> ·        Specification Document(s): *Section 3*
> <https://openid.net/specs/openid-connect-discovery-1_0-29.html#ProviderMetadata> of
> this document
>
> ·        Metadata Name: userinfo_encryption_alg_values_supported
>
> ·        Metadata Description: JSON array containing a list of the JWE
> "alg" values supported by the UserInfo Endpoint
>
> ·        Change Controller: OpenID Foundation Artifact Binding Working
> Group - [email-masked]
> <mailto:[email-masked]>
>
> ·        Specification Document(s): *Section 3*
> <https://openid.net/specs/openid-connect-discovery-1_0-29.html#ProviderMetadata> of
> this document
>
> ·        Metadata Name: userinfo_encryption_enc_values_supported
>
> ·        Metadata Description: JSON array containing a list of the JWE
> "enc" values supported by the UserInfo Endpoint
>
> ·        Change Controller: OpenID Foundation Artifact Binding Working
> Group - [email-masked]
> <mailto:[email-masked]>
>
> ·        Specification Document(s): *Section 3*
> <https://openid.net/specs/openid-connect-discovery-1_0-29.html#ProviderMetadata> of
> this document
>
> ·        Metadata Name: request_object_signing_alg_values_supported
>
> ·        Metadata Description: JSON array containing a list of the JWS
> "alg" values supported by the OP for Request Objects
>
> ·        Change Controller: OpenID Foundation Artifact Binding Working
> Group - [email-masked]
> <mailto:[email-masked]>
>
> ·        Specification Document(s): *Section 3*
> <https://openid.net/specs/openid-connect-discovery-1_0-29.html#ProviderMetadata> of
> this document
>
> ·        Metadata Name: request_object_encryption_alg_values_supported
>
> ·        Metadata Description: JSON array containing a list of the JWE
> "alg" values supported by the OP for Request Objects
>
> ·        Change Controller: OpenID Foundation Artifact Binding Working
> Group - [email-masked]
> <mailto:[email-masked]>
>
> ·        Specification Document(s): *Section 3*
> <https://openid.net/specs/openid-connect-discovery-1_0-29.html#ProviderMetadata> of
> this document
>
> ·        Metadata Name: request_object_encryption_enc_values_supported
>
> ·        Metadata Description: JSON array containing a list of the JWE
> "enc" values supported by the OP for Request Objects
>
> ·        Change Controller: OpenID Foundation Artifact Binding Working
> Group - [email-masked]
> <mailto:[email-masked]>
>
> ·        Specification Document(s): *Section 3*
> <https://openid.net/specs/openid-connect-discovery-1_0-29.html#ProviderMetadata> of
> this document
>
> ·        Metadata Name: display_values_supported
>
> ·        Metadata Description: JSON array containing a list of the
> "display" parameter values that the OpenID Provider supports
>
> ·        Change Controller: OpenID Foundation Artifact Binding Working
> Group - [email-masked]
> <mailto:[email-masked]>
>
> ·        Specification Document(s): *Section 3*
> <https://openid.net/specs/openid-connect-discovery-1_0-29.html#ProviderMetadata> of
> this document
>
> ·        Metadata Name: claim_types_supported
>
> ·        Metadata Description: JSON array containing a list of the
> Claim Types that the OpenID Provider supports
>
> ·        Change Controller: OpenID Foundation Artifact Binding Working
> Group - [email-masked]
> <mailto:[email-masked]>
>
> ·        Specification Document(s): *Section 3*
> <https://openid.net/specs/openid-connect-discovery-1_0-29.html#ProviderMetadata> of
> this document
>
> ·        Metadata Name: claims_supported
>
> ·        Metadata Description: JSON array containing a list of the
> Claim Names of the Claims that the OpenID Provider MAY be able to
> supply values for
>
> ·        Change Controller: OpenID Foundation Artifact Binding Working
> Group - [email-masked]
> <mailto:[email-masked]>
>
> ·        Specification Document(s): *Section 3*
> <https://openid.net/specs/openid-connect-discovery-1_0-29.html#ProviderMetadata> of
> this document
>
> ·        Metadata Name: claims_locales_supported
>
> ·        Metadata Description: Languages and scripts supported for
> values in Claims being returned, represented as a JSON array of BCP 47
> language tag values
>
> ·        Change Controller: OpenID Foundation Artifact Binding Working
> Group - [email-masked]
> <mailto:[email-masked]>
>
> ·        Specification Document(s): *Section 3*
> <https://openid.net/specs/openid-connect-discovery-1_0-29.html#ProviderMetadata> of
> this document
>
> ·        Metadata Name: claims_parameter_supported
>
> ·        Metadata Description: Boolean value specifying whether the OP
> supports use of the "claims" parameter
>
> ·        Change Controller: OpenID Foundation Artifact Binding Working
> Group - [email-masked]
> <mailto:[email-masked]>
>
> ·        Specification Document(s): *Section 3*
> <https://openid.net/specs/openid-connect-discovery-1_0-29.html#ProviderMetadata> of
> this document
>
> ·        Metadata Name: request_parameter_supported
>
> ·        Metadata Description: Boolean value specifying whether the OP
> supports use of the "request" parameter
>
> ·        Change Controller: OpenID Foundation Artifact Binding Working
> Group - [email-masked]
> <mailto:[email-masked]>
>
> ·        Specification Document(s): *Section 3*
> <https://openid.net/specs/openid-connect-discovery-1_0-29.html#ProviderMetadata> of
> this document
>
> ·        Metadata Name: request_uri_parameter_supported
>
> ·        Metadata Description: Boolean value specifying whether the OP
> supports use of the "request_uri" parameter
>
> ·        Change Controller: OpenID Foundation Artifact Binding Working
> Group - [email-masked]
> <mailto:[email-masked]>
>
> ·        Specification Document(s): *Section 3*
> <https://openid.net/specs/openid-connect-discovery-1_0-29.html#ProviderMetadata> of
> this document
>
> ·        Metadata Name: require_request_uri_registration
>
> ·        Metadata Description: Boolean value specifying whether the OP
> requires any "request_uri" values used to be pre-registered
>
> ·        Change Controller: OpenID Foundation Artifact Binding Working
> Group - [email-masked]
> <mailto:[email-masked]>
>
> ·        Specification Document(s): *Section 3*
> <https://openid.net/specs/openid-connect-discovery-1_0-29.html#ProviderMetadata> of
> this document
>
>  
>