Subject: [oauth-ext-review] [IANA #1175814] expert review for draft-ietf-oauth-jwsreq-26 (OAuth Parameters - oauth-parameters)

From: "Amanda Baber via RT" <[email-masked]>
Date: Sat, 05 Sep 2020 23:05:05 +0000

Hi Hannes,

Have you had a chance to review this one yet?

thanks,
Amanda

On Mon Aug 31 07:05:32 2020, [email-masked] wrote:
> Hi Nat, Hi all,
> 
> I am back from my sabbatical leave tomorrow and will take a look at it
> tomorrow. Sorry for the delay.
> 
> Ciao
> Hannes
> 
> From: Nat Sakimura <[email-masked]>
> Sent: Sunday, August 30, 2020 10:08 PM
> To: [email-masked]
> Cc: [email-masked]; Hannes Tschofenig
> <[email-masked]>
> Subject: Re: [oauth-ext-review] [IANA #1175814] expert review for
> draft-ietf-oauth-jwsreq-26 (OAuth Parameters - oauth-parameters)
> 
> Hannes? Could you do the review, please?
> 
> On Sat, Aug 22, 2020 at 2:08 AM Amanda Baber via RT <drafts-expert-
> [email-masked]<mailto:[email-masked]>>
> wrote:
> Hi Hannes,
> 
> This is a reminder for IANA's OAuth Parameters review request for
> draft-ietf-oauth-jwsreq. The document has been approved, but we need
> your review before we can make the registrations.
> 
> thanks,
> Amanda
> 
> On Wed Aug 12 21:04:02 2020, amanda.baber wrote:
> > Dear Hannes,
> >
> > As the designated expert for the OAuth Parameters registry, can you
> > review the registrations in Section 9.1 of this document?
> >
> > https://tools.ietf.org/html/draft-ietf-oauth-jwsreq
> >
> > The two-week review period would end on August 26th.
> >
> > This document is on tomorrow's IESG telechat agenda, but we're
> > notifying the ADs that it still requires IANA review. (When this
> > document was last sent to IANA, there were no registry actions.)
> >
> > Best regards,
> >
> > Amanda Baber
> > Lead IANA Services Specialist
> 
> _______________________________________________
> oauth-ext-review mailing list
> [email-masked]<mailto:[email-masked]>
> https://www.ietf.org/mailman/listinfo/oauth-ext-review
> 
> 
> --
> Nat Sakimura
> NAT.Consulting LLC
> IMPORTANT NOTICE: The contents of this email and any attachments are
> confidential and may also be privileged. If you are not the intended
> recipient, please notify the sender immediately and do not disclose
> the contents to any other person, use it for any purpose, or store or
> copy the information in any medium. Thank you.

---

From: Hannes Tschofenig <[email-masked]>
Date: Mon, 7 Sep 2020 15:12:38 +0000

Hi all,

I reviewed Section 9.1 of https://tools.ietf.org/html/draft-ietf-oauth-jwsreq-28 and I am OK with registering the listed parameters. Note that these parameters are not meant to be used in practice, as the draft says.

FWIW I noticed that some of the parameters indicate that the IESG is the change controller while other parameters say IETF as the change controller. I noticed that the IANA registry itself is inconsistent in that regard. Ultimately, it does not matter but at least within a single document the change controller should either be listed as IETF or IESG but not both.

Ciao
Hannes

From: oauth-ext-review <[email-masked]> On Behalf Of Hannes Tschofenig
Sent: Monday, August 31, 2020 9:05 AM
To: Nat Sakimura <[email-masked]>; [email-masked]
Cc: [email-masked]
Subject: Re: [oauth-ext-review] [IANA #1175814] expert review for draft-ietf-oauth-jwsreq-26 (OAuth Parameters - oauth-parameters)

Hi Nat, Hi all,

I am back from my sabbatical leave tomorrow and will take a look at it tomorrow. Sorry for the delay.

Ciao
Hannes

From: Nat Sakimura <[email-masked]<mailto:[email-masked]>>
Sent: Sunday, August 30, 2020 10:08 PM
To: [email-masked]<mailto:[email-masked]>
Cc: [email-masked]<mailto:[email-masked]>; Hannes Tschofenig <[email-masked]<mailto:[email-masked]>>
Subject: Re: [oauth-ext-review] [IANA #1175814] expert review for draft-ietf-oauth-jwsreq-26 (OAuth Parameters - oauth-parameters)

On Sat, Aug 22, 2020 at 2:08 AM Amanda Baber via RT <[email-masked]<mailto:[email-masked]>> wrote:
Hi Hannes,

This is a reminder for IANA's OAuth Parameters review request for draft-ietf-oauth-jwsreq. The document has been approved, but we need your review before we can make the registrations.

thanks,
Amanda

--
Nat Sakimura
NAT.Consulting LLC
IMPORTANT NOTICE: The contents of this email and any attachments are confidential and may also be privileged. If you are not the intended recipient, please notify the sender immediately and do not disclose the contents to any other person, use it for any purpose, or store or copy the information in any medium. Thank you.
IMPORTANT NOTICE: The contents of this email and any attachments are confidential and may also be privileged. If you are not the intended recipient, please notify the sender immediately and do not disclose the contents to any other person, use it for any purpose, or store or copy the information in any medium. Thank you.

---

From: Mike Jones <[email-masked]>
Date: Mon, 7 Sep 2020 20:28:39 +0000

Thanks for reviewing the submissions, Hannes.  We can update the draft to consistently use either IETF or IESG.  Roman, the IESG seems to have gone back and forth between these two.  Is “IETF” the current Change Controller of preference?

                                                          Thanks,
                                                          -- Mike

From: oauth-ext-review <[email-masked]> On Behalf Of Hannes Tschofenig
Sent: Monday, September 7, 2020 8:13 AM
To: Hannes Tschofenig <[email-masked]>; Nat Sakimura <[email-masked]>; [email-masked]
Cc: [email-masked]
Subject: Re: [oauth-ext-review] [IANA #1175814] expert review for draft-ietf-oauth-jwsreq-26 (OAuth Parameters - oauth-parameters)

Hi all,

Ciao
Hannes

From: oauth-ext-review <[email-masked]<mailto:[email-masked]>> On Behalf Of Hannes Tschofenig
Sent: Monday, August 31, 2020 9:05 AM
To: Nat Sakimura <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>
Cc: [email-masked]<mailto:[email-masked]>
Subject: Re: [oauth-ext-review] [IANA #1175814] expert review for draft-ietf-oauth-jwsreq-26 (OAuth Parameters - oauth-parameters)

Hi Nat, Hi all,

Ciao
Hannes

thanks,
Amanda

---

From: "Amanda Baber via RT" <[email-masked]>
Date: Tue, 08 Sep 2020 21:44:15 +0000

Hi Mike, Roman, all,

We've had confirmation from Barry that "IETF" is preferred.

I'll move ahead with the registry actions and use "IETF." If there's a reason to prefer "IESG," let me know.

Best regards,
Amanda

On Mon Sep 07 20:29:02 2020, [email-masked] wrote:
> Thanks for reviewing the submissions, Hannes.  We can update the draft
> to consistently use either IETF or IESG.  Roman, the IESG seems to
> have gone back and forth between these two.  Is “IETF” the current
> Change Controller of preference?
> 
> Thanks,
> -- Mike
> 
> To: Hannes Tschofenig <[email-masked]>; Nat Sakimura
> <[email-masked]>; [email-masked]
> I reviewed Section 9.1 of https://tools.ietf.org/html/draft-ietf-
> oauth-jwsreq-28 and I am OK with registering the listed parameters.
> Note that these parameters are not meant to be used in practice, as
> the draft says.
> 
> FWIW I noticed that some of the parameters indicate that the IESG is
> the change controller while other parameters say IETF as the change
> controller. I noticed that the IANA registry itself is inconsistent in
> that regard. Ultimately, it does not matter but at least within a
> single document the change controller should either be listed as IETF
> or IESG but not both.
> 
> Ciao
> Hannes
> 
> From: oauth-ext-review <oauth-ext-review-
> [email-masked]<mailto:[email-masked]>> On Behalf
> Of Hannes Tschofenig
> To: Nat Sakimura <[email-masked]<mailto:[email-masked]>>;
> [email-masked]<mailto:drafts-expert-review-
> [email-masked]>
> Cc: [email-masked]<mailto:[email-masked]>;
> Hannes Tschofenig
> <[email-masked]<mailto:[email-masked]>>

---

From: John Bradley <[email-masked]>
Date: Tue, 8 Sep 2020 19:57:34 -0300

thanks

On 9/8/2020 6:44 PM, Amanda Baber via RT wrote:
> [email-masked]

---

From: John Bradley <[email-masked]>
Date: Tue, 8 Sep 2020 19:57:34 -0300

thanks