Subject: Re: [OAUTH-WG] JSON Web Token (JWT) Specification Draft

From: Mike Jones <[email-masked]>
Date: Fri, 24 Sep 2010 00:40:52 +0000

FYI, I've also posted this at http://self-issued.info/docs/draft-goland-json-web-token-00.html and http://self-issued.info/docs/draft-goland-json-web-token-00.xml for easy reference by those who didn't receive the original attachments.

                                                            -- Mike

From: Mike Jones
Sent: Thursday, September 23, 2010 5:22 PM
To: [email-masked]'
Cc: Yaron Goland
Subject: JSON Web Token (JWT) Specification Draft

Recognizing that there is substantial interest in representing sets of claims in JSON tokens, Yaron Goland and I have put together a draft JSON Web Token (JWT) spec for that purpose.

To answer the obvious question, while this was produced independently of Dirk's JSON token proposal<http://balfanz.github.com/jsontoken-spec/draft-balfanz-jsontoken-00.html>, both of us agree that we should come up with a unified spec.  Consider this an additional point in the possible design space from which to start discussions and drive consensus.  (If you read the two proposals, I think you'll find that there's already a lot in common, which is great.)

Thanks to those of you who have already given us feedback to improve the draft prior to this point.

                                                            Cheers,
                                                            -- Mike

---

From: Eran Hammer-Lahav <[email-masked]>
Date: Thu, 23 Sep 2010 18:12:54 -0700

Why aren't these published as an IETF I-D?

EHL

On 9/23/10 5:40 PM, "Mike Jones" <[email-masked]> wrote:

                                                            -- Mike

From: Mike Jones

To answer the obvious question, while this was produced independently of Dirk's JSON token proposal <http://balfanz.github.com/jsontoken-spec/draft-balfanz-jsontoken-00.html> , both of us agree that we should come up with a unified spec.  Consider this an additional point in the possible design space from which to start discussions and drive consensus.  (If you read the two proposals, I think you'll find that there's already a lot in common, which is great.)

                                                            Cheers,
                                                            -- Mike