Subject: [OAUTH-WG] Shepherd writeup for the JSON Web Token (JWT) Profile for OAuth 2.0 Access Tokens -- Information about Implementations

From: Hannes Tschofenig <[email-masked]>
Date: Thu, 17 Sep 2020 12:55:29 +0000

Hi Vittorio, Hi all,

I am working on the shepherd writeup for <draft-ietf-oauth-access-token-jwt> and you can find the latest version here:
https://github.com/hannestschofenig/tschofenig-ids/blob/master/shepherd-writeups/Writeup_OAuth_JWT-Profile-for-AccessTokens.txt

I am in need for information about implementations that are conformant to this specification. This information would be listed in this write-up, as background information to the IESG.

Ciao
Hannes

IMPORTANT NOTICE: The contents of this email and any attachments are confidential and may also be privileged. If you are not the intended recipient, please notify the sender immediately and do not disclose the contents to any other person, use it for any purpose, or store or copy the information in any medium. Thank you.

---

From: Filip Skokan <[email-masked]>
Date: Thu, 17 Sep 2020 16:00:37 +0200

Hi Hannes, 

Node.js project oidc-provider (https://github.com/panva/node-oidc-provider) has an option to issue Access Tokens conform to this profile. 

Best, 
Filip

Odesláno z iPhonu

> 17. 9. 2020 v 14:56, Hannes Tschofenig <[email-masked]>:
> 
> Hi Vittorio, Hi all,
> 
> _______________________________________________
> OAuth mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/oauth

---

From: Nicolas Mora <[email-masked]>
Date: Thu, 17 Sep 2020 19:33:03 -0400

Hello,

> I am in need for information about implementations that are conformant to this specification. This information would be listed in this write-up, as background information to the IESG.
Glewlwyd's OIDC plugin implements the specification "JSON Web Token
(JWT) Profile for OAuth 2.0 Access Tokens - draft 05".

https://github.com/babelouest/glewlwyd/blob/master/docs/OIDC.md#access-token-format

https://github.com/babelouest/glewlwyd

/Nicolas

---

From: Dominick Baier <[email-masked]>
Date: Fri, 18 Sep 2020 23:07:43 -0700

IdentityServer is.

https://github.com/IdentityServer

Cheers
———
Dominick Baier

On 17. September 2020 at 14:56:01, Hannes Tschofenig (
[email-masked]) wrote:

Hi Vittorio, Hi all,

I am working on the shepherd writeup for
<draft-ietf-oauth-access-token-jwt> and you can find the latest version
here:
https://github.com/hannestschofenig/tschofenig-ids/blob/master/shepherd-writeups/Writeup_OAuth_JWT-Profile-for-AccessTokens.txt

I am in need for information about implementations that are conformant to
this specification. This information would be listed in this write-up, as
background information to the IESG.

Ciao
Hannes

IMPORTANT NOTICE: The contents of this email and any attachments are
confidential and may also be privileged. If you are not the intended
recipient, please notify the sender immediately and do not disclose the
contents to any other person, use it for any purpose, or store or copy the
information in any medium. Thank you.

---

From: Vladimir Dzhuvinov <[email-masked]>
Date: Tue, 22 Sep 2020 00:04:47 +0300

A conforming implementation and looking forward to the final spec :)

https://connect2id.com/products/server/docs/datasheet#access-token-encoding-jwt