Subject: Re: [ogpx] A Review of Multi-Domain Use Cases [Was: Re: OpenID and OGP : beginning the discussion ...]

From: Infinity Linden <[email-masked]>
Date: Wed, 1 Jul 2009 13:11:33 -0700

cool. i think we're in violent agreement.

> Therefore, I'd like to propose this:
>
>  1. Arbitrary in-world name tags, which have only one intent: to provide a
>    customer-satisfying visual name.
>  2. Globally unique identifiers, either UUID or formed by composition of N-part
>    local name @ issuing authority, that remain the same over logins for any
>    given account and that are passed to every viewer that receives 1).
>  3. Entirely separate authentication credentials, in other words, unrelated to
>    1) or 2).

---

From: Kajikawa Jeremy <[email-masked]>
Date: Thu, 09 Jul 2009 16:48:14 +0900

Are the UUIDs given on any individual instance (region domain/agent
domain) 
  exposable across to another domain ?

It appears that you would need a <UUID>@<GridID> arrangement...
 specifically recognising Avatar UUIDs as @local and using an
@<gridstring> 
 when exposed as being from a remote grid ("GridID/GridString" simply
naming a
 connection handle?)

potentialy useful or am I getting hung up on details?

On Mon, 2009-06-29 at 12:25 -0700, Charles Krinke wrote:
> Hmmm. Well, it seems reasonable to me that each grid has one and only
> one first/last avatar of any particular first and last.
> 
> Admiteddly, I am more focused on the OpenSim and the OSGrid side of
> this interop discussion, but, since the precedent has already been set
> for <first>.<last>@GridName.Com it seems a reasonable and
> non-ambiguous method.
> 
> All avatars on OpenSim grids do have a UUID, so that could certainly
> be exposed. Then we could have conversations between
> "0123-4567-89ab-123456899abc-defa" and others instead of
> <first>.<last>@gridname.com, I suppose.
> 
> Charles Krinke
> 
> 
> 
> ______________________________________________________________________
> From: Infinity Linden <[email-masked]>
> To: Charles Krinke <[email-masked]>
> Cc: Carlo Wood <[email-masked]>; Meadhbh Siobhan
> <[email-masked]>; [email-masked]
> Sent: Monday, June 29, 2009 12:19:18 PM
> Subject: Re: [ogpx] A Review of Multi-Domain Use Cases [Was: Re:
> OpenID and OGP : beginning the discussion ...]
> 
> hmm... i think over in the OGP world we have a history of being
> enamored with capabilities and RESTful resources, ergo my suggestion
> that an agent's unique ID be an URL. If the public URL a service may
> go to to get public information about an agent is the unique ID for an
> avatar, then you don't need a name to service resolution step, which
> has some advantages. i don't want to sound partisan, but the
> formulation below (that looks like an email address) seems to have the
> potential for ambiguity.
> 
> On Mon, Jun 29, 2009 at 11:11 AM, Charles Krinke<[email-masked]>
> wrote:
> > In some interop scenarios, and I am using HyperGrid as an example as
> it
> > addresses the same problem, the current solution is to use:
> >
> > <First>.<Last>@GridName.Com
> >
> > Which is not an email, but is a unique identifier for an avatar on a
> > particular grid.
> >
> > As OGP moves forward, it seems reasonable to me that the Grids (or
> perhaps
> > AgentDomains to use the vernacular here) are the authority for a
> particular
> > avatar that comes from that grid.
> >
> > Charles Krinke
> >
> > ________________________________
> > From: Carlo Wood <[email-masked]>
> > To: Meadhbh Siobhan <[email-masked]>
> > Cc: Infinity Linden <[email-masked]>; [email-masked]
> > Sent: Monday, June 29, 2009 9:18:15 AM
> > Subject: Re: [ogpx] A Review of Multi-Domain Use Cases [Was: Re:
> OpenID and
> > OGP : beginning the discussion ...]
> >
> > On Mon, Jun 29, 2009 at 06:11:21PM +0200, Carlo Wood wrote:
> >> If this is the case, then I'm happy and there should be no problems
> >> in the future regarding this. If no separate ID is provided then
> >> several problems occur:
> >> * Impersonation (people deliberately using the same shape and skin
> etc)
> >> * IM's will be logged to the same file, because the viewer can't
> >>  know who is who.
> >>
> >> Also, the ID has to be same every time - because the viewer will
> >> need to recognize that this John Smith is not AGAIN a new one,
> >> but the same, every time.
> >
> > To clarify; what started this thread was this:
> >
> >    & identifier = {
> >        type: 'agent',
> >        first_name: string,
> >        last_name: string,
> >    }
> >
> > Here I only see 'first_name' and 'last_name'.
> > As we've established now (I hope) this is not enough at
> > any level of the protocol, not between servers, but also
> > not between server and client.
> >
> > Hence, it worried me. If you say "identifier" I expect
> > something globally unique.
> >
> > I think this should be:
> >
> >    & identifier = {
> >        type: 'agent',
> >     uuid: string,
> >        first_name: string,
> >        last_name: string,
> >    }
> >
> > Where the uuid is not only unique, but constant for any given
> > account (it doesn't change if one logs out and logs in again).
> > It could be an email address, but for privacy reasons I think
> > that should not be used; some hash seems much more logical.
> >
> > --
> > Carlo Wood <[email-masked]>
> > _______________________________________________
> > ogpx mailing list
> > [email-masked]
> > https://www.ietf.org/mailman/listinfo/ogpx
> >
> 
> _______________________________________________
> ogpx mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ogpx