Subject: Re: [ogpx] The Role of Policy and Processing Expectations in Protocol Development

From: "[email-masked]" <[email-masked]>
Date: Sun, 23 Aug 2009 03:21:07 GMT

There's no need to misrepresent what I've been writing, Infinity.

You are engaging in policy prescriptions under the guise of "technology". It's the method that's been used on previous iterations of the Internet, for example, to try to force-feed the ideology of "Free" to cover up the cost of coders themselves, for example, on Web 1.0 or force-feed the ideology that "OMGZORZ walled gardens are evil" and we must have sieves and hooks and pulleys and interop hops in 2.0

I didn't say all words "have to adopt" SL's c/m/t. I said they had to *respect* c/m/t or the items shouldn't *lawfully* leave the SL grid. Very simple proposition. There is no reason why the simple regime of c/m/t can't be accommodated and respected, and not just with notecards. Not everybody sniffs the supersekrit packets on the previous session; if they do, you have a record and a crime file.

As we know, the OpenSim copies content from SL promiscuously and unlawfully and there are a huge number of documented cases of IP theft. Rezzable, maker and seller of BuilderBot, is saying "oh, we can't put creators' ID because those avatars aren't on our grids so we strip out the information". Well...if you have to strip  out information because those avatars don't exist on your grid, that should tell you that...you have unauthorized property and if you do accept it -- and SL hands it off -- then you are mechanically violating IP. 

For the millionth-and-second time, yeah, we get it that the point then is not to prevent this "mechanically impossible" (rolls eyes) operation which of course we totally realize is hackable by evil hackers. No, the point is to *record it* so that you can build a crime file.

And there are easy ways to deal with this once you aren't hobbled by ideology. You have viewers register, such as on this proposal:
http://jira.secondlife.com/browse/VWR-14778

A good example of a practical and moderate proposal that is assaulted by extremists.

Prokofy Neva

____________________________________________________________
Need Money for College?
Connect to the top online colleges offering financial aid. Free info!
http://thirdpartyoffers.juno.com/TGL2141/c?cp=M-KmxEvs7GPBmyPQzTm3mQAAJ1BAkQUOY6racJgsKTPwXVdzAAQAAAAFAAAAAB1a5D0AAAAAAAAAAAAAAAAACYhWAAAAAA==

---

From: Carlo Wood <[email-masked]>
Date: Sun, 23 Aug 2009 14:19:39 +0200

On Sun, Aug 23, 2009 at 03:21:07AM +0000, [email-masked] wrote:
> I didn't say all worlds "have to adopt" SL's c/m/t.

/me notes that Prokofy uses the word "World" to have the same meaning as Morgaine and me:
regions running under a different administration, but still reachable by "teleport" in theory.

> I said they had to *respect* c/m/t or
> the items shouldn't *lawfully* leave the SL grid. Very simple proposition. There is no
> reason why the simple regime of c/m/t can't be accommodated and respected, and not just
> with notecards.

Of course the protocol will support the Second Life model.
But it is policy whether or not to honour the c/m/t bits.

I can imagine that if some world (not the use of the word) refuses to sign a legal
paper saying they will honour the c/m/t bit in their policy (within reason: as
you say yourself, evil hackers can always get around it anyway) then Linden Lab
won't trust them with their assets.

At this moment no worlds get ANYTHING from Linden Lab (perfect security regarding
the OGP: there IS no OGP yet!). Yet, you see "a huge number of IP theft" or so
you say (I believe you). Then where in the protocol could we possibly, ever, prohibit
that?

> As we know, the OpenSim copies content from SL promiscuously and unlawfully and there
> are a huge number of documented cases of IP theft. Rezzable, maker and seller of BuilderBot,
> is saying "oh, we can't put creators' ID because those avatars aren't on our grids
> so we strip out the information". Well...if you have to strip  out information because
> those avatars don't exist on your grid, that should tell you that...
> you have unauthorized property and if you do accept it -- and SL hands it off -- then
> you are mechanically violating IP. 

I have to disagree here. Adding all kinds of complex attempts to enforce technically
what cannot be done (sorry, but it's true), you'd only make the protocol NEEDLESS complex.

It is way better to keep things mathematically simple and only enforce what is
REALLY enforcable.

> For the millionth-and-second time, yeah, we get it that the point then is not to prevent this
> "mechanically impossible" (rolls eyes) operation which of course we totally realize is
> hackable by evil hackers. No, the point is to *record it* so that you can build a crime file.

That is 100% policy and has nothing to do with either the protocol or this list, imho.

-- 
Carlo Wood <[email-masked]>

---

From: Carlo Wood <[email-masked]>
Date: Sun, 23 Aug 2009 14:24:26 +0200

> I can imagine that if some world (not the use of the word) refuses to sign a legal

...
I can imagine that if some world (NOTE the use of the word) refuses to sign a legal
...

damn typos.