Subject: [Ohttp] OHTTP name change

From: Francesca Palombini <[email-masked]>
Date: Fri, 3 Sep 2021 10:29:17 +0000

Hi all,

Following up on the discussion that happened during and after the BoF, I realize that some confusion came from the intended use cases, and that was reflected in the name of the proposed wg, which according to some conveyed too broad applicability.

Martin has worked on the charter, and included text that has clarified what use cases are addressed by this work, which has gotten very good feedback. Thanks Martin!

Regarding the name, after some consideration I think it would be beneficial to change the name to:

Oblivious Applications using Proxied HTTP (OAPH)

In my opinion, including the terms "applications" and "Proxied HTTP"  are enough to give a hint that this is not intended for general purpose/web browsing. And for any more specific details, one can refer to the charter.

This mail is to inform you of this change, and to make sure no-one thinks this name change is harmful. I understand the temptation to bikeshed is great with names, but I'll ask you to please consider this name and see if you can live with it, and only raise concerns if you see a big red flag that I might have missed. Of course we want to have a good working group name, but the name is only important to a point, most important is that the charter is clear and that we can progress the work.

Additionally, I am considering changing the mailing list to reflect this change - I have been told that the secretariat is able to subscribe everybody who is subscribed here to the new mailing list, so that should not be a hassle for you. There are examples both where the old mailing list has been kept and where it has been changed. I'll keep you updated.

With this name change, I will move the charter to the next step soon, which is external review. Feedback from the community will be welcome then. Please note that because of the name change, you will see some additional traffic mentioning working group creation and 2 weeks internal review, which come from the datatracker, but have in practice already been executed, which is why we will move directly to external review.

Thanks,
Francesca

---

From: Mark Nottingham <[email-masked]>
Date: Sat, 4 Sep 2021 09:30:10 +1000

Hi Francesca,

In HTTP, "proxy" has a very specific meaning, and IIRC the architecture that Martin describes is not a proxy in that sense -- it's effectively a new type of application built on top of HTTP. Functionally that application is proxying, but it is not a HTTP proxy in the sense defined in the RFCs.

This is of course arguable, and I may hear the faint sound of angels dancing as I type this. I don't think the name needs further changing, so long as it's understood that the group's work may not produce something that is strictly a HTTP proxy, and that it doesn't constrain what the final product is named.

Cheers,

P.S. will the mailing list name change? 

> On 3 Sep 2021, at 8:29 pm, Francesca Palombini <francesca.palombini=[email-masked]> wrote:
> 
> Hi all,
> 
> -- 
> Ohttp mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ohttp

--
Mark Nottingham   https://www.mnot.net/

---

From: Lars Eggert <[email-masked]>
Date: Sat, 4 Sep 2021 07:58:42 +0300

Would “relay” work better? Would result in OARH, which is even a bit more pronounceable.

-- 
Sent from a mobile device; please excuse typos.

> On Sep 4, 2021, at 02:30, Mark Nottingham <[email-masked]> wrote:
> 
> Hi Francesca,
>

---

From: Tommy Pauly <[email-masked]>
Date: Sat, 04 Sep 2021 06:16:41 -0700

Yeah, I imagine Relayed would work. OARH = Oblivious Applications using Relayed HTTP; or OAHR = Oblivious Applications using HTTP Relays. 

Tommy

> On Sep 3, 2021, at 9:59 PM, Lars Eggert <[email-masked]> wrote:
>

---

From: Jari Arkko <[email-masked]>
Date: Mon, 6 Sep 2021 12:54:56 +0300

Relayed sounds ok to me.

Jari

---

From: Francesca Palombini <[email-masked]>
Date: Mon, 6 Sep 2021 15:35:13 +0000

Thanks Mark for pointing this out, and thanks all for the feedback (and quick modification), relayed it is. 

To answer your question: my preference at the moment is to change the mailing list to the new name and subscribe everyone over to the new one. Will keep you all updated.

Francesca

---

From: Wes Hardaker <[email-masked]>
Date: Wed, 08 Sep 2021 09:00:15 -0700

Tommy Pauly <tpauly=[email-masked]> writes:

> Yeah, I imagine Relayed would work. OARH = Oblivious Applications
> using Relayed HTTP; or OAHR = Oblivious Applications using HTTP
> Relays.

I can't believe you're missing this wonderful opportunity:

Applications using Robust Relayed Routing == ARRR

-- 
Wes Hardaker
USC/ISI

---

From: Eric Rescorla <[email-masked]>
Date: Wed, 8 Sep 2021 09:15:00 -0700

Oblivious HTTP Application Intermediaries (OHAI).

-Ekr