Subject: [Omcast] Microsoft ConferenceXP

From: "Marshall Eubanks" <[email-masked]>
Date: Wed, 28 Sep 2005 13:04:29 -0400

Is ConferenceXP related to the OMCast goals ?

http://www.conferencexp.net/community/Default.aspx?tabindex=12&tabid=22

ConferenceXP employs a peer-to-peer architecture. Because no server is involved, this architecture
makes deployment easy, and it prevents network traffic bottlenecks and single points of failure.
This architecture uses multicast to ensure efficiency and scaling for multipoint video conferencing
over a broadband network, as well as for sharing documents and ink over a 802.11b wireless network.
It also supports point-to-point unicast for environments where multicast is unavailable.

There is also

Inter-Partition Networking for Overlay Multicast
Sauleh Eetemadi
Michigan State University

http://www.conferencexp.net/community/library/papers/InternPartitionNetworking.pdf

Regards
Marshall

_______________________________________________
Omcast mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/omcast

---

From: Mark Pullen <[email-masked]>
Date: Wed, 28 Sep 2005 21:52:24 -0400 (EDT)

> It also supports point-to-point unicast for environments where multicast is unavailable.
Yes, I would say this is related to OMcast goals. I would prefer that
the interface to the application be an open one - ours is plain
IP multicast, which is about as open as you can get. Although the
ConferenceXP interface is an API that looks to be proprietary from
what I see on the webpage, they must have a group communications
service lower in their architecture and they might be interested
in defining a common standard. In any event I believe it would be
a bad idea to rule out the possibility before learning what interests
they may have.

> http://www.conferencexp.net/community/library/papers/InternPartitionNetworking.pdf

As I read the abstract, this is an analytical treatment of an important
part of the problem that we have been working on at GMU. Because we are
experimentalists, we have implemented a working prototype and have people
interested in using it; but this thesis appears to be an important
contribution to the theoretical basis of routing in overlay networks. So
yes it definitely fits and thats for pointing it out.

Mark