Subject: [Openpgp-dt] minutes for design-team meeting 2021-08-27

From: Daniel Kahn Gillmor <[email-masked]>
Date: Sat, 28 Aug 2021 11:31:10 -0400

OpenPGP Design Team
2021-08-27 meeting notes

---------

Attending:

    dkg
    daniel huigens
    justus winter
    sftcd

We didn't have quorum, so no decisions were made, but we did make
progress discussing AEAD and figuring out how to include curve448:

# https://gitlab.com/openpgp-wg/rfc4880bis/-/merge_requests/59
- want to get that landed (but Paul/Werner not on call)
- for those on the call (incl. chairs as chairs) we'd prefer to be more terse and e.g. to omit the text about why smaller chunks are better for interop
- Action: SF to comment on MR to that effect (DONE)

# https://gitlab.com/openpgp-wg/rfc4880bis/-/merge_requests/61
- Some (initial) discussion of encodings for 25519 & 448
- opinions vary wrt adopting same encoding as other protocols ("just use these octets") vs using MPI encoding as previously done in PGP
- separable questions:

    - is #61 ok now or not?

    - what do we prefer to do about 448 and why?

- maybe instead of immediately trying for a merge request we instead provide example encodings for 448 keys etc and see if we can reach consensus about which encoding we prefer (and if there is, then we can figure how best to represent that consensus in spec text) 
- Action: Daniel H will send a mail outlining and naming options for HOWTO handle 448
- Action: Justus will propose some alternate text for #61
- Daniel H: we could better document how 25519 is handled maybe (in another MR yet to be done)
- Action: Justus to modify #61

---------

  --dkg

---

From: Paul Wouters <[email-masked]>
Date: Mon, 30 Aug 2021 04:19:22 -0400 (EDT)

On Sat, 28 Aug 2021, Daniel Kahn Gillmor wrote:

> Subject: [Openpgp-dt] minutes for design-team meeting 2021-08-27

Sorry I was not able to make the call.

> - Action: SF to comment on MR to that effect (DONE)

I updated the PR to remove the explanatory text.

Paul