Subject: [Openpgp-dt] OpenPGP DT Meeting Notes from 2021-12-22

From: Daniel Kahn Gillmor <[email-masked]>
Date: Wed, 22 Dec 2021 15:55:18 +0200

Thanks for the discussion today!  Here are the notes:

# OpenPGP Design Team Meeting

## 2021-12-22

Present:
	* gniibe
	* dkg
	* Daniel Huigens
	* jeffrey
	* stephen
	* justus
	* paul

# Agenda

## Plan for new year

Goal: DT aim declare victory for end-Jan (where victory == DT think we're done, back over to WG, maybe with some remaining gaps). That might require us to be more agressive in terms of how we merge MRs...

Action on all: we should each "approve" or thumbs-down and/or comment on all non-"unchartered" MRs by Jan 3rd.

Guideline: avoid creating new MRs except as already noted ('cause step-by-step or Daniel H existing action). Creating new issues is fine.

Subsequent to us achieving that goal: Editor emits I-D, chairs think about WGLC and hopefully ask the WG list about that.

## review of step-by-step branch

Paul said he's been doing this and will do again. 

## !86 and !85 (mutually exclusive, both have approval and thumbsdown)
https://gitlab.com/openpgp-wg/rfc4880bis/-/merge_requests/85 - suggests dropping v5 sigs
https://gitlab.com/openpgp-wg/rfc4880bis/-/merge_requests/86 - suggests a way to fix v5 sigs
	possibly coupled with https://gitlab.com/openpgp-wg/rfc4880bis/-/merge_requests/91 
related issue: https://gitlab.com/openpgp-wg/rfc4880bis/-/issues/49 

Action: DKG rewrite 86 to be three steps: remove v5 signatures; deprecate literal packet metadata; reintroduce v5 signatures with just the updated counters; and then Justus will rebase 91 based on 86; we will close 85

## https://gitlab.com/openpgp-wg/rfc4880bis/-/merge_requests/101
Daniel H noticed v5 PKESK internal checksum didn't cover alg ids, so changed to do that.  No objections from the DT
Action SF: add a note to the WEP thing this reminded him of, just to be sure we're not committing the same sin (we probably aren't)

## https://gitlab.com/openpgp-wg/rfc4880bis/-/merge_requests/100
justus/cleanup-implementation-nits to be rebased on top of #107
(https://gitlab.com/openpgp-wg/rfc4880bis/-/merge_requests/107) 

## Wrap-up

Action: (on "new" v. "old" packet formats) Justus suggests 20 years old is not "new" and he may propose something to fix the terminology.

Justus notes some issues don't have MRs; Justus threatens to propose some textto address outstanding issues.

OpenPGP card issue #63, Justus and gniibe agreed on stuff that SF and dkg didn't follow:-)
Action: Justus will note result of discussion on #63 (gniibe will review)

## Next Meeting

We'll take the last Wednesday of the year off; next meeting will be 2022-01-05

---

From: Daniel Kahn Gillmor <[email-masked]>
Date: Wed, 22 Dec 2021 22:13:08 +0200

On Wed 2021-12-22 15:55:18 +0200, Daniel Kahn Gillmor wrote:
> Action: DKG rewrite 86 to be three steps: remove v5 signatures;
> deprecate literal packet metadata; reintroduce v5 signatures with just
> the updated counters;

This is now done.  I've also closed !85.

Please take a look!

       --dkg

---

From: Stephen Farrell <[email-masked]>
Date: Thu, 23 Dec 2021 03:58:17 +0000

Hi folks,

> We'll take the last Wednesday of the year off; next meeting will be 2022-01-05

I just wanted to take the opportunity to say that despite
and because of my ignorance of pgp I've enjoyed our calls
as I've learned from 'em. So thanks for that, and I look
forward to learning more in the new year! (This is also a
bit of an apology-in-advance, because once we do get to a
place where we think the DT are "done," I'll likely do a
full read-through of the whole shebang, and will maybe be
a bit of a PITA then as I yet-again expose my ignorance;-)

Meanwhile, thanks and happy Christmas/Holidays/New-year
as appropriate and thanks again for helping me understand
this stuff at least a bit better,
Cheers,
S.

PS: If/when we do get to meet in person next year or after,
I will be delighted to buy the first round of beer/other
(and even happier to consume the last beer:-)