Subject: [openpgp] WG Review: Open Specification for Pretty Good Privacy (openpgp)

From: The IESG <[email-masked]>
Date: Thu, 26 Nov 2020 15:46:08 -0800

A new IETF WG has been proposed in the Security Area. The IESG has not made
any determination yet. The following draft charter was submitted, and is
provided for informational purposes only. Please send your comments to the
IESG mailing list ([email-masked]) by 2020-12-06.

Open Specification for Pretty Good Privacy (openpgp)
-----------------------------------------------------------------------
Current status: Proposed WG

Chairs:
  Stephen Farrell <[email-masked]>
  Daniel Gillmor <[email-masked]>

Assigned Area Director:
  Benjamin Kaduk <[email-masked]>

Security Area Directors:
  Benjamin Kaduk <[email-masked]>
  Roman Danyliw <[email-masked]>

Mailing list:
  Address: [email-masked]
  To subscribe: https://www.ietf.org/mailman/listinfo/openpgp
  Archive: https://mailarchive.ietf.org/arch/browse/openpgp/

Group page: https://datatracker.ietf.org/group/openpgp/

Charter: https://datatracker.ietf.org/doc/charter-ietf-openpgp/

OpenPGP is an Internet standard that covers object encryption, object
signing, and identity certification. These were defined by the first
incarnation of the OpenPGP working group.

The following is an excerpt from the charter of the original incarnation
of the openpgp working group

> The goal of the OpenPGP working group is to provide IETF
> standards for the algorithms and formats of PGP processed
> objects as well as providing the MIME framework for exchanging
> them via e-mail or other transport protocols.

The working group concluded this work and was closed in March of 2008.
In the intervening period, there has been a rough consensus reached that
the RFC that defined the IETF openpgp standard, RFC4880, is in need of
revision.

This incarnation of the working group is chartered to primarily produce
a revision of RFC4880 to address issues that have been identified by the
community since the working group was originally closed.

These revisions will include, but are not necessarily limited to:

- Inclusion of elliptic curves recommended by the Crypto Forum
Research Group (CFRG) (see note below)

- A symmetric encryption mechanism that offers modern message integrity
protection (e.g. AEAD)

- Revision of mandatory-to-implement algorithm selection and deprecation
of weak algorithms

- An updated public-key fingerprint mechanism

The Working Group will perform the following work:

- Revise RFC4880.  The intent is to start from the current rfc4880bis draft.

- Other work related to OpenPGP may be entertained by the working group
as long as it does not interfere with the completion of the RFC4880
revision. As the revision of RFC4880 is the primary goal of the working
group, other work may be undertaken, so long as:

1. The work will not unduly delay the closure of the working group after
the revision is finished (unless the working group is rechartered).

2. The work has widespread support in the working group.

These additional work items may only be added with approval from the
responsible Area Director who may additionally require re-chartering
for certain work items, as needed.

Inclusion of CFRG Curves
-----------------------------

The Working Group will consider CFRG curves as possible Mandatory to
Implement (MTI) algorithms.

Working Group Process
--------------------------

The working group will endeavor to complete most if not all of its work
online on the working group's mailing list. We expect that the
requirement for face-to-face sessions at IETF meetings to be minimal.

For the revision of RFC 4880, all changes from RFC 4880, and for other
work items, all content, require both consensus on the mailing list and
the demonstration of interoperable support by at least two independent
implementations, before being submitted to the IESG.

Furthermore, the working group will adopt no I-D's as working group
items unless there is a review by at least two un-interested parties of
the I-D as part of the adoption process.

Milestones:

  Jun 2021 - submit RFC 4880 revision to the IESG

---

From: Stephen Farrell <[email-masked]>
Date: Fri, 27 Nov 2020 00:05:58 +0000

Hi all,

Just as a reminder - this is the bureaucracy playing itself
out:-) WG charter changes like this are circulated to other
SDOs (IEEE, W3C etc) and to the IETF list partly to check the
content doesn't overlap with other stuff in a silly manner.
It's still entirely fine to comment on the text, but there's
no pressing need for participants in the putative WG to do
that if it's mostly ok already.

Cheers,
S.

-------- Forwarded Message --------
Subject: [openpgp] WG Review: Open Specification for Pretty Good Privacy 
(openpgp)
Date: Thu, 26 Nov 2020 15:46:08 -0800
From: The IESG <[email-masked]>
Reply-To: [email-masked]
To: IETF-Announce <[email-masked]>
CC: [email-masked]

Chairs:

Assigned Area Director:

Security Area Directors:

Mailing list:

Inclusion of CFRG Curves

Working Group Process

Milestones:

_______________________________________________
openpgp mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/openpgp

---

From: Bob Hinden <[email-masked]>
Date: Thu, 26 Nov 2020 17:23:50 -0800

IESG,

I support forming this proposed working group.  I am a user of PGP and think updating the specification is a good idea.

Bob

> On Nov 26, 2020, at 3:46 PM, The IESG <[email-masked]> wrote:
> 
> IETF-Announce mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ietf-announce

---

From: "Salz, Rich" <[email-masked]>
Date: Fri, 27 Nov 2020 02:53:08 +0000

What is different that folks think it will succeed this time?

---

From: Stephen Farrell <[email-masked]>
Date: Fri, 27 Nov 2020 03:27:04 +0000

Hi Rich,

> What is different that folks think it will succeed this time?

That's a fair question. My substantive reaction is twofold:

1: DKG has done and is willing to do a pile more work on
exactly the (limited) topic of the WG, and I don't believe
he's alone at all in striving to help folks generate a stable
update to our base RFC. So if we can get a sufficient number
of other sensible folks concentrated, then it may work.
The plan (well, really DKG's fine plan), is to try find a
way to enable WG participants to decide the smallish set
of non-trivial issues shown up by that analysis on a
weekly or bi-weekly schedule until we've collectively
decided on success. My minor input is that, based on my
respect for PGP implementers and people who've worked on
the code and documents for years, is that I think that plan's
definitely worth a shot. (None of the above means to discount
the work done by editors/implementers since the last official
incarnation of the openpgp WG, but I think your question
relates more to likely WG success than to history.)

2: I think PGP is an important protocol, that we should
document as well as we (the IETF) can, so the fact that
a previous iteration of this effort didn't pan out is not
a reason to fail to try again. As is true with many things,
once you get the timing right, everything else falls into
place: - my gut is sufficiently insistent that the time is
close enough to maybe-right, that I said yes when asked to
co-chair;-) That's not a particularly convincing argument
for anyone else of course, but it worked enough for me.

So, bottom line: it'll be good if it works, so is very
worth trying again. And I hope we can get your fine input
to that as we go.

Cheers,
S.

---

From: Michael Richardson <[email-masked]>
Date: Sat, 28 Nov 2020 01:05:09 -0500

> What is different that folks think it will succeed this time?

It's unclear to me what "it" refers to, or "this time".

It could be the WG, it could be the protocol, it could be that email will be
become ubiquitously encrypted/signed.

Stephen seems to have answered with "it == WG", but it's not clear to me that
you mean that.

--
Michael Richardson <[email-masked]>   . o O ( IPv6 IøT consulting )
           Sandelman Software Works Inc, Ottawa and Worldwide

---

From: "Salz, Rich" <[email-masked]>
Date: Sat, 28 Nov 2020 14:24:05 +0000

you mean that.

I did.