Subject: [OPS-AREA] Proposal for a OPS Area Working Group

From: "Romascanu, Dan \(Dan\)" <[email-masked]>
Date: Mon, 19 Mar 2007 19:35:00 +0200

The following text was included in the slide that was proposing the
formation of a OPS Area Working Group. 

Please provide feedback on this list before the second area meeting on
Wednesday.

Thanks and Regards,

Dan

--------------------------

Goal - improved efficiency in the OPS Area
	Reduce the number of AD-sponsored documents
	Give a chance for new ideas to materialize faster

Framework for Operations and Management documents that do not find a
home in WGs
	Continuation of work in completed WGs
	Documents that are important enough to work on but less than a
critical mass for a separate WG

Model used in other IETF areas (routing, transport)
	From the TSVWG charter
		The Transport Area receives occasional proposals for the
development 
		and publication of RFCs dealing with transport topics
that are not in 
		scope of an existing working group or do not justify the
formation of 
		a new working group. TSVWG will serve as the forum for
developing 
		such work items in the IETF.

		The TSVWG mailing list is an open discussion forum for
such work 
		items, when they arise. The working group meets if there
are active 
		proposals that require discussion. The working group
milestones are 
		updated as needed to reflect the current work items and
their 
		associated milestones.

Will happen only if there is community support and particpation

_______________________________________________
OPS-AREA mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ops-area

---

From: "Wijnen, Bert \(Bert\)" <[email-masked]>
Date: Mon, 19 Mar 2007 19:02:03 +0100

I wonder if it should be one WG for both OPS and NM o maybe two
of them, one for OPS and one for NM??

Other than that, It probably makes sense to have such a WG.

Bert 

> -----Original Message-----
> From: Romascanu, Dan (Dan) [mailto:[email-masked]] 
> Sent: maandag 19 maart 2007 18:35
> To: [email-masked]
> Subject: [OPS-AREA] Proposal for a OPS Area Working Group
> 
> 
> The following text was included in the slide that was 
> proposing the formation of a OPS Area Working Group. 
> 
> Please provide feedback on this list before the second area 
> meeting on Wednesday.
> 
> Thanks and Regards,
> 
> Dan
> 
> Framework for Operations and Management documents that do not 
> find a home in WGs
> 	Documents that are important enough to work on but less 
> than a critical mass for a separate WG
> 
> 		The Transport Area receives occasional 
> proposals for the development 
> 		and publication of RFCs dealing with transport 
> topics that are not in 
> 		scope of an existing working group or do not 
> justify the formation of 
> 		a new working group. TSVWG will serve as the 
> forum for developing 
> 		The TSVWG mailing list is an open discussion 
> forum for such work 
> 		items, when they arise. The working group meets 
> if there are active 
> 		proposals that require discussion. The working 
> group milestones are 
> 		updated as needed to reflect the current work 
> items and their 
> 		associated milestones.
>

---

From: "Natale, Bob" <[email-masked]>
Date: Mon, 19 Mar 2007 22:14:35 -0400

I agree that such a WG should be formed and actively leveraged.

I can see the rationale for separate OPS and NM WGs, but feel we would
be better served initially by a single combined WG.  While we need more
OPS focus, we have an equal or possibly greater need for integrated
awareness across both perspectives.

Cheers,
BobN

-----Original Message-----
From: Wijnen, Bert (Bert) [mailto:[email-masked]] 
Sent: Monday, March 19, 2007 2:02 PM
To: Romascanu, Dan (Dan); [email-masked]
Subject: RE: [OPS-AREA] Proposal for a OPS Area Working Group

Bert

---

From: Andy Bierman <[email-masked]>
Date: Mon, 19 Mar 2007 20:32:00 -0700

> Please provide feedback on this list before the second area meeting on

If I cared about IETF process, I would be a bit concerned about 
chartering a WG
without a clear purpose, set of milestones, or any deliverables.  I  think
the success of the OPS-NM area should be measured in deployed useful 
standards,
not the number of drafts published, or other internal metrics related to 
the IETF process.

IMO,  there should be an OPS-NM Infrastructure and Tools team, who delivered
freely available tools (where a tool is loosely defined -- could be 
running code,
could be a data model template, could be enhancement requests for 
xml2rfc, etc.)

I would like to see an articulated vision for convergence in IETF NM 
standards.
I am very opposed to the idea of telling WGs to use whatever NM or 
whatever OPS
protocols they want, provide whatever functionality they want.  We 
already have that
situation with proprietary solutions.  An SDO should set higher goals 
than that.

The first step is to start being proactive about standards and 
standards-based tools,
like the IETF tools team has done with xml2rfc and the administrative 
WEB pages.

> Dan

Andy

---

From: "Romascanu, Dan \(Dan\)" <[email-masked]>
Date: Tue, 20 Mar 2007 09:19:12 +0200

See in line. 

Regards,

Dan

> From: Andy Bierman [mailto:[email-masked]] 
> Sent: Tuesday, March 20, 2007 5:32 AM
> To: Romascanu, Dan (Dan)
> Cc: [email-masked]
> Subject: Re: [OPS-AREA] Proposal for a OPS Area Working Group
> 
> meeting on 
> If I cared about IETF process, I would be a bit concerned 
> about chartering a WG without a clear purpose, set of 
> milestones, or any deliverables. 

I agree. The slide and text in this mail was provided for the purpose of
discussions. If we decide to go ahead the charter would include clear
purpose, milestones, deliverables.  

>  I  think the success of the 
> OPS-NM area should be measured in deployed useful standards, 
> not the number of drafts published, or other internal metrics 
> related to the IETF process.

Absolutely. There is one metrics which related to timely delivery of the
charter items which I would not abandon though. 

> 
> IMO,  there should be an OPS-NM Infrastructure and Tools 
> team, who delivered freely available tools (where a tool is 
> loosely defined -- could be running code, could be a data 
> model template, could be enhancement requests for xml2rfc, etc.)

Do you have concrete proposals on this respect? If such proposals where
available and the community would agree on a plan we could push this
proposal through the IESG, also ask for some funding and logistics
support

> 
> I would like to see an articulated vision for convergence in 
> IETF NM standards.
> I am very opposed to the idea of telling WGs to use whatever 
> NM or whatever OPS protocols they want, provide whatever 
> functionality they want.  We already have that situation with 
> proprietary solutions.  An SDO should set higher goals than that.

Maybe. I do not believe that anybody disagrees about the need for
convergence, but we do not seem to be able to agree on the level where
this convergence happens. My opinion as a member of the community is
that the one protocol model did not succeed, and as functionality in the
management space is becoming only more complex, we need to talk about a
tool set, and one tool only. 

> 
> The first step is to start being proactive about standards 
> and standards-based tools, like the IETF tools team has done 
> with xml2rfc and the administrative WEB pages.

I count on your help and on everybody's help on this. Things will happen
only if we want them to happen and put some work behind our will. 

Dab

> topics that are not 
> > in
> justify the formation 
> > of

---

From: "Romascanu, Dan \(Dan\)" <[email-masked]>
Date: Tue, 20 Mar 2007 09:28:40 +0200

See in line. 
(with some typos corrected) 

Regards,

Dan

> related to the IETF process.

Absolutely. There is one metrics which is related to timely delivery of
the
charter items which I would not abandon though. 

tool set, and not about one tool only. 

Dab

---

From: Andy Bierman <[email-masked]>
Date: Tue, 20 Mar 2007 04:07:19 -0700

Romascanu, Dan (Dan) wrote:
> >>..

Yes, but rather than going into detail now,
I will just say that IMO, following all the CLRs that exist to publish
a decent MIB module RFC is more work (for mere mortals) than
actually designing the MIB in the first place. 

Juergen says this tool is easy, so maybe he will design it for us,
but I want to make it hard NOT to create a great data model
that passes all the CLRs, uses all the BCPs, and passes every
MIB Doctor review will flying colors on the first try.
Oh, and I want to get data models that can be used for NETCONF and/or SNMP
out of the same source module.  And I want the tool to write most of
the I-D for me, based on the source data model.

I also want a new document section (uh-oh!) called Operational 
Considerations.
IMO, bad NM spills over into bad OPS.
I am reminded of a certain switch vendor who hardwired the IP address
of an NTP server into a box, shipped about a million of them, and swamped
a certain server in the Midwest.  Bad NM caused a serious operational
problem in this case.

Part of what I want is really in the scope of the EDU team's charter I 
guess.

Andy

>>> Framework for Operations and Management documents that do 
>>>       
>> not find a 
>>     
>>> home in WGs

---

From: David Kessens <[email-masked]>
Date: Tue, 20 Mar 2007 07:12:21 -0700

Bert,

> of them, one for OPS and one for NM??

My personal preference is for a single working group. There are real
synergies between the two parts of the Ops & Management and the kind
of documents that don't fit a particular Ops & Management working
group are often right on the edge between the two parts of the Ops &
Management Area.

David Kessens
---