Subject: [OPS-AREA] Minutes of 3GPP - IETF teleconference 17th Feb 2010

From: <[email-masked]>
Date: Fri, 19 Feb 2010 13:25:43 +0100

Dear all,

please find below the meeting minutes from the 3GPP - IETF teleconference on the 17th of February 2010. The same minutes are shared on four mailing lists: 3GPP TSG CT, IETF RAI, INT, OPS.

Dependency document on 3GPP website will be updated soon for the coming March TSG plenaries.

Date: 17th Feb 2010
Time: 16:00 - 18:00 UTC
Venue: Phone conference
Participants:
Hannu Hietalahti (notetaker)
Milan Patel
Atle Monrad
Gonzalo Camarillo
Tom Tailor
Scott Lawrence
Hannes Tschofenig
Mary Barnes
Adam Roach
Jari Arkko
Ben Campbell
Julien Laganier
Spencer Dawkins
Ralph Droms
Marc Linsner

Agenda:
-------------
1. Roll call
2. Review of action points
3. Joint workshop on IPv6 in March 2010
4. IANA registrations
5. Emergency calls
6. Review of 3GPP IETF dependency document
7. Next meeting
8. AOB
9. Closing

1.      Roll call
All participants are listed above.

2.      REview of action points
AP      Title   Responsible     Status
1       Request expert comments on the best approach to IANA registration of Service ID namespace assignment    Mary Barnes     Closed
2       Check the registration status of IANA registration of 3gpp-ims+xml      Cullen Jennings Closed
3       Provide a written explanation of why it could be considered that IANA registration of feature tags g.3gpp.icsi and g.3gpp.iari could proceed according to RFC 2506 without procedural change    Atle Monrad     Closed
4       Escalate the previous summary by Atle for RAI leadership review during IETF #74 to find a recommended way forward       Cullen Jennings Closed
5       Report the SA3 meeting outcome to Jari Arkko    Valtteri Niemi  Closed
6       Arrange a telco on media security on Friday the 7th of Nov 2008 Valtteri Niemi  Closed
 7      Find the original 3gpp-ims+xml registration document and forward it to Cullen   Hannu Hietalahti        Closed
8       Set up a meeting between 3GPP and IETF to agree how to proceed in the IANA registration of feature tags g.3gpp.icsi and g.3gpp.iari     Gonzalo Camarillo       Closed
9       Check the real 3GPP need for draft-arkko-mext-rfc3775-altcoa-check      Raj Patil       Closed
10      Hannu to ask on CT1 mailing list if anyone knows any reason why phonebcp -draft would not be applicable in cellular environment Hannu   Closed
        New APs assigned in this meeting
11      Check the status of IANA registration of EAP-AKA attributes required by 3GPP    Jari Arkko      done
12      Jari Arkko as the sponsor of draft-das-mipshop-andsf-dhcp-options needs to know of any changes in the requirements from 3GPP side where the discussion on the 3GPP TS 24.302 requirements for ANDSF discovery are still ongoing. Hannu to inform Jari of 3GPP decisions in this area.   Hannu Hietalahti        Open
13      The status of draft-mmusic-ice-tcp is marked dead in I-D Tracker, but a new version has been since then submitted. Hannu to find out from the responsible AD (Cullen) whether 3GPP should expect the draft to remain dead or not?       Hannu Hietalahti        done
14

3.      Joint workshop in March 2010
The planning of IPv6 migration workshop in San Francisco on 1 - 2 March 2010 is well underway by the co-chairs Fred Baker and Balazs Bertenyi.

This workshop is informative and any agreements still need to be documented according to normal working procedures in IETF or 3GPP or both, as applicable.

4.      IANA registrations
All pending IANA registrations related with 3GPP work are expected to progress as part of the work when the related drafts become RFCs.

It was not known at the time of meeting whether there is an open item in IANA registration of EAP-AKA attributes. Jari Arkko volunteered to check the status (AP 11).

5.      Emergency calls
Feedback mechanism via option tag has been discussed draft-patel-ecrit-sos-parameter to inform the UE whether the request was understood by the registrar or not. The latest version does not add the option tag, but adds an explanation of why emergency registration is needed is added and what happens if the registrar does not support the URI parameter in registration request. This draft has been agreed to progress as AD sponsored document (Cullen Jennings)

Callback has also been discussed recently in ECRIT and the work is progressing. Possible future work area may raise in non-voice emergency calls. The requirements need to be identified first and it was assumed (but not confirmed during the meeting) that NENA would be liaising to 3GPP on non-voice emergency calls.

Callback is removed from 3GPP Rel-9 requirements but this does not mean that 3GPP is abandoning that requirement. This decision should be considered as commitment to use IETF based approach for callback indication and giving more time to get it completed.

6.      Review of 3GPP - IETF dependency document
The following new Rel-8 dependencies have been identified since the previous update of the dependency document:
*       draft-ietf-sipcore-invfix
*       draft-ietf-sip-ipv6-abnf-fix
*       draft-ietf-mmusic-ice-tcp
*       draft-ietf-sipcore-keep
*       draft-ietf-mediactrl-vxml
*       draft-ietf-mediactrl-sip-control-framework
*       draft-ietf-mediactrl-ivr-control-package
*       draft-ietf-mediactrl-mixer-control-package
*       draft-kaplan-dispatch-session-id

draft-ietf-simple-xcap-diff: Waiting for AD go-ahead in Sep 2009 (Robert Sparks) New version published in Jan 2010. It is being evaluated whether WG still needs to re-review this draft.

draft-ietf-simple-common-policy-caps: The draft has expired, and is not going to proceed to RFC. CT1 needs to take out the reference from 24.141

draft-ietf-sip-xcapevent and draft-sipping-config-framework: CT1 have replaced their references to config-framework with refs to xcapevent. SA4 have also analysed their situation and intend to keep using config-framework in 3GPP TS 26.237.

draft-ietf-ipv6-abnf-fix will progress as AD sponsored draft (Robert Sparks).

draft-drage-sipping-rfc3455bis has expired but it will be needed by 3GPP. It has been agreed to discuss among the interested people in San Francisco during CT1 #63 meeting week how to progress this work. The draft should progress as AD sponsored draft and further discussions on IETF side should take place on SIPPING list.

draft-dime-qos-attributes is now an RFC.

draft-patel-dispatch-cpc-oli-parameter replaces draft-mahy-iptlel-cpc. This work is expected to spin of a new mini-WG under DISPATCH.

draft-drage-sipping-service-identification has been in IESG evaluation since September 2009 and revised draft is needed to handle the comments that have been made.

draft-ietf-mmusic-sdp-capability-negotiation has been in IESG evaluation since June 2009, revised ID is needed and we are waiting for new version. New version was submitted and it has been requested that this draft should go back to WG

draft-uy-tel-dai is indicated as dead in I-D tracker. There has been intention to submit a new version to DISPATCH, but that has not happened yet. New version of the draft would need to be submitted.

draft-netlmm-pmip6-ipv4-support is in IESG evaluation since Nov 2009 and has received comments in IPSec area. Substantial re-write of the draft to address the comments has received rough consensus. AD review of the new version is still required before asking for IESG approval

draft-ietf-mip4-rfc3344bis has been revised to new draft version in Jan 2010. It is waiting for shepherd writeup. There has been very little activity in TSG CT on 24.304 recently as the latest versions do not require changes in 3GPP TSs, so CT1 is waiting for the draft to be completed.

draft-johnston-sipping-cc-uui has been revised to draft-johnston-dispatch-cc-uui. CT1 needs to update 24.229. It has been agreed to charter a new mini-WG to handle this draft.

draft-jesske-sipping-etsi-ngn-reason is replaced with draft-jesske-dispatch-reason-in-responses. The editor has been requested to split out the protocol changes from the use cases more clearly

draft-das-mipshop-andsf-dhcp-options proceeds as an AD sponsored draft (Jari Arkko). MIPSHOP review was requested and that has now been passed. 3GPP needs to determine more precisely the use of the draft.

draft-vanelburg-sipping-private-network-indication has a new name under DISPATCH WG and CT1 needs to check whether they have updated their specifications already. The authors need to drive this work in DISPATCH group.

draft-ietf-bliss-call-completion needs the editor to respond to technical issues that have been raised before the draft is ready for WG LC.

Two drafts have been merged to draft-dawes-sipping-debug and CT1 have already updated their specifications on this. It was agreed that the work on this draft will need to continue in DISPATCH.

draft-bakker-sipping-3gpp-ims-xml-body-handling will progress as AD sponsored draft (Cullen Jennings).

draft-mmusic-ice-tcp is marked as dead in IETF I-D tracker, but a new version has been distributed. 3GPP has got a reference towards this draft and needs to know whether the document is expected to progress or not.

7.      Next meeting
Hannu cannot participate IETF #77 so the next meeting was agreed to be a telco on the last week of April 2010, with April 28 agreed as the tentative date.

8.      Any Other business
It was agreed to collect comments and revisions on these minutes until Friday the 19th of February 12:00 noon UTC so that Hannu can distribute the reviewed and agreed version on 3GPP TSG CT mailing list and IETF RAI, INT and OPS mailing lists during the same day.

Jari Arkko gave the following comment via email after the meeting, to cover his AP 11 from this meeting:

"IANA has an expert that reviews these requests (Vesa Lehtovirta). While he was also specifying some of this work on the 3GPP side, in the IANA review he did spot an issue in the way that the attribute bit fields are defined. The issue is being rectified in CT1, they will handle a CR next week to fix 24.302. Once this is approved, I think we are all set and the IANA allocation can be made."

Cullen Jennings made the following comment related with AP 13 on draft-mmusic-ice-tcp from this meeting:

"This draft expired (no new version for 6 months) and for some reasons the idtracker moved it to dead when it expired. I'm not sure why this happened but I moved it back to AD-Watching. My understanding of the situation is that the ietf community believes ice-tcp is needed and would like it to move forward but it needs a lot of work and the no one seems willing to put the time in to finish it. So with no one really moving ice-tcp forward, there is not much happening on the SDP attributes for it. It is not making much forward progress right now."

9.      Closing
The meeting was closed at 17:50 UTC.

BR,
Hannu Hietalahti
3GPP TSG CT Chairman
tel: +358 40 5021724

---

From: Cullen Jennings <[email-masked]>
Date: Wed, 24 Feb 2010 22:03:10 -0800

> draft-bakker-sipping-3gpp-ims-xml-body-handling will progress as AD sponsored draft (Cullen Jennings).

Could anyone clarify where this came from in the call? 

Thanks, Cullen

---

From: "Spencer Dawkins" <[email-masked]>
Date: Thu, 25 Feb 2010 14:58:39 -0600

Hi, Cullen,

For what it's worth, my notes on this said

"bakker-sipping-3gpp-ims-xml-body-handling - never had a direct reference 
from 24.229, but specification is needed for IANA registration. Mary punted 
this to ADs last week. Need to ask if this needs expert review, if it's 
going to be AD-sponsored."

Spencer