Subject: [OPS-AREA] Fwd: [IPFIX] Export of MIB variable in IPFIX: new IETF draft

From: Benoit Claise <[email-masked]>
Date: Tue, 19 Oct 2010 17:11:08 +0200

Ron and Dan,

Since this draft concerns a (kind of) consolidation between two data 
models within OPS, it might make sense to also present this work in the 
OPS-AREA meeting. What do you think?

Regards, Benoit.

-------- Original Message --------
Subject: 	[IPFIX] Export of MIB variable in IPFIX: new IETF draft
Date: 	Tue, 19 Oct 2010 16:52:40 +0200
From: 	Benoit Claise <[email-masked]>
To: 	[email-masked] <[email-masked]>

Dear all,

Andrew, Paul, and I posted this new draft, "Exporting MIB variables
using the IPFIX Protocol".
http://www.ietf.org/staging/draft-johnson-ipfix-mib-variable-export-00.txt

        Abstract

           This document specifies a way to export Management
           Information Base (MIB) objects within the IPFIX protocol,
           avoiding the need to define new IPFIX Information Elements
           for existing Management Information Base objects that are
           already fully specified.

           This method requires an extension to the current IPFIX
           protocol.  New Template Set and Options Template Sets are
           specified to allow the export of Simple Network Management
           Protocol (SNMP) MIB Objects.

The problem we want to solve is that we keep development two data models
for a unique information model (*) , i.e. MIB and IPFIX information
elements, which are overlapping. For example: there is an IPFIX
information element representing the ifName MIB Object. Note that some
more advantages are specified in the draft.
(*) RFC 3444, "On the Difference between Information Models and Data Models"

Please read it and send your feedback.

I would like to have a slot at the next meeting to present this work.

Regards, Benoit.
_______________________________________________
IPFIX mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/ipfix

---

From: "Romascanu, Dan (Dan)" <[email-masked]>
Date: Tue, 19 Oct 2010 17:12:55 +0200

Makes sense to me. How much time do you need? 
 
Regards,
 
Dan

________________________________

	From: [email-masked]
[mailto:[email-masked]] On Behalf Of Benoit Claise
	Sent: Tuesday, October 19, 2010 5:11 PM
	To: [email-masked]
	Subject: [OPS-AREA] Fwd: [IPFIX] Export of MIB variable in
IPFIX: new IETFdraft

	Ron and Dan,
	
	Since this draft concerns a (kind of) consolidation between two
data models within OPS, it might make sense to also present this work in
the OPS-AREA meeting. What do you think? 
	
	Regards, Benoit.

	-------- Original Message -------- 
Subject: 	[IPFIX] Export of MIB variable in IPFIX: new IETF draft	
Date: 	Tue, 19 Oct 2010 16:52:40 +0200	
From: 	Benoit Claise <[email-masked]> <mailto:[email-masked]> 	
To: 	[email-masked] <[email-masked]> <mailto:[email-masked]> 	

	Dear all,
	
	Andrew, Paul, and I posted this new draft, "Exporting MIB
variables 
	using the IPFIX Protocol".
	
http://www.ietf.org/staging/draft-johnson-ipfix-mib-variable-export-00.t
xt
	
	       Abstract
	
	          This document specifies a way to export Management
	          Information Base (MIB) objects within the IPFIX
protocol,
	          avoiding the need to define new IPFIX Information
Elements
	          for existing Management Information Base objects that
are
	          already fully specified.
	
	          This method requires an extension to the current IPFIX
	          protocol.  New Template Set and Options Template Sets
are
	          specified to allow the export of Simple Network
Management
	          Protocol (SNMP) MIB Objects.

	The problem we want to solve is that we keep development two
data models 
	for a unique information model (*) , i.e. MIB and IPFIX
information 
	elements, which are overlapping. For example: there is an IPFIX 
	information element representing the ifName MIB Object. Note
that some 
	more advantages are specified in the draft.
	(*) RFC 3444, "On the Difference between Information Models and
Data Models"

	I would like to have a slot at the next meeting to present this
work.
	
	Regards, Benoit.

---

From: Benoit Claise <[email-masked]>
Date: Tue, 19 Oct 2010 17:18:14 +0200

Hi Dan,

Around 20 minutes.

Regards, Benoit.
>     ------------------------------------------------------------------------
>     *From:* [email-masked]
>     [mailto:[email-masked]] *On Behalf Of *Benoit Claise
>     *Sent:* Tuesday, October 19, 2010 5:11 PM
>     *To:* [email-masked]
>     *Subject:* [OPS-AREA] Fwd: [IPFIX] Export of MIB variable in
>     IPFIX: new IETFdraft
>
>     Ron and Dan,
>
>     data models within OPS, it might make sense to also present this
>     work in the OPS-AREA meeting. What do you think?
>
>     Regards, Benoit.
>
>