Subject: [OPS-AREA] configuration: writable MIB modules versus NETCONF/YANG modules

From: David Meyer <[email-masked]>
Date: Fri, 14 Feb 2014 07:12:41 -0800

>> Dear all,
>>
>> We occasionally see read-write MIB module proposals within the IETF.
>> However, the write capabilities of those MIB modules are rarely
>> implemented.
>>
>> While discussing this issue with the MIB doctors, we arrive to the
>> conclusion that it's now time to set the direction for future MIB
>> developments within the IETF. Basically, let's not specify read-write
>> MIB modules unless we have a good reason. Read-only MIB modules
>> are still fine though, as SNMP is clearly used for monitoring purposes.
>>
>> Here is the statement we came up with:
>>
>> The OPS area recommends the use of NETCONF/YANG standards for
>> configuration. IETF working groups are therefore encouraged to use the
>> NETCONF/YANG standards for configuration, specifically in new
>> charters. SNMP MIB modules modifying persistent configuration state
>> should only be produced by working groups in cases of clear utility
>> and consensus to use SNMP write operations for configuration.
>>
I>> deally, this should become an IESG statement.
>> Your feedback is most welcome.
>>
>> Regards, the MIB doctors & Benoit

Eminently reasonable and needed.

+1

--dmm

---

From: "Diego R. Lopez" <[email-masked]>
Date: Fri, 14 Feb 2014 15:19:15 +0000

> Eminently reasonable and needed.

Indeed!

+1 as well
--
"Esta vez no fallaremos, Doctor Infierno"

Dr Diego R. Lopez
Telefonica I+D
http://people.tid.es/diego.lopez/

e-mail: [email-masked]
Tel:    +34 913 129 041
Mobile: +34 682 051 091
-----------------------------------------

________________________________

Este mensaje se dirige exclusivamente a su destinatario. Puede consultar nuestra política de envío y recepción de correo electrónico en el enlace situado más abajo.
This message is intended exclusively for its addressee. We only send and receive email on the basis of the terms set out at:
http://www.tid.es/ES/PAGINAS/disclaimer.aspx

---

From: Balazs Lengyel <[email-masked]>
Date: Fri, 14 Feb 2014 16:20:28 +0100

+1
Balazs

On 2014-02-14 16:19, Diego R. Lopez wrote:
> _______________________________________________
> OPS-AREA mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ops-area

-- 
Balazs Lengyel                       Ericsson Hungary Ltd.
System Manager
ECN: 831 7320                        Tel: +36-1-437-7320
Mobile: +36-70-330-7909              email: [email-masked]