Subject: RE: [OPS-NM] RE: [OPS-AREA] Re: [MIB-DOCTORS] OPS Area BOFs in Prague

From: "Romascanu, Dan \(Dan\)" <[email-masked]>
Date: Thu, 21 Dec 2006 14:02:38 +0200

I am not in the position to disagree :-)

We need however to start from something. This 'something' is in my
opinion a document to guide IETF authors in writing manageability and
operational requirements in their protocol documents. Today in the
absence of such a reference I encounter huge problems in my role of Area
Director when I come and say 'we cannot approve this new protocol
because it says nothing about how it will be managed or what impact it
will have in the operation of the network'. The typical answers are 'who
says it needs to say something about management and operations?' or
'what is the reference for what we need to include about manageability
and operations'? 

Dan

> -----Original Message-----
> From: Natale, Bob [mailto:[email-masked]] 
> Sent: Wednesday, December 20, 2006 9:23 PM
> To: [email-masked]; [email-masked]; [email-masked]; IESG
> Cc: [email-masked]; MIB Doctors; DNS Directorate
> Subject: [OPS-NM] RE: [OPS-AREA] Re: [MIB-DOCTORS] OPS Area 
> BOFs in Prague
> 
> 
> Hi,
> 
> I strongly agree with Andy's position (from below):
> 
> "IMO, to advance to Draft Standard, a protocol should meet 
> strict manageability requirements, which would obviously need 
> to be documented in an RFC."
> 
> Cheers,
> BobN
> 
> -----Original Message-----
> From: Andy Bierman [mailto:[email-masked]]
> Sent: Wednesday, December 20, 2006 2:10 PM
> To: David B Harrington
> Cc: [email-masked]; [email-masked]; 'MIB Doctors'; 
> 'DNS Directorate'; 'IESG'; [email-masked]; [email-masked]
> Subject: [OPS-AREA] Re: [MIB-DOCTORS] OPS Area BOFs in Prague
> 
> David B Harrington wrote:
> > Hi,
> > 
> > Please respond only to the OPS-area mailing list.
> > 
> > I would like to raise three potential areas of discussion. 
> These may 
> > be suitable for BOFs or mini-BOFs.
> > 
> > 1) An OpsNM BOF, designed to lead to a WG similar to the 
> OpSec WG, to 
> > have **operators** document how they actually manage 
> networks today, 
> > and to document what features they utilize in equipment today to 
> > accomplish such management.
> 
> 
> I think such a documentation project could be a lot of work.
> If there were enough participation, it would be very useful.
> 
> 
> > 
> > For example, DavidK mentioned during the last OPSarea open-office 
> > meetings that there are three major approaches to managing service 
> > provider networks (Motorola, ??, ??). I don't think this is
> documented
> > anyplace in IETF documents. I don't know if these approaches are 
> > documented elsewhere.
> > 
> > I don't know what they are, since my background is not SP-oriented, 
> > which is true of many IETF NM people. As we move toward a more 
> > SP-centric Internet, it would be helpful to get these approaches 
> > documented in the IETF.
> > 
> > 2) The IETF has limited resources to accomplish its work, and it
> would
> > be good to not waste resources trying to solve problems we think
> might
> > exist, when we could be working on the problems we know exist.
> > 
> > In the OpSec WG, few enterprise equipment vendors participated. It 
> > might be time to have a discussion of whether the IETF 
> should simply 
> > move to be more SP-centric, especially the IETF management 
> protocols.
> > If enterprise equipment vendors do not believe it is important for 
> > them to contribute to IETF protocol designs, then enterprise
> equipment
> > vendors (and their customers) may need to move toward an SP-centric 
> > approach to utilize emerging/future IETF protocols.
> > 
> > How do we want to focus our Operations and Management resources? Is 
> > the IETF OPS area still relevant for operating and managing the 
> > Internet? Should we adopt the management standards from other SDOs,
> or
> > let the other IETF areas design their own focus-appropriate
> management
> > solutions?
> 
> 
> IMO this tends to work itself out in the end.
> The people involved in a WG will influence its outcome, and 
> the people not involved in a WG will not influence its outcome.
> 
> Labels like Enterprise and SP are not that helpful here.
> Some companies have both kinds of products.
> 
> 
> > 
> > 3) A manageability considerations BOF. There is already work being 
> > done on manageability considerations guidelines (how to consider 
> > manageability requirements, not a required section in all 
> documents).
> > There was  a lot of discussion about this in the last OPS Area open 
> > meeting as well. This would benefit from achieving consensus from 
> > operators and standards writers, and would probably be a 
> good choice 
> > for an EDU tutorial once consensus is reached.
> > 
> > Obviously, this would benefit from the discussions of #1 and #2.
> > 
> 
> More documentation work.  It would be useful to both RFC 
> readers and writers, so I couldn't argue against it.  I want 
> every WG that creates a protocol to think about how operators 
> and developers are going to securely and efficiently manage 
> the protocol, including configuration.  It should not be left 
> as a proprietary component forever.  IMO, to advance to Draft 
> Standard, a protocol should meet strict manageability 
> requirements, which would obviously need to be documented in an RFC.
> 
> 
> > dbh
> 
> Andy
> 
> _______________________________________________
> OPS-AREA mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/ops-area
> 
> _______________________________________________
> OPS-NM mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/ops-nm
> 

_______________________________________________
OPS-NM mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ops-nm

---

From: Brian E Carpenter <[email-masked]>
Date: Thu, 21 Dec 2006 14:28:44 +0100

I think Dan has it right, as far as a practical first step is concerned.
It's far from clear that we have IETF consensus for anything stronger
than guidance, but guidance is certainly needed.

     Brian

---

From: Andy Bierman <[email-masked]>
Date: Thu, 21 Dec 2006 08:03:10 -0800

> than guidance, but guidance is certainly needed.

Agreed -- it is just my opinion that Draft Standard
should actually stand for something objectively useful.
But that is a different thread which has certainly been
discussed at length already.

Andy