Subject: [OPS-NM] OPS Area WG

From: Ron Bonica <[email-masked]>
Date: Thu, 10 May 2007 14:37:43 -0400

Folks,

Dan and I would like to propose an area-wide working group whose charter
is reflected below. Please read and comment upon the proposed charter.

                               Dan and Ron

=============================================================
Operations and Management Area Working Group (opsawg)

Chair(s):

TBD
TBD

Area Directors:

Dan Romascanu <[email-masked]>
Ronald Bonica <[email-masked]>

The Operations and Management Area receives occasional proposals for
the development and publication of RFCs dealing with operational and
management topics that are not in scope of an existing working group
or do not justify the formation of a new working group. The OPSAWG will
serve as the forum for developing such work items in the IETF.

The OPSAWG mailing list is an open discussion forum for such work
items, when they arise. The working group meets if there
are active proposals that require discussion. The working group
milestones are updated as needed to reflect the current work items and
their associated milestones. All new work items and rechartering
proposals will be brought for approval with the IESG.

The focus of the work will be on topics that govern the behavior or
WGs in the O&M area  (e.g., manageability
requirements) and on small, highly focused projects that don't merit a
WG of their own or belong to WGs that have already concluded (e.g.
advancement of documents on the standards track,  application
statements, extensions of MIB modules).

The OPSAWG will undertake only work items that are proved to have at
least a reasonable level of interest from the operators and users
community and have a committed number of editors and reviewers.  It is
not within the scope of the OPSAWG to pick up failed WG work or parts
of a WG charter items that could not come to convergence on what they
were chartered to do.

The currently active OPSAWG work items mostly fall under the following
topics:

(A) Development of a BCP document that will provide guidelines for
operational and manageability requirements that need to be covered in
IETF documents, especially those documents that include requirements
and specification of new protocols or protocol extensions.

(B) Templates and tools for Operations and Management Area Documents

(C) Maintenance and extensions of documents that define MIB modules
which were developped in working groups that have concluded.

Goals and Milestones:

June 2007 - Initial submission for the Guidelines for Considering
Operations and Management of New Protocols Internet-Draft

October 2007 - Initial submission for the Template for Generic
Management Data Models

October 2007 - Initial submission for the Structured Data Elements
(SDEs) for syslog

December  2007 - WGLC for the Guidelines for Considering Operations and
Management of New Protocols Internet-Draft

February 2008 - Submit the Guidelines for Considering Operations and
Management of New Protocols Internet-Draft to the IESG for consideration
as BCP

April 2008 - WGLC for the Template for Generic
Management Data Models

April 2008 - WGLC for the  Structured Data Elements
(SDEs) for syslog

June 2008 - Submit the Template for Generic
Management Data Models to the IESG for consideration as BCP

June 2008 - Submit the  Structured Data Elements
(SDEs) for syslog to the IESG for consideration as Proposed Standard

_______________________________________________
OPS-NM mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ops-nm

---

From: "Romascanu, Dan \(Dan\)" <[email-masked]>
Date: Thu, 10 May 2007 22:02:09 +0300

One more thing - please send feedback until May 17 the latest as we want
to put the charter for approval on the agenda of the may 24 IESG
telechat. 

Dan and Ron

> -----Original Message-----
> From: Ron Bonica [mailto:[email-masked]] 
> Sent: Thursday, May 10, 2007 9:38 PM
> To: [email-masked]; [email-masked]
> Subject: [OPS-NM] OPS Area WG
> 
> Folks,
> 
> Dan and I would like to propose an area-wide working group 
> whose charter is reflected below. Please read and comment 
> upon the proposed charter.
> 
>                                Dan and Ron
> 
> The Operations and Management Area receives occasional 
> proposals for the development and publication of RFCs dealing 
> with operational and management topics that are not in scope 
> of an existing working group or do not justify the formation 
> of a new working group. The OPSAWG will serve as the forum 
> for developing such work items in the IETF.
> 
> The OPSAWG mailing list is an open discussion forum for such 
> work items, when they arise. The working group meets if there 
> are active proposals that require discussion. The working 
> group milestones are updated as needed to reflect the current 
> work items and their associated milestones. All new work 
> items and rechartering proposals will be brought for approval 
> with the IESG.
> 
> The focus of the work will be on topics that govern the 
> behavior or WGs in the O&M area  (e.g., manageability
> requirements) and on small, highly focused projects that 
> don't merit a WG of their own or belong to WGs that have 
> already concluded (e.g.
> The OPSAWG will undertake only work items that are proved to 
> have at least a reasonable level of interest from the 
> operators and users community and have a committed number of 
> editors and reviewers.  It is not within the scope of the 
> OPSAWG to pick up failed WG work or parts of a WG charter 
> items that could not come to convergence on what they were 
> chartered to do.
> 
> (A) Development of a BCP document that will provide 
> guidelines for operational and manageability requirements 
> that need to be covered in IETF documents, especially those 
> documents that include requirements and specification of new 
> protocols or protocol extensions.
> 
> (C) Maintenance and extensions of documents that define MIB 
> modules which were developped in working groups that have concluded.
> 
> Goals and Milestones:
> 
> June 2007 - Initial submission for the Guidelines for 
> Considering Operations and Management of New Protocols Internet-Draft
> 
> October 2007 - Initial submission for the Template for 
> Generic Management Data Models
> 
> December  2007 - WGLC for the Guidelines for Considering 
> February 2008 - Submit the Guidelines for Considering 
> Operations and Management of New Protocols Internet-Draft to 
> the IESG for consideration as BCP
> 
> April 2008 - WGLC for the Template for Generic Management Data Models
> 
> June 2008 - Submit the Template for Generic Management Data 
> Models to the IESG for consideration as BCP
>

---

From: Juergen Schoenwaelder <[email-masked]>
Date: Thu, 10 May 2007 20:58:20 +0200

> October 2007 - Initial submission for the Template for Generic

What is this? And is there consensus that this is a WG work item?

/js

PS: And can we avoid the cross posting? ;-)

-- 
Juergen Schoenwaelder           Jacobs University Bremen gGmbH
Phone: +49 421 200 3587         Campus Ring 1, 28759 Bremen, Germany
Fax:   +49 421 200 3103         <http://www.jacobs-university.de/>

---

From: "STEPHAN Emile RD-CORE-LAN" <[email-masked]>
Date: Tue, 15 May 2007 15:39:53 +0200

Dear Dan and Ron,

> (B) Templates and tools for Operations and Management Area Documents

I enhanced XSL part of draft-stephan-ops-xml-mib-module-template. The last version transforms a RFC2629-based XML MIB draft in a XML schema directly under Mozilla.

I think it's a good starting point for working on an update of RFC2629 leading to a common document format for specifying datamodels.

Regards
Emile

-----Message d'origine-----
De : Romascanu, Dan (Dan) [mailto:[email-masked]] 
Envoyé : jeudi 10 mai 2007 21:02
À : Ron Bonica; [email-masked]; [email-masked]
Objet : [OPS-AREA] RE: [OPS-NM] OPS Area WG

Dan and Ron

_______________________________________________
OPS-AREA mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ops-area