Subject: Re: [OPSAWG] REMINDER: A proposal about how to get the real cause of SNMP failed requests. Please feed back your comments, thanks.

From: banshimin 01376 <[email-masked]>
Date: Tue, 30 Sep 2008 08:54:42 +0800

Hi,

> > The 'security name' is the user name of the application or of 
> SNMPv3?
> Not necessarily.  Its the name of the user on whose behalf that 
> applicationis operating, from the perspective of VACM.
> 

VACM is only used by SNMPv3, how about SNMPv1 and SNMPv2?
When the agent creates an entry in the error inforamtion table, how does it know its securty name?
Is it possible to apply for Internet Draft?

Shimin

_______________________________________________
OPSAWG mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/opsawg

---

From: "David Harrington" <[email-masked]>
Date: Mon, 29 Sep 2008 23:21:34 -0400

Hi,

> VACM is only used by SNMPv3
That is incorrect. VACM can be used for SNMPv1, v2c, and v3. It should
also be able to be used with RFC3411-compliant snmpv4, v5, v6, ...
v99, etc. 

The User-based security model extracts information for the SNMPv3
message to determine the securityName.
The SNMPv1 and SNMPv2 Community security models are used by SNMPv1 and
SNMPv2c respectively, and per the COMMUNITY-MIB of RFC3584, the
contextEngineID, contaxtName, and community name are mapped to a
securityName.
The Transport security model being developed in the ISMS WG determines
a securityName from the information provided by transport layer
security protocols, such as SSH and TLS and DTLS.

VACM can be used with any version of SNMP that can provide all the
parameters needed for an IsAccessAllowed decision.

dbh

> -----Original Message-----
> From: [email-masked] 
> [mailto:[email-masked]] On Behalf Of banshimin 01376
> Sent: Monday, September 29, 2008 8:55 PM
> To: [email-masked]
> Subject: Re: [OPSAWG] REMINDER: A proposal about how to get 
> the real cause of SNMP failed requests. Please feed back your 
> comments, thanks.
> 
> Hi,
> 
> When the agent creates an entry in the error inforamtion 
> table, how does it know its securty name?