Subject: [OPSAWG] start WGLC ondraft-ietf-opsawg-smi-datatypes-in-xsd-04.txt

From: Mehmet Ersue <[email-masked]>
Date: Wed, 4 Feb 2009 17:37:37 +0000 (GMT)

Hi,

I reviewed this document. One small XSD issue we solved offline.

I think the document is valuable to provide a standard schema 
representation of the SMIv2 data types for XML.

I would like to see this document as an RFC to facilitate the usage 
for XML-based applications.

Mehmet

---

From: "Bert Wijnen \(IETF\)" <[email-masked]>
Date: Wed, 4 Feb 2009 23:41:27 +0100

Using my ietf user account, so the mailing list accepts my posting.

I believe Bob has already answered.

Bert

  Bert
  ----- Original Message ----- 
  From: Bert Wijnen 
  To: Natale, Bob 
  Cc: [email-masked] 
  Sent: Wednesday, February 04, 2009 5:39 PM
  Subject: Re: [OPSAWG] start WGLC on draft-ietf-opsawg-smi-datatypes-in-xsd-04.txt

  W.r.t. my second point, section 4 states:

     This document concerns only the SMI base datatypes -- i.e., the
     eleven "ObjectSyntax" datatypes defined in RFC2578.  These datatypes
     -- via tag values defined in the SMI to identify them in varbinds --
     constrain values carried "on-the-wire" in SNMP PDUs between SNMP
     management applications and SNMP agents:

  And then after that colon, it lists the names of the dtaatypes as you define them in sect 4, namely
  the names used in teh XSD.

  If they refer to SMI datatype, then I would have expected OBJECT IDENTIFIER instead of
  ObjectIdentifier and OCTET STRING instead of OctetString.

  Not a big deal, but it had me put on the wrong leg at first.

  By the way, in teh IANA considerations there is also text and URIs w.r.t.
  "other 2 documents" in the "set of documents".

  Bert
    ----- Original Message ----- 
    From: Natale, Bob 
    To: Bert Wijnen (IETF) 
    Cc: [email-masked] 
    Sent: Wednesday, February 04, 2009 2:17 PM
    Subject: RE: [OPSAWG] start WGLC on draft-ietf-opsawg-smi-datatypes-in-xsd-04.txt

    Hi Bert,

    Thanks for your comments and assessment.

    - The misspellings of "opaque" (with a "g") have been corrected.

    - The use of "datatypes" in the file name and title was, in fact, intended to refer to "SMI datatypes" as implied by the general usage in RFC 2578, Sec. 7.1, "Mapping of the Syntax Clause", to wit:

    "The SYNTAX clause, which must be present, defines the abstract data structure corresponding to that object.  The data structure must be one of the following: a base type, the BITS construct, or a textual convention.  (SEQUENCE OF and SEQUENCE are also possible for conceptual tables, see section 7.1.12).  The base types are those defined in the ObjectSyntax CHOICE.  A textual convention is a newly-defined type defined as a sub-type of a base type [3]."

    So, "datatypes" is used a bit loosely for "base types".would you prefer that the latter term be used?  (The document text currently makes it clear that it deals only with expressing the base types of RFC 2578 in XSD.)

    - Yes, the text that Juergen questioned is being removed (also had helpful guidance from David Harrington on this point), so that this "base types" document stands alone.

    Please confirm or clarify the second point.I will have the -05 version, reflecting final mods based on this last call round, ready immediately after expiration of the last call period (12-Feb-09).

    Cheers,

    BobN

    From: [email-masked] [mailto:[email-masked]] On Behalf Of Bert Wijnen (IETF)
    Sent: Wednesday, February 04, 2009 4:57 AM
    To: [email-masked]
    Subject: Re: [OPSAWG] start WGLC ondraft-ietf-opsawg-smi-datatypes-in-xsd-04.txt

    My comments:

    - page 7, section 4

      - speaks about opague. I think you mean opaque (with a Q)

      You may also want to make an explicit statement that those are the datatype

      names as ytou specify them in XSD. I first though they were the datatypes

      as specified in SMIv2.

    - Opague (with a G) is again used in the 1st para of sect 5.3 and 

       in the first bullet on page 12 and also 3rd bullet.

    I share/support Juergen Shoenwaelder's comment w.r.t. the discussion about 3 documents

    in a document set. Where, how is that otehr work scheduled/planned?

    Other than that, this document seems fine.

    Bert

      ----- Original Message ----- 

      From: Scott O. Bradner 

      To: [email-masked] 

      Sent: Friday, January 30, 2009 3:10 AM

      Subject: Re: [OPSAWG] start WGLC ondraft-ietf-opsawg-smi-datatypes-in-xsd-04.txt

      back on Nov 6th we sent out a WGLC on 
      draft-ietf-opsawg-smi-datatypes-in-xsd-04.txt

      there was no response to that last call that I can 
      find in the mail list archive (or in my memory)

      we gotta see a bit more interest than that to proceed
      with this document.  

      So, I'll try again 

      this is a WGLC for draft-ietf-opsawg-smi-datatypes-in-xsd-04.txt
      please comment (one way or the other) by Feb 12

      tnx

      Scott
      _______________________________________________
      OPSAWG mailing list
      [email-masked]
      https://www.ietf.org/mailman/listinfo/opsawg