Subject: [OPSAWG] last-wg-last-call on syslog/snmp docs

From: [email-masked] (Scott O. Bradner)
Date: Tue, 19 May 2009 10:40:18 -0400 (EDT)

the syslog/snmp IDs have been updated based on a previous WGLC

this is a last check to see if the WG feels that these IDs are ready
to be sent to the IESG to be published as proposed standards

please send comments to the list by a week from today (i.e by
May 26th) on the folloing IDs

	draft-ietf-opsawg-syslog-snmp-03.txt
		and
	draft-ietf-opsawg-syslog-msg-mib-03.txt

tnx

Scott

---

From: "tom.petch" <[email-masked]>
Date: Fri, 22 May 2009 10:03:18 +0200

My previous comments have been addressed.

"is 1:0..*. "
technically correct and easy to read for those with the right background but I
would prefer it expanded eg to
"ranges from one-to-zero to one-to-many"

The syntax used for the example in the SyslogTimeStamp TEXTUAL CONVENTION is not
the same as that in section 8; neither is as clear as it might be, how to pack
25 'characters' into 13 OCTET, but I have not thought of a better one (yet:-).
This is one of those times when seeing the BER.1 might make it clearer.

syslogMsgHostName
        /constraints/constrains/

 syslogMsgSDID
        /constraints/constrains/

 syslogMsgSDParamName
        /constraints/constrains/

 Tom Petch

----- Original Message -----
From: "Scott O. Bradner" <[email-masked]>
To: <[email-masked]>
Sent: Tuesday, May 19, 2009 4:40 PM
Subject: [OPSAWG] last-wg-last-call on syslog/snmp docs

> _______________________________________________
> OPSAWG mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/opsawg

---

From: Juergen Schoenwaelder <[email-masked]>
Date: Fri, 22 May 2009 23:57:41 +0200

On Fri, May 22, 2009 at 10:03:18AM +0200, tom.petch wrote:
 
> "is 1:0..*. "
> technically correct and easy to read for those with the right
> background but I would prefer it expanded eg to "ranges from
> one-to-zero to one-to-many"

I am fine with spelling this out if that helps readability.
 
> The syntax used for the example in the SyslogTimeStamp TEXTUAL
> CONVENTION is not the same as that in section 8; neither is as clear
> as it might be, how to pack 25 'characters' into 13 OCTET, but I
> have not thought of a better one (yet:-).  This is one of those
> times when seeing the BER.1 might make it clearer.

BER is the encoding of common SNMP transports; only few
implementatioms store the MIB in BER format...

>         /constraints/constrains/

Thanks.

/js

-- 
Juergen Schoenwaelder           Jacobs University Bremen gGmbH
Phone: +49 421 200 3587         Campus Ring 1, 28759 Bremen, Germany
Fax:   +49 421 200 3103         <http://www.jacobs-university.de/>

---

From: "tom.petch" <[email-masked]>
Date: Tue, 26 May 2009 10:29:27 +0200

----- Original Message ----- 
From: "Juergen Schoenwaelder" <[email-masked]>
To: "tom.petch" <[email-masked]>
Cc: <[email-masked]>; "Scott O. Bradner" <[email-masked]>
Sent: Friday, May 22, 2009 11:57 PM
Subject: Re: [OPSAWG] last-wg-last-call on syslog/snmp docs

> On Fri, May 22, 2009 at 10:03:18AM +0200, tom.petch wrote:
<snip>
> implementatioms store the MIB in BER format...

True, but I would still like section 8 brought in line with the 
SyslogTimeStamp TEXTUAL CONVENTION.

Tom Petch

<snip>

---

From: Juergen Schoenwaelder <[email-masked]>
Date: Tue, 26 May 2009 13:11:23 +0200

> SyslogTimeStamp TEXTUAL CONVENTION.

Sorry, I did not see what the problem was. I assume you mean:

OLD
     syslogMsgTimeStamp.1 = 2003-10-11 22:14:15.003+00:00

NEW
     syslogMsgTimeStamp.1 = 2003-10-11,22:14:15.003,+0:0

Is that what you are looking for? If not, can you simply post what you
think should be there?

/js

---

From: "tom.petch" <[email-masked]>
Date: Tue, 26 May 2009 17:07:15 +0200

---- Original Message -----
From: "Juergen Schoenwaelder" <[email-masked]>
To: "tom.petch" <[email-masked]>
Cc: <[email-masked]>; "Scott O. Bradner" <[email-masked]>
Sent: Tuesday, May 26, 2009 1:11 PM
Subject: Re: [OPSAWG] last-wg-last-call on syslog/snmp docs

> Is that what you are looking for? If not, can you simply post what you

Yes, that was what I had in mind.  I was also wondering if there was a better
representation for it, but suspect that that is as good as we will get.  Good
enough for RFC2579 so good enough for here.

Tom Petch

---

From: Juergen Schoenwaelder <[email-masked]>
Date: Thu, 28 May 2009 22:28:14 +0200

> 	draft-ietf-opsawg-syslog-msg-mib-03.txt

There were only a few editorial comments and I have made the changes
in my sources. I don't think posting a new ID is really necessary;
perhaps this can wait until we have gone through IETF last call.
Do you agree, Scott?

/js