Subject: Re: [OPSAWG] I-D Action:draft-davies-reusable-ipv4-address-block-00.txt

From: Brian E Carpenter <[email-masked]>
Date: Fri, 13 Nov 2009 16:59:04 +1300

Hi,

As a straightforward request to the IANA, there isn't much to say
about this draft. However, it contains no motivation. I understand
that some ISPs believe this approach to be essential as part of an
IPv6 deployment strategy, but so far the draft-shirasaki-*
documents haven't (apparently) convinced the community that
the motivation is sufficient. In fact there is some fear that
allocating more ambiguous private address space will only make
things move more slowly.

So, I believe that either this draft needs a convincing
motivation section, or a companion document, so that the
community can reach a considered consensus. I believe interest
in this will be extremely wide once it gets to a last call,
so the motivation needs to be very solid.

IMHO.

   Brian

---

From: Brian E Carpenter <[email-masked]>
Date: Fri, 13 Nov 2009 17:50:17 +1300

Greg,

But that doesn't motivate either

a) why the ISP would want to use private space
or
b) how this make IPv6 deployment happen sooner.

Let me be clear about the counter-argument: if we
refuse to allocate this new private space, ISPs will
run out of IPv4 addresses sooner and will deploy IPv6
faster. You may not like this but it's an argument
I've heard.

   Brian

On 2009-11-13 17:35, Davies, Greg J wrote:
> Thanks Brian for the feedback, perhaps we can bring out the motivation more strongly.
> 
> The key motivation is to to avoid address conflicts with customers when the service provider is using private IPv4 addresses (e.g. as in the NAT444 or the incremental CGN solutions). 
> 
> Many customers use the 10 range in their LAN evironments and in some cases it is as bad as having the subnet set as the whole /8 (this may even have been the default CPE configuration).  Where there is an overlap between the LAN and WAN addresses the customer is likely to have problems and this will result in frustration and support calls.  Given most consumer customers don't need to know about IP addresses and subnets the best approach is to avoid any potential for address conflict in the first place.  Hence the need for an alternative address block to be used during the IPv4 to IPv6 transition phase.
> 
> Regards
> Greg Davies
> 
> 
> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On Behalf Of Brian E Carpenter
> Sent: Friday, 13 November 2009 2:59 PM
> To: [email-masked]
> Subject: Re: [OPSAWG] I-D Action:draft-davies-reusable-ipv4-address-block-00.txt
> 
> Hi,
> 
> _______________________________________________
> OPSAWG mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/opsawg
>

---

From: "Davies, Greg J" <[email-masked]>
Date: Fri, 13 Nov 2009 16:16:40 +1100

Brian,
       I agree that deploying IPv6 as soon as possible is very important, but unfortunately it is only one part of the transition.  Even if a service provider had IPv6 deployed today, in a dual-stack approach, they are still likely to run out of public IPv4 addresses following the global run-out.  The provider will need to continue supporting IPv4 because customers are not likely to have a complete IPv6 environment for many years (e.g. they will have IPv4 only games consoles, Windows XP PCs without IPv6 enabled, IPv4-only apps, other IPv4-only devices, etc.).

The issue is not one of whether you can force service providers to adopt IPv6 more quickly it is that you can't force customers to completely overhaul their environement to be fully IPv6 in a short timeframe.  We have to give them time to make the transition in line with lifecycle replacement of their equipment. 

Providers thus have to do two things:
1. Introduce IPv6 as the long term solution
2. Implement a solution that will maintain IPv4 connectivity for customers once public IPv4 addresses have been exhausted.

Regards,
Greg

-----Original Message-----
From: Brian E Carpenter [mailto:[email-masked]] 
Sent: Friday, 13 November 2009 3:50 PM
To: Davies, Greg J
Cc: [email-masked]
Subject: Re: [OPSAWG] I-D Action:draft-davies-reusable-ipv4-address-block-00.txt

Greg,

   Brian

---

From: Brian E Carpenter <[email-masked]>
Date: Fri, 13 Nov 2009 18:26:49 +1300

Greg,

This is exactly what needs to be stated clearly and simply
in the draft, IMHO.

   Brian

---

From: Christopher LILJENSTOLPE <[email-masked]>
Date: Fri, 13 Nov 2009 16:43:58 +1100

Begin forwarded message:

> From: Christopher LILJENSTOLPE <[email-masked]>
> Date: November 13, 2009 4:42:27 PM GMT+11:00
> To: Brian E Carpenter <[email-masked]>
> Cc: "Davies, Greg J" <[email-masked]>,  
> "[email-masked]" <[email-masked]>
> Greetings Brian,
> 	I've talked to the AD's, and I am going to do another draft that  
> states this as a specific problem statement.  The Davies draft will  
> then refer to that as a informative reference.
>
> 	Chris
>
> On Nov 13, 2009, at 4:26 PM, Brian E Carpenter wrote:
>
>> Greg,
>>
>>>      I agree that deploying IPv6 as soon as possible is very  
>>> important, but unfortunately it is only one part of the  
>>> transition.  Even if a service provider had IPv6 deployed today,  
>>> in a dual-stack approach, they are still likely to run out of  
>>> public IPv4 addresses following the global run-out.  The provider  
>>> will need to continue supporting IPv4 because customers are not  
>>> likely to have a complete IPv6 environment for many years (e.g.  
>>> they will have IPv4 only games consoles, Windows XP PCs without  
>>> IPv6 enabled, IPv4-only apps, other IPv4-only devices, etc.).
>>>
>>> The issue is not one of whether you can force service providers to  
>>> adopt IPv6 more quickly it is that you can't force customers to  
>>> completely overhaul their environement to be fully IPv6 in a short  
>>> timeframe.  We have to give them time to make the transition in  
>>> line with lifecycle replacement of their equipment.
>>>
>>> 2. Implement a solution that will maintain IPv4 connectivity for  
>>> customers once public IPv4 addresses have been exhausted.
>>>
>>> Regards,
>>> Greg
>>>
>>>
>>>> The key motivation is to to avoid address conflicts with  
>>>> customers when the service provider is using private IPv4  
>>>> addresses (e.g. as in the NAT444 or the incremental CGN solutions).
>>>>
>>>> Many customers use the 10 range in their LAN evironments and in  
>>>> some cases it is as bad as having the subnet set as the whole /8  
>>>> (this may even have been the default CPE configuration).  Where  
>>>> there is an overlap between the LAN and WAN addresses the  
>>>> customer is likely to have problems and this will result in  
>>>> frustration and support calls.  Given most consumer customers  
>>>> don't need to know about IP addresses and subnets the best  
>>>> approach is to avoid any potential for address conflict in the  
>>>> first place.  Hence the need for an alternative address block to  
>>>> be used during the IPv4 to IPv6 transition phase.
>>>>
>>>> Regards
>>>> Greg Davies
>>>>
>>>>
> ---
> 李柯睿
> Check my PGP key here:
> https://www.asgaard.org/~cdl/cdl.asc
>

---
李柯睿
Check my PGP key here:
https://www.asgaard.org/~cdl/cdl.asc

---

From: Christopher LILJENSTOLPE <[email-masked]>
Date: Fri, 13 Nov 2009 16:41:38 +1100

+1

	Chris

On Nov 13, 2009, at 4:16 PM, Davies, Greg J wrote:

> important, but unfortunately it is only one part of the transition.   
> Even if a service provider had IPv6 deployed today, in a dual-stack  
> approach, they are still likely to run out of public IPv4 addresses  
> following the global run-out.  The provider will need to continue  
> supporting IPv4 because customers are not likely to have a complete  
> IPv6 environment for many years (e.g. they will have IPv4 only games  
> consoles, Windows XP PCs without IPv6 enabled, IPv4-only apps, other  
> IPv4-only devices, etc.).
>
> timeframe.  We have to give them time to make the transition in line  
> with lifecycle replacement of their equipment.
>
>> The key motivation is to to avoid address conflicts with customers  
>> when the service provider is using private IPv4 addresses (e.g. as  
>> in the NAT444 or the incremental CGN solutions).
>>
>> there is an overlap between the LAN and WAN addresses the customer  
>> is likely to have problems and this will result in frustration and  
>> support calls.  Given most consumer customers don't need to know  
>> about IP addresses and subnets the best approach is to avoid any  
>> potential for address conflict in the first place.  Hence the need  
>> for an alternative address block to be used during the IPv4 to IPv6  
>> transition phase.
>>
>> Regards
>> Greg Davies
>>
>>

---
李柯睿
Check my PGP key here:

---

From: Christopher LILJENSTOLPE <[email-masked]>
Date: Fri, 13 Nov 2009 16:42:27 +1100

Greetings Brian,

	Chris

On Nov 13, 2009, at 4:26 PM, Brian E Carpenter wrote:

>> transition.  Even if a service provider had IPv6 deployed today, in  
>> a dual-stack approach, they are still likely to run out of public  
>> IPv4 addresses following the global run-out.  The provider will  
>> need to continue supporting IPv4 because customers are not likely  
>> to have a complete IPv6 environment for many years (e.g. they will  
>> have IPv4 only games consoles, Windows XP PCs without IPv6 enabled,  
>> IPv4-only apps, other IPv4-only devices, etc.).
>>
>>> for an alternative address block to be used during the IPv4 to  
>>> IPv6 transition phase.
>>>
>>> Regards
>>> Greg Davies
>>>
>>>

---
李柯睿
Check my PGP key here: