Subject: [OPSAWG] draft-azinger-additional-private-ipv4-space-issues

From: "Azinger, Marla" <[email-masked]>
Date: Fri, 2 Apr 2010 17:57:29 -0400

Hello-

Leo and I are following up on the OPSWAG session at IETF 77 in Anaheim.  As discussed we are requesting any final input people have for this draft.  During the session there was a vote to move this forward and the majority of those people saw this draft ready for publishing.  At this point only minor changes are in need of adjustment and a last call for comments. During the WG session in Anaheim there was one suggestion for some of the language in 5.1 to be tightened up a bit.  We would appreciate text suggestions for this change and any other changes people would like to submit.

Thank you everyone for your participation in regards to this document.

Thank you Ron Bonica for stepping forward as the sponsoring Area Director for this document.

Many thanks,
Marla & Leo

---

From: Matthew Ford <[email-masked]>
Date: Tue, 06 Apr 2010 16:11:15 +0100

Marla,

Thanks for the continued opportunity to comment on this work. I think 
the document is a well-organised summary of the issues and concerns that 
pertain in this space.

I do have a number of observations on the latest (-03) revision:

Section 4.3 could also mention that any address space obtained in this 
way is unlikely to be contiguous, adding to the network management 
burden for the operator.

Section 4.5 states, "Nonetheless, network operators are naturally 
disinclined to request unique IPv4 addresses for a purpose that could be 
met with private addresses were it not for the size of the network."

I must admit to being a bit puzzled by this statement. You suggest the 
disinclination to request registered address space is 'natural', but I 
can't imagine why that might be the case, unless there is a significant 
financial disincentive to doing so. Can you shed a little more light here?

Section 5.1 - I think the title could be improved - I'd suggest 
'Redefining Existing Unicast Space as Additional Private Address Space' 
- this wording change would apply to the last para of the Section as 
well, and to the title of Section 5.3.

Also in Section 5.1, 'It would be possible...' is a pretty opaque 
construction. What are you trying to say? It *is* possible? It *might 
be* possible? Or what?

Section 5.2 could usefully include a back-reference to Section 4.4 as 
the issues created are very similar.

Mat

On 02/04/2010 22:57, Azinger, Marla wrote:
> Marla&  Leo
> _______________________________________________
> OPSAWG mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/opsawg

---

From: "Azinger, Marla" <[email-masked]>
Date: Tue, 6 Apr 2010 12:22:29 -0400

Thank you Mat.  We will go over these points and inquiries very soon and let you know what we come up with.

Cheers
Marla 

-----Original Message-----
From: Matthew Ford [mailto:[email-masked]] 
Sent: Tuesday, April 06, 2010 8:11 AM
To: Azinger, Marla
Cc: [email-masked]
Subject: Re: [OPSAWG] draft-azinger-additional-private-ipv4-space-issues

Marla,

Thanks for the continued opportunity to comment on this work. I think the document is a well-organised summary of the issues and concerns that pertain in this space.

Section 4.3 could also mention that any address space obtained in this way is unlikely to be contiguous, adding to the network management burden for the operator.

Section 4.5 states, "Nonetheless, network operators are naturally disinclined to request unique IPv4 addresses for a purpose that could be met with private addresses were it not for the size of the network."

I must admit to being a bit puzzled by this statement. You suggest the disinclination to request registered address space is 'natural', but I can't imagine why that might be the case, unless there is a significant financial disincentive to doing so. Can you shed a little more light here?

Section 5.1 - I think the title could be improved - I'd suggest 'Redefining Existing Unicast Space as Additional Private Address Space' 
- this wording change would apply to the last para of the Section as well, and to the title of Section 5.3.

Also in Section 5.1, 'It would be possible...' is a pretty opaque construction. What are you trying to say? It *is* possible? It *might
be* possible? Or what?

Section 5.2 could usefully include a back-reference to Section 4.4 as the issues created are very similar.

Mat