Subject: Re: [OPSAWG] pmDemandEnergyParametersIntervalMode in claise-energy-monitoring-mib-04

From: "Mouli Chandramouli (moulchan)" <[email-masked]>
Date: Mon, 4 Oct 2010 01:17:33 -0500

Minoru,

Can you please give provide us an use case where multiple modes of
energy measurement (sliding, period) would be required. 
With either methods, there will be a computational overhead to poll the
device to collect the energy measurement over time. 
In that context, would it be useful to collect energy measurement using
multiple modes. 

Thanks
Mouli

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf
Of [email-masked]
Sent: Tuesday, August 31, 2010 6:15 AM
To: Benoit Claise (bclaise); [email-masked]
Subject: [OPSAWG] pmDemandEnergyParametersIntervalMode in
claise-energy-monitoring-mib-04

Dear Benoit,

[My apologies for if this is a repost. Previous posting seems to have
failed.]
I had a question about how to use pmDemandEnergyParametersIntervalMode.
We have already talked the question about it in Maastricht, but I am not
sure I understand it.
In pmDemandEnergyParametersTable, are pmIndex and
pmDemandEnergyParametersIntervalMode the one-on-one relationships?
I assume that there may be the case that both 'period' and 'total' are
necessary at an object of 'PmIndex'.

        pmDemandEnergyParametersIntervalMode OBJECT-TYPE
          SYNTAX          INTEGER  {
                              period(1),
                              sliding(2),
                              total(3)
                          }

Don't we need to define two or more modes of
pmDemandEnergyParametersIntervalMode in one object?

Best regards,
Minoru
_______________________________________________
OPSAWG mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/opsawg

---

From: <[email-masked]>
Date: Mon, 4 Oct 2010 16:53:08 +0900

Hi Mouli,

Assuming a situation which requires the value of total energy and the
value of interval energy.  The value of total energy can be obtained by
calculating on the manager side from the value of periodical enery.  In
the case of 'sliding', it is necessary to acquire the value of total
energy by different means.

Best regards,
Minoru 

> From: Mouli Chandramouli (moulchan) [mailto:[email-masked]] 
> Sent: Monday, October 04, 2010 3:18 PM
> To: Teraoka, Minoru ([email-masked]); Benoit 
> Claise (bclaise); [email-masked]
> Subject: RE: [OPSAWG] pmDemandEnergyParametersIntervalMode in 
> Can you please give provide us an use case where multiple 
> modes of energy measurement (sliding, period) would be required. 
> With either methods, there will be a computational overhead 
> to poll the device to collect the energy measurement over time. 
> In that context, would it be useful to collect energy 
> measurement using multiple modes. 
> 
> Thanks
> Mouli
> 
> From: [email-masked] 
> [mailto:[email-masked]] On Behalf Of 
> [email-masked]
> [My apologies for if this is a repost. Previous posting seems 
> to have failed.] I had a question about how to use 
> pmDemandEnergyParametersIntervalMode.
> We have already talked the question about it in Maastricht, 
> but I am not sure I understand it.
> I assume that there may be the case that both 'period' and 
> 'total' are necessary at an object of 'PmIndex'.
>

---

From: Benoit Claise <[email-masked]>
Date: Wed, 13 Oct 2010 14:28:41 +0200

Hi Minoru,

That makes sense. Then we can use the 
pmDemandEnergyParametersIntervalMode as an extra index in

         pmDemandEnergyEntry OBJECT-TYPE
             SYNTAX          PmDemandEnergyEntry
             MAX-ACCESS      not-accessible
             STATUS          current
             DESCRIPTION
                 "An entry describing energy measurements "

             INDEX  { pmIndex,pmDemandEnergyParametersIntervalMode, pmDemandEnergyIntervalStartTime }
             ::= { pmDemandEnergyTable 1 }

Regards, Benoit.