Subject: Re: [OPSAWG] draft-junsheng-cloud-virtual-resource-management

From: Christopher LILJENSTOLPE <[email-masked]>
Date: Sun, 3 Jul 2011 18:25:25 +0000

I concur Dan.

Chris

On Jun 28, 2011, at 9:02 AM, Romascanu, Dan (Dan) wrote:

> 
> 
> 
> 
> Hi,
> 
> I also read the I-D and I have the same comments and questions as Ron
> plus an extra one - I think that we need a short discussion about the
> operational model of management of virtual resources in a data center,
> and definition and a description of hypervisors and their role in the
> management architecture. 
> 
> 
> Thanks and Regards,
> 
> Dan
> 
> From: [email-masked] [mailto:[email-masked]] On Behalf
> Of Ronald Bonica
> Sent: Tuesday, June 28, 2011 1:18 AM
> To: [email-masked]; [email-masked]
> Subject: Re: [OPSAWG] draft-junsheng-cloud-virtual-resource-management
> 
> 
> 
> Chu,
> 
> 
> 
> Thanks for submitting your draft. The following are a few comments:
> 
> 
> 
> -          This work appears to have at least one foot in the APPS Area.
> You might want to run it past an APPS WG
> 
> -          You appear to have come to the conclusion that REST is the
> best solution. Why not an existing IETF Protocol (e..g., NETCONF)?
> 
> -          Is there significant operator interest in making this an open
> protocol?
> 
> -          Is there any interest among Hypervisor vendors in supporting
> a common API?
> 
> 
> 
> 
> Ron
> 
> 
> 
> 
> 
> From: [email-masked] [mailto:[email-masked]] On Behalf
> Of [email-masked]
> Sent: Sunday, June 26, 2011 9:39 PM
> To: [email-masked]
> Subject: [OPSAWG] draft-junsheng-cloud-virtual-resource-management
> 
> 
> 
> 
> Hello, All 
> 
> I am Chu Junsheng from ZTE Corp.. At Bhumip's request I upload an I-D. 
> Please review and give your comments. 
> 
> http://datatracker.ietf.org/doc/draft-junsheng-cloud-virtual-resource-ma
> nagement/ 
> 
> Filename:
> draft-junsheng-cloud-virtual-resource-management
> Revision:                         00
> Title:                                   Virtual Resource Management in
> Cloud
> Creation date:                  2011-06-27
> WG ID:                                   Individual Submission
> Number of pages: 55
> 
> Abstract:
>  In current Cloud and Data Center (DC) environment, the manageable
>  virtualized resources aggregated by the Resource Management Platform
>  (RMP) may be supplied by different types of hypervisor
>  implementations.  The RMP needs to support a variety of hypervisor
>  APIs to allow access, management and integration of different types
>  of resources.  In order to decouple the RMP from any particular
>  hypervisor implementation, a unified API needs to be developed.  This
>  draft presents the requirements and preliminary implementation
>  considerations for such an API.
> 
> 
> Thanks. 
> 
> _______________________________________________
> OPSAWG mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/opsawg

---
李柯睿
Check my PGP key here:
https://www.asgaard.org/~cdl/cdl.asc

---

From: [email-masked]
Date: Wed, 6 Jul 2011 17:38:24 +0800

Dear Ron,

Sorry for reply late and thanks for your comments.
Please see inline.

Thanks.

Ronald Bonica <[email-masked]> 
2011-06-28 06:18

收件人
"[email-masked]" <[email-masked]>, "[email-masked]" 
<[email-masked]>
抄送

主题
RE: [OPSAWG]  draft-junsheng-cloud-virtual-resource-management

Chu,

-          This work appears to have at least one foot in the APPS Area. 
You might want to run it past an APPS WG
 [Junson] Yes, it has something to do with the APPS Area. I'll forward it 
to APPS WG for comments.

-          You appear to have come to the conclusion that REST is the best 
solution. Why not an existing IETF Protocol (e..g., NETCONF)?
[Junson] REST is very simple and lightweight, so it is suggested. 
Actually, it is just a mechanism  to facilitate interaction between a 
client and a server. Other solutions like XML-RPC, SOAP also work. NETCONF 
is XML-RPC based, so it can be used in the interfaces between the System 
Management entity and Resource Manager or Resource Provider entity, maybe 
some extensions are needed. 
We recommend REST as a good option but we also think it is an open issue 
and depends on the discussion.

-          Is there significant operator interest in making this an open 
protocol?
[Junson] Currently, Verizon, China Mobile, China unicom, China telecom and 
some other operators show strong interest in the virtual resource 
management in DC environment.  Because there are many private 
implementations, they bring difficulty and raise the OPEX for the data 
center operation. Some of the operators agree our basic idea before 
submiting the draft for discussion. We want to get more interest on this 
topic when we present it to OPSAWG.

-          Is there any interest among Hypervisor vendors in supporting a 
common API? 
 [Junson] It is not yet clear. The common API is above the hypervisor, and 
we can do the interface convertion based on the open hypervisor interface 
provided by hypervisor vedors,  just like some open source cloud projects 
(such as openstack, openNebula, libvirt, etc) do.
We show our idea in OPSAWG and want to catch more interest on this issue, 
especially opinions from hypervisor vendors.

                                          Junson
       Ron

Hello, All 

I am Chu Junsheng from ZTE Corp.. At Bhumip’s request I upload an I-D. 
Please review and give your comments. 

http://datatracker.ietf.org/doc/draft-junsheng-cloud-virtual-resource-management/ 

Filename: draft-junsheng-cloud-virtual-resource-management
Revision:                         00
Title:                                   Virtual Resource Management in 
Cloud
Creation date:                  2011-06-27
WG ID:                                   Individual Submission
Number of pages: 55

Abstract:

Thanks.

---

From: [email-masked]
Date: Wed, 6 Jul 2011 17:58:51 +0800

Dear Chris, Dan

Thanks for your comment.

I think the following draft may clarify your concerns.
https://datatracker.ietf.org/doc/draft-khasnabish-cloud-reference-framework/

Thanks.

Christopher LILJENSTOLPE <[email-masked]> 
2011-07-04 02:25

收件人
"Romascanu, Dan (Dan)" <[email-masked]>
抄送
"Ronald Bonica" <[email-masked]>, <[email-masked]>, 
<[email-masked]>
主题
Re: [OPSAWG] draft-junsheng-cloud-virtual-resource-management

I concur Dan.

Chris

Hi,

Thanks and Regards,

Dan

Chu,

Ron

Hello, All 

Filename:

Abstract:

Thanks. 

---
李柯睿
Check my PGP key here:

---

From: Juergen Schoenwaelder <[email-masked]>
Date: Wed, 6 Jul 2011 12:21:03 +0200

On Wed, Jul 06, 2011 at 05:38:24PM +0800, [email-masked] wrote:

> [...] NETCONF is XML-RPC based, so it can be used in the interfaces
> between the System Management entity and Resource Manager or
> Resource Provider entity, maybe some extensions are needed.

I do not think NETCONF is XML-RPC based, perhaps you have a different
definition of XML-RPC than I have. To be precise, NETCONF is _not_
using <http://en.wikipedia.org/wiki/XML-RPC>.

/js

-- 
Juergen Schoenwaelder           Jacobs University Bremen gGmbH
Phone: +49 421 200 3587         Campus Ring 1, 28759 Bremen, Germany
Fax:   +49 421 200 3103         <http://www.jacobs-university.de/>

---

From: [email-masked]
Date: Wed, 6 Jul 2011 18:56:18 +0800

I understand the model Chris refers to is the virtual resource management 
model, so I think the following diagram could make some sense to Chris's 
concern. It is from Junsheng's draft:
http://datatracker.ietf.org/doc/draft-junsheng-cloud-virtual-resource-management/

Of course, it is our viewpoint and we need further dicussion to clarify.

Thanks.

[email-masked] 
发件人:  [email-masked]
2011-07-06 17:58

收件人
Christopher LILJENSTOLPE <[email-masked]>, "Romascanu, Dan (Dan)" 
<[email-masked]>
抄送
[email-masked]
主题
[OPSAWG] 答复: Re:  draft-junsheng-cloud-virtual-resource-management

Dear Chris, Dan 

Thanks for your comment. 

Thanks. 

收件人

I concur Dan. 

Chris 

Hi,

Thanks and Regards,

Dan

Chu,

Ron

Hello, All 

Filename:

Abstract:

Thanks. 

--- 
李柯睿
Check my PGP key here: