Subject: Re: [OPSAWG] WGLC on draft-ietf-opsawg-automated-network-configuration-01.txt

From: "Cathy Zhou(Qian)" <[email-masked]>
Date: Tue, 05 Jul 2011 03:46:22 +0000

Hi all,
Some comments below:
1. After finding the Configuration Server, we should specify that a static routing should be generated based on the IP addresses of the new device, Configuration Server and the neighboring device.
Every time a new device joins in the network, it needs to know its neighboring devices since it acquires the information of the Configuration Server from it neighboring devices. After the configuration server is discovered by the new device, a static routing is generated by default. I think we should point it out in the document to be complete.
2. In clause 5.2, shall we specify where is the IP address acquisition from? E.g., from the neighboring devices? Because the new device may acquire its address from the neighboring devices via DHCP or SLAAC.

Best Regards,
Cathy

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Scott O. Bradner
Sent: Monday, June 20, 2011 6:39 PM
To: [email-masked]
Subject: [OPSAWG] WGLC on draft-ietf-opsawg-automated-network-configuration-01.txt

this starts a WGLC on draft-ietf-opsawg-automated-network-configuration-01.txt
please read the ID and let the list know if you think the ID is ready
for publication as an informational RFC

thanks

Scott
_______________________________________________
OPSAWG mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/opsawg

---

From: Juergen Schoenwaelder <[email-masked]>
Date: Tue, 5 Jul 2011 10:10:08 +0200

> Every time a new device joins in the network, it needs to know its neighboring devices since it acquires the information of the Configuration Server from it neighboring devices. After the configura…

Cathy,

section 5.2 "Acquisition of IP Addresses and Basic Routing
Information" describes how connectivity is established. I do not see
why additional static routing entries would be needed after step 5.3
has been carried out or what such routing table entries would look
like.

> 2. In clause 5.2, shall we specify where is the IP address acquisition from? E.g., from the neighboring devices? Because the new device may acquire its address from the neighboring devices via DHCP…

I believe the text in section 5.2 covers both DHCP and SLAAC. Can you
detail what you believe is missing?

/js

-- 
Juergen Schoenwaelder           Jacobs University Bremen gGmbH
Phone: +49 421 200 3587         Campus Ring 1, 28759 Bremen, Germany
Fax:   +49 421 200 3103         <http://www.jacobs-university.de/>

---

From: "Cathy Zhou(Qian)" <[email-masked]>
Date: Wed, 06 Jul 2011 09:12:06 +0000

Hi Juergen,
Please see inline.

Best Regards,
Cathy

-----Original Message-----
From: Juergen Schoenwaelder [mailto:[email-masked]] 
Sent: Tuesday, July 05, 2011 4:10 PM
To: Cathy Zhou(Qian)
Cc: Scott O. Bradner; [email-masked]
Subject: Re: [OPSAWG] WGLC on draft-ietf-opsawg-automated-network-configuration-01.txt

Cathy,

Cathy: The static routing information is for the Secure Channel establishment. I think the configuration server needs to get this information after step 5.3.

Cathy: My intention is to detail the procedure how to acquire the IP address using DHCP or SLAAC. But the existing RFCs have specified it. I am not sure whether we need to repeat it here.

/js

---

From: Juergen Schoenwaelder <[email-masked]>
Date: Wed, 6 Jul 2011 11:32:05 +0200

On Wed, Jul 06, 2011 at 09:12:06AM +0000, Cathy Zhou(Qian) wrote:

> Cathy: The static routing information is for the Secure Channel
> establishment. I think the configuration server needs to get this
> information after step 5.3.

Sorry, I do not understand what you want to be added. Please explain
or provide proposed text.

> Cathy: My intention is to detail the procedure how to acquire the IP
> address using DHCP or SLAAC. But the existing RFCs have specified
> it. I am not sure whether we need to repeat it here.

The point of a reference is that one does not need to repeat what is
already said elsewhere.

/js