Subject: [OPSAWG] Use of DHCP to provision routers

From: Tom Taylor <[email-masked]>
Date: Tue, 18 Jun 2013 11:06:17 -0400

Does anyone object in principle to the use of DHCP to provision routers 
as opposed to hosts? In particular, is there a problem in principle with 
the proposed DHCP options for finding log and notification servers in 
draft-schoenw-opsawg-nm-dhc?

Tom Taylor

---

From: "Adrian Farrel" <[email-masked]>
Date: Tue, 18 Jun 2013 16:23:44 +0100

Tom,

"Configure routers" is the name of the thin end of a very large wedge :-)

If, for example, you were to suggest dynamically installing routes on routers
using DHCP, you might hear some opposition.

This may be a question you also want to ask on the routing-discussion list.

A

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On Behalf
> Of Tom Taylor
> Sent: 18 June 2013 16:06
> To: [email-masked]
> Subject: [OPSAWG] Use of DHCP to provision routers
> 
> _______________________________________________
> OPSAWG mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/opsawg

---

From: Tom Taylor <[email-masked]>
Date: Tue, 18 Jun 2013 12:29:03 -0400

Posting to routing-discussion would automatically imply something we 
don't intend, I think. I suppose I should qualify by saying our 
intention is *initial* configuration of routers.

Tom

---

From: "Adrian Farrel" <[email-masked]>
Date: Tue, 18 Jun 2013 17:35:45 +0100

:-)

In that case your email would say "Don't Panic!"

At the point of initial configuration, isn't a router just a host? [Stands back
behind blast-proof wall]

A

> From: Tom Taylor [mailto:[email-masked]]
> Sent: 18 June 2013 17:29
> To: [email-masked]
> Cc: [email-masked]
> Subject: Re: [OPSAWG] Use of DHCP to provision routers
>

---

From: "Christopher LILJENSTOLPE" <[email-masked]>
Date: Tue, 18 Jun 2013 09:50:30 -0700

> At the point of initial configuration, isn't a router just a host? [Stands back

<hat off>
Actually, I would concur with Adrian here IFF we are talking about a router as a host (i.e. configuring the management interface, management infrastructure (such as ntp, syslog, etc).  If we are talking about configuring "traffic" interfaces, I'd have to think really hard about that…

	Christopher

</hat off>

--
李柯睿
Check my PGP key here: http://www.asgaard.org/cdl/cdl.asc
Current vCard here: http://www.asgaard.org/cdl/cdl.vcf

---

From: Juergen Schoenwaelder <[email-masked]>
Date: Tue, 18 Jun 2013 19:40:12 +0200

On Tue, Jun 18, 2013 at 11:06:17AM -0400, Tom Taylor wrote:
> Does anyone object in principle to the use of DHCP to provision
> routers as opposed to hosts? In particular, is there a problem in
> principle with the proposed DHCP options for finding log and
> notification servers in draft-schoenw-opsawg-nm-dhc?

Tom,

the term "router" may refer to very different things, such as

(a) a backbone network router
(b) a router in an access network
(c) a router in an enterprise network
(d) a router in a remote office location
(e) a CPE home router 
(f) a (virtual) router in a virtual machine environment
(g) a routing function embedded in a layer-2 switch
(h) a routing function embedded in a good old host
(i) a routing function embedded in a middlebox
(j) ...

and I guess depending on which interpretation you choose of the term
'router', you will get very different answers.

/js

-- 
Juergen Schoenwaelder           Jacobs University Bremen gGmbH
Phone: +49 421 200 3587         Campus Ring 1, 28759 Bremen, Germany
Fax:   +49 421 200 3103         <http://www.jacobs-university.de/>

---

From: Tom Taylor <[email-masked]>
Date: Tue, 18 Jun 2013 14:15:38 -0400

My take-away from this is that there is no objection in principle 
specifically to draft-schoenw-opsawg-nm-dhc.

The next question is whether the WG sees configuration of log and 
notification servers via DHCP as potentially useful in some networks or 
totally redundant.

Tom

> Actually, I would concur with Adrian here IFF we are talking about a router as a host (i.e. configuring the management interface, management infrastructure (such as ntp, syslog, etc).  If we are ta…
...

---

From: Tom Taylor <[email-masked]>
Date: Tue, 18 Jun 2013 14:16:31 -0400

The cases I'm particularly interested in are (a) and (b).

---

From: "Adrian Farrel" <[email-masked]>
Date: Tue, 18 Jun 2013 19:23:48 +0100

I find it a bit surprising that a backbone network router or a router in an
access network would benefit from "dynamic" configuration.
I have an image of a whole backbone network bootstrapping itself outwards from
the DHCP server.

At this point, I'd probably like to sit down and think about the problem before
jumping to use DHCP.

A

> Sent: 18 June 2013 19:17

---

From: Warren Kumari <[email-masked]>
Date: Tue, 18 Jun 2013 14:47:39 -0400

> access network would benefit from "dynamic" configuration.

+1.

There are folk who use DHCP to configure the IP address on router interfaces.

As an example, Cisco does this ( http://www.cisco.com/en/US/docs/ios/12_4t/ip_addr/configuration/guide/htdhcpcl.html )

Most folk avoid this as it is inclined to end poorly -- you really want your network devices to be stable and not rely on a: some other service or b: the rest of the network being up.

If you have a network with more than a few devices you run into odd boot-strapping issues -- for example you lose power / have some other large scale outage and all of the boxes reboot. Some box out at the edge of the network boots a little faster than other divides towards the DHCP server. By the time you actually have routability to the DHCP server the edge devices have gotten annoyed and start sulking.

If your network is sufficiently small (a doctor's office is the standard example) you can make this irk, but honestly, for routers it's usually much safer to just statically configure them…

There are a whole bunch of other devices that do get their addresses via DHCP, such as access-points and phones and camera and such.
For example, we use Cisco access points at the IETF meetings. There are fairly dynamically deployed, and rely on DHCP -- when initially booting they go off and get a DHCP address, which they use to TFTP an AP specific config. We specify the SNMP / Syslog / similar in the TFTPed config, but I could see this being useful for other network type widgets like other APs, monitoring things, UPSs, camera, etc.

> I have an image of a whole backbone network bootstrapping itself outwards from

Yeah, don't do that :-P

W

--
"Let's just say that if complete and utter chaos was lightning, he'd be the sort to stand on a hilltop in a thunderstorm wearing wet copper armour and shouting 'All gods are bastards'."

    -- Rincewind discussing Twoflower (Terry Pratchett, The Colour of Magic)

---

From: "George, Wes" <[email-masked]>
Date: Tue, 18 Jun 2013 16:42:15 -0400

> Of Adrian Farrel
> Sent: Tuesday, June 18, 2013 2:24 PM
> To: 'Tom Taylor'; [email-masked]

[WEG] Well, renumbering would be easier in some cases. Instead of talking about it in terms of DHCP, you may want to think of it more in terms of separating the IP from the miscellaneous subtending configuration that depends on it in something like a router (neighbor config, ACLs, etc). In other words, why does the IP config need to be static, what actually breaks? You probably can make a distinction between things like WAN IPs and things like loopbacks. To go further, how many of those breakage cases are solved if you can refer to the device via DNS instead of by IP (yes, this adds a failure domain, just follow me for a second) or use config that works by pulling the assigned IP into the right places elsewhere in the config? Not trying to minimize the scale and other issues with the bootstrapping problem, just framing the question a little differently. 6renum definitely spent some time talking about things like parameterized config and inheritance to address the fact that many IP addresses in a router affect multiple parts of the config such that you have to change it multiple places. Also things like ILNP focus on splitting locator and identifier so that one can change without affecting the other. Making a network work with dynamically configured addresses goes in that general direction. But that sort of digresses from the original question...
> At this point, I'd probably like to sit down and think about the problem
[WEG] Generally I agree. In a lot of cases, the problem may be better solved by proper element management systems to push the right config to the right places, rather than using DHCP in lieu of such, but depending on the application, DHCP may be the right level of lightweight where a heavyweight element management system might not be the right choice, especially for (lots of ) small devices that are supposed to boot and configure themselves with little or no human hand-holding or preconfiguration.

Wes George

This E-mail and any of its attachments may contain Time Warner Cable proprietary information, which is privileged, confidential, or subject to copyright belonging to Time Warner Cable. This E-mail is intended solely for the use of the individual or entity to which it is addressed. If you are not the intended recipient of this E-mail, you are hereby notified that any dissemination, distribution, copying, or action taken in relation to the contents of and attachments to this E-mail is strictly prohibited and may be unlawful. If you have received this E-mail in error, please notify the sender immediately and permanently delete the original and any copy of this E-mail and any printout.

---

From: "George, Wes" <[email-masked]>
Date: Tue, 18 Jun 2013 16:42:15 -0400

Wes George