Subject: [OPSAWG] SNMP SetBulk Operat

From: Tom Sanders <[email-masked]>
Date: Mon, 8 Jul 2013 21:03:25 +0530

Hi,

I know that we dont have a setbulk operation in SNMP. Am just wondering as
to why it isnt there. Is there a reason why we only have a getbulk PDU and
not a setbulk PDU? Will not having a SETBULK PDU speed up configs as we
dont have to set multiple SET PDUs.

-- 
Toms.

---

From: Michael MacFaden <[email-masked]>
Date: Mon, 8 Jul 2013 08:55:27 -0700 (PDT)

> I know that we dont have a setbulk operation in SNMP. Am just wondering as to
> why it isnt there. Is there a reason why we only have a getbulk PDU and not
> a setbulk PDU? Will not having a SETBULK PDU speed up configs as we dont
> have to set multiple SET PDUs.

Yet message size would still limited udp transport. 
Reminds me of the apple airport mgmt interface for config, 
recall it used snmp set with one very large octet string. 

Anyway standardization efforts have long since focused 
what operators thought would be a more acceptable approach, 
...doing config with NETCONF. 

Mike

---

From: "ietfdbh" <[email-masked]>
Date: Mon, 8 Jul 2013 11:59:34 -0400

+1

David Harrington

 <mailto:[email-masked]> [email-masked]

+1-603-828-1401

From: [email-masked] [mailto:[email-masked]] On Behalf Of Michael MacFaden
Sent: Monday, July 08, 2013 11:55 AM
To: Tom Sanders
Cc: [email-masked]
Subject: Re: [OPSAWG] SNMP SetBulk Operat

I know that we dont have a setbulk operation in SNMP. Am just wondering as to why it isnt there. Is there a reason why we only have a getbulk PDU and not a setbulk PDU? Will not having a SETBULK PDU speed up configs as we dont have to set multiple SET PDUs.

 

Mike

---

From: Tom Sanders <[email-masked]>
Date: Mon, 8 Jul 2013 21:45:38 +0530

Mike,

I hear you when you say that operators might want to use NETCONF. However,
there are still many out there that use provisioning tools that use SNMP as
the underlying protocol who might benefit from such a PDU.

Regardless of this, i would like to understand the rational (if anybody
knows) of only having a GETBULK PDU and not a SETBULK PDU?

Toms

-- 
Toms.

---

From: Mike MacFaden <[email-masked]>
Date: Mon, 8 Jul 2013 09:34:07 -0700

On Jul 8, 2013, at 9:15 AM, Tom Sanders <[email-masked]> wrote:

> I hear you when you say that operators might want to use NETCONF.

Operators did more than say they might, they wore t-shirts that read:

"It's the CLI stupid"  

IIRC that was during NANOG 19 conference plus or minus.

> Regardless of this, i would like to understand the rational (if anybody knows) of only having a GETBULK PDU and not a SETBULK PDU?

First of all sets require a layer of security and that took a bit longer to accomplish, not until 2002/SNMPv3.
Secondly  what would a set bulk do differently than a SET command?

Thirdly ….  http://tools.ietf.org/html/rfc3512

Mike

---

From: Tom Sanders <[email-masked]>
Date: Mon, 8 Jul 2013 22:14:01 +0530

Assume that a user wants to create 100 vlans. Instead of using 100 set
operations, cant we use one SETBULK operation since in this case its only
the index that is different - all other parameters are the same.

Toms

-- 
Toms.

---

From: Mike MacFaden <[email-masked]>
Date: Mon, 8 Jul 2013 10:23:58 -0700

On Jul 8, 2013, at 9:44 AM, Tom Sanders <[email-masked]> wrote:

> Assume that a user wants to create 100 vlans. Instead of using 100 set operations, cant we use one SETBULK operation

> since in this case its only the index that is different - all other parameters are the same.

SNMP defines a transaction as a single SET command and is constrained by UDP transport message size. 
SETBULK  would still be constrained by the general problems found with doing SETs and snmp -- including
"too"  many variables issue that can cause problems for devices with large configurations.

RFC 3512 contained design patterns for MIB module writers to consider solving this problem
with existing SET. We had to consider the important case of backward compatibility i.e. v3 client talking to v1 server
via PROXY or visa versa. In any case by the time the RFC was published
most IETF WGs were not interested in SET with snmp only monitoring/GET.

Mike

---

From: Juergen Schoenwaelder <[email-masked]>
Date: Mon, 8 Jul 2013 19:36:49 +0200

> dont have to set multiple SET PDUs.

Getbulk makes sense because it allows to retrieve data out of a
namespace that is not know by a management application (the next N
iterations over a portion of a varbind list in lexicographic order).

For writing, a management application can be assumed to know the
namespace and hence the management application can stuff as much data
into the varbind list as there is space.

You can create 100 vlans in a single SNMP set today - if your message
size handles this.

/js

PS: Sure, there are corner cases where the management application
    may not be fully aware of the namespace usage but corner cases
    do not justify new PDUs.

PS: There once was a WG called EOS and it might be useful to look at
    stuff discussed back in those days.

-- 
Juergen Schoenwaelder           Jacobs University Bremen gGmbH
Phone: +49 421 200 3587         Campus Ring 1, 28759 Bremen, Germany
Fax:   +49 421 200 3103         <http://www.jacobs-university.de/>

---

From: Robert Story <[email-masked]>
Date: Mon, 8 Jul 2013 14:37:47 -0400

On Mon, 8 Jul 2013 19:36:49 +0200 Juergen wrote:
JS> PS: There once was a WG called EOS and it might be useful to look at
JS>     stuff discussed back in those days.

Yep, OID compression would allow more varbinds in all PDUs, not just sets.

Robert

--
Senior Software Engineer
Parsons Government Services , National Security & Defense Division

---

From: Andrew Donati <[email-masked]>
Date: Mon, 8 Jul 2013 22:56:42 -0400

Let's  take as an example  the setting of ifAdminStatus of all interfaces of a particular device to down.   SETBULK can work in this example as all data types and values will be the same for all instances for the ifAdminStatus column but special considerations need to be taken on the last PDU.  The last PDU will likely over extend the target column object making it fail as the next column can be read only for example.

As an alternative, SET operations using multiple variable bindings in one PDU can be used but it is necessary to keep in mind the maximum UDP message size. There is also additional  flexibility using this method as each binding can be unrelated.

-Andy

On Jul 8, 2013, at 12:44 PM, Tom Sanders <[email-masked]> wrote:

> Assume that a user wants to create 100 vlans. Instead of using 100 set operations, cant we use one SETBULK operation since in this case its only the index that is different - all other parameters are the same.
> 
> Toms
> 
> 
> _______________________________________________
> OPSAWG mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/opsawg