Subject: Re: [OPSAWG] CAPWAP Control and Data Plane Separation Draft - draft-zhang-opsawg-capwap-cds

From: "Cao,Zhen" <[email-masked]>
Date: Fri, 19 Jul 2013 11:36:42 +0800

Hello Everyone,

The draft-zhang-opsawg-capwap-cds-00.txt is an update/subvert of
draft-zhang-opsawg-capwap-eap-00 (which we presented on Orlando) with
a new title and a new methodology, based on review of multiple experts
recommended by OPS ADs.

Here is a highlight of the update in this version:

The current draft proposes to split data and control plane by having
two elements AC-CP and AC-DP. AC-DP handles all user payload with the
exception of layer 2 management frames between the AC and use such as
IEEE 802.11 association, authentication, probe, Action Frame. AC-CP
handles all control messages between the WTP and AC.  In addition, the
AC-CP will handle user payload related to layer-2 management frames
such as those mentioned above. The WTP will have one set of Control
and Data Tunnel to AC-CP and another data-tunnel to AC-DP.

The key difference from  the previous version is that the previous
draft suggested
1) AC-CP has a control and data channel (instead of only a control
channel in current draft)
2) EAP messages were sent on Control Channel (instead of Data channel
in current draft)

We also do an analyze of CAPWAP local bridge model to support such
scenarios, as recommended by Dorothy.

Thank ALL that reviewed the draft and looking forward to your new comments.

Best regards,
-cz

On Mon, Jul 15, 2013 at 11:02 PM, Cao,Zhen <[email-masked]> wrote:
> FYI.
>
>
> ---------- Forwarded message ----------
> From:  <[email-masked]>
> Date: Sun, Jul 14, 2013 at 8:50 PM
> Subject: I-D Action: draft-zhang-opsawg-capwap-cds-00.txt
> To: [email-masked]
>
>
>
> A New Internet-Draft is available from the on-line Internet-Drafts directories.
>
>
>         Title           : Separation of CAPWAP Control and Data Plane:
> Scenarios, Requirements and Solutions
>         Author(s)       : Rong Zhang
>                           Zhen Cao
>                           Hui Deng
>                           Rajesh S. Pazhyannur
>                           Sri Gundavelli
>         Filename        : draft-zhang-opsawg-capwap-cds-00.txt
>         Pages           : 8
>         Date            : 2013-07-14
>
> Abstract:
>    This document describes the scenarios and requirements of separating
>    CAPWAP Data and Control plane.  This specification provides a CAPWAP
>    extension to allow two distinct AC component: AC-DP (AC-Data Plane)
>    and AC-CP (AC-Control Plane).  AC-DP handles all user payload with
>    the exception of layer 2 management frames between the AC and user
>    such as IEEE 802.11 association, authentication, probe, Action Frame.
>    AC-CP handles all control messages between the WTP and AC.  In
>    addition, the AC-CP wil handle user payload related to layer-2
>    management frames such as those mentioned above.
>
>
> The IETF datatracker status page for this draft is:
> https://datatracker.ietf.org/doc/draft-zhang-opsawg-capwap-cds
>
> There's also a htmlized version available at:
> http://tools.ietf.org/html/draft-zhang-opsawg-capwap-cds-00
>
>
> Internet-Drafts are also available by anonymous FTP at:
> ftp://ftp.ietf.org/internet-drafts/
>
> _______________________________________________
> I-D-Announce mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/i-d-announce
> Internet-Draft directories: http://www.ietf.org/shadow.html
> or ftp://ftp.ietf.org/ietf/1shadow-sites.txt

---

From: Liu Dapeng <[email-masked]>
Date: Fri, 19 Jul 2013 16:56:23 +0800

Hi Zhen,

The update of the draft actually proposes a way of encapsulating any new
controlling messages to an independent CAPWAP Data tunnel. This way is
straightforward, but do you think there is a need of signaling and
selection of multiple Data tunnels on the WTP?

Regards,

Dapeng Liu

2013/7/19 Cao,Zhen <[email-masked]>

> OPSAWG mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/opsawg
>

-- 

------
Best Regards,
Dapeng Liu

---

From: Rong Zhang <[email-masked]>
Date: Wed, 24 Jul 2013 09:50:27 +0800

Prefer the method of utilizing the current capability other than
changing the specs.

Regards.

Rong

---

From: Satoru Matsushima <[email-masked]>
Date: Mon, 29 Jul 2013 06:41:19 +0200

Hi Zhen,

That's sound interesting draft. Just one clarification about AP configuration.
It looks that AP is required an IP address information which is configured to identify separated CAPWAP-DATA. Otherwise AP send both of channel packet to single IP address, make sense?

cheers,
--satoru