Subject: Re: [OPSAWG] SNMP SetBulk Operat

From: Randy Presuhn <[email-masked]>
Date: Mon, 8 Jul 2013 09:26:44 -0700 (GMT-07:00)

Hi -

>From: Tom Sanders <[email-masked]>
>Sent: Jul 8, 2013 9:15 AM
>To: Michael MacFaden <[email-masked]>
>Cc: [email-masked]
>Subject: Re: [OPSAWG] SNMP SetBulk Operat
...
>Regardless of this, i would like to understand the rational (if anybody
>knows) of only having a GETBULK PDU and not a SETBULK PDU?
...

I'm not sure what you have in mind.  How would the "SETBULK
PDU" (and presumably the corresponding response PDU) you're
thinking of be different (syntactically and semantically)
from the existing SetRequest-PDU?

Randy

---

From: Randy Presuhn <[email-masked]>
Date: Mon, 8 Jul 2013 09:51:16 -0700 (GMT-07:00)

Hi -

>Sent: Jul 8, 2013 9:44 AM
>To: Mike MacFaden <[email-masked]>
>Cc: [email-masked]
>Assume that a user wants to create 100 vlans. Instead of using 100 set
>operations, cant we use one SETBULK operation since in this case its only
>the index that is different - all other parameters are the same.

What would the *syntax* of such a request look like?
What would the syntax of the response be?

How would this work with tables with multiple indexes?
How would this work with tables with non-integer indexes?
How would this work with a table that is already populated?
How would this work with a partially-populated table?

Randy

---

From: Randy Presuhn <[email-masked]>
Date: Mon, 8 Jul 2013 09:55:24 -0700 (GMT-07:00)

Hi -

>From: Mike MacFaden <[email-masked]>
>Sent: Jul 8, 2013 9:34 AM
>To: Tom Sanders <[email-masked]>
>Cc: [email-masked]
...
>Thirdly ….  http://tools.ietf.org/html/rfc3512

In fairness, netconf bears scant resemblance to what
the operators at the IAB workshop seemed to me to be
asking for.

Randy