Subject: [OPSAWG] draft-ietf-opsawg-capwap-alt-tunnel and draft-xue-opsawg-capwap-alt-tunnel-information relationship

From: Benoit Claise <[email-masked]>
Date: Wed, 19 Nov 2014 20:50:11 +0100

Dear CAPWAP authors,

After the draft-xue-opsawg-capwap-alt-tunnel-information presentation at 
the last IETF meeting, I've been wondering about the relationship 
between the two drafts:
- draft-ietf-opsawg-capwap-alt-tunnel provides the tunnel types
   Note:this draft is currently in AD review, so close to be sent to the 
IESG.
- draft-xue-opsawg-capwap-alt-tunnel-information provides the encoding 
of the tunnel-specific fields.

I believe I'm correct that the draft-ietf-opsawg-capwap-alt-tunnel 
doesn't provide a complete solution without 
draft-xue-opsawg-capwap-alt-tunnel-information?

I'm aware of the changes between version 3 and 4 (attached picture and 
http://tools.ietf.org/rfcdiff?url2=draft-ietf-opsawg-capwap-alt-tunnel-04.txt)

But now I wonder: why do we have two different drafts, as opposed to a 
single one?

Regards, Benoit

---

From: "Rajesh Pazhyannur (rpazhyan)" <[email-masked]>
Date: Thu, 20 Nov 2014 08:30:31 +0000

Hi Benoit

But now I wonder: why do we have two different drafts, as opposed to a single one?

This is a good question.
Yes, you are correct that draft-ietf-opsawg-capwap-alt-tunnel does not provide a complete solution and needs something like  draft-ietf-opsawg-capwap-alt-tunnel to complete the solution. The best answer I have is  that we wanted the keep the following two areas separate (and in different drafts)

  1.  Discover and negotiation of alternate tunneling capability. These are  independent of specific alternate tunnel method
  2.  Definition of tunnel specific message elements. While draft-ietf-opsawg-capwap-alt-tunnel contains message elements for most of the tunneling methods defined in  draft-ietf-opsawg-capwap-alt-tunnel, I had anticipated separate drafts for each tunneling protocol.

Finishing 1. would allow 2. to be completed separately and independently in potentially different drafts (and potentially different groups with relevant expertise). It is somewhat akin (though not identical) to separation between RFC 5415 and RFC 5416 where RFC 5415 is wireless technology independent and RFC 5416 is 802.11 specific.

Hope the above  makes sense.

Regards

Rajesh
From: "Benoit Claise (bclaise)" <[email-masked]<mailto:[email-masked]>>
Date: Wednesday, November 19, 2014 at 11:50 AM
To: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Cc: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: [OPSAWG] draft-ietf-opsawg-capwap-alt-tunnel and draft-xue-opsawg-capwap-alt-tunnel-information relationship

Dear CAPWAP authors,

After the draft-xue-opsawg-capwap-alt-tunnel-information presentation at the last IETF meeting, I've been wondering about the relationship between the two drafts:
- draft-ietf-opsawg-capwap-alt-tunnel provides the tunnel types
  Note:this draft is currently in AD review, so close to be sent to the IESG.
- draft-xue-opsawg-capwap-alt-tunnel-information provides the encoding of the tunnel-specific fields.

I believe I'm correct that the draft-ietf-opsawg-capwap-alt-tunnel doesn't provide a complete solution without draft-xue-opsawg-capwap-alt-tunnel-information?

I'm aware of the changes between version 3 and 4 (attached picture and http://tools.ietf.org/rfcdiff?url2=draft-ietf-opsawg-capwap-alt-tunnel-04.txt)
But now I wonder: why do we have two different drafts, as opposed to a single one?

Regards, Benoit

---

From: "Rajesh Pazhyannur (rpazhyan)" <[email-masked]>
Date: Mon, 1 Dec 2014 00:08:33 +0000

Hello

I realized there was a typographical error in my response below.
Please see corrections.

Regards

Rajesh
From: Rajesh Pazhyannur <[email-masked]<mailto:[email-masked]>>
Date: Thursday, November 20, 2014 at 12:30 AM
To: "Benoit Claise (bclaise)" <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Cc: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: Re: [OPSAWG] draft-ietf-opsawg-capwap-alt-tunnel and draft-xue-opsawg-capwap-alt-tunnel-information relationship

Hi Benoit

This is a good question.

[original] Yes, you are correct that draft-ietf-opsawg-capwap-alt-tunnel does not provide a complete solution and needs something like  draft-ietf-opsawg-capwap-alt-tunnel to complete the solution.
[corrected statement] Yes, you are correct that draft-ietf-opsawg-capwap-alt-tunnel does not provide a complete solution and needs something like  draft-xue-opsawg-capwap-alt-tunnel-information to complete the solution.

The best answer I have is  that we wanted the keep the following two areas separate (and in different drafts)

  1.  Discover and negotiation of alternate tunneling capability. These are  independent of specific alternate tunnel method
  2.  [original] Definition of tunnel specific message elements. While draft-ietf-opsawg-capwap-alt-tunnel contains message elements for most of the tunneling methods defined in  draft-ietf-opsawg-capwap-alt-tunnel, I had anticipated separate drafts for each tunneling protocol.

[corrected] 2 Definition of tunnel specific message elements. While draft-ietf-opsawg-capwap-alt-tunnel contains message elements for most of the tunneling methods defined in  draft-xue-opsawg-capwap-alt-tunnel-information I had anticipated separate drafts for each tunneling protocol.

Regards

Rajesh

Dear CAPWAP authors,

Regards, Benoit