Subject: Re: [OPSAWG] WG adoption poll for In-Situ OAM drafts

From: joel jaeggli <[email-masked]>
Date: Thu, 19 Jan 2017 07:28:22 -0800

Hi,

I thought I would try and wrap this up since we're a bit over a month
since we put out the initial call after Seoul.

By my observation there have been a number of favorable expressions of
interest in pursuing this work both in OPS and elsewhere in the Routing
area. That said I think one of the conclusions the IESG has taken from
this is that In-band OAM is a cros- area activity and there is strong
interest or perhaps need to have input and review in the Routing area.
We have been exploring chartering this activity, which if it occurs
renders the question of adoption here moot.

The Ops and Routing chairs are trying to close the loop here, but I
expect that a proposed charter will be forthcoming shortly and we should
be able to progress this work.

The statements of support and enthusiasm for pursuing it has been useful
in gauging what to do with this proposal.

Thanks
joel

On 12/6/16 10:36 PM, Zhoutianran wrote:
>
> Hi All,
>
>  
>
> In Seoul, we got enough interest on the In Situ OAM work and positive
> response on related drafts.
> So this email starts a formal poll for adoption the following I-Ds.
>
>  
>
> https://tools.ietf.org/html/draft-brockners-inband-oam-requirements-02.txt
> https://tools.ietf.org/html/draft-brockners-inband-oam-data-02.txt
> https://tools.ietf.org/html/draft-brockners-proof-of-transit-02.txt
>
>  
>
> To be efficient, we have the poll for three I-Ds in one thread. But
> you can give your opinion on each of them. And the result is per I-D.
>
>  
>
> The question is:
> Do you think that the WG should adopt all or some of these drafts?
>
>  
>
> It would be helpful if you could indicate whether you have read the
> drafts. If "yes", would you like to review the drafts and help to
> improve the drafts? If "no", it is important that you provide reasons.
>
>  
>
> This poll will last for two weeks, ending on Tuesday, December 20.
>
>  
> Thanks,
> Tianran & Warren
>
>
>
> _______________________________________________
> OPSAWG mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/opsawg

---

From: Linda Dunbar <[email-masked]>
Date: Thu, 19 Jan 2017 16:28:15 +0000

Joel, 

As I stated in my earlier email, I think the in-band OAM is important area to work on. 
Just want to make sure that the proposed charter has room for other people to contribute alternative mechanisms that are not exactly same as the drafts currently being published. 

Linda

-----Original Message-----
From: OPSAWG [mailto:[email-masked]] On Behalf Of joel jaeggli
Sent: 2017年1月19日 9:28
To: Tianran Zhou <[email-masked]>; [email-masked]
Cc: [email-masked]; [email-masked]
Subject: Re: [OPSAWG] WG adoption poll for In-Situ OAM drafts

Hi,

I thought I would try and wrap this up since we're a bit over a month since we put out the initial call after Seoul.

By my observation there have been a number of favorable expressions of interest in pursuing this work both in OPS and elsewhere in the Routing area. That said I think one of the conclusions the IESG has taken from this is that In-band OAM is a cros- area activity and there is strong interest or perhaps need to have input and review in the Routing area.
We have been exploring chartering this activity, which if it occurs renders the question of adoption here moot.

The Ops and Routing chairs are trying to close the loop here, but I expect that a proposed charter will be forthcoming shortly and we should be able to progress this work.

The statements of support and enthusiasm for pursuing it has been useful in gauging what to do with this proposal.

Thanks
joel

---

From: "Alvaro Retana (aretana)" <[email-masked]>
Date: Thu, 19 Jan 2017 22:35:32 +0000

[routing-ads -> rtg-ads]

Hi!

As Joel mentioned, a proposed charter is forthcoming – there should be plenty of time for comments.

Thanks!

Alvaro.

On 1/19/17, 11:28 AM, "OPSAWG on behalf of Linda Dunbar" <[email-masked]<mailto:[email-masked]> on behalf of [email-masked]<mailto:[email-masked]>> wrote:

---

From: Tianran Zhou <[email-masked]>
Date: Fri, 20 Jan 2017 16:54:46 +0000

Great to see this interesting work could get more contribution and wider discussion.
I hope good OAM experiences could be adopted in the common OAM header and applied by many protocols. And the mode could be in-band/out of band, active/passive, and many new telemetry method...

Best,
Tianran
________________________________________
发件人: joel jaeggli [[email-masked]]
发送时间: 2017年1月19日 23:28
收件人: Tianran Zhou; [email-masked]
抄送: [email-masked]; [email-masked]; Benoit Claise (bclaise)
主题: Re: [OPSAWG] WG adoption poll for In-Situ OAM drafts

Hi,

Thanks
joel

---

From: "Bert Wijnen (IETF)" <[email-masked]>
Date: Tue, 24 Jan 2017 09:56:45 +0100

Thanks Joel. I think this is much better than just adopting one
set of documents (or one approach) in the OPSAWG. As I mentioned
in the WG session Seoul, there are multiple efforts and approaches
in this space and various of them have indeed been presented in
a number of WG and/or RG sessions.

- Where will you send the proposed charter for discussion?
   Both OPS and RTG area mailing lists (or maybe OPSAWG instead of OPS)?
- Are you gonna do a call for volunteers to co-chair the WG?
- It sounds like you are not gonna do a BOF first, right?
   that is OK with me.

Thanks,
Bert

---

From: "Frank Brockners (fbrockne)" <[email-masked]>
Date: Sun, 29 Jan 2017 18:00:35 +0000

Thanks Joel.

In order to continue discussions on in-situ OAM and evolve to a new WG, we have new mailing-list now: [email-masked] 
If interested in the in-situ OAM discussions, please subscribe here: https://www.ietf.org/mailman/listinfo/ioam

Regards, Frank

-----Original Message-----
From: OPSAWG [mailto:[email-masked]] On Behalf Of joel jaeggli
Sent: Donnerstag, 19. Januar 2017 16:28
To: Zhoutianran <[email-masked]>; [email-masked]
Cc: [email-masked]; [email-masked]
Subject: Re: [OPSAWG] WG adoption poll for In-Situ OAM drafts

Hi,

Thanks
joel