Subject: Re: [OPSAWG] CLAT (was TR: New Version Notification for draft-ietf-opsawg-nat-yang-00.txt)

From: <[email-masked]>
Date: Fri, 18 Aug 2017 14:35:45 +0000

Re-,

Forwarded to the OPSAWG list. 

Please use this messages when replying. 

Apologies for the inconvenience. 

Cheers,
Med

> -----Message d'origine-----
> De : BOUCADAIR Mohamed IMT/OLN
> Envoyé : vendredi 18 août 2017 16:19
> À : 'Lee Howard'; [email-masked]
> Cc : [email-masked]; JACQUENET Christian IMT/OLN; Senthil
> Sivakumar (ssenthil); 'Qin Wu'; [email-masked]
> Objet : CLAT (was TR: New Version Notification for draft-ietf-opsawg-nat-
> yang-00.txt)
> 
> Hi Lee,
> 
> (I'm adding Jordi to the discussion since he is familiar with CLAT in a
> CPE)
> 
> You suggested in Prague to add CLAT to the NAT YANG module.
> 
> Please find below how we are planning to cover it in the next iteration of
> the draft:
> 
> (1) If a dedicated prefix is configured for CLAT, then only a stateless
> XLAT will be required. That is, no mapping table will be maintained at
> all. Since the module already includes NAT64 prefix(es), the CLAT IPv6
> prefix will be missing. The tree structure can be updated as follows:
> 
> OLD:
>              +--rw nat64-prefixes* [nat64-prefix]
>              |  +--rw nat64-prefix               inet:ipv6-prefix
>              |  +--rw destination-ipv4-prefix* [ipv4-prefix]
>              |     +--rw ipv4-prefix    inet:ipv4-prefix
> 
> NEW:
> 
>              +--rw nat64-prefixes* [nat64-prefix]
>              |  +--rw nat64-prefix               inet:ipv6-prefix
>              |  +--rw destination-ipv4-prefix* [ipv4-prefix]
>              |     +--rw ipv4-prefix    inet:ipv4-prefix
>              +--rw clat-ipv6-prefix?             inet:ipv6-prefix
> 
> (2) If no dedicated /64 prefix is provided, a NAT44 will be required. A
> stateless XLAT will be then applied on NATed packets. This case is
> natively supported by the current YANG model.
> 
> A CLAT module can automatically select an IPv4 address from 192.0.0.0/29
> (RFC7335). This address can also be set. To do so, the tree structure can
> be updated with:
> 
> NEW:
>              ...
>              +--rw clat-ipv4-address?            inet:ipv4-address
>              ...
> 
> The CLAT IPv4 address will be taken by default from 192.0.0.0/29. Other
> addresses can be used.
> 
> Lee/Jordi, are there any other required changes?
> 
> Thank you.
> 
> Cheers,
> Med
> 
> > -----Message d'origine-----
> > De : OPSAWG [mailto:[email-masked]] De la part de
> > [email-masked]
> > Envoyé : vendredi 18 août 2017 15:46
> > À : [email-masked]
> > Cc : [email-masked]; JACQUENET Christian IMT/OLN
> > Objet : [OPSAWG] TR: New Version Notification for draft-ietf-opsawg-nat-
> > yang-00.txt
> >
> > Dear all,
> >
> > The -00 version integrates the comments received during the Call for
> > Adoption:
> >
> > - Clarify how Destination NAT is covered (Tianran)
> > - Follow the NMDA guidelines (Juergen and Qin)
> > - Include a generic structure for ALGs instead of listing supported ones
> > (Juergen)
> > - Include a discussion about how other transport protocols are/can be
> > supported (Juergen)
> > - Include a comprehensive list of examples  (Juergen)
> > - Move the example to an appendix (Juergen)
> >
> > We do still have one pending comment that was raised by Lee Howard when
> I
> > presented in Prague: add CLAT to the list.
> >
> > Comments are more than welcome. Please review.
> >
> > Cheers,
> > Med
> >
> > > -----Message d'origine-----
> > > De : [email-masked] [mailto:[email-masked]]
> > > Envoyé : vendredi 18 août 2017 15:31
> > > À : BOUCADAIR Mohamed IMT/OLN; Senthil Sivakumar; JACQUENET Christian
> > > IMT/OLN; [email-masked]; Qin Wu
> > > Objet : New Version Notification for draft-ietf-opsawg-nat-yang-00.txt
> > >
> > >
> > > A new version of I-D, draft-ietf-opsawg-nat-yang-00.txt
> > > has been successfully submitted by Mohamed Boucadair and posted to the
> > > IETF repository.
> > >
> > > Name:		draft-ietf-opsawg-nat-yang
> > > Revision:	00
> > > Title:		A YANG Data Model for Network Address Translation (NAT)
> and
> > > Network Prefix Translation (NPT)
> > > Document date:	2017-08-18
> > > Group:		opsawg
> > > Pages:		67
> > > URL:            https://www.ietf.org/internet-drafts/draft-ietf-
> opsawg-
> > > nat-yang-00.txt
> > > Status:         https://datatracker.ietf.org/doc/draft-ietf-opsawg-
> nat-
> > > yang/
> > > Htmlized:       https://tools.ietf.org/html/draft-ietf-opsawg-nat-
> yang-
> > 00
> > > Htmlized:       https://datatracker.ietf.org/doc/html/draft-ietf-
> opsawg-
> > > nat-yang-00
> > >
> > >
> > > Abstract:
> > >    For the sake of network automation and the need for programming
> > >    Network Address Translation (NAT) function in particular, a data
> > >    model for configuring and managing the NAT is essential.  This
> > >    document defines a YANG data model for the NAT function.  NAT44,
> > >    NAT64, and NPTv6 are covered in this document.
> > >
> > >
> > >
> > >
> > > Please note that it may take a couple of minutes from the time of
> > > submission
> > > until the htmlized version and diff are available at tools.ietf.org.
> > >
> > > The IETF Secretariat
> >
> > _______________________________________________
> > OPSAWG mailing list
> > [email-masked]
> > https://www.ietf.org/mailman/listinfo/opsawg

---

From: Lee Howard <[email-masked]>
Date: Sun, 20 Aug 2017 17:35:52 -0400

Thank you!

Lee