Subject: [OPSAWG] I-D Action: draft-ietf-opsawg-nat-yang-02.txt

From: [email-masked]
Date: Wed, 23 Aug 2017 06:29:37 -0700

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the Operations and Management Area Working Group WG of the IETF.

        Title           : A YANG Data Model for Network Address Translation (NAT) and Network Prefix Translation (NPT)
        Authors         : Mohamed Boucadair
                          Senthil Sivakumar
                          Christian Jacquenet
                          Suresh Vinapamula
                          Qin Wu
	Filename        : draft-ietf-opsawg-nat-yang-02.txt
	Pages           : 75
	Date            : 2017-08-23

Abstract:
   For the sake of network automation and the need for programming
   Network Address Translation (NAT) function in particular, a data
   model for configuring and managing the NAT is essential.  This
   document defines a YANG data model for the NAT function.

   NAT44, Network Address and Protocol Translation from IPv6 Clients to
   IPv4 Servers (NAT64), Customer-side transLATor (CLAT), Explicit
   Address Mappings for Stateless IP/ICMP Translation (SIIT EIM), and
   IPv6 Network Prefix Translation (NPTv6) are covered in this document.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-opsawg-nat-yang/

There are also htmlized versions available at:
https://tools.ietf.org/html/draft-ietf-opsawg-nat-yang-02
https://datatracker.ietf.org/doc/html/draft-ietf-opsawg-nat-yang-02

A diff from the previous version is available at:
https://www.ietf.org/rfcdiff?url2=draft-ietf-opsawg-nat-yang-02

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: <[email-masked]>
Date: Wed, 23 Aug 2017 13:43:34 +0000

Dear all, 

Fred (Baker) has kindly accepted to review the NPTv6 part of this specification. Many thanks to him. 

This new version integrates the comments raised by Fred. The main changes are:

- Specify the interface(s) on which the translation function applies. The model allows to characterize both internal and external interfaces. When no interface is defined, this assumes that the underlying system is capable to determine the interface on which the NAT must be executed. For example, a CPE device is able to determine its LAN and WAN interfaces.
- Rename "pool-id" under NPTv6 prefixes to "translation-id" to avoid confusing with a NAT44 pool
- Update the NPTv6 appendix accordingly. 

Fred may still have comments on this version. I will let him confirm/infirm. 

Cheers,
Med

> -----Message d'origine-----
> De : OPSAWG [mailto:[email-masked]] De la part de internet-
> [email-masked]
> Envoyé : mercredi 23 août 2017 15:30
> À : [email-masked]
> Cc : [email-masked]
> Objet : [OPSAWG] I-D Action: draft-ietf-opsawg-nat-yang-02.txt
> 
> 
>         Title           : A YANG Data Model for Network Address
> Translation (NAT) and Network Prefix Translation (NPT)
> _______________________________________________
> OPSAWG mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/opsawg