Subject: [OPSAWG] draft-ietf-opsawg-mud-15 naming nit

From: "M. Ranganathan" <[email-masked]>
Date: Tue, 30 Jan 2018 15:53:33 -0500

In the acldns yang file I see

    augment "/acl:access-lists/acl:acl/acl:aces/acl:ace/acl:matches" {
       description
         "adding abstractions to avoid need of IP addresses";
       container mud {

This leads to a few annoying naming conflicts when the Yang file is used to
auto-generate java code. It would be convenient (although not necessary) if
the container name were changed to mud-acl (the way it used to be).

Sorry for nit-picking.

Regards,

-- 
M. Ranganathan

“If debugging is the process of removing software bugs, then programming
must be the process of putting them in.” – Edsger Dijkstra

---

From: Eliot Lear <[email-masked]>
Date: Tue, 30 Jan 2018 22:04:04 +0100

Hi Ranga,

I understand this to be a tooling issue.  Nevertheless, I will revert
the change back to mud-acl as we progress the draft.

Eliot

On 30.01.18 21:53, M. Ranganathan wrote:
> This leads to a few annoying naming conflicts when the Yang file is
> used to auto-generate java code. It would be convenient (although not
> necessary) if the container name were changed to mud-acl (the way it
> used to be).
>
> Sorry for nit-picking.
>
> Regards,
>
> -- 
> M. Ranganathan
>
> “If debugging is the process of removing software bugs, then
> programming must be the process of putting them in.” – Edsger Dijkstra
>
>
>
> _______________________________________________
> OPSAWG mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/opsawg