Subject: Re: [OPSAWG] network telemetry framework

From: Joe Clarke <[email-masked]>
Date: Mon, 2 Apr 2018 14:52:20 -0400

On 3/21/18 04:01, Haoyu song wrote:
> Dear all,
> 
>  
> 
> The WG presentation triggered a lot warm discussions on this topic.
> 
> While we agree that at present it’s too aggressive to try to unify the
> telemetry protocols, we feel it is needed to formalize the terminologies
> and clarify the technique classifications from multiple dimensions so to
> ensure we have a common language in addressing such issues for the
> upcoming network architectures such intent driven network.

Thanks for continuing to work on this document, Haoyu.  The idea of a
"common taxonomy" is a good one.  However, the current draft mentions a
desire to "[integrate] multiple telemetry approaches" into a framework.
I think the comments stated in London were of the vein that given the
amount of work involved (and the use cases and solutions that have been
put forward thus far), this is a monumental undertaking.

As a contributor, perhaps there is something unique to the IBN/IDN
architecture(s) that need a well-defined, common framework to how
telemetry is approached.  That would at least refine scope a bit more.

> 
>  
> 
> The latest version can be found at:
> 
> https://tools.ietf.org/html/draft-song-ntf-01
> 
> The document is still at its early stage. Please continue to provide
> your comments and suggestions to scope it and contribute to it.

The -01 modifications do help with readability, and I do encourage
others to read and comment.

Joe

> 
> Thank you very much!
> 
>  
> 
> Best regards,
> 
> Haoyu
> 
> 
> 
> _______________________________________________
> OPSAWG mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/opsawg
>

---

From: Haoyu song <[email-masked]>
Date: Mon, 2 Apr 2018 21:32:00 +0000

Hi Joe,

Thanks for the comment!
Yes it's clear our first step would be to set up the common taxonomy in this area and help people to understand the status quo as well as the technical gaps. 

We do believe there are something unique to IBN/IDN in terms of the network telemetry. We have heard people expressed the desire to 
1) normalize the data collection means
2) be able to interactively refine the data collection
3) be able to collect customized data on the on-demand basis
4) be able to directly collect data from the data plane forwarding path

Some existing work shows the potentials to meet some of the requirements, but I feel we are still far from that.
So I think this document at least can partially serve the purpose to clear the path.  

We welcome collaborations on this topic because we believe this work needs the contributions from the entire community.

Best,
Haoyu 

-----Original Message-----
From: Joe Clarke [mailto:[email-masked]] 
Sent: Monday, April 02, 2018 11:52 AM
To: Haoyu song <[email-masked]>; opsawg <[email-masked]>
Subject: Re: [OPSAWG] network telemetry framework

On 3/21/18 04:01, Haoyu song wrote:
> While we agree that at present it's too aggressive to try to unify the 
> telemetry protocols, we feel it is needed to formalize the 
> terminologies and clarify the technique classifications from multiple 
> dimensions so to ensure we have a common language in addressing such 
> issues for the upcoming network architectures such intent driven network.

Thanks for continuing to work on this document, Haoyu.  The idea of a "common taxonomy" is a good one.  However, the current draft mentions a desire to "[integrate] multiple telemetry approaches" into a framework.
I think the comments stated in London were of the vein that given the amount of work involved (and the use cases and solutions that have been put forward thus far), this is a monumental undertaking.

As a contributor, perhaps there is something unique to the IBN/IDN
architecture(s) that need a well-defined, common framework to how telemetry is approached.  That would at least refine scope a bit more.

> your comments and suggestions to scope it and contribute to it.

The -01 modifications do help with readability, and I do encourage others to read and comment.

Joe