Subject: [OPSAWG] Fwd: New Version Notification for draft-lear-opsawg-mud-bw-profile-00.txt

From: Eliot Lear <[email-masked]>
Date: Sat, 20 Oct 2018 15:50:12 +0200

This is a little ditty that Jerome Henry and I have started in response
to some requests that we have some ability to profile bandwidth usage in
a MUD file.  This is a very brief draft.  I would appreciate if I could
have 10 minutes to talk about it.  There are a few questions that I
would like to ask the room.

Specifically:

 1. In profiling bandwidth, would you like in the model (a) an aggregate
    statement of how bandwidth is supposed to be used, (b) a fine grain
    view by port/service, or (c) both?
 2. Does the draft have the right units in there?  Right now I list both
    packets per second and bits per second with a configurable time period.
 3. Is this something you would be interested in reviewing, pursuing,
    editing, etc.'ing?

Thanks!

Eliot

Subject: New Version Notification for draft-lear-opsawg-mud-bw-profile-00.txt
From: <[email-masked]>
To: Eliot Lear <[email-masked]>, Jerome Henry <[email-masked]>, Owen Friel <[email-masked]>
Date: Sat, 20 Oct 2018 06:44:59 -0700

A new version of I-D, draft-lear-opsawg-mud-bw-profile-00.txt
has been successfully submitted by Eliot Lear and posted to the
IETF repository.

Name:		draft-lear-opsawg-mud-bw-profile
Revision:	00
Title:		Network QoS Expectations Extensions for MUD
Document date:	2018-10-20
Group:		Individual Submission
Pages:		9
URL:            https://www.ietf.org/internet-drafts/draft-lear-opsawg-mud-bw-profile-00.txt
Status:         https://datatracker.ietf.org/doc/draft-lear-opsawg-mud-bw-profile/
Htmlized:       https://tools.ietf.org/html/draft-lear-opsawg-mud-bw-profile-00
Htmlized:       https://datatracker.ietf.org/doc/html/draft-lear-opsawg-mud-bw-profile

Abstract:
   Manufacturer Usage Descriptions (MUD) are a means by which devices
   can establish expectations about how they are intended to behave, and
   how the network should treat them.  Earlier work focused on access
   control.  This draft specifies a means by which manufacturers can
   express to deployments what form of bandwidth profile devices are
   expected to have with respect to specific services.

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

The IETF Secretariat

---

From: Jacques Latour <[email-masked]>
Date: Mon, 22 Oct 2018 13:54:48 +0000

Hi,

I will not be there, but yes I think bandwidth is just one of many attributes we can define in MUD profiles, additional feature of MUD would be to identify the IoT device functionality, to say this device has a camera stream available on port YXZ, that alerts can be seen at this URL, that the control panel can be access at this URL, and more.  I have many examples at the end of this presentation. https://github.com/CIRALabs/Secure-IoT-Home-Gateway/blob/master/CIRA%20Labs%20-%20Secure%20Home%20Gateway%20Project%202018-09.pdf

Jacques

From: OPSAWG <[email-masked]> On Behalf Of Eliot Lear
Sent: October 20, 2018 3:50 PM
To: [email-masked]
Subject: [OPSAWG] Fwd: New Version Notification for draft-lear-opsawg-mud-bw-profile-00.txt

This is a little ditty that Jerome Henry and I have started in response to some requests that we have some ability to profile bandwidth usage in a MUD file.  This is a very brief draft.  I would appreciate if I could have 10 minutes to talk about it.  There are a few questions that I would like to ask the room.

Specifically:

  1.  In profiling bandwidth, would you like in the model (a) an aggregate statement of how bandwidth is supposed to be used, (b) a fine grain view by port/service, or (c) both?
  2.  Does the draft have the right units in there?  Right now I list both packets per second and bits per second with a configurable time period.
  3.  Is this something you would be interested in reviewing, pursuing, editing, etc.'ing?

Thanks!

Eliot

---

From: "M. Ranganathan" <[email-masked]>
Date: Mon, 22 Oct 2018 12:15:10 -0400

The bandwidth is "max bandwidth per burst".

I don't see "interval between bursts".  Also, need to define  the case
where the device is streaming continuously, burst length is "infinity" and
interval between bursts is 0.

Regards,

Ranga.

On Sat, Oct 20, 2018 at 9:50 AM Eliot Lear <[email-masked]> wrote:

> This is a little ditty that Jerome Henry and I have started in response to
> some requests that we have some ability to profile bandwidth usage in a MUD
> file.  This is a very brief draft.  I would appreciate if I could have 10
> minutes to talk about it.  There are a few questions that I would like to
> ask the room.
>
> Specifically:
>
>    1. In profiling bandwidth, would you like in the model (a) an
>    aggregate statement of how bandwidth is supposed to be used, (b) a fine
>    grain view by port/service, or (c) both?
>    2. Does the draft have the right units in there?  Right now I list
>    both packets per second and bits per second with a configurable time period.
> ---------- Forwarded message ----------
> To: Eliot Lear <[email-masked]>, Jerome Henry <[email-masked]>
> Cc:
> Bcc:
> URL:
> https://www.ietf.org/internet-drafts/draft-lear-opsawg-mud-bw-profile-00.txt
> Status:
> https://datatracker.ietf.org/doc/draft-lear-opsawg-mud-bw-profile/
> Htmlized:
> https://tools.ietf.org/html/draft-lear-opsawg-mud-bw-profile-00
> Htmlized:
> https://datatracker.ietf.org/doc/html/draft-lear-opsawg-mud-bw-profile
>
>
> Abstract:
> _______________________________________________
> OPSAWG mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/opsawg
>

-- 
M. Ranganathan