Subject: Re: [OPSAWG] iFIT framework draft

From: Giuseppe Fioccola <[email-masked]>
Date: Thu, 12 Sep 2019 14:37:30 +0000

Dear All,
I have read the draft and, I think it is a very good framework, in particular with reference to the real practical challenges.
My suggestion is to highlight a bit more the enabled closed-loop approach that is a great added value in my opinion.
A possible way can be to introduce a new Section named "Intelligent Network telemetry" about the flexible and dynamic monitoring. Some concepts like the interactive query with dynamic network probes can be included.
An example could also be in draft-ietf-ippm-multipoint-alt-mark, that describes a flexible performance monitoring approach based on the network condition and an iFIT Application on top of the Controllers could apply this intelligent mechanism. Or, also, other examples can be reported.

Let me know what you think.

Best Regards,

Giuseppe

From: OPSAWG [mailto:[email-masked]] On Behalf Of Haoyu Song
Sent: Wednesday, July 17, 2019 8:06 PM
To: [email-masked]; [email-masked]
Subject: [OPSAWG] iFIT framework draft

Hi all,

We recently uploaded a newer version of the iFIT framework draft.
https://datatracker.ietf.org/doc/draft-song-opsawg-ifit-framework/

The purposes of the drafts are:

  1.  Clarify the terms and underlying techniques for data plane on-path telemetry
  2.  Present a framework that addresses the practical implementation and deployment issues
  3.  Identify the open issues and directions for related standard development

Given the wide industry interests on adopting such techniques, we believe this informational draft is useful and
In the scope of OPSAWG.  Please review the draft and provide your opinions, suggestions, and comments.

Thank you very much!

Haoyu

---

From: Haoyu Song <[email-masked]>
Date: Thu, 12 Sep 2019 17:56:30 +0000

Hi Giuseppe,

Thank you very much for the very good suggestion. Indeed, the closed-loop nature of the framework allows numerous new applications which I believe is indispensable in future's network operation architecture.
If you have any suggested section or text available, I'll be happy to include it in the draft. That way, you can fully construe your thought. Otherwise, I'll add some text by myself later. What do you  think?

Best,
Haoyu

From: Giuseppe Fioccola <[email-masked]>
Sent: Thursday, September 12, 2019 7:38 AM
To: Haoyu Song <[email-masked]>; [email-masked]; [email-masked]
Subject: RE: iFIT framework draft

Dear All,

Best Regards,

Giuseppe

From: OPSAWG [mailto:[email-masked]] On Behalf Of Haoyu Song
Sent: Wednesday, July 17, 2019 8:06 PM
To: [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>
Subject: [OPSAWG] iFIT framework draft

Hi all,

We recently uploaded a newer version of the iFIT framework draft.
https://datatracker.ietf.org/doc/draft-song-opsawg-ifit-framework/<https://nam03.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fdraft-song-opsawg-ifit-framework%2F&data=02%7C01%7Chaoyu.song%40futurewei.com%7C8c5d65776ddb4158c64508d7378ebeef%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C1%7C637038958551827671&sdata=Iufu9kamS5%2BV5dWoa9G8MhK7Bw%2FIzZipm9w6z3jj8f8%3D&reserved=0>

Thank you very much!

Haoyu

---

From: Giuseppe Fioccola <[email-masked]>
Date: Fri, 13 Sep 2019 11:51:09 +0000

Dear Haoyu,
Yes, I'm happy to send you some text in the coming days, so you can include it in the draft.

Best Regards,

Giuseppe

From: Haoyu Song [mailto:[email-masked]]
Sent: Thursday, September 12, 2019 7:57 PM
To: Giuseppe Fioccola <[email-masked]>; [email-masked]; [email-masked]
Subject: RE: iFIT framework draft

Hi Giuseppe,

Best,
Haoyu

From: Giuseppe Fioccola <[email-masked]<mailto:[email-masked]>>
Sent: Thursday, September 12, 2019 7:38 AM
To: Haoyu Song <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>
Subject: RE: iFIT framework draft

Dear All,

Best Regards,

Giuseppe

Hi all,

Thank you very much!

Haoyu

---

From: Giuseppe Fioccola <[email-masked]>
Date: Wed, 18 Sep 2019 12:57:06 +0000

Dear Haoyu, All,
As promised, here is the proposed new section.
Feel free to edit and let me know your opinion.

"
#.  Intelligent Network Telemetry applications

   The closed-loop nature of the IFIT framework allows numerous new
   applications which enable future network operation architecture.

   In general, it is resource consuming to monitor continuously all
   the flows and all the paths of the network. So a flexible and
   dynamic performance monitoring approach is desired. Some concepts
   like the Interactive Query with Dynamic Network Probes, as
   previously described, go in this direction.

   A good example could be in [I-D.ietf-ippm-multipoint-alt-mark]
   that describes an intelligent performance management based on the
   network condition. The idea is to split the monitoring network
   into Clusters. The Cluster partition that can be applied to every
   type of network graph and the possibility to combine Clusters at
   different levels enable the so called Network Zooming. It allows
   a Controller to calibrate the network telemetry, so that it can
   start without examining in depth and monitor the network as a
   whole. In case of necessity (packet loss or too high delay), an
   immediate detailed analysis can be reconfigured. In particular,
   the Controller, that is aware of the network topology, can set up
   the most suited Cluster partition by changing the traffic filter
   or activate new measurement points and the problem can be localized
  with a step-by-step process.

   To apply this mechanism an IFIT Application on top of the Controllers
   can manage and the IFIT closed loop allows its dynamic and flexible
   operation.
"

Best Regards,

Giuseppe

From: Giuseppe Fioccola
Sent: Friday, September 13, 2019 1:51 PM
To: 'Haoyu Song' <[email-masked]>; [email-masked]; [email-masked]
Subject: RE: iFIT framework draft

Dear Haoyu,

Best Regards,

Giuseppe

From: Haoyu Song [mailto:[email-masked]]
Sent: Thursday, September 12, 2019 7:57 PM
To: Giuseppe Fioccola <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>
Subject: RE: iFIT framework draft

Hi Giuseppe,

Best,
Haoyu

Dear All,

Best Regards,

Giuseppe

Hi all,

Thank you very much!

Haoyu

---

From: Haoyu Song <[email-masked]>
Date: Wed, 18 Sep 2019 16:55:26 +0000

Hi Giuseppe,

Thank you very much for your contribution! I'll merge it into our next revision of the draft.
Indeed, I hope the framework can inspire more applications.

Best,
Haoyu

From: Giuseppe Fioccola <[email-masked]>
Sent: Wednesday, September 18, 2019 5:57 AM
To: Haoyu Song <[email-masked]>; [email-masked]; [email-masked]
Subject: RE: iFIT framework draft

Dear Haoyu, All,

"

Best Regards,

Giuseppe

From: Giuseppe Fioccola
Sent: Friday, September 13, 2019 1:51 PM
To: 'Haoyu Song' <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>
Subject: RE: iFIT framework draft

Dear Haoyu,

Best Regards,

Giuseppe

Hi Giuseppe,

Best,
Haoyu

Dear All,

Best Regards,

Giuseppe

Hi all,

We recently uploaded a newer version of the iFIT framework draft.
https://datatracker.ietf.org/doc/draft-song-opsawg-ifit-framework/<https://nam03.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fdraft-song-opsawg-ifit-framework%2F&data=02%7C01%7Chaoyu.song%40futurewei.com%7C96507be0170c49d0d5a408d73c37b72f%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637044082325736265&sdata=7l94rTlxPgbgXM5ftLhKRaUU6%2FZUT60PQOokJ0wSCjo%3D&reserved=0>

Thank you very much!

Haoyu

---

From: "qinfengwei" <[email-masked]>
Date: Fri, 20 Sep 2019 22:09:13 +0800

Hi Haoyu,

I have read the draft and think the iFIT is useful for operators to identify
the issue quickly. You know that the silent failures are our biggest pain
points, the precision location and network self-healing are our rigid
demand. You say that iFIT is a closed-loop framework, in my opinion, it
should include how to diagnose and restore the network, but I haven't seen
either. Do I not understand or would you have explained it in other draft?

Beat Regard,

Fengwei Qin

发件人: OPSAWG [mailto:[email-masked]] 代表 Haoyu Song
发送时间: 2019年7月18日 02:06
收件人: [email-masked]; [email-masked]
主题: [OPSAWG] iFIT framework draft

Hi all,

1.	Clarify the terms and underlying techniques for data plane on-path
telemetry
2.	Present a framework that addresses the practical implementation and
deployment issues
3.	Identify the open issues and directions for related standard
development

Given the wide industry interests on adopting such techniques, we believe
this informational draft is useful and 

In the scope of OPSAWG.  Please review the draft and provide your opinions,
suggestions, and comments.

Thank you very much!

Haoyu

---

From: Haoyu Song <[email-masked]>
Date: Fri, 20 Sep 2019 17:29:50 +0000

Hi Fengwei,

Thanks for the feedback. My understanding is that there are two types of closed loops. In our draft, iFIT’s closed loop is for changing the telemetry requirements based on previous telemetry results, so the whole loop is still for the telemetry purpose. Another type of closed loop is so called closed control loop, which means, based on the telemetry results, the application will automatically change the network policy or configuration. For this type, iFIT is just part of the loop and we may not want to cover that because it might belong to a bigger topic (such as automatic network) . But I think it’s useful to clarify this point in the draft.

The “self-healing” case you mentioned might belong to the second type, but the “precision location of silent failures” case might belong to the first type, depending on a better understanding of the case, i.e., what kind of failures and how data-path telemetry can help to detect. If you and anybody else have such information, I would like to hear and include the discussion in the draft.

Thanks!

Haoyu

From: qinfengwei <[email-masked]>
Sent: Friday, September 20, 2019 7:09 AM
To: Haoyu Song <[email-masked]>; [email-masked]; [email-masked]
Subject: 答复: [OPSAWG] iFIT framework draft

Hi Haoyu,
I have read the draft and think the iFIT is useful for operators to identify the issue quickly. You know that the silent failures are our biggest pain points, the precision location and network self-healing are our rigid demand. You say that iFIT is a closed-loop framework, in my opinion, it should include how to diagnose and restore the network, but I haven't seen either. Do I not understand or would you have explained it in other draft?

Beat Regard,
Fengwei Qin

发件人: OPSAWG [mailto:[email-masked]] 代表 Haoyu Song
发送时间: 2019年7月18日 02:06
收件人: [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>
主题: [OPSAWG] iFIT framework draft

Hi all,

We recently uploaded a newer version of the iFIT framework draft.
https://datatracker.ietf.org/doc/draft-song-opsawg-ifit-framework/<https://nam03.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fdraft-song-opsawg-ifit-framework%2F&data=02%7C01%7Chaoyu.song%40futurewei.com%7C22e31da5670b48dcbbea08d73dd43232%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637045853915262328&sdata=7dKlBcMx%2FyrDVSPNUOmG%2BaC0x4AfRGVQvgoAWmmyEYc%3D&reserved=0>

Thank you very much!

Haoyu

---

From: "qinfengwei" <[email-masked]>
Date: Thu, 26 Sep 2019 09:25:24 +0800

Hi Haoyu,

I am interested in your thoughts on the two closed loops. I agree with you. I think it's useful to clarify this point in the draft.

The per packet hop by hop monitoring will cost too much resource. So the solution we are looking for is iterative. Spatially, we can monitor selected services or tunnels at one time, and switch to other monitoring objects then. Temporally, we can do the end to end or sampled monitoring, and switch to the fine grained monitoring once the SLA degrade. 

And so the telemetry could be interactive. For example, when we detect the end to end packet loss, we firstly evaluate the frequency, the pattern and see if it's caused by some obvious reason (e.g., the power failure). Then we decide whether to apply the fine grained monitoring and locate the fault.  

I think these could all be implemented in a closed loop telemetry.

 

Best Regards,

Fengwei Qin

发件人: Haoyu Song [mailto:[email-masked]] 
发送时间: 2019年9月21日 01:30
收件人: qinfengwei; [email-masked]; [email-masked]
主题: RE: [OPSAWG] iFIT framework draft

Hi Fengwei,

Thanks!

Haoyu

Hi Haoyu,

 

Beat Regard,

Fengwei Qin

Hi all,

https://datatracker.ietf.org/doc/draft-song-opsawg-ifit-framework/ <https://nam03.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fdraft-song-opsawg-ifit-framework%2F&data=02%7C01%7Chaoyu.song%40futurewei.com%7C22e31da5670b48dcbbea08d73dd43232%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637045853915262328&sdata=7dKlBcMx%2FyrDVSPNUOmG%2BaC0x4AfRGVQvgoAWmmyEYc%3D&reserved=0> 

Thank you very much!

Haoyu

---

From: Haoyu Song <[email-masked]>
Date: Thu, 26 Sep 2019 17:24:39 +0000

Yes, exactly. The closed loop for telemetry is interactive and dynamic. Under such a framework, we are expecting many interesting applications that solve various network monitoring and measurement problems.

Haoyu

From: qinfengwei <[email-masked]>
Sent: Wednesday, September 25, 2019 6:25 PM
To: Haoyu Song <[email-masked]>; [email-masked]; [email-masked]
Subject: 答复: [OPSAWG] iFIT framework draft

Hi Haoyu,

Best Regards,
Fengwei Qin

发件人: Haoyu Song [mailto:[email-masked]]
发送时间: 2019年9月21日 01:30
收件人: qinfengwei; [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>
主题: RE: [OPSAWG] iFIT framework draft

Hi Fengwei,

Thanks!

Haoyu

From: qinfengwei <[email-masked]<mailto:[email-masked]>>
Sent: Friday, September 20, 2019 7:09 AM
To: Haoyu Song <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>
Subject: 答复: [OPSAWG] iFIT framework draft

Hi Haoyu,

Beat Regard,
Fengwei Qin

Hi all,

We recently uploaded a newer version of the iFIT framework draft.
https://datatracker.ietf.org/doc/draft-song-opsawg-ifit-framework/<https://nam03.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fdraft-song-opsawg-ifit-framework%2F&data=02%7C01%7Chaoyu.song%40futurewei.com%7Cb638388e15014220332e08d742207823%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637050579561924462&sdata=XxOdDdZoW99S7afDtwZMlB5aMuLBJyy46B7DaJOXK0I%3D&reserved=0>

Thank you very much!

Haoyu