Subject: [OPSAWG] [opsawg] appropriateness of draft-shytyi-opsawg-vysm-00 to OPSAWG.

From: Dmytro Shytyi <[email-masked]>
Date: Sun, 22 Sep 2019 22:08:16 +0200

Hello,

This draft-shytyi-opsawg-vysm-00 describes a YANG model for uCPE management and defines a uCPE equipment.

Is this draft appropriate here?

A new version of I-D, draft-shytyi-opsawg-vysm-00.txt 

has been successfully submitted by Dmytro Shytyi and posted to the 

IETF repository. 

Name:        draft-shytyi-opsawg-vysm 

Revision:    00 

Title:        A YANG Module for uCPE management. 

Document date:    2019-09-21 

Group:        Individual Submission 

Pages:        14 

URL: https://www.ietf.org/internet-drafts/draft-shytyi-opsawg-vysm-00.txt 

Status: https://datatracker.ietf.org/doc/draft-shytyi-opsawg-vysm/ 

Htmlized: https://tools.ietf.org/html/draft-shytyi-opsawg-vysm-00 

Htmlized: https://datatracker.ietf.org/doc/html/draft-shytyi-opsawg-vysm 

Abstract: 

This document provides a YANG data model for uCPE management (VYSM) 

and definition of the uCPE equipment. The YANG Service Model serves 

as a base framework for managing an universal Customer-Premises 

Equipment (uCPE) subsystem. The model can be used by a Network 

Service Orchestrator. 

______________
Dmytro SHYTYI

---

From: "Joe Clarke (jclarke)" <[email-masked]>
Date: Mon, 23 Sep 2019 13:40:23 +0000

On Sep 22, 2019, at 16:08, Dmytro Shytyi <[email-masked]<mailto:[email-masked]>> wrote:

Hello,

Yes, I think it would be appropriate to have a discussion about this draft in opsawg.

You may want to do more than just post your data tracker publication email, though.  Tee up some key questions you’d like to ask the WG to help get the conversation going.

Joe

Abstract:

______________
Dmytro SHYTYI

_______________________________________________
OPSAWG mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/opsawg

---

From: Dmytro Shytyi <[email-masked]>
Date: Mon, 23 Sep 2019 22:18:23 +0200

Hello,
Thank you for comment.

I have few  questions to the group members. (This model should be considered as one that is located in the orchestrator.)
Your comments will allow to improve this yang model.
1. First question related to the mgmnt IP address. 
Would it be appropriate to add to the model the part related to the ipv4/IPv6 config of ucpe for example activation of DHCP/SLAAC/static?
2. Should the yang model include tacacs client config ? Ntp? Syslog?
3. Or it would be better if it would concentrate on the network service management in the ucpe as it currently is?(KISS way)

Best regards, 
Dmytro.

⁣Get BlueMail for Android ​

On Sep 23, 2019, 15:40, at 15:40, "Joe Clarke (jclarke)" <[email-masked]> wrote:
>
>
>On Sep 22, 2019, at 16:08, Dmytro Shytyi
><[email-masked]<mailto:[email-masked]>> wrote:
>
>Hello,
>
>You may want to do more than just post your data tracker publication
>email, though.  Tee up some key questions you’d like to ask the WG to
>help get the conversation going.
>
>Joe
>
>
>
>URL:
>https://www.ietf.org/internet-drafts/draft-shytyi-opsawg-vysm-00.txt
>Htmlized:
>https://datatracker.ietf.org/doc/html/draft-shytyi-opsawg-vysm
>
>
>Abstract:

---

From: "Joe Clarke (jclarke)" <[email-masked]>
Date: Mon, 23 Sep 2019 22:51:30 +0000

On Sep 23, 2019, at 16:18, Dmytro Shytyi <[email-masked]<mailto:[email-masked]>> wrote:

Hello,
Thank you for comment.

Speaking now as a contributor.

Seems to me that should be left to other models like the system model (just like you would leave NETCONF configuration to the netconf-server model).  I think your focus is on the embedded network functions on this appliance.

I would say no for the same reason as above.  There are other models for that.

Focus on what this appliance does differently from other things would be my individual advice.

Joe

Best regards,
Dmytro.

Get BlueMail for Android<http://www.bluemail.me/r?b=15656>
On Sep 23, 2019, at 15:40, "Joe Clarke (jclarke)" <[email-masked]<mailto:[email-masked]>> wrote:

On Sep 22, 2019, at 16:08, Dmytro Shytyi < [email-masked]<mailto:[email-masked]>> wrote:

Hello,

Joe

Abstract:

______________
Dmytro SHYTYI

---

From: Dmytro Shytyi <[email-masked]>
Date: Tue, 24 Sep 2019 10:32:43 +0200

Thank you for this valuable comment. Indeed, I agree,  it is appropriate to concentrate on the specific functionality of the device.

Another question to the group members   is related to the use cases examples.
In the document( internet draft) we may provide more use cases of the network services inside of the ucpe. Would it be appropriate?

One more question regarding the definition of the uCPE. Do we need to add something specific to the definition of ucpe? Maybe it would be nice to define the requirements for the uCPE as a platform?

Best regards, 
Dmytro.

On Sep 24, 2019, 00:51, at 00:51, "Joe Clarke (jclarke)" <[email-masked]> wrote:
>
>
>On Sep 23, 2019, at 16:18, Dmytro Shytyi
>I have few  questions to the group members. (This model should be
>considered as one that is located in the orchestrator.)
>Would it be appropriate to add to the model the part related to the
>ipv4/IPv6 config of ucpe for example activation of DHCP/SLAAC/static?
>
>Seems to me that should be left to other models like the system model
>(just like you would leave NETCONF configuration to the netconf-server
>model).  I think your focus is on the embedded network functions on
>this appliance.
>
>3. Or it would be better if it would concentrate on the network service
>management in the ucpe as it currently is?(KISS way)
>
>On Sep 23, 2019, at 15:40, "Joe Clarke (jclarke)"
><[email-masked]<mailto:[email-masked]>> wrote:
>
>
>On Sep 22, 2019, at 16:08, Dmytro Shytyi <
>[email-masked]<mailto:[email-masked]>> wrote:
>
>Hello,
>

---

From: Dmytro Shytyi <[email-masked]>
Date: Thu, 26 Sep 2019 18:13:29 +0200

Hello, we updated the draft with a new version.

Modifications:

added types of VNF that could be executed on the uCPE platform.

added examples of ucpe internal service.

We invite opsawg participants to consult the updated document. 

Comments are welcome :)

A new version of I-D, draft-shytyi-opsawg-vysm-01.txt

IETF repository.

Revision:    01

Document date:    2019-09-26

Pages:        15

URL: https://www.ietf.org/internet-drafts/draft-shytyi-opsawg-vysm-01.txt

Htmlized: https://tools.ietf.org/html/draft-shytyi-opsawg-vysm-01

Diff: https://www.ietf.org/rfcdiff?url2=draft-shytyi-opsawg-vysm-01

Abstract:

Service Orchestrator.

______________
Dmytro SHYTYI

---- On Tue, 24 Sep 2019 10:32:43 +0200 Dmytro Shytyi <[email-masked]> wrote ----

Best regards, 

Dmytro.

Get http://www.bluemail.me/r?b=15656

On Sep 24, 2019, at 00:51, "Joe Clarke (jclarke)" <mailto:[email-masked]> wrote:

OPSAWG mailing list 

[email-masked] 

On Sep 23, 2019, at 16:18, Dmytro Shytyi < mailto:[email-masked]> wrote:

Hello, 

Thank you for comment. 

Joe

Best regards, 

Dmytro. 

Get http://www.bluemail.me/r?b=15656

On Sep 23, 2019, at 15:40, "Joe Clarke (jclarke)" < mailto:[email-masked]> wrote: 

On Sep 22, 2019, at 16:08, Dmytro Shytyi < mailto:[email-masked]> wrote:

Hello, 

Joe

IETF repository.  

Revision:    00  

Pages:        14  

Abstract:  

Service Orchestrator.  

______________ 
 Dmytro SHYTYI

 OPSAWG mailing list 

 mailto:[email-masked]