Subject: [OPSAWG] IOAM export through IPFIX

From: "Joe Clarke (jclarke)" <[email-masked]>
Date: Tue, 3 Sep 2019 16:40:15 +0000

At opsawg 105, the draft https://tools.ietf.org/html/draft-spiegel-ippm-ioam-rawexport-02 was presented describing how to use IPFIX to export IOAM data.

A question was raised at the end as to whether or not the work should be done in opsawg or ippm?  Where would this work get more reviews?

In my reading of the draft (as a contributor), I think it would probably do well in opsawg as it describes how existing IEs will be used for IOAM and what new IEs will be required.  I think the IPFIX expertise is more likely here than in ippm.

Other thoughts and comments on this work?

Joe

---

From: Haoyu Song <[email-masked]>
Date: Tue, 3 Sep 2019 21:20:53 +0000

I support to discuss this work in OPSAWG. I also think the scope of the work may need to be extended. It only covers the raw export format which is not flexible enough and put all the data parsing complexity on the data collector. As we suggested in the iFIT framework, a flexible solution should allow the device to customize the IOAM data export. In that sense, a generic IPFIX-based export scheme is more proper.   If the author agree, we could extend the current draft; otherwise, I think another proposal draft is needed to complement this solution. 

Haoyu

-----Original Message-----
From: OPSAWG <[email-masked]> On Behalf Of Joe Clarke (jclarke)
Sent: Tuesday, September 03, 2019 9:40 AM
To: [email-masked]
Subject: [OPSAWG] IOAM export through IPFIX

At opsawg 105, the draft https://nam03.safelinks.protection.outlook.com/?url=https%3A%2F%2Ftools.ietf.org%2Fhtml%2Fdraft-spiegel-ippm-ioam-rawexport-02&amp;data=02%7C01%7Chaoyu.song%40futurewei.com%7C0bf2cbd995724004483f08d7308d7f3f%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C1%7C637031256600129445&amp;sdata=qvQKbXOkaERYB%2BmaawAkE5euiWEpGngzDYAIVlN04Ys%3D&amp;reserved=0 was presented describing how to use IPFIX to export IOAM data.

Joe
_______________________________________________
OPSAWG mailing list
[email-masked]
https://nam03.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Fmailman%2Flistinfo%2Fopsawg&amp;data=02%7C01%7Chaoyu.song%40futurewei.com%7C0bf2cbd995724004483f08d7308d7f3f%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C1%7C637031256600129445&amp;sdata=gRB4%2Fc6jfdMVUbpH3NX%2FgKvflV7cSJtQWr8nC776nJI%3D&amp;reserved=0