Subject: [OPSAWG] draft-gray-sampled-streaming-01.txt

From: "Gray, Andrew A" <[email-masked]>
Date: Thu, 26 Sep 2019 20:09:11 +0000

I have updated draft-gray-sampled-streaming with the feedback I have received to do (thank you to those that reviewed and provided that feedback).

-01 includes additional clarifications about format, clarifying how traffic direction is handled, and some other cleanups.  I have not yet had a chance to look at Flowspec for rule definitions, so that part is not in yet.

Please feel free to take a look, and am interested in getting feedback back.  Thanks!

A new version of I-D, draft-gray-sampled-streaming-01.txt
has been successfully submitted by Andrew Gray and posted to the
IETF repository.

Name:		draft-gray-sampled-streaming
Revision:	01
Title:		Sampled Traffic Streaming
Document date:	2019-09-25
Group:		Individual Submission
Pages:		18
URL:            https://www.ietf.org/internet-drafts/draft-gray-sampled-streaming-01.txt
Status:         https://datatracker.ietf.org/doc/draft-gray-sampled-streaming/
Htmlized:       https://tools.ietf.org/html/draft-gray-sampled-streaming-01
Htmlized:       https://datatracker.ietf.org/doc/html/draft-gray-sampled-streaming
Diff:           https://www.ietf.org/rfcdiff?url2=draft-gray-sampled-streaming-01

Abstract:
   This document standardizes the means of requesting a sampled capture
   stream from a router, receiving details about the resulting data
   flow, and the structure of the data flow itself.  This is
   specifically tailored to having various hardware ASICs be able to
   perform this operation as quickly as possible, by allowing
   communication of the specific bit formats of headers applied to the
   packet flow, in a way that enhances interoperability between sources
   and sinks.  Historically, NetFlow and its ilk have been used for
   these use cases, however the growth in hardware forward speeds is far
   outpacing the growth in CPU speeds, and the CPU-heavy parts of
   NetFlow is resulting in a reduction of sampling rates that include
   all of the fields provided by NetFlow that require CPU lookups.

E-MAIL CONFIDENTIALITY NOTICE: 
The contents of this e-mail message and any attachments are intended solely for the addressee(s) and may contain confidential and/or legally privileged information. If you are not the intended recipient of this message or if this message has been addressed to you in error, please immediately alert the sender by reply e-mail and then delete this message and any attachments. If you are not the intended recipient, you are notified that any use, dissemination, distribution, copying, or storage of this message or any attachment is strictly prohibited.

---

From: Dmytro Shytyi <[email-masked]>
Date: Fri, 27 Sep 2019 08:50:39 +0200

Hello,

Is it possible that this approach is applicable to non ASIC equipment? 
For example the devices that are running NFVIs (uCPE I-D "opsawg vysm") with x86 capabilities. Normally the tcpdump/tshark can be started in this kind of devices. One can imagine that this yang model variables could be mapped to the filter arguments  on the sniffing software?

Best,
Dmytro Shytyi.

⁣Get BlueMail for Android ​

On Sep 26, 2019, 22:09, at 22:09, "Gray, Andrew A" <[email-masked]> wrote:
>I have updated draft-gray-sampled-streaming with the feedback I have
>received to do (thank you to those that reviewed and provided that
>feedback).
>
>-01 includes additional clarifications about format, clarifying how
>traffic direction is handled, and some other cleanups.  I have not yet
>had a chance to look at Flowspec for rule definitions, so that part is
>not in yet.
>
>URL:           
>https://www.ietf.org/internet-drafts/draft-gray-sampled-streaming-01.txt
>Status:        
>https://datatracker.ietf.org/doc/draft-gray-sampled-streaming/
>Htmlized:      
>https://tools.ietf.org/html/draft-gray-sampled-streaming-01
>Htmlized:      
>https://datatracker.ietf.org/doc/html/draft-gray-sampled-streaming
>Diff:          
>https://www.ietf.org/rfcdiff?url2=draft-gray-sampled-streaming-01
>
>Abstract:
>The contents of this e-mail message and any attachments are intended
>solely for the addressee(s) and may contain confidential and/or legally
>privileged information. If you are not the intended recipient of this
>message or if this message has been addressed to you in error, please
>immediately alert the sender by reply e-mail and then delete this
>message and any attachments. If you are not the intended recipient, you
>are notified that any use, dissemination, distribution, copying, or
>storage of this message or any attachment is strictly prohibited.
>_______________________________________________
>OPSAWG mailing list
>[email-masked]
>https://www.ietf.org/mailman/listinfo/opsawg