Subject: Re: [OPSAWG] draft-ietf-opsawg-l3sm-l3nm

From: Erez Segev <[email-masked]>
Date: Sun, 3 Nov 2019 15:04:56 +0000

Hi Stephane,

We find the Site-Network-Access (SNA) concept as defined in RFC8299 a bit inconvenient  ,since in our equipment each LIF can have up to 4 IPv6 addresses and single IPv4 address, so each SNA build of 5 different sub SNAs and the information is duplicated.
In addition the BGP session is configured  in the VRF level and not in the LIF level (as well as static routes) as such we take the SNA information and set it on the VRFs.

Anyhow, in the current use case , we are dealing with integrated service of L2 and L3 VPN as follows:

L3VPN A  On GW nodes
– connected to 3rd party equipment using RT values over IP/MPLS network ,
Connected to Access nodes via eBGP sessions over P2P PHT connection (PW)

L3VPN 3  On Access nodes

-          Connected to GW nodes via eBGP sessions over P2P PHT connection (PW)

-          Connected to  clients using MP2MP IRB

My intention is to represent L3VPN-A and L3VPN-B without SNAs since the SNAs are the EPs of the P2P PHT L2VPN

So… for each L3VPN I need to set list of eBGP sessions to its neighbor(s) which must have different Autonomous system numbers and there is a need to set it somehow.

In the bottom line, you are right that SNAs can be used , for single eBGP session per single destination per interface , but since the eBGP starts from the VRF and not from the LIF it is legal to created several eBGP sessions to elements connected via single interface.

Regards,
Erez

From: [email-masked] [mailto:[email-masked]]
Sent: Thursday, October 31, 2019 5:22 PM
To: 'SAMIER BARGUIL GIRALDO' <[email-masked]>; Erez Segev <[email-masked]>; [email-masked]; 'Oscar González de Dios' <[email-masked]>; 'Victor Lopez' <[email-masked]>; [email-masked]
Subject: RE: [OPSAWG] draft-ietf-opsawg-l3sm-l3nm

Hi Erez,

What is the exact setup that you want to achieve ?
Currently the BGP is linked to the site-network-access. If a site has multiple site-network-access on the same PE, there is no issue to get multiple BGP sessions with the current model.
What is your use case for having multiple BGP sessions on the same access ? There are two that I could think of but I prefer to hear from you first, so you are not influenced 😉

regarding the AS, why do you need the SP AS in the model (I guess you mean the ASN of the PE) ? SP knows which ASN the PE is belonging to.

Brgds,

Stephane

From: OPSAWG <[email-masked]<mailto:[email-masked]>> On Behalf Of SAMIER BARGUIL GIRALDO
Sent: jeudi 31 octobre 2019 15:23
To: Erez Segev <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>; Oscar González de Dios <[email-masked]<mailto:[email-masked]>>; Victor Lopez <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>
Subject: Re: [OPSAWG] draft-ietf-opsawg-l3sm-l3nm

Hi Erez,

After checking the model, you are right this key does not allow the configuration of several BGP sessions on the Same VPN.

Regarding the AS; We have already discussed and the idea is to include it in the New Version. Thanks for your feedback.

Regards,

Samier Barguil
Transport & IP Networks | GCTIO - Technology | CIT Centro Integrado de Transporte |

Móvil +57 311 2402952

Móvil +34 665416074

E-mail [email-masked]<mailto:[email-masked]>

E-mail [email-masked]<mailto:[email-masked]>

________________________________
De: Erez Segev <[email-masked]<mailto:[email-masked]>>
Enviado: jueves, 31 de octubre de 2019 8:34
Para: SAMIER BARGUIL GIRALDO <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]> <[email-masked]<mailto:[email-masked]>>; Oscar González de Dios <[email-masked]<mailto:[email-masked]>>; Victor Lopez <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]> <[email-masked]<mailto:[email-masked]>>
Asunto: RE: draft-ietf-opsawg-l3sm-l3nm

Hi Samier,

In addition to my previous mail, is there’s an ability to determine the provider’s autonomous-system, in order to initiate eBPG from the customer premises to the L2VPN , I believe ths attribute should be added to vpn-node container.

Thanks,

Erez

From: SAMIER BARGUIL GIRALDO [mailto:[email-masked]]
Sent: Thursday, October 31, 2019 1:00 PM
To: Erez Segev <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>; Oscar González de Dios <[email-masked]<mailto:[email-masked]>>; Victor Lopez <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>
Subject: RE: draft-ietf-opsawg-l3sm-l3nm

Hi Erez,

We have defined the routing protocols inside the Network Access as a List. So you can have several routing protocols enabled at the same time, including two or more eBGP sesions or BGP+ OSPF or OSPF+ Static Route.

In fact we have added the multihop count to be able to support BGP connections with not directly connected peers. So in this case an static route + BGP connection is enabled.

Reagards

Samier Barguil
Transport & IP Networks | GCTIO - Technology | CIT Centro Integrado de Transporte |

Móvil +57 311 2402952

Móvil +34 665416074

E-mail [email-masked]<mailto:[email-masked]>

E-mail [email-masked]<mailto:[email-masked]>

________________________________

De: OPSAWG <[email-masked]<mailto:[email-masked]>> en nombre de Erez Segev <[email-masked]<mailto:[email-masked]>>
Enviado: jueves, 31 de octubre de 2019 4:59
Para: [email-masked]<mailto:[email-masked]> <[email-masked]<mailto:[email-masked]>>; Oscar González de Dios <[email-masked]<mailto:[email-masked]>>; Victor Lopez <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]> <[email-masked]<mailto:[email-masked]>>
Asunto: [OPSAWG] draft-ietf-opsawg-l3sm-l3nm

Dear Authors of draft-ietf-opsawg-l3sm-l3nm

Question regarding eBGP ,

what if I’d like several eBGP sessions to

-          Multiple destinations

-          Different AS  .

How do I set several eBGP sessions per site?

Where does the AS of the other side defined?

                     |     +--rw bgp {rtg-bgp}?

                     |     |  +--rw autonomous-system    uint32

                     |     |  +--rw address-family*      address-family

                     |     |  +--rw neighbor?            inet:ip-address

                     |     |  +--rw multihop?            uint8

                     |     |  +--rw security

                     |     |     +--rw auth-key?   string

Thanks,

Erez

Erez Segev

NFV&SDN System Engineer

T:

+972.3.9287393

M:

+972.50.7057393

E:

[email-masked]<mailto:[email-masked]>

www.ecitele.com<http://www.ecitele.com/>

___________________________________________________________________________

This e-mail message is intended for the recipient only and contains information which is
CONFIDENTIAL and which may be proprietary to ECI Telecom. If you have received this
transmission in error, please inform us by e-mail, phone or fax, and then delete the original
and all copies thereof.
___________________________________________________________________________

________________________________

Este mensaje y sus adjuntos se dirigen exclusivamente a su destinatario, puede contener información privilegiada o confidencial y es para uso exclusivo de la persona o entidad de destino. Si no es usted. el destinatario indicado, queda notificado de que la lectura, utilización, divulgación y/o copia sin autorización puede estar prohibida en virtud de la legislación vigente. Si ha recibido este mensaje por error, le rogamos que nos lo comunique inmediatamente por esta misma vía y proceda a su destrucción.

The information contained in this transmission is privileged and confidential information intended only for the use of the individual or entity named above. If the reader of this message is not the intended recipient, you are hereby notified that any dissemination, distribution or copying of this communication is strictly prohibited. If you have received this transmission in error, do not read it. Please immediately reply to the sender that you have received this communication in error and then delete it.

Esta mensagem e seus anexos se dirigem exclusivamente ao seu destinatário, pode conter informação privilegiada ou confidencial e é para uso exclusivo da pessoa ou entidade de destino. Se não é vossa senhoria o destinatário indicado, fica notificado de que a leitura, utilização, divulgação e/ou cópia sem autorização pode estar proibida em virtude da legislação vigente. Se recebeu esta mensagem por erro, rogamos-lhe que nos o comunique imediatamente por esta mesma via e proceda a sua destruição

___________________________________________________________________________

This e-mail message is intended for the recipient only and contains information which is
CONFIDENTIAL and which may be proprietary to ECI Telecom. If you have received this
transmission in error, please inform us by e-mail, phone or fax, and then delete the original
and all copies thereof.
___________________________________________________________________________

________________________________

Este mensaje y sus adjuntos se dirigen exclusivamente a su destinatario, puede contener información privilegiada o confidencial y es para uso exclusivo de la persona o entidad de destino. Si no es usted. el destinatario indicado, queda notificado de que la lectura, utilización, divulgación y/o copia sin autorización puede estar prohibida en virtud de la legislación vigente. Si ha recibido este mensaje por error, le rogamos que nos lo comunique inmediatamente por esta misma vía y proceda a su destrucción.

The information contained in this transmission is privileged and confidential information intended only for the use of the individual or entity named above. If the reader of this message is not the intended recipient, you are hereby notified that any dissemination, distribution or copying of this communication is strictly prohibited. If you have received this transmission in error, do not read it. Please immediately reply to the sender that you have received this communication in error and then delete it.

Esta mensagem e seus anexos se dirigem exclusivamente ao seu destinatário, pode conter informação privilegiada ou confidencial e é para uso exclusivo da pessoa ou entidade de destino. Se não é vossa senhoria o destinatário indicado, fica notificado de que a leitura, utilização, divulgação e/ou cópia sem autorização pode estar proibida em virtude da legislação vigente. Se recebeu esta mensagem por erro, rogamos-lhe que nos o comunique imediatamente por esta mesma via e proceda a sua destruição

___________________________________________________________________________

This e-mail message is intended for the recipient only and contains information which is 
CONFIDENTIAL and which may be proprietary to ECI Telecom. If you have received this 
transmission in error, please inform us by e-mail, phone or fax, and then delete the original 
and all copies thereof.
___________________________________________________________________________

---

From: SAMIER BARGUIL GIRALDO <[email-masked]>
Date: Mon, 4 Nov 2019 11:55:20 +0000

Hi All,

According to Erez comments. The authors has proposed some changes in the model to achieve to support two use cases without affecting the current implementation have already tested of the L3NM. The use cases an it's proposed solution are:

  1.  Allow several IP address under the same Network Access.
We have created a list of Static Ip Addresses under IPv4/IPv6 containers. The primary address in this case would be referenced based on an "address-id"-

           |     |     |  +--rw ipv4 {ipv4}?

           |     |     |  |  +--rw static-addresses

           |     |     |  |     +--rw primary-address?   -> /l3vpn-ntw/vpn-services/vpn-nodes/network-accesses/network-acces/ip-connection/ipv4/static-addresses/address/address-id

           |     |     |  |     +--rw address* [address-id]

           |     |     |  |        +--rw address-id          string

           |     |     |  |        +--rw provider-address?   inet:ipv4-address

           |     |     |  |        +--rw customer-address?   inet:ipv4-address

           |     |     |  |        +--rw prefix-length?      uint8

With this augmentation we are able to assign several ip addresses under the Same Network Access.  This is a common scenario on SPs deployments.

2.Allow several BGP sessions under the same Network Access.
To support several Routing Protocols sessions under the same Network Access we have changed the Key to have an ID to allow several protocols under the same Network Access:

           |     |        +--rw routing-protocol* [id]

           |     |           +--rw id                  string

           |     |           +--rw type?               identityref

           |     |           +--rw routing-profiles* [id]

           |     |           |  +--rw id      -> /l3vpn-ntw/vpn-profiles/valid-provider-identifiers/routing-profile-identifier/id

           |     |           |  +--rw type?   ie-type

           |     |           +--rw ospf {rtg-ospf}?

           |     |           |  +--rw address-family*   address-family

           |     |           |  +--rw area-address      yang:dotted-quad

           |     |           |  +--rw metric?           uint16

           |     |           |  +--rw mtu?              uint16

           |     |           |  +--rw security

           |     |           |  |  +--rw auth-key?   string

           |     |           |  +--rw sham-links {rtg-ospf-sham-link}?

           |     |           |     +--rw sham-link* [target-site]

           |     |           |        +--rw target-site    svc-id

           |     |           |        +--rw metric?        uint16

           |     |           +--rw bgp {rtg-bgp}?

           |     |           |  +--rw autonomous-system    uint32

           |     |           |  +--rw address-family*      address-family

           |     |           |  +--rw neighbor?            inet:ip-address

           |     |           |  +--rw multihop?            uint8

           |     |           |  +--rw security

           |     |           |     +--rw auth-key?   string

           |     |           +--rw static

           |     |           |  +--rw cascaded-lan-prefixes

           |     |           |     +--rw ipv4-lan-prefixes* [lan next-hop] {ipv4}?

           |     |           |     |  +--rw lan         inet:ipv4-prefix

           |     |           |     |  +--rw lan-tag?    string

           |     |           |     |  +--rw next-hop    inet:ipv4-address

           |     |           |     +--rw ipv6-lan-prefixes* [lan next-hop] {ipv6}?

           |     |           |        +--rw lan         inet:ipv6-prefix

           |     |           |        +--rw lan-tag?    string

           |     |           |        +--rw next-hop    inet:ipv6-address

           |     |           +--rw rip {rtg-rip}?

           |     |           |  +--rw address-family*   address-family

           |     |           +--rw vrrp {rtg-vrrp}?

I'm attaching the new tree.

Regards,
--

Samier Barguil

Móvil +57 311 2402952

Móvil +34 665416074

E-mail [email-masked]

E-mail [email-masked]

________________________________
De: Erez Segev <[email-masked]>
Enviado: domingo, 3 de noviembre de 2019 10:04
Para: [email-masked] <[email-masked]>; SAMIER BARGUIL GIRALDO <[email-masked]>; [email-masked] <[email-masked]>; Oscar González de Dios <[email-masked]>; Victor Lopez <[email-masked]>; [email-masked] <[email-masked]>
Asunto: RE: [OPSAWG] draft-ietf-opsawg-l3sm-l3nm

Hi Stephane,

L3VPN A  On GW nodes

L3VPN 3  On Access nodes

Regards,

Erez

Hi Erez,

Brgds,

Stephane

Hi Erez,

Regards,

Samier Barguil

Móvil +57 311 2402952

Móvil +34 665416074

Hi Samier,

Thanks,

Erez

Hi Erez,

Reagards

Samier Barguil

Móvil +57 311 2402952

Móvil +34 665416074

-          Multiple destinations

-          Different AS  .

                     |     +--rw bgp {rtg-bgp}?

                     |     |  +--rw security

Thanks,

Erez

Erez Segev

NFV&SDN System Engineer

T:

+972.3.9287393

M:

+972.50.7057393

E:

---

From: Erez Segev <[email-masked]>
Date: Tue, 5 Nov 2019 07:40:33 +0000

Hi Samier,

Thanks for the update , two questions

-          For the first change, will the same going to be added for IPv6?

-          I have also suggested to add AS number to vpn-nodes container , it is necessary for eBGP session creation, if we are setting the provider side , the customer need to initiate a session to the provider address + the providers AS number.

Thanks.
Erez

From: SAMIER BARGUIL GIRALDO [mailto:[email-masked]]
Sent: Monday, November 04, 2019 1:55 PM
To: Erez Segev <[email-masked]>; [email-masked]; [email-masked]; Oscar González de Dios <[email-masked]>; Victor Lopez <[email-masked]>; [email-masked]
Subject: RE: [OPSAWG] draft-ietf-opsawg-l3sm-l3nm

Hi All,

           |     |     |  +--rw ipv4 {ipv4}?

           |     |           +--rw id                  string

           |     |           |  +--rw mtu?              uint16

           |     |           |  +--rw security

           |     |           +--rw bgp {rtg-bgp}?

           |     |           |  +--rw security

           |     |           +--rw static

           |     |           +--rw rip {rtg-rip}?

Regards,
--

Samier Barguil

Móvil +57 311 2402952

Móvil +34 665416074

Para: [email-masked]<mailto:[email-masked]> <[email-masked]<mailto:[email-masked]>>; SAMIER BARGUIL GIRALDO <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]> <[email-masked]<mailto:[email-masked]>>; Oscar González de Dios <[email-masked]<mailto:[email-masked]>>; Victor Lopez <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]> <[email-masked]<mailto:[email-masked]>>

Hi Stephane,

L3VPN A  On GW nodes

L3VPN 3  On Access nodes

Regards,

Erez

From: [email-masked]<mailto:[email-masked]> [mailto:[email-masked]]
Sent: Thursday, October 31, 2019 5:22 PM
To: 'SAMIER BARGUIL GIRALDO' <[email-masked]<mailto:[email-masked]>>; Erez Segev <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>; 'Oscar González de Dios' <[email-masked]<mailto:[email-masked]>>; 'Victor Lopez' <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>
Subject: RE: [OPSAWG] draft-ietf-opsawg-l3sm-l3nm

Hi Erez,

Brgds,

Stephane

Hi Erez,

Regards,

Samier Barguil

Móvil +57 311 2402952

Móvil +34 665416074

Hi Samier,

Thanks,

Erez

Hi Erez,

Reagards

Samier Barguil

Móvil +57 311 2402952

Móvil +34 665416074

-          Multiple destinations

-          Different AS  .

                     |     +--rw bgp {rtg-bgp}?

                     |     |  +--rw security

Thanks,

Erez

Erez Segev

NFV&SDN System Engineer

T:

+972.3.9287393

M:

+972.50.7057393

E:

---

From: SAMIER BARGUIL GIRALDO <[email-masked]>
Date: Tue, 5 Nov 2019 09:54:50 +0000

Hi Erez,

Yes IPv4 and IPv6 are covered. And AS Number also Included in BGP Session:

           +--rw vpn-nodes

           |  +--rw vpn-node* [vpn-node-id ne-id]

           |     +--rw vpn-node-id             string

           |     +--rw autonomous-system?      uint32

           |     +--rw description?            string

Regards,

Samier Barguil

Móvil +57 311 2402952

Móvil +34 665416074

________________________________
De: Erez Segev <[email-masked]>
Enviado: martes, 5 de noviembre de 2019 2:40
Para: SAMIER BARGUIL GIRALDO <[email-masked]>; [email-masked] <[email-masked]>; [email-masked] <[email-masked]>; Oscar González de Dios <[email-masked]>; Victor Lopez <[email-masked]>; [email-masked] <[email-masked]>
Asunto: RE: [OPSAWG] draft-ietf-opsawg-l3sm-l3nm

Hi Samier,

Thanks.

Erez

Hi All,

           |     |     |  +--rw ipv4 {ipv4}?

           |     |           +--rw id                  string

           |     |           |  +--rw mtu?              uint16

           |     |           |  +--rw security

           |     |           +--rw bgp {rtg-bgp}?

           |     |           |  +--rw security

           |     |           +--rw static

           |     |           +--rw rip {rtg-rip}?

Regards,

--

Samier Barguil

Móvil +57 311 2402952

Móvil +34 665416074

Hi Stephane,

L3VPN A  On GW nodes

L3VPN 3  On Access nodes

Regards,

Erez

Hi Erez,

Brgds,

Stephane

Hi Erez,

Regards,

Samier Barguil

Móvil +57 311 2402952

Móvil +34 665416074

Hi Samier,

Thanks,

Erez

Hi Erez,

Reagards

Samier Barguil

Móvil +57 311 2402952

Móvil +34 665416074

-          Multiple destinations

-          Different AS  .

                     |     +--rw bgp {rtg-bgp}?

                     |     |  +--rw security

Thanks,

Erez

Erez Segev

NFV&SDN System Engineer

T:

+972.3.9287393

M:

+972.50.7057393

E: