Subject: Re: [OPSAWG] conclusion//RE: WG adoption call for draft-wu-model-driven-management-virtualization-07

From: Qin Wu <[email-masked]>
Date: Thu, 14 Nov 2019 07:09:57 +0000

Tom:
-----邮件原件-----
发件人: tom petch [mailto:[email-masked]] 
发送时间: 2019年11月14日 0:38
收件人: Qin Wu <[email-masked]>; Brian E Carpenter <[email-masked]>; Tianran Zhou <[email-masked]>; [email-masked]
抄送: [email-masked]; [email-masked]
主题: Re: [OPSAWG] conclusion//RE: WG adoption call for draft-wu-model-driven-management-virtualization-07

----- Original Message -----
From: "Qin Wu" <[email-masked]>
Sent: Wednesday, November 13, 2019 2:59 AM
> How about draft-ietf-opsawg-model-automation-framework if we agree to
change the name?:-)

Mutter mutter... As I said, I see it as an identifier, nothing more, not to be laden with semantic meaning as the filename will disappear into the dust of history.  As Brian says, it is rather long but then I never have to type it in.  It does spill off the side of the screen but that only becomes a problem when we have
draft-wu-model-driven-management-visualization-00 or something like that.

The Title in the I-D/RFC lasts for ever so that is the one that I think deserves attention; here, that Title is quite different and I think it is fine.

As to draft-author becoming draft-ietf, there was a comment recently by the PCE AD(Deborah Brungard) that a particular draft had to be named draft-ietf because the data-tracker relies on that; else the processes fail.  Reading between the lines, I was thnking that our ever more clever data-tracker might be relying on draft-author-wg-anyold becoming draft-ietf-wg-anyold for its processes to succeed although I know of no recent evidence for that.  But then I am forever being surprised by what the data-tracker gets up to - it seems to quite outside the control of the IAD, IESG, IETF, ...

[Qin]: I think this is responsibility of WG chairs to make sure draft-author-wg-anyold and draft-ietf-wg-anyold in the WG process, it might be a good idea to add history of draft-ietf-wg-anyold in the shepherd writeup before it is moved to the hand of AD.
I have experience that when draft-author-wg1-anyold is moved to wg 2 and changed the name to draft-author-wg2-anyold, but chair is not willing to establish the link between draft-author-wg1-anyold and draft-author-wg2-anyold, this may lead to the problem to track
the old history of the document.
If the link button can be controlled by the responsible chair or author of the draft is given the flexibility to make the link between drafts, this problem can be easily solved.

Historically, there have been problems with name changes because the WG Chairs had manually to make a link and they did not know that they should.  I think that this came up at IESG Review when ADs could not look back at earlier versions of the I-D because the link between draft-author-wgname-oldname and draft-ietf-wgname-differentname was missing and only those who had been around the WG in question some years earlier knew of the connection..

[Qin]:Understand, maybe it is a good idea to provide guideline on how to name the draft and how to link the draft, who is responsible for this.
Tom Petch

> -Qin
> -----邮件原件-----
> 发件人: Brian E Carpenter [mailto:[email-masked]]
> 发送时间: 2019年11月13日 9:56
> 收件人: Tianran Zhou <[email-masked]>; Qin Wu
<[email-masked]>; tom petch <[email-masked]>; [email-masked]
> 抄送: [email-masked];
[email-masked]
> 主题: Re: [OPSAWG] conclusion//RE: WG adoption call for
draft-wu-model-driven-management-virtualization-07
>
> Actually there are no 100% rules but the tools work better if you
stick to draft-ietf-opsawg-something-00, and use the "Replaces" option when submitting the draft.
>
> "something" is really a matter of choice. However,
> draft-ietf-opsawg-model-driven-management-automation-00 is very very
long.
>
> Regards
>    Brian
>
> On 13-Nov-19 14:34, Tianran Zhou wrote:
> > Hi Tom and Qin,
> >
> > Anyway we need to change the name. As the author agreed the proposed
naming is better, IMHO, I do not see the workload.
> > Or is there any rule that not suggest to do so?
> >
> > Tianran
> >> -----Original Message-----
> >> From: Qin Wu
> >> Sent: Wednesday, November 13, 2019 9:07 AM
> >> To: tom petch <[email-masked]>; Tianran Zhou 
> >> <[email-masked]>; [email-masked]
> >> Cc:
[email-masked];
> >> [email-masked]
> >> Subject: RE: [OPSAWG] conclusion//RE: WG adoption call for
> >> draft-wu-model-driven-management-virtualization-07
> >>
> >> Hi, Tom and Tianran:
> >> It looks the new proposed draft name more reflects what it is, but 
> >> referencing to IETF standards process, the draft name change rule
is
> >> nothing more than one mentioned by Tom.
> >> I knew in the history, there was some exception about draft name 
> >> changes, e.g., change draft-fielding-http-spec-01 into 
> >> draft-ietf-http-v10-spec, using "replace" button to link them 
> >> together  and published as RFC1945, but it is the rare thing that
seldom happens.
> >> Therefore I have no strong preference on what WG draft name should
be changed.
> >> Thanks!
> >>
> >> -Qin
> >> -----邮件原件-----
> >> 发件人: tom petch [mailto:[email-masked]]
> >> 发送时间: 2019年11月12日 18:02
> >> 收件人: Tianran Zhou <[email-masked]>; [email-masked]
> >> 抄送:
[email-masked];
> >> [email-masked]
> >> 主题: Re: [OPSAWG] conclusion//RE: WG adoption call for
> >> draft-wu-model-driven-management-virtualization-07
> >>
> >> ----- Original Message -----
> >> From: "Tianran Zhou" <[email-masked]>
> >> Sent: Tuesday, November 12, 2019 6:10 AM
> >>
> >>> Hi WG,
> >>>
> >>> Now we conclude the poll and adopt this document as WG draft.
> >>> We collected many interests and supports that can help the
document
> >> evolution.
> >>>
> >>> Authors,
> >>> The chairs think "virtualization" in the draft name is confusing, 
> >>> and
> >> suggest to rename it as "model-driven-management-automation".
What's
> >> your thoughts?
> >>> Please republish
draft-wu-model-driven-management-virtualization-07
> >>> as
> >> draft-ietf-model-driven-management-automation-00 with only the date 
> >> and file name changed. And please use "replace" in the data
tracker.
> >>
> >>
> >> Tianran
> >>
> >> I think that that is a bad idea.  Who cares what the draft name is?
> >> What is needed is a stable handle for it as it wends its way
through
> >> the IETF after which the draft name vanishes in the dust of
history.
> >> The only expected change is from draft-authername to draft-ietf at
the time of adoption.
> >> Anything else just increases the workload, if only a fraction, for 
> >> everyone involved.
> >>
> >> Tom Petch
> >>
> >>
> >>> Cheers,
> >>> Tianran & Joe
> >>>
> >>>> -----Original Message-----
> >>>> From: OPSAWG [mailto:[email-masked]] On Behalf Of
Tianran
> >> Zhou
> >>>> Sent: Tuesday, October 29, 2019 9:44 AM
> >>>> To: [email-masked]
> >>>> Cc:
> >> [email-masked];
> >>>> [email-masked]
> >>>> Subject: [OPSAWG] WG adoption call for
> >>>> draft-wu-model-driven-management-virtualization-07
> >>>>
> >>>> Hi WG,
> >>>>
> >>>> This email starts a 2 weeks working group adoption call for 
> >>>> draft-wu-model-driven-management-virtualization-07.
> >>>>
> >>
https://datatracker.ietf.org/doc/draft-wu-model-driven-management-vir
> >> tua
> >>>> lization/
> >>>> This document provides a framework that describes and discusses
an
> >>>> architecture for service and network management automation that
> >> takes
> >>>> advantage of YANG modeling technologies.
> >>>>
> >>>> If you support adopting this document please say so, and please 
> >>>> give
> >> an
> >>>> indication of why you think it is important. Also please say if
you
> >> will be
> >>>> willing to review and help the draft.
> >>>> If you do not support adopting this document as a starting point 
> >>>> for
> >> work
> >>>> on this topic, please say why.
> >>>> This poll will run until Nov 11.
> >>>>
> >>>> Thanks,
> >>>> Tianran and Joe
> >>>>

---

From: "Joe Clarke (jclarke)" <[email-masked]>
Date: Fri, 15 Nov 2019 04:24:20 +0000

I don’t see a problem with changing the name to match more closely to the topic of the document so long as the “Replaces” action is done correctly.  We won’t lose history.  This has worked (at least for me) in the past.  Yes, it may cause some small confusion internally at first, but I think it will be more helpful when we do IESG and other external reviews.

Joe