Subject: Re: [OPSAWG] WG adoption call for draft-wu-model-driven-management-virtualization-07

From: "Wubo (lana)" <[email-masked]>
Date: Thu, 7 Nov 2019 02:53:46 +0000

Hi,

I support the adoption.
I think this draft helps to understand the YANG models scattered across different WGs and the role of these models in network automation management. 

Thanks,
Bo

-----邮件原件-----
发件人: OPSAWG [mailto:[email-masked]] 代表 Tianran Zhou
发送时间: 2019年10月29日 9:44
收件人: [email-masked]
抄送: [email-masked]; [email-masked]
主题: [OPSAWG] WG adoption call for draft-wu-model-driven-management-virtualization-07

Hi WG,

This email starts a 2 weeks working group adoption call for draft-wu-model-driven-management-virtualization-07.
https://datatracker.ietf.org/doc/draft-wu-model-driven-management-virtualization/
This document provides a framework that describes and discusses an architecture for service and network management automation that takes advantage of YANG modeling technologies.

If you support adopting this document please say so, and please give an indication of why you think it is important. Also please say if you will be willing to review and help the draft.
If you do not support adopting this document as a starting point for work on this topic, please say why.
This poll will run until Nov 11.
 
Thanks,
Tianran and Joe

_______________________________________________
OPSAWG mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/opsawg

---

From: "[email-masked]" <[email-masked]>
Date: Thu, 7 Nov 2019 11:14:32 +0800

Hi all，

I support this draft.
It is really necessary to make a framework for service and network management.

Thanks

________________________________
Liu Chang
China Unicom
Email: [email-masked]
Phone: +8618601102572
Tel: 010-68799999-7294
如果您错误接收了该邮件，请通过电子邮件立即通知我们。请回复邮件到 [email-masked]，即可以退订此邮件。我们将立即将您的信息从我们的发送目录中删除。 If you have received this email in error please notify us immediately by e-mail. Please reply to [email-masked] ,you can unsubscribe from this mail. We will immediately remove your information from send catalogue of our.

---

From: Qin Wu <[email-masked]>
Date: Thu, 7 Nov 2019 13:53:28 +0000

Thanks Aijun. One size can not fit all, similarly one model can not fit all. In multi-layer, multi-domain scenario, you do need network layer model to establish the mapping between service request and underlying network resource.
In addition, network topology model and TE tunnel are also seen as network layer model which provide play key role when scheduling resource to meet the service requirements.

Regarding how these models are interleaved together, this is what we have clarified in section 3.1 and 4.3. and section 4.4, I.e., using policy model, schema mount model for same level model interleaving, using service mapping, service translation for different layer model interleaving. We can add more text to increase the clarity on the point you raised, thanks.

-Qin
-----邮件原件-----
发件人: Aijun Wang [mailto:[email-masked]] 
发送时间: 2019年11月7日 14:22
收件人: Tianran Zhou <[email-masked]>; [email-masked]
抄送: [email-masked]; [email-masked]
主题: 答复: [OPSAWG] WG adoption call for draft-wu-model-driven-management-virtualization-07

Support the adoption.

This draft give the overall view for the different layers of Yang modules that defined within IETF(also applicable for Yang defined by other STD).
What I wondering is the that necessaries of the network layer model. More layers means more conversions between different layers, increased complex for the service automation management system and the relationship management between these models. 
Is there any way or mechanism to manage these interleaved modules in more automatic manners?

Can the above concerns be described in the updated version after its adoption?

Best Regards.

Aijun Wang
China Telecom

-----邮件原件-----
发件人: [email-masked] [mailto:[email-masked]] 代表
Tianran Zhou
发送时间: 2019年10月29日 9:44
收件人: [email-masked]
抄送: [email-masked];
[email-masked]
主题: [OPSAWG] WG adoption call for
draft-wu-model-driven-management-virtualization-07

Hi WG,

This email starts a 2 weeks working group adoption call for draft-wu-model-driven-management-virtualization-07.
https://datatracker.ietf.org/doc/draft-wu-model-driven-management-virtualiza
tion/
This document provides a framework that describes and discusses an architecture for service and network management automation that takes advantage of YANG modeling technologies.

Thanks,
Tianran and Joe

---

From: Qin Wu <[email-masked]>
Date: Thu, 7 Nov 2019 14:02:09 +0000

-----邮件原件-----
发件人: Joe Clarke (jclarke) [mailto:[email-masked]] 
发送时间: 2019年10月31日 1:11
收件人: Tianran Zhou <[email-masked]>
抄送: [email-masked]; [email-masked]; [email-masked]
主题: Re: WG adoption call for draft-wu-model-driven-management-virtualization-07

> On Oct 28, 2019, at 21:43, Tianran Zhou <[email-masked]> wrote:
> 
> Hi WG,
> 
> https://datatracker.ietf.org/doc/draft-wu-model-driven-management-virt
> ualization/ This document provides a framework that describes and 
> discusses an architecture for service and network management automation that takes advantage of YANG modeling technologies.
> 

As an individual, I support adoption.  I had some private comments for the authors on the latest revision that I will share here because I think they are critical to the adoption call.  I realize some of these may have been corrected in an upcoming rev.
[Qin]: Thanks Joe, most of your comments have been addressed in v-07. Figure 1 in section 3.1 needs to be fall back to v-06, thanks Med for good catch.
* I found some of the text meandering and confusing.  The intro, for example, laid out a challenge around telemetry consumption, but this doc doesn’t really address the scale issue.
[Qin]:Fixed.
* Section 4.2.3 also crosses from a pure model discussion to something more NETCONF protocol-specific in directly mentioning <operational> (and without reference).  I agree operational state is important, but this mention seems out of place.
[Qin]:Fixed in v-07.
* I’d also like to see your examples go through the entire lifecycle, or at least more so than they do.  For example, getting to fault diagnosis would be helpful since Section 4.2.4 doesn’t really give much content there.
[Qin]:Improved, thanks.
Joe

---

From: "Mr. Jaehoon Paul Jeong" <[email-masked]>
Date: Wed, 13 Nov 2019 19:59:58 +0900

Hi OPSAWG,
This is Paul from I2NSF WG.
I support this draft as a WG draft in OPSAWG.

I am working for the policy translation between a service-level security
policy to a device-level security policy with a security policy translator:
https://datatracker.ietf.org/doc/draft-yang-i2nsf-security-policy-translation/

I believe that Wu's draft will be a good foundation to bridge two (or
three) YANG levels.

Thanks.

Paul
-- 
===========================
Mr. Jaehoon (Paul) Jeong, Ph.D.
Associate Professor
Department of Software
Sungkyunkwan University
Office: +82-31-299-4957
Email: [email-masked], [email-masked]
Personal Homepage: http://iotlab.skku.edu/people-jaehoon-jeong.php
----------------------------------

On 29/10/2019, 02:43, "Tianran Zhou" <[email-masked]>
<[email-masked]&gt>; wrote:

    Hi WG,

    This email starts a 2 weeks working group adoption call for
draft-wu-model-driven-management-virtualization-07.
    https://datatracker.ietf.org/doc/draft-wu-model-driven-management-virtualization/
    This document provides a framework that describes and discusses an
architecture for service and network management automation that takes
advantage of YANG modeling technologies.

    If you support adopting this document please say so, and please
give an indication of why you think it is important. Also please say
if you will be willing to review and help the draft.
    If you do not support adopting this document as a starting point
for work on this topic, please say why.
    This poll will run until Nov 11.

    Thanks,
    Tianran and Joe

<http://cpslab.skku.edu/people-jaehoon-jeong.php>