Subject: [OPSAWG] L2NM: Layer 2 VPN Network Model: Request for Feedback and Review

From: Oscar González de Dios <[email-masked]>
Date: Thu, 2 Apr 2020 12:22:38 +0000

Dear Opsawg colleagues,

In the line of the success of the L3NM, and also receiving request in the mailing list for a similar work for L2VPNs, we have prepared a new document, which will also be presented in the next OPSAWG virtual meeting, called  A Layer 2 VPN Network Yang Model draft-barguil-opsawg-l2sm-l2nm-01. You can find it in:

https://tools.ietf.org/html/draft-barguil-opsawg-l2sm-l2nm-01

The document defines a Yang Data model, L2NM, that can be used to manage the provisioning of Layer 2 VPN services in a Service Provider Network.  The Yang module defined in the document provides representation of the Layer 2 VPN Service and is aimed at being used  by a Network Controller, which can derive from it the configuration  information that will be sent to the network devices, as well as selecting a preference on the underlay transport network in a service provider environment.

We would like to request the OPSA Working Group colleagues for feedback and review of the document. We would also like to know if you consider this piece of work helpful in automating and programming the networks.

Best Regards and stay safe during the time that a small piece of ARN is ruling our lifes,

            Oscar

________________________________

Este mensaje y sus adjuntos se dirigen exclusivamente a su destinatario, puede contener información privilegiada o confidencial y es para uso exclusivo de la persona o entidad de destino. Si no es usted. el destinatario indicado, queda notificado de que la lectura, utilización, divulgación y/o copia sin autorización puede estar prohibida en virtud de la legislación vigente. Si ha recibido este mensaje por error, le rogamos que nos lo comunique inmediatamente por esta misma vía y proceda a su destrucción.

The information contained in this transmission is privileged and confidential information intended only for the use of the individual or entity named above. If the reader of this message is not the intended recipient, you are hereby notified that any dissemination, distribution or copying of this communication is strictly prohibited. If you have received this transmission in error, do not read it. Please immediately reply to the sender that you have received this communication in error and then delete it.

Esta mensagem e seus anexos se dirigem exclusivamente ao seu destinatário, pode conter informação privilegiada ou confidencial e é para uso exclusivo da pessoa ou entidade de destino. Se não é vossa senhoria o destinatário indicado, fica notificado de que a leitura, utilização, divulgação e/ou cópia sem autorização pode estar proibida em virtude da legislação vigente. Se recebeu esta mensagem por erro, rogamos-lhe que nos o comunique imediatamente por esta mesma via e proceda a sua destruição

---

From: <[email-masked]>
Date: Thu, 2 Apr 2020 12:40:57 +0000

Hi Oscar,

I agree this is an important piece of work. I will send you a PR.

Cheers,
Med

De : OPSAWG [mailto:[email-masked]] De la part de Oscar González de Dios
Envoyé : jeudi 2 avril 2020 14:23
À : [email-masked]
Objet : [OPSAWG] L2NM: Layer 2 VPN Network Model: Request for Feedback and Review

Dear Opsawg colleagues,

            Oscar

---

From: tom petch <[email-masked]>
Date: Wed, 22 Apr 2020 10:28:57 +0000

From: OPSAWG <[email-masked]> on behalf of Oscar González de Dios <[email-masked]>
Sent: 02 April 2020 13:22
Dear Opsawg colleagues,

<tp>
I never realised how much difference formatting made to legibility until I came across a YANG module that is not formatted the same way as every other one is, namely, this one!  I am not inclined to spend more time on it in its present format, I am just too slow.

I got as far as noting that 
- IANA Considerations registers an existing prefix
- YANG imports mostly lack reference statements.
 -Abstract 'The L2SM complements the Layer 2 Service model ...'

Tom Petch

            Oscar

---

From: Oscar González de Dios <[email-masked]>
Date: Wed, 22 Apr 2020 11:35:23 +0000

Hi Tom,

   Apologies for the formatting issue.. Let us prepare a new version addressing all your comments and cleaning the format. I hope then the readability improves and the document can be reviewed properly.

   Lots of thanks and Best Regards,

       Oscar

________________________________
De: tom petch <[email-masked]>
Enviado: miércoles, 22 de abril de 2020 12:28
Para: Oscar González de Dios <[email-masked]>; [email-masked] <[email-masked]>
Asunto: Re: L2NM: Layer 2 VPN Network Model: Request for Feedback and Review

<tp>

Tom Petch

            Oscar