Subject: [OPSAWG] Call for adoption: draft-boydseda-ipfix-psamp-bulk-data-yang-model

From: "Joe Clarke (jclarke)" <[email-masked]>
Date: Sat, 18 Apr 2020 21:13:17 +0000

As was discussed in the April 7 virtual interim, we are doing a three-week call for opsawg adoption for this work.

This draft was an AD-sponsored work with Ignas and has now moved under Rob.  It has received a number of reviews (some thorough, some more cursory), and it is destined to obsolete 6728 (Configuration Data Model for the IP Flow Information Export (IPFIX) and Packet Sampling (PSAMP) Protocols) if ratified.  Because of that latter point, making this a WG item seems more appropriate than pushing it through as an AD-sponsored document.

To that end, does the WG feel this work is important and wants to take it up?  In a nutshell, this document breaks up the original YANG module into three for the IPFIX collector and exporter functions, the PSAMP functions, and the templates for bulk data exports.  While it preserves the SCTP support, SCTP is no longer mandatory.  It also adds support for ietf-interfaces and hardware management (those did not exist at the time of 6728).

The reason for the three-week call is to give people enough time to read through and digest this document.  Please reply with support (or objections) as well as comments by May 10, 2020.

Thanks.

Joe

---

From: tom petch <[email-masked]>
Date: Thu, 23 Apr 2020 10:10:33 +0000

From: OPSAWG <[email-masked]> on behalf of Joe Clarke (jclarke) <jclarke=[email-masked]>
Sent: 18 April 2020 22:13
To: opsawg
As was discussed in the April 7 virtual interim, we are doing a three-week call for opsawg adoption for this work.

<tp>
Tricky

It is the second largest I-D I have seen but is not the second hardest to read; it is sort of modular which makes it easier to follow.  Martin has done a sterling job in comparing it with the MIB and I suspect that that will be the only comprehensive review that it gets so should it become an RFC?  tricky.

I note that the IANA  Considerations does not match the YANG prefix statements and I do not like either of them.  ietf-ipfix is fine, but ieff-ipfix-packet-sampling fails the brevity test while ibde breaks the rules.  perhaps ietf-ipfix-ps and ietf-ipfix-bde

If adopted, I would suggest keeping the name  as draft-ietf-ipfix...  much easier to track for me

6.3.1 seems a bit too 'tentative'

Tom Petch

Thanks.

Joe
_______________________________________________
OPSAWG mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/opsawg