Subject: Re: [OPSAWG] I,Scope of FIT Capability: a node or a link?

From: Tianran Zhou <[email-masked]>
Date: Mon, 6 Apr 2020 14:48:14 +0000

Hi Greg,

Thanks very much for your interest on both IFIT framework and IFIT capability draft. And thanks for your review comments.
Your perspective on both drafts are correct.
On the node or link capability, thanks for your suggestion.
I agree with both you and Jeff. The link capability can make the information more clear and accurate for different scenarios.
Why we only considered the node capability? That’s the trade off to reduce complexity. We just want to start from simple cases.
If the WG think link capability is necessary, we would like to add link capabilities to the update.

Cheers,
Tianran

发件人: Greg Mirsky [mailto:[email-masked]]
发送时间: 2020年4月5日 10:33
收件人: [email-masked]; [email-masked]; [email-masked]; [email-masked]
主题: I,Scope of FIT Capability: a node or a link?

Dear All,
I've read these two drafts with interest. In light of the discussion on the LSR WG list, I've been thinking about the scenarios where IFIT is being used.
draft-song-opsawg-ifit-framework defines the overall IFIT architecture that, as I understand it, applicable to different methods of collecting and transporting telemetry information. draft-wang-lsr-ifit-node-capability-advertisement is based on the view that IFIT is a node-wide capability advertised as a binary flag for each listed method of collecting telemetry information (Option-Type enabled Flag). On-path telemetry collection is performed in the fast path, i.e., at a link layer. But a node might include ports with different capabilities. How such a heterogeneous, IFIT-wise, node will advertise IFIT Capability? To better use available resources for telemetry information collection, it might be helpful to advertise IFIT as a capability of a link, not of a node?
What do you think?

Regards,
Greg

---

From: "Les Ginsberg (ginsberg)" <[email-masked]>
Date: Mon, 6 Apr 2020 15:06:09 +0000

This discussion is interesting, but please do not ignore the considerable feedback from multiple folks indicating that this advertisement does not belong in the IGP at all (regardless of scope).
My opinion on that has not changed.

Thanx.

   Les

From: Lsr <[email-masked]> On Behalf Of Tianran Zhou
Sent: Monday, April 06, 2020 7:48 AM
To: Greg Mirsky <[email-masked]>; [email-masked]; [email-masked]; [email-masked]; [email-masked]
Subject: Re: [Lsr] I,Scope of FIT Capability: a node or a link?

Hi Greg,

Cheers,
Tianran

发件人: Greg Mirsky [mailto:[email-masked]]
发送时间: 2020年4月5日 10:33
收件人: [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>
主题: I,Scope of FIT Capability: a node or a link?

Dear All,

Regards,
Greg

---

From: Tony Li <[email-masked]>
Date: Mon, 6 Apr 2020 08:57:20 -0700

> My opinion on that has not changed.

+1

IS-IS is not the correct place to implement Service Discovery mechanisms. The management plane already has ample mechanisms for service and capability discovery.

Tony

---

From: Jeff Tantsura <[email-masked]>
Date: Mon, 6 Apr 2020 11:32:47 -0700

+1
Please do not take my comments about link vs node capabilities, as support for the solution, they are semantical.

Cheers,
Jeff
On Apr 6, 2020, 8:58 AM -0700, Tony Li <[email-masked]>, wrote:
> _______________________________________________
> Lsr mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/lsr

---

From: "Acee Lindem (acee)" <[email-masked]>
Date: Mon, 6 Apr 2020 18:54:02 +0000

Speaking as WG member – It seems that additional IFIT-specific information is required to make this useful and the IGPs are certainly not the case. Additionally, the point was made that an IFIT specific information channel would anyway be required to provision the telemetry generation.
Thanks,
Acee

From: Lsr <[email-masked]> on behalf of Jeff Tantsura <[email-masked]>
Date: Monday, April 6, 2020 at 2:33 PM
To: "Les Ginsberg (ginsberg)" <ginsberg=[email-masked]>, Tony Li <[email-masked]>
Cc: Greg Mirsky <[email-masked]>, "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>, Tianran Zhou <[email-masked]>, "[email-masked]" <[email-masked]>
Subject: Re: [Lsr] I,Scope of FIT Capability: a node or a link?

+1

Cheers,
Jeff

+1

Tony

---

From: Tony Przygienda <[email-masked]>
Date: Mon, 6 Apr 2020 11:55:55 -0700

+1

IGP is NOT an AD scope generic L3 broadcast mechanism ;-)
BGP is NOT an world scope generic L3 broadcast mechanism ;-)

--- tony

On Mon, Apr 6, 2020 at 8:06 AM Les Ginsberg (ginsberg) <ginsberg=
[email-masked]> wrote:

> This discussion is interesting, but please do not ignore the considerable
> feedback from multiple folks indicating that this advertisement does not
> belong in the IGP at all (regardless of scope).
>
> *From:* Lsr <[email-masked]> *On Behalf Of *Tianran Zhou
> *Sent:* Monday, April 06, 2020 7:48 AM
> *To:* Greg Mirsky <[email-masked]>;
> [email-masked]; [email-masked];
> [email-masked]; [email-masked]
> *Subject:* Re: [Lsr] I,Scope of FIT Capability: a node or a link?
>
>
>
> Hi Greg,
>
>
>
> Thanks very much for your interest on both IFIT framework and IFIT
> capability draft. And thanks for your review comments.
>
> I agree with both you and Jeff. The link capability can make the
> information more clear and accurate for different scenarios.
>
> Why we only considered the node capability? That’s the trade off to reduce
> complexity. We just want to start from simple cases.
>
> *发件人**:* Greg Mirsky [mailto:[email-masked] <[email-masked]>]
>
> *发送时间:* 2020年4月5日 10:33
> *收件人:* [email-masked];
> [email-masked]; [email-masked]; [email-masked]
> *主题:* I,Scope of FIT Capability: a node or a link?
>
>
>
> Dear All,
>
> I've read these two drafts with interest. In light of the discussion on
> the LSR WG list, I've been thinking about the scenarios where IFIT is being
> used.
>
> draft-song-opsawg-ifit-framework defines the overall IFIT architecture
> that, as I understand it, applicable to different methods of collecting and
> transporting telemetry
> information. draft-wang-lsr-ifit-node-capability-advertisement is based on
> the view that IFIT is a node-wide capability advertised as a binary flag
> for each listed method of collecting telemetry information (Option-Type
> enabled Flag). On-path telemetry collection is performed in the fast path,
> i.e., at a link layer. But a node might include ports with different
> capabilities. How such a heterogeneous, IFIT-wise, node will advertise IFIT
> Capability? To better use available resources for telemetry information
> collection, it might be helpful to advertise IFIT as a capability of a
> link, not of a node?
>
> What do you think?
>
>
>
> Regards,
>
> Greg