Subject: Re: [OPSAWG] [Lsr] I,Scope of FIT Capability: a node or a link?

From: Tianran Zhou <[email-masked]>
Date: Tue, 7 Apr 2020 07:22:39 +0000

Hi Acee,

About the “IFIT specific information channel”, as in https://datatracker.ietf.org/doc/draft-qin-idr-sr-policy-ifit/
we propose to use bgp enabled sr-policy for IFIT auto deployment.
It’s reasonable to incorporate both traffic engineering and monitoring.

Thanks,
Tianran

发件人: Acee Lindem (acee) [mailto:[email-masked]]
发送时间: 2020年4月7日 2:54
收件人: Jeff Tantsura <[email-masked]>; Les Ginsberg (ginsberg) <ginsberg=[email-masked]>; Tony Li <[email-masked]>
抄送: Greg Mirsky <[email-masked]>; [email-masked]; [email-masked]; [email-masked]; Tianran Zhou <[email-masked]>; [email-masked]
主题: Re: [Lsr] I,Scope of FIT Capability: a node or a link?

Speaking as WG member – It seems that additional IFIT-specific information is required to make this useful and the IGPs are certainly not the case. Additionally, the point was made that an IFIT specific information channel would anyway be required to provision the telemetry generation.
Thanks,
Acee

From: Lsr <[email-masked]<mailto:[email-masked]>> on behalf of Jeff Tantsura <[email-masked]<mailto:[email-masked]>>
Date: Monday, April 6, 2020 at 2:33 PM
To: "Les Ginsberg (ginsberg)" <ginsberg=[email-masked]<mailto:ginsberg=[email-masked]>>, Tony Li <[email-masked]<mailto:[email-masked]>>
Cc: Greg Mirsky <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, Tianran Zhou <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: Re: [Lsr] I,Scope of FIT Capability: a node or a link?

+1
Please do not take my comments about link vs node capabilities, as support for the solution, they are semantical.

Cheers,
Jeff
On Apr 6, 2020, 8:58 AM -0700, Tony Li <[email-masked]<mailto:[email-masked]>>, wrote:

This discussion is interesting, but please do not ignore the considerable feedback from multiple folks indicating that this advertisement does not belong in the IGP at all (regardless of scope).
My opinion on that has not changed.

+1

IS-IS is not the correct place to implement Service Discovery mechanisms. The management plane already has ample mechanisms for service and capability discovery.

Tony

_______________________________________________
Lsr mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/lsr

---

From: "Acee Lindem (acee)" <[email-masked]>
Date: Tue, 7 Apr 2020 20:25:25 +0000

Speaking as WG member:

Hi Tianran,

The more I look, the less I like this. We have a YANG infra-structure for telemetry data using YANG pub/sub. It is being implement and deployed over both NETCONF and proprietary transports. Why would we want to take just this type of telemetry out and handle it differently??? See an inline below…

From: Tianran Zhou <[email-masked]>
Date: Tuesday, April 7, 2020 at 3:22 AM
To: Acee Lindem <[email-masked]>, Jeff Tantsura <[email-masked]>, "Les Ginsberg (ginsberg)" <ginsberg=[email-masked]>, Tony Li <[email-masked]>
Cc: Greg Mirsky <[email-masked]>, "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>
Subject: RE: [Lsr] I,Scope of FIT Capability: a node or a link?

Hi Acee,

I think this is a terrible idea. Why wouldn’t you just provision it via a YANG subscription? An SR Policy could be identified by a <color, endpoint> tuple in the subscription? There can be many candidate SR policies but only the best-path is active. You’d need to update all the candidate policies in order to assure your iFIT tracing is enabled on the corresponding SR path. Why would you want to put this in BGP?

Acee

Thanks,
Tianran

+1

Cheers,
Jeff

+1

Tony

---

From: "Acee Lindem (acee)" <[email-masked]>
Date: Tue, 7 Apr 2020 20:28:38 +0000

Speaking as WG member:

With respect to your use case for transit router advertisement… What I was unsuccessfully trying to articulate to you during the interim was that the management system will typically not know the exact path between two endpoints so the use case is flawed. In fact, many times tracing is used by the management system to discover the path – as in traceroute…

Thanks,
Acee

Hi Acee,

Thanks,
Tianran

+1

Cheers,
Jeff

+1

Tony

---

From: Tianran Zhou <[email-masked]>
Date: Wed, 8 Apr 2020 06:35:07 +0000

Hi Acee,

>Why wouldn’t you just provision it via a YANG subscription?

YANG subscription is about exporting data to the collector. Here we firstly need to enable IFIT measurement along the path.

>An SR Policy could be identified by a <color, endpoint> tuple in the subscription? There can be many candidate SR policies but only the best-path is active. You’d need to update all the candidate policies in order to assure your iFIT tracing is enabled on the corresponding SR path.

Yes. But that’s how SR-Policy encoded in BGP and PCEP. There may be different algorithms/logic from the path computation entities, which generate multiple candidate paths. I think both granularity, SR-policy and Candidate Path, are useful. Like the discussion on node or link granularity.

>Why would you want to put this in BGP?

SR-Policy is encoded in BGP. And not just BGP, but also PCEP.
https://datatracker.ietf.org/doc/draft-chen-pce-sr-policy-ifit/

Best Wishes,
Tianran

From: Acee Lindem (acee) [mailto:[email-masked]]
Sent: Wednesday, April 8, 2020 4:25 AM
To: Tianran Zhou <[email-masked]>; Jeff Tantsura <[email-masked]>; Les Ginsberg (ginsberg) <ginsberg=[email-masked]>; Tony Li <[email-masked]>
Cc: Greg Mirsky <[email-masked]>; [email-masked]; [email-masked]; [email-masked]; [email-masked]
Subject: Re: [Lsr] I,Scope of FIT Capability: a node or a link?

Speaking as WG member:

Hi Tianran,

From: Tianran Zhou <[email-masked]<mailto:[email-masked]>>
Date: Tuesday, April 7, 2020 at 3:22 AM
To: Acee Lindem <[email-masked]<mailto:[email-masked]>>, Jeff Tantsura <[email-masked]<mailto:[email-masked]>>, "Les Ginsberg (ginsberg)" <ginsberg=[email-masked]<mailto:ginsberg=[email-masked]>>, Tony Li <[email-masked]<mailto:[email-masked]>>
Cc: Greg Mirsky <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: RE: [Lsr] I,Scope of FIT Capability: a node or a link?

Hi Acee,

Acee

Thanks,
Tianran

发件人: Acee Lindem (acee) [mailto:[email-masked]]
发送时间: 2020年4月7日 2:54
收件人: Jeff Tantsura <[email-masked]<mailto:[email-masked]>>; Les Ginsberg (ginsberg) <ginsberg=[email-masked]<mailto:ginsberg=[email-masked]>>; Tony Li <[email-masked]<mailto:[email-masked]>>
抄送: Greg Mirsky <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>; Tianran Zhou <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>
主题: Re: [Lsr] I,Scope of FIT Capability: a node or a link?

+1

Cheers,
Jeff

+1

Tony

---

From: Tianran Zhou <[email-masked]>
Date: Wed, 8 Apr 2020 06:51:15 +0000

Hi Acee,

Tracing is of course useful.
Here we  also consider to combine the traffic engineering and monitoring. So the transit nodes are visible.
For the loose TE, the intermediate SR nodes construct the segment monitoring.

Tianran

Sent: Wednesday, April 8, 2020 4:29 AM

Speaking as WG member:

Thanks,
Acee

Hi Acee,

Thanks,
Tianran

+1

Cheers,
Jeff

+1

Tony

---

From: "Acee Lindem (acee)" <[email-masked]>
Date: Wed, 8 Apr 2020 11:04:27 +0000

Tianran,

You keep missing my point. Even if the potential transit nodes advertise the capability, the management function doesn’t know which nodes will be transited in the path. Hence, you’re second use case is misguided.

Acee

From: Lsr <[email-masked]> on behalf of Tianran Zhou <[email-masked]>
Date: Wednesday, April 8, 2020 at 2:51 AM
To: Acee Lindem <[email-masked]>, Jeff Tantsura <[email-masked]>, "Les Ginsberg (ginsberg)" <ginsberg=[email-masked]>, Tony Li <[email-masked]>
Cc: Greg Mirsky <[email-masked]>, "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>
Subject: Re: [Lsr] I,Scope of FIT Capability: a node or a link?

Hi Acee,

Tianran

Speaking as WG member:

Thanks,
Acee

Hi Acee,

Thanks,
Tianran

+1

Cheers,
Jeff

+1

Tony

---

From: Tianran Zhou <[email-masked]>
Date: Thu, 9 Apr 2020 02:13:04 +0000

Hi Acee,

Please let’s firstly align on the same use case we discussed.
I talked about the TE. And the path computation entity can use the IFIT capability information for the path decision. On the other hand if the path is decided, the capability information can help the entity to deploy a suitable IFIT option.
So did you talk about the BE? Node only know the next hop, not the whole path. So the management system need the trace to get the path information. How BE could use the IFIT capability is another use case. Is this you want to know?

Tianran

From: Acee Lindem (acee) [mailto:[email-masked]]
Sent: Wednesday, April 8, 2020 7:04 PM
To: Tianran Zhou <[email-masked]>; Jeff Tantsura <[email-masked]>; Les Ginsberg (ginsberg) <ginsberg=[email-masked]>; Tony Li <[email-masked]>
Cc: Greg Mirsky <[email-masked]>; [email-masked]; [email-masked]; [email-masked]; [email-masked]
Subject: Re: [Lsr] I,Scope of FIT Capability: a node or a link?

Tianran,

Acee

From: Lsr <[email-masked]<mailto:[email-masked]>> on behalf of Tianran Zhou <[email-masked]<mailto:[email-masked]>>
Date: Wednesday, April 8, 2020 at 2:51 AM
To: Acee Lindem <[email-masked]<mailto:[email-masked]>>, Jeff Tantsura <[email-masked]<mailto:[email-masked]>>, "Les Ginsberg (ginsberg)" <ginsberg=[email-masked]<mailto:ginsberg=[email-masked]>>, Tony Li <[email-masked]<mailto:[email-masked]>>
Cc: Greg Mirsky <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: Re: [Lsr] I,Scope of FIT Capability: a node or a link?

Hi Acee,

Tianran

From: Acee Lindem (acee) [mailto:[email-masked]]
Sent: Wednesday, April 8, 2020 4:29 AM
To: Tianran Zhou <[email-masked]<mailto:[email-masked]>>; Jeff Tantsura <[email-masked]<mailto:[email-masked]>>; Les Ginsberg (ginsberg) <ginsberg=[email-masked]<mailto:ginsberg=[email-masked]>>; Tony Li <[email-masked]<mailto:[email-masked]>>
Cc: Greg Mirsky <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>
Subject: Re: [Lsr] I,Scope of FIT Capability: a node or a link?

Speaking as WG member:

Thanks,
Acee

Hi Acee,

Thanks,
Tianran

+1

Cheers,
Jeff

+1

Tony