Subject: Re: [OPSAWG] L2NM: Layer 2 VPN Network Model: Request for Feedback and Review

From: Qin Wu <[email-masked]>
Date: Thu, 2 Apr 2020 13:32:12 +0000

+1，support it.

-Qin
发件人: OPSAWG [mailto:[email-masked]] 代表 [email-masked]
发送时间: 2020年4月2日 20:41
收件人: Oscar González de Dios <[email-masked]>; [email-masked]
主题: Re: [OPSAWG] L2NM: Layer 2 VPN Network Model: Request for Feedback and Review

Hi Oscar,

I agree this is an important piece of work. I will send you a PR.

Cheers,
Med

De : OPSAWG [mailto:[email-masked]] De la part de Oscar González de Dios
Envoyé : jeudi 2 avril 2020 14:23
À : [email-masked]<mailto:[email-masked]>
Objet : [OPSAWG] L2NM: Layer 2 VPN Network Model: Request for Feedback and Review

Dear Opsawg colleagues,

In the line of the success of the L3NM, and also receiving request in the mailing list for a similar work for L2VPNs, we have prepared a new document, which will also be presented in the next OPSAWG virtual meeting, called  A Layer 2 VPN Network Yang Model draft-barguil-opsawg-l2sm-l2nm-01. You can find it in:

https://tools.ietf.org/html/draft-barguil-opsawg-l2sm-l2nm-01

The document defines a Yang Data model, L2NM, that can be used to manage the provisioning of Layer 2 VPN services in a Service Provider Network.  The Yang module defined in the document provides representation of the Layer 2 VPN Service and is aimed at being used  by a Network Controller, which can derive from it the configuration  information that will be sent to the network devices, as well as selecting a preference on the underlay transport network in a service provider environment.

We would like to request the OPSA Working Group colleagues for feedback and review of the document. We would also like to know if you consider this piece of work helpful in automating and programming the networks.

Best Regards and stay safe during the time that a small piece of ARN is ruling our lifes,

            Oscar

________________________________

Este mensaje y sus adjuntos se dirigen exclusivamente a su destinatario, puede contener información privilegiada o confidencial y es para uso exclusivo de la persona o entidad de destino. Si no es usted. el destinatario indicado, queda notificado de que la lectura, utilización, divulgación y/o copia sin autorización puede estar prohibida en virtud de la legislación vigente. Si ha recibido este mensaje por error, le rogamos que nos lo comunique inmediatamente por esta misma vía y proceda a su destrucción.

The information contained in this transmission is privileged and confidential information intended only for the use of the individual or entity named above. If the reader of this message is not the intended recipient, you are hereby notified that any dissemination, distribution or copying of this communication is strictly prohibited. If you have received this transmission in error, do not read it. Please immediately reply to the sender that you have received this communication in error and then delete it.

Esta mensagem e seus anexos se dirigem exclusivamente ao seu destinatário, pode conter informação privilegiada ou confidencial e é para uso exclusivo da pessoa ou entidade de destino. Se não é vossa senhoria o destinatário indicado, fica notificado de que a leitura, utilização, divulgação e/ou cópia sem autorização pode estar proibida em virtude da legislação vigente. Se recebeu esta mensagem por erro, rogamos-lhe que nos o comunique imediatamente por esta mesma via e proceda a sua destruição

---

From: SAMIER BARGUIL GIRALDO <[email-masked]>
Date: Thu, 2 Apr 2020 14:12:35 +0000

as an author I support it.

Samier Barguil
Transport & IP Networks | GCTIO - Technology | CIT Centro Integrado de Transporte |

Móvil +57 3017026430

Móvil +34 665416074

E-mail [email-masked]

E-mail [email-masked]

________________________________
De: OPSAWG <[email-masked]> en nombre de Qin Wu <[email-masked]>
Enviado: jueves, 2 de abril de 2020 8:32
Para: [email-masked] <[email-masked]>; Oscar González de Dios <[email-masked]>; [email-masked] <[email-masked]>
Asunto: Re: [OPSAWG] L2NM: Layer 2 VPN Network Model: Request for Feedback and Review

+1，support it.

-Qin

Hi Oscar,

Cheers,

Med

Dear Opsawg colleagues,

            Oscar

---

From: Oscar González de Dios <[email-masked]>
Date: Thu, 2 Apr 2020 14:16:36 +0000

Thanks Med, Qin, Samier,

                In addition to comments in the mailing list, I have set up a private git to collect issues.

                Please feel free to send reviews and critics to the list.

                @WG chairs, do you think there are other WGs where the work can be helpful and of interest?

                Oscar

De: SAMIER BARGUIL GIRALDO <[email-masked]>
Enviado el: jueves, 2 de abril de 2020 16:13
Para: [email-masked]
CC: Oscar González de Dios <[email-masked]>
Asunto: RE: L2NM: Layer 2 VPN Network Model: Request for Feedback and Review

Samier Barguil

Móvil +57 3017026430

Móvil +34 665416074

E-mail [email-masked]<mailto:[email-masked]>

E-mail [email-masked]<mailto:[email-masked]>

________________________________
De: OPSAWG <[email-masked]<mailto:[email-masked]>> en nombre de Qin Wu <[email-masked]<mailto:[email-masked]>>
Enviado: jueves, 2 de abril de 2020 8:32
Para: [email-masked]<mailto:[email-masked]> <[email-masked]<mailto:[email-masked]>>; Oscar González de Dios <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]> <[email-masked]<mailto:[email-masked]>>
Asunto: Re: [OPSAWG] L2NM: Layer 2 VPN Network Model: Request for Feedback and Review

+1，support it.

-Qin

发件人: OPSAWG [mailto:[email-masked]] 代表 [email-masked]<mailto:[email-masked]>
发送时间: 2020年4月2日 20:41
收件人: Oscar González de Dios <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>
主题: Re: [OPSAWG] L2NM: Layer 2 VPN Network Model: Request for Feedback and Review

Hi Oscar,

Cheers,

Med

Dear Opsawg colleagues,

            Oscar

---

From: Erez Segev <[email-masked]>
Date: Thu, 2 Apr 2020 15:08:31 +0000

+1; A very important model, giving a good network perspective of a customer service.

From: OPSAWG <[email-masked]> On Behalf Of Oscar Gonz?lez de Dios
Sent: Thursday, April 2, 2020 5:17 PM
To: SAMIER BARGUIL GIRALDO <[email-masked]>; [email-masked]
Subject: Re: [OPSAWG] L2NM: Layer 2 VPN Network Model: Request for Feedback and Review

Thanks Med, Qin, Samier,

                Oscar

De: SAMIER BARGUIL GIRALDO <[email-masked]<mailto:[email-masked]>>
Enviado el: jueves, 2 de abril de 2020 16:13
Para: [email-masked]<mailto:[email-masked]>
CC: Oscar González de Dios <[email-masked]<mailto:[email-masked]>>
Asunto: RE: L2NM: Layer 2 VPN Network Model: Request for Feedback and Review

Samier Barguil

Móvil +57 3017026430

Móvil +34 665416074

+1，support it.

-Qin

Hi Oscar,

Cheers,

Med

Dear Opsawg colleagues,

https://tools.ietf.org/html/draft-barguil-opsawg-l2sm-l2nm-01<https://clicktime.symantec.com/33ivrfSSA6eLpzzAL4jqrdE6H2?u=https%3A%2F%2Ftools.ietf.org%2Fhtml%2Fdraft-barguil-opsawg-l2sm-l2nm-01>

            Oscar

___________________________________________________________________________

This e-mail message is intended for the recipient only and contains information which is 
CONFIDENTIAL and which may be proprietary to ECI Telecom. If you have received this 
transmission in error, please inform us by e-mail, phone or fax, and then delete the original 
and all copies thereof.
___________________________________________________________________________

---

From: Tianran Zhou <[email-masked]>
Date: Thu, 2 Apr 2020 15:17:49 +0000

VPN and TE related wg? Like Bess, teas I think.

Sent from WeLink
发件人： Oscar González de Dios<[email-masked]<mailto:[email-masked]>>
收件人： SAMIER BARGUIL GIRALDO<[email-masked]<mailto:[email-masked]>>;opsawg<[email-masked]<mailto:[email-masked]>>
主题： Re: [OPSAWG] L2NM: Layer 2 VPN Network Model: Request for Feedback and Review
时间： 2020-04-02 22:17:21

Thanks Med, Qin, Samier,

                Oscar

Samier Barguil

Móvil +57 3017026430

Móvil +34 665416074

+1，support it.

-Qin

Hi Oscar,

Cheers,

Med

Dear Opsawg colleagues,

            Oscar

---

From: Oscar González de Dios <[email-masked]>
Date: Thu, 2 Apr 2020 15:22:06 +0000

Thanks Tianran,

                Indeed we made a collaboration with TEAS for the service mapping in https://tools.ietf.org/html/draft-ietf-teas-te-service-mapping-yang-03

                They included mappings from both L3NM and L2NM. However, we did not do any “public” announcement to the list, so note taken.

                With BESS, great, it would be then good to add in the relations with other models pointers to the bess models, especially for EVPN.

                Oscar

De: Tianran Zhou <[email-masked]>
Enviado el: jueves, 2 de abril de 2020 17:18
Para: Oscar González de Dios <[email-masked]>; SAMIER BARGUIL GIRALDO <[email-masked]>; opsawg <[email-masked]>
Asunto: RE: [OPSAWG] L2NM: Layer 2 VPN Network Model: Request for Feedback and Review

Sent from WeLink

Thanks Med, Qin, Samier,

                Oscar

Samier Barguil

Móvil +57 3017026430

Móvil +34 665416074

+1，support it.

-Qin

Hi Oscar,

Cheers,

Med

Dear Opsawg colleagues,

            Oscar

---

From: Tianran Zhou <[email-masked]>
Date: Fri, 3 Apr 2020 01:58:00 +0000

Good job! Thanks for your efforts.
I just tried to search the L2VPN model in BESS. Surprise to see it’s expired recently.
https://www.ietf.org/archive/id/draft-ietf-bess-l2vpn-yang-10.txt

Tianran
From: Oscar González de Dios [mailto:[email-masked]]
Sent: Thursday, April 2, 2020 11:22 PM
To: Tianran Zhou <[email-masked]>; SAMIER BARGUIL GIRALDO <[email-masked]>; opsawg <[email-masked]>
Subject: RE: [OPSAWG] L2NM: Layer 2 VPN Network Model: Request for Feedback and Review

Thanks Tianran,

                Oscar

De: Tianran Zhou <[email-masked]<mailto:[email-masked]>>
Enviado el: jueves, 2 de abril de 2020 17:18
Para: Oscar González de Dios <[email-masked]<mailto:[email-masked]>>; SAMIER BARGUIL GIRALDO <[email-masked]<mailto:[email-masked]>>; opsawg <[email-masked]<mailto:[email-masked]>>
Asunto: RE: [OPSAWG] L2NM: Layer 2 VPN Network Model: Request for Feedback and Review

Sent from WeLink

Thanks Med, Qin, Samier,

                Oscar

Samier Barguil

Móvil +57 3017026430

Móvil +34 665416074

+1，support it.

-Qin

Hi Oscar,

Cheers,

Med

Dear Opsawg colleagues,

            Oscar