Subject: Re: [OPSAWG] RV: New Version Notification for draft-barguil-opsawg-l2sm-l2nm-02.txt

From: "Roque Gagliano (rogaglia)" <[email-masked]>
Date: Tue, 26 May 2020 18:34:56 +0000

Hi Oscar,

If I am a developer that only want to implement l2nm, having a dependency on l3nm does not sound as the right architecture IMHO.

This probably goes into the  same discussion as of common module for types and libraries for any shared structures.

Regards,
Roque

On 26.05.20, 19:59, "OPSAWG on behalf of Oscar González de Dios" <[email-masked] on behalf of [email-masked]> wrote:

    Dear colleagues,

    A new version of l2nm has been submitted, please find bellow the details.

    The main changes are the clean-up of the Yang module adding references and fixing the prefix, as per Tom Petch review. The underlay transport selection is taken from l3nm.

    Please consider this version for reviewing the yang module of l2nm as it is more readable.

    Oscar

    -----Mensaje original-----
    De: [email-masked] <[email-masked]>
    Enviado el: martes, 26 de mayo de 2020 19:52
    Para: Oscar González de Dios <[email-masked]>; SAMIER BARGUIL GIRALDO <[email-masked]>; Oscar González de Dios <[email-masked]>; Luis Munoz <[email-masked]>; Mohamed Boucadair <[email-masked]>; Luis Angel Munoz <[email-masked]>; Luay Jalil <[email-masked]>; Jichun Ma <[email-masked]>
    Asunto: New Version Notification for draft-barguil-opsawg-l2sm-l2nm-02.txt

    A new version of I-D, draft-barguil-opsawg-l2sm-l2nm-02.txt
    has been successfully submitted by Oscar Gonzalez de Dios and posted to the IETF repository.

    Name:draft-barguil-opsawg-l2sm-l2nm
    Revision:02
    Title:A Layer 2 VPN Network YANG Model
    Document date:2020-05-26
    Group:Individual Submission
    Pages:93
    URL:            https://www.ietf.org/internet-drafts/draft-barguil-opsawg-l2sm-l2nm-02.txt
    Status:         https://datatracker.ietf.org/doc/draft-barguil-opsawg-l2sm-l2nm/
    Htmlized:       https://tools.ietf.org/html/draft-barguil-opsawg-l2sm-l2nm-02
    Htmlized:       https://datatracker.ietf.org/doc/html/draft-barguil-opsawg-l2sm-l2nm
    Diff:           https://www.ietf.org/rfcdiff?url2=draft-barguil-opsawg-l2sm-l2nm-02

    Abstract:
       This document defines a YANG Data model (called, L2NM) that can be
       used to manage the provisioning of Layer 2 VPN services within a
       Service Provider Network.  This YANG module provides representation
       of the Layer 2 VPN Service from a network standpoint.  The module is
       meant to be used by a Network Controller to derive the configuration
       information that will be sent to relevant network devices.

       The L2NM YANG Data model complements the Layer 2 Service Model
       (RFC8466) by providing a network-centric view of the service that is
       internal to a Service Provider.

    Please note that it may take a couple of minutes from the time of submission until the htmlized version and diff are available at tools.ietf.org.

    The IETF Secretariat

    ________________________________

    Este mensaje y sus adjuntos se dirigen exclusivamente a su destinatario, puede contener información privilegiada o confidencial y es para uso exclusivo de la persona o entidad de destino. Si no es usted. el destinatario indicado, queda notificado de que la lectura, utilización, divulgación y/o copia sin autorización puede estar prohibida en virtud de la legislación vigente. Si ha recibido este mensaje por error, le rogamos que nos lo comunique inmediatamente por esta misma vía y proceda a su destrucción.

    The information contained in this transmission is privileged and confidential information intended only for the use of the individual or entity named above. If the reader of this message is not the intended recipient, you are hereby notified that any dissemination, distribution or copying of this communication is strictly prohibited. If you have received this transmission in error, do not read it. Please immediately reply to the sender that you have received this communication in error and then delete it.

    Esta mensagem e seus anexos se dirigem exclusivamente ao seu destinatário, pode conter informação privilegiada ou confidencial e é para uso exclusivo da pessoa ou entidade de destino. Se não é vossa senhoria o destinatário indicado, fica notificado de que a leitura, utilização, divulgação e/ou cópia sem autorização pode estar proibida em virtude da legislação vigente. Se recebeu esta mensagem por erro, rogamos-lhe que nos o comunique imediatamente por esta mesma via e proceda a sua destruição
    _______________________________________________
    OPSAWG mailing list
    [email-masked]
    https://www.ietf.org/mailman/listinfo/opsawg

---

From: tom petch <[email-masked]>
Date: Wed, 27 May 2020 16:01:14 +0000

From: OPSAWG <[email-masked]> on behalf of Roque Gagliano (rogaglia) <rogaglia=[email-masked]>
Sent: 26 May 2020 19:34

Hi Oscar,

This probably goes into the  same discussion as of common module for types and libraries for any shared structures.
<tp>
Well, as I said before, RFC6991 has gained a bit of traction, albeit based on decades of experience with SMI.  I see the ..NM part as offering potential scope especially when the references are to upper layers, transport and above, which they may have in common.

Even if L2NM is thought to have nothing in common with the other three, it may be worth splitting out types, identities and such like into a separate YANG module at least so that the two can progress separately
Tom Petch

egards,
Roque

    Dear colleagues,

    Oscar

    -----Mensaje original-----
    De: [email-masked] <[email-masked]>
    Enviado el: martes, 26 de mayo de 2020 19:52
    Para: Oscar González de Dios <[email-masked]>; SAMIER BARGUIL GIRALDO <[email-masked]>; Oscar González de Dios <[email-masked]>; Luis Munoz <[email-masked]>; Mohamed Boucadair <[email-masked]>; Luis Angel Munoz <[email-masked]>; Luay Jalil <[email-masked]>; Jichun Ma <[email-masked]>
    Asunto: New Version Notification for draft-barguil-opsawg-l2sm-l2nm-02.txt

    Abstract:

    The IETF Secretariat