Subject: Re: [OPSAWG] CALL FOR ADOPTION: draft-tgraf-ipfix-mpls-sr-label-type

From: Qin Wu <[email-masked]>
Date: Fri, 14 Aug 2020 06:08:07 +0000

Support, I think this draft fill the missing piece for IPFIX to support SR, it will be useful for this draft to cover SRv6 data plane as well.

-Qin
-----邮件原件-----
发件人: OPSAWG [mailto:[email-masked]] 代表 Joe Clarke (jclarke)
发送时间: 2020年8月13日 20:41
收件人: opsawg <[email-masked]>
主题: [OPSAWG] CALL FOR ADOPTION: draft-tgraf-ipfix-mpls-sr-label-type

Hello, WG members.  During the IETF 108 virtual meeting, we had Thomas present this work.  It has been reviewed by SPRING as well as on this list.  The SPRING consensus was the work is better suited for opsawg.  The adoption hum during the IETF 108 virtual meeting was “Piano” which was middle of the road (though given the hum rules that is somewhat inconclusive).

Regardless, the chairs want to hear from the list.  This document aims to modernize the IPFIX MPLS label type for segment routing in order to provide more visibility for the MPLS-SR data plane.  Does opsawg want to adopt this work?

This starts a two-week call for adoption.  It will be concluded on August 27, 2020.

Joe
_______________________________________________
OPSAWG mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/opsawg

---

From: <[email-masked]>
Date: Sun, 16 Aug 2020 12:05:21 +0000

Hi Qin Wu,

Thanks for feedback. I agree, covering SRv6 as well makes sense and I take this as action point for the next update of the draft once its being adopted. 

The IE SrSidType is actually agnostic to SR-MPLS and SRv6. So the update would be on IE46 mplsTopLabelType. Adding IPv6 as label protocol. I have already a feedback from LSR to add BGP prefix SID, RFC 8669 as well. I think by now we are complete with all the SR capable label protocols.

Hi Joe,

Covering both SRv6 and MPLS-SR, I would like to take the opportunity to rename the draft from draft-tgraf-ipfix-mpls-sr-label-type to draft-opsawg-ipfix-sr-label-type when it is being adopted to the working group. Removing mpls from the document name and remain on sr, Not sure about the procedure and if it makes sense to do it that way. Here I need your support.

Best Wishes
Thomas

-----Original Message-----
From: OPSAWG <[email-masked]> On Behalf Of Qin Wu
Sent: Friday, August 14, 2020 8:08 AM
To: Joe Clarke (jclarke) <jclarke=[email-masked]>; opsawg <[email-masked]>
Subject: Re: [OPSAWG] CALL FOR ADOPTION: draft-tgraf-ipfix-mpls-sr-label-type

-Qin
-----邮件原件-----
发件人: OPSAWG [mailto:[email-masked]] 代表 Joe Clarke (jclarke)
发送时间: 2020年8月13日 20:41
收件人: opsawg <[email-masked]>
主题: [OPSAWG] CALL FOR ADOPTION: draft-tgraf-ipfix-mpls-sr-label-type

Joe
_______________________________________________
OPSAWG mailing list
[email-masked]
https://eur03.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Fmailman%2Flistinfo%2Fopsawg&amp;data=02%7C01%7CThomas.Graf%40swisscom.com%7Cd37c7f24b3b74053ea7d08d840187cf2%7C364e5b87c1c7420d9beec35d19b557a1%7C1%7C0%7C637329821202115623&amp;sdata=WrCx2htpypT64rmU5kOwS%2FGadFvfw9WkE6oNY5zujrQ%3D&amp;reserved=0
_______________________________________________
OPSAWG mailing list
[email-masked]
https://eur03.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Fmailman%2Flistinfo%2Fopsawg&amp;data=02%7C01%7CThomas.Graf%40swisscom.com%7Cd37c7f24b3b74053ea7d08d840187cf2%7C364e5b87c1c7420d9beec35d19b557a1%7C1%7C0%7C637329821202125573&amp;sdata=K71SrWBREEYtWdyWr5kz19cHjk%2BWcc%2FGunt6vf8KWjs%3D&amp;reserved=0

---

From: <[email-masked]>
Date: Sun, 16 Aug 2020 15:07:32 +0000

Hi Qin, Hi Joe,

Please ignore my last email in regards to SRv6 and name change. SRv6 is covered with draft-patki-srv6-ipfix-00
https://tools.ietf.org/html/draft-patki-srv6-ipfix-00

draft-tgraf-ipfix-mpls-sr-label-type is focusing on MPLS-SR.

Best Wishes
Thomas

-----Original Message-----
From: Graf Thomas, INI-NET-DCF 
Sent: Sunday, August 16, 2020 2:05 PM
To: Qin Wu <[email-masked]>; Joe Clarke (jclarke) <jclarke=[email-masked]>; opsawg <[email-masked]>
Subject: RE: CALL FOR ADOPTION: draft-tgraf-ipfix-mpls-sr-label-type

Hi Qin Wu,

Hi Joe,

Best Wishes
Thomas

-----Original Message-----
From: OPSAWG <[email-masked]> On Behalf Of Qin Wu
Sent: Friday, August 14, 2020 8:08 AM
To: Joe Clarke (jclarke) <jclarke=[email-masked]>; opsawg <[email-masked]>
Subject: Re: [OPSAWG] CALL FOR ADOPTION: draft-tgraf-ipfix-mpls-sr-label-type

-Qin
-----邮件原件-----
发件人: OPSAWG [mailto:[email-masked]] 代表 Joe Clarke (jclarke)
发送时间: 2020年8月13日 20:41
收件人: opsawg <[email-masked]>
主题: [OPSAWG] CALL FOR ADOPTION: draft-tgraf-ipfix-mpls-sr-label-type

Joe