Subject: Re: [OPSAWG] Call for adoption: draft-boydseda-ipfix-psamp-bulk-data-yang-model

From: "Padmanabhan, Sowrirajan (Nokia - IN/Chennai)" <[email-masked]>
Date: Thu, 13 Aug 2020 13:02:24 +0000

Hello WG,
This draft addresses the following aspects for logical/ functional split and to ensure broader acceptance and therefore must be considered for further progress

  *   Individual monitoring control of IPFIX transport sessions
  *   Logical segregation of the model into collector/exporter, PSAMP and bulk-data export
  *   Removes the hard requirement of SCTP and facilitates use of TLS
Regards,
Sowrirajan

---

From: "Neyens, Philip (Nokia - BE/Antwerp)" <[email-masked]>
Date: Fri, 14 Aug 2020 07:44:07 +0000

Hello WG,

I'm keen to see this progressing forward to come to standard reference for vendors and service providers active in the Netconf/Yang/IPFIX domain and in particular on the bulk data export.

I welcome the split in yang design to come to clear cut on the yang modeling specific to the IPFIX exporter and collector versus the modeling supporting the cache template configuration.

The IPFIX yang model gives good choice in options in which exporter and collector can relate to in which transport layer to use and have  transport-layer security added (TLS for TCP). In an cloud based operational network nothing moves without properly addressing secure transport. Good to see options are given.

With a modular cut between PSAMP and bulk-data export implementation choices are given per specific yang module reducing the overhead of incorporate unused yang models with deviation statements (not-supported).

Best regards,
Philip

---

From: "Carey, Timothy (Nokia - US)" <[email-masked]>
Date: Sat, 15 Aug 2020 16:45:42 +0000

Hi,

I would also support the adoption of this draft by the working group. IPFIX is used as a bulk data collection protocol within the Fixed Access networks and it is important that this draft for the reasons Joey Boyd has already stated.

BR,
Tim

---

From: steve smith <[email-masked]>
Date: Wed, 19 Aug 2020 15:52:36 +1000

I would like to add my weight to the call for support for adoption of this
draft. As the operator of a large network of DPUs from 3 different vendors,
we desperately need a standardized, scalable solution to our telemetry
needs, and any solution must be one that all vendors involved can be
confident in committing to.

*Steve Smith*

*Senior Architect, Access Network Platforms**, nbn (Australia)*